source: projects/specs/trunk/O/ORBit/ORBit-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A high-performance CORBA Object Request Broker.
2Summary(ja):    高機能な CORBA Object Request Broker.
3Name:           ORBit
4Version:        0.5.17
5Release:        17%{?_dist_release}
6
7URL:            http://www.labs.redhat.com/orbit/
8Source:         ftp://ftp.gnome.org/pub/GNOME/sources/ORBit/0.5/%{name}-%{version}.tar.gz
9Patch0:         ORBit-0.5.17-aligned-access.patch
10Patch1:         ORBit-underquoted.patch
11
12Group:          System Environment/Daemons
13License:        LGPL/GPL
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  glib-devel
16BuildRequires:  tcp_wrappers
17BuildRequires:  pkgconfig
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22Packager: inagaki
23
24%description
25ORBit is a high-performance CORBA (Common Object Request Broker
26Architecture) ORB (object request broker). It allows programs to send
27requests and receive replies from other programs, regardless of the
28locations of the two programs. CORBA is an architecture that enables
29communication between program objects, regardless of the programming
30language they are written in or the operating system they run on.
31
32You will need to install this package and ORBIT-devel if you want to
33write programs that use CORBA technology.
34
35%package devel
36Summary:        Development libraries, header files and utilities for ORBit.
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       indent
40Requires:       pkgconfig
41Requires:       glib-devel
42Requires(post):  /sbin/install-info
43Requires(preun): /sbin/install-info
44
45%description devel
46ORBit is a high-performance CORBA (Common Object Request Broker
47Architecture) ORB (object request broker) with support for the
48C language.
49
50This package contains the header files, libraries, and utilities
51necessary to write programs that use CORBA technology. If you want to
52write such programs, you also need to install the ORBit package.
53
54%prep
55%setup -q
56%patch0 -p1 -b .aligned
57%patch1 -p1 -b .underquoted
58
59%build
60%configure
61make %{?_smp_mflags}
62
63%install
64[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
65
66%makeinstall
67
68#%find_lang %{name}
69
70# remove unneeded files
71rm -f $RPM_BUILD_ROOT%{_bindir}/ior-decode
72rm -f $RPM_BUILD_ROOT%{_bindir}/old-name-server
73rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
74rm -f $RPM_BUILD_ROOT%{_datadir}/idl/orbit-1.0/*
75rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
76
77%post -p /sbin/ldconfig
78
79%postun -p /sbin/ldconfig
80
81%post devel
82/sbin/install-info %{_infodir}/libIDL.info.gz %{_infodir}/dir
83
84%preun devel
85if [ $1 = 0 ]; then
86   /sbin/install-info --delete %{_infodir}/libIDL.info.gz %{_infodir}/dir
87fi
88
89%clean
90rm -rf %{buildroot}
91
92%files
93%defattr(-,root,root)
94
95%doc AUTHORS COPYING ChangeLog NEWS README TODO
96%doc -P libIDL/COPYING libIDL/ChangeLog libIDL/AUTHORS
97%doc -P libIDL/README* libIDL/NEWS libIDL/BUGS libIDL/tstidl.c
98
99%{_libdir}/lib*.so*
100%{_bindir}/orbit-event-server
101%{_bindir}/orbit-name-server
102#don't install old-name-server
103#%{prefix}/bin/old-name-server
104%{_bindir}/name-client
105%{_bindir}/orbit-ird
106#{_bindir}/ior-decode
107
108%files devel
109%defattr(-,root,root)
110%{_bindir}/orbit-idl
111%{_bindir}/orbit-config
112%{_bindir}/libIDL-config
113%{_libdir}/*.a
114#{_libdir}/*.la
115%{_libdir}/*.sh
116%{_includedir}/*
117%{_libdir}/pkgconfig/*.pc
118%{_datadir}/aclocal/*
119%{_infodir}/libIDL.info.gz
120
121%changelog
122* Wed Jun 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.17-17
123- spec in UTF-8
124
125* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.17-16
126- applied new versioning policy
127
128* Sun Jun 03 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.17-15vl1
129- rebuilt with new toolchain
130- added Patch1 from Fedora
131  * Fri Aug  6 2004 Tim Waugh <twaugh@redhat.com> 1:0.5.17-14
132  - Fixed another m4 warning.
133  * Thu Jul 15 2004 Tim Waugh <twaugh@redhat.com> 1:0.5.17-13
134  - Fixed warnings in shipped m4 file.
135
136* Thu Feb 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.17-8vl2
137- rebuild
138- move PreReq: install-info to devel package
139- disable %%find_lang macro
140- remove unneeded files
141- add %%{_libdir}/pkgconfig/*.pc to devel package
142
143* Wed May  7 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.17-8vl1
144- rebuild with new toolchains
145- apply Patch0 from Redhat Rawhide 0.5.17-8
146  - Wed Apr  2 2003 Matt Wilson <msw@redhat.com> 1:0.5.17-8
147  - added ORBit-0.5.17-aligned-access.patch to fix accesses on some
148    non-ia32 architectures (#86347)
149
150* Fri Oct 25 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.17-0vl1
151- New upstream release.
152
153* Fri Dec 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5.12-0vl1
154- New upstream release.
155
156* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5.8-0vl1
157- New upstream release.
158
159* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5.7-1vl2
160- Fixed missing files.
161
162* Thu Jan 18 2001 Elliot Lee <sopwith@redhat.com>
163- 0.5.7
164
165* Tue Dec 19 2000 Elliot Lee <sopwith@redhat.com>
166- 0.5.6
167
168* Thu Nov 30 2000 Elliot Lee <sopwith@redhat.com>
169- 0.5.5
170
171* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
172- Up Epoch and release
173
174* Tue Jul 25 2000 Elliot Lee <sopwith@redhat.com>
175- 0.5.3
176
177* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
178- fixed to work with new cpp.
179
180* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
181- automatic rebuild
182
183* Tue Jul 11 2000 Jonathan Blandford <jrb@redhat.com>
184- Upgraded to 0.5.2 - a bug fix release.
185
186* Tue Jun 27 2000 Havoc Pennington <hp@redhat.com>
187- Trying to build the package for Preston and the build
188  system wants a new changelog entry
189
190* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
191- defattr the devel pkg
192- FHS paths
193
194* Fri May 19 2000 Jonathan Blandford <jrb@redhat.com>
195- Upgraded to 0.5.1
196
197* Tue Feb  3 2000 Elliot Lee <sopwith@redhat.com> 0.5.0-3
198- Strip shared libraries
199
200* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.4.94-1
201- Spec file fixes from RHL 6.0.
202
203* Wed Jun 2 1999  Jose Mercado <jmercado@mit.edu>
204- Fixed configure.in so spec.in could be used.
205
206* Mon Nov 23 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
207
208- improved %files section, and added use of %{prefix} and install-info
209  (well,... no. The info file has not dir info inside, commented out)
Note: See TracBrowser for help on using the repository browser.