source: projects/specs/trunk/M/MySQL/MySQL-vl.spec @ 7513

Revision 7513, 33.8 KB checked in by tomop, 11 years ago (diff)

MySQL-5.5.30-1

Line 
1%define mysqld_user             mysql
2%define mysqld_group            mysql
3%define server_suffix -community
4%define mysqldatadir /var/lib/mysql
5
6%{?_with_static:%define STATIC_BUILD 1}
7%{!?_with_static:%define STATIC_BUILD 0}
8
9# Working around perl dependency problem
10%global __perl_requires %{SOURCE998}
11%global __perllib_requires %{SOURCE998}
12
13# We don't package all files installed into the build root by intention -
14# See BUG#998 for details.
15%define _unpackaged_files_terminate_build 0
16
17%define see_base For a description of MySQL see the base MySQL RPM or http://www.mysql.com
18
19%define mysql_base_version      5.5
20%define mysql_version           5.5.30
21%define client_version          18
22
23%if %{?_dist_release}!="vl5"
24%define libpkgname libmysqlclient%{client_version}
25%else
26%define libpkgname MySQL-shared
27%endif
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager:       tomop
32
33Name: MySQL
34Summary:        MySQL: a very fast and reliable SQL database server
35Version:        %{mysql_version}
36Release:        1%{_dist_release}
37
38Group:          Applications/Databases
39# exceptions allow client libraries to be linked with most open source SW,
40# not only GPL code.
41License:        GPLv2 with exceptions
42URL:            http://www.mysql.com/
43
44Source:         mysql-%{version}.tar.gz
45# Don't depend on lib::mtr*
46Source998:      perl-requires-%{name}.sh
47Source1000:     macros.mysql.in
48Patch0:         mysql-5.5.15-jp-all.patch
49
50# lib64 patch for vine
51Patch200:       pysql-5.1.44-lib64.patch
52
53BuildRoot:      %{_tmppath}/%{name}-%{version}-root
54BuildRequires:  perl, readline-devel, libaio-devel
55BuildRequires:  gcc-c++, ncurses-devel, zlib-devel, openssl-devel
56BuildRequires:  groff, cmake, bison
57Requires:       fileutils sh-utils
58Provides:       msqlormysql MySQL-server mysql
59Obsoletes:      mysql MySQL5
60
61# From the manual
62%description
63The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
64and robust SQL (Structured Query Language) database server. MySQL Server
65is intended for mission-critical, heavy-load production systems as well
66as for embedding into mass-deployed software. MySQL is a trademark of
67Sun Microsystems, Inc.
68
69Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
70Use is subject to license terms.
71
72This software comes with ABSOLUTELY NO WARRANTY. This is free software,
73and you are welcome to modify and redistribute it under the GPL license.
74
75The MySQL web site (http://www.mysql.com/) provides the latest
76news and information about the MySQL software. Also please see the
77documentation and the manual for more information.
78
79%package server
80Release: %{release}
81Summary:        MySQL: a very fast and reliable SQL database server
82Group:          Applications/Databases
83Requires:       fileutils sh-utils net-tools
84Provides:       mysql-server mysql MySQL MySQL5-server mysqlserver-%{mysql_base_version}
85Obsoletes:      MySQL mysql mysql-server MySQL5-server
86
87%description server
88The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
89and robust SQL (Structured Query Language) database server. MySQL Server
90is intended for mission-critical, heavy-load production systems as well
91as for embedding into mass-deployed software. MySQL is a trademark of
92Sun Microsystems, Inc.
93
94Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
95Use is subject to license terms.
96
97This software comes with ABSOLUTELY NO WARRANTY. This is free software,
98and you are welcome to modify and redistribute it under the GPL license.
99
100The MySQL web site (http://www.mysql.com/) provides the latest
101news and information about the MySQL software. Also please see the
102documentation and the manual for more information.
103
104This package includes the MySQL server binary (incl. InnoDB) as well
105as related utilities to run and administrate a MySQL server.
106
107If you want to access and work with the database, you have to install
108package "MySQL-client" as well!
109
110%package client
111Summary: MySQL - Client
112Group: Applications/Databases
113Obsoletes: mysql-client MySQL5-client
114Provides: mysql-client MySQL5-client  mysqlclient-%{mysql_base_version}
115
116%description client
117This package contains the standard MySQL clients and administration tools.
118
119%{see_base}
120
121%package source
122Summary: MySQL - Source
123Group: Development/Libraries
124Requires: MySQL-devel = %{version}-%{release}
125AutoReqProv: no
126
127%description source
128This package contains the sources files of MySQL.
129
130%{see_base}
131
132%package test
133Requires: %{name}-client = %{version}-%{release} perl-DBI perl
134Summary: MySQL - Test suite
135Group: Applications/Databases
136Obsoletes: mysql-bench MySQL5-bench MySQL-bench
137Provides: perl(mtr_misc.pl)
138
139%description test
140This package contains the MySQL regression test suite.
141
142%{see_base}
143
144%package devel
145Summary: MySQL - Development header files and libraries
146Group: Development/Libraries
147Requires: %{libpkgname} = %{version}-%{release}
148Requires: openssl-devel, zlib-devel
149Provides: mysql-devel MySQL5-devel
150Obsoletes: mysql-devel MySQL5-devel
151
152%description devel
153This package contains the development header files and libraries
154necessary to develop MySQL client applications.
155
156%{see_base}
157
158%package -n %{libpkgname}
159Summary: The shared libraries required for MySQL clients
160Group: System Environment/Libraries
161%if %{?_dist_release}!="vl5"
162Obsoletes: MySQL-shared < %{version}
163%endif
164
165%description -n %{libpkgname}
166This package contains the shared libraries (*.so*) which certain
167languages and applications need to dynamically load and use MySQL.
168
169
170#%package embedded
171#Summary: MySQL as an embeddable library
172#Group: System Environment/Libraries
173#Obsoletes: mysql-embedded MySQL5-embedded
174#Provides: mysql-embedded MySQL5-embedded
175
176#%description embedded
177#MySQL is a multi-user, multi-threaded SQL database server. This
178#package contains a version of the MySQL server that can be embedded
179#into a client application instead of running as a separate process.
180
181#%{see_base}
182
183%package embedded-devel
184Summary: Development files for MySQL as an embeddable library
185Group: Development/Libraries
186Requires: %{name}-devel = %{version}-%{release}
187
188%description embedded-devel
189MySQL is a multi-user, multi-threaded SQL database server. This
190package contains files needed for developing and testing with
191the embedded version of the MySQL server.
192
193%{see_base}
194
195%prep
196%setup -q -n mysql-%{version}
197
198%patch0 -p1 -b .jp
199#%if %{_lib} == lib64
200#%patch200 -p0 -b .lib64
201#%endif
202#aclocal
203#autoheader
204#libtoolize --automake --force
205#automake --add-missing --copy
206#autoconf
207#perl -pi -e 's/-Werror"/"/' configure
208
209
210%build
211
212# Be strict about variables, bail at earliest opportunity, etc.
213set -eu
214
215# Optional package files
216touch optional-files-devel
217
218export PATH=${MYSQL_BUILD_PATH:-$PATH}
219export CC=${MYSQL_BUILD_CC:-${CC:-gcc}}
220export CXX=${MYSQL_BUILD_CXX:-${CXX:-gcc}}
221export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
222export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
223export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
224export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
225export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
226
227# Build full release
228mkdir release
229(
230  cd release
231  # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
232  # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
233  ${CMAKE} ../ -DBUILD_CONFIG=mysql_release -DINSTALL_LAYOUT=RPM \
234           -DCMAKE_BUILD_TYPE=RelWithDebInfo \
235           -DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
236           -DFEATURE_SET="community" \
237           -DCOMPILATION_COMMENT="VineLinux MySQL RPM" \
238           -DMYSQL_SERVER_SUFFIX="%{server_suffix}" \
239           -DWITH_PIC="ON" \
240           -DWITH_ZLIB="system" \
241           -DWITH_EMBEDDED_SERVER="ON" \
242           -DWITH_SSL="yes"
243  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
244  make %{?_smp_mflags} VERBOSE=1
245)
246
247# Use the build root for temporary storage of the shared libraries.
248RBR=$RPM_BUILD_ROOT
249
250# Clean up the BuildRoot first
251[ "$RBR" != "/" ] && [ -d "$RBR" ] && rm -rf "$RBR";
252
253# For gcc builds, include libgcc.a in the devel subpackage (BUG 4921).  This
254# needs to be during build phase as $CC is not set during install.
255if "$CC" -v 2>&1 | grep '^gcc.version' >/dev/null 2>&1
256then
257  libgcc=`$CC $CFLAGS --print-libgcc-file`
258  if [ -f $libgcc ]
259  then
260    mkdir -p $RBR%{_libdir}/mysql
261#    install -m 644 $libgcc $RBR%{_libdir}/mysql/libmygcc.a
262#    echo "%{_libdir}/mysql/libmygcc.a" >>optional-files-devel
263  fi
264fi
265
266##############################################################################
267%install
268RBR=$RPM_BUILD_ROOT
269MBD=$RPM_BUILD_DIR/mysql-%{mysql_version}
270
271rm -rf $RBR
272
273# Ensure that needed directories exists
274install -d $RBR%{_sysconfdir}/{logrotate.d,init.d}
275install -d $RBR%{mysqldatadir}/mysql
276install -d $RBR%{_datadir}/mysql-test
277install -d $RBR%{_includedir}
278install -d $RBR%{_libdir}
279install -d $RBR%{_mandir}
280install -d $RBR%{_sbindir}
281
282# Install all binaries
283# Install all binaries
284(
285  cd $MBD/release
286  make DESTDIR=$RBR install
287)
288
289# Install logrotate and autostart
290install -m 644 $MBD/release/support-files/mysql-log-rotate $RBR%{_sysconfdir}/logrotate.d/mysql
291install -m 755 $MBD/release/support-files/mysql.server $RBR%{_sysconfdir}/init.d/mysql
292
293# Create a symlink "rcmysql", pointing to the init.script. SuSE users
294# will appreciate that, as all services usually offer this.
295ln -s %{_sysconfdir}/init.d/mysql $RBR%{_sbindir}/rcmysql
296
297# Touch the place where the my.cnf config file might be located
298# Just to make sure it's in the file list and marked as a config file
299touch $RBR%{_sysconfdir}/my.cnf
300
301# Remove man pages we explicitly do not want to package, avoids 'unpackaged
302# files' warning.
303rm -f $RBR%{_mandir}/man1/make_win_bin_dist.1*
304
305mkdir -p $RBR%{_datadir}/%{name}-source
306pushd $RBR%{_datadir}/%{name}-source
307tar zxf %{SOURCE0}
308find $RBR%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
309popd
310
311mkdir -p $RBR%{_sysconfdir}/rpm
312sed -e 's/@BASEVERSION@/%{mysql_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > $RBR%{_sysconfdir}/rpm/macros.mysql
313
314rm -f $RBR%{_libdir}/mysql/plugin/daemon_example.ini
315
316##############################################################################
317
318
319%pre server
320# Shut down a previously installed server first
321if test -x %{_sysconfdir}/init.d/mysql
322then
323  %{_sysconfdir}/init.d/mysql stop > /dev/null 2>&1
324  echo "Giving mysqld a couple of seconds to exit nicely"
325  sleep 5
326elif test -x %{_sysconfdir}/rc.d/init.d/mysql
327then
328  %{_sysconfdir}/rc.d/init.d/mysql stop > /dev/null 2>&1
329  echo "Giving mysqld a couple of seconds to exit nicely"
330  sleep 5
331fi
332
333%post server
334mysql_datadir=%{mysqldatadir}
335
336# Create data directory if needed
337if test ! -d $mysql_datadir; then mkdir -m 755 $mysql_datadir; fi
338if test ! -d $mysql_datadir/mysql; then mkdir $mysql_datadir/mysql; fi
339if test ! -d $mysql_datadir/test; then mkdir $mysql_datadir/test; fi
340
341# Make MySQL start/shutdown automatically when the machine does it.
342# use insserv for older SuSE Linux versions
343if test -x /sbin/insserv
344then
345        /sbin/insserv %{_sysconfdir}/init.d/mysql
346# use chkconfig on Red Hat and newer SuSE releases
347elif test -x /sbin/chkconfig
348then
349        /sbin/chkconfig --add mysql
350fi
351
352# Create a MySQL user and group. Do not report any problems if it already
353# exists.
354groupadd -r %{mysqld_group} 2> /dev/null || true
355useradd -M -r -d $mysql_datadir -s /bin/bash -c "MySQL server" -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
356# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
357usermod -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
358
359# Change permissions so that the user that will run the MySQL daemon
360# owns all database files.
361chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
362
363# Initiate databases if needed
364%{_bindir}/mysql_install_db --rpm --user=%{mysqld_user}
365
366# Upgrade databases if needed would go here - but it cannot be automated yet
367
368# Change permissions again to fix any new files.
369chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
370
371# Fix permissions for the permission database so that only the user
372# can read them.
373chmod -R og-rw $mysql_datadir/mysql
374
375# Restart in the same way that mysqld will be started normally.
376%{_sysconfdir}/init.d/mysql start
377
378# Allow mysqld_safe to start mysqld and print a message before we exit
379sleep 2
380
381#echo "Thank you for installing the MySQL Community Server! For Production
382#systems, we recommend MySQL Enterprise, which contains enterprise-ready
383#software, intelligent advisory services, and full production support with
384#scheduled service packs and more.  Visit www.mysql.com/enterprise for more
385#information."
386
387%preun server
388if test $1 = 0
389then
390  # Stop MySQL before uninstalling it
391  if test -x %{_sysconfdir}/init.d/mysql
392  then
393    %{_sysconfdir}/init.d/mysql stop > /dev/null
394
395    # Remove autostart of mysql
396    # for older SuSE Linux versions
397    if test -x /sbin/insserv
398    then
399      /sbin/insserv -r %{_sysconfdir}/init.d/mysql
400    # use chkconfig on Red Hat and newer SuSE releases
401    elif test -x /sbin/chkconfig
402    then
403      /sbin/chkconfig --del mysql
404    fi
405  fi
406fi
407
408# We do not remove the mysql user since it may still own a lot of
409# database files.
410
411%post -n %{libpkgname}
412/sbin/ldconfig
413
414%postun -n %{libpkgname}
415/sbin/ldconfig
416
417# Clean up the BuildRoot
418%clean
419[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
420
421%files server
422%defattr(-,root,root,0755)
423
424%doc COPYING README
425%doc Docs/ChangeLog
426%doc Docs/INFO_SRC*
427%doc release/Docs/INFO_BIN*
428%doc release/support-files/my-*.cnf
429
430%doc %attr(644, root, root) %{_infodir}/mysql.info*
431
432%doc %attr(644, root, man) %{_mandir}/man1/innochecksum.1*
433%doc %attr(644, root, man) %{_mandir}/man1/my_print_defaults.1*
434%doc %attr(644, root, man) %{_mandir}/man1/myisam_ftdump.1*
435%doc %attr(644, root, man) %{_mandir}/man1/myisamchk.1*
436%doc %attr(644, root, man) %{_mandir}/man1/myisamlog.1*
437%doc %attr(644, root, man) %{_mandir}/man1/myisampack.1*
438%doc %attr(644, root, man) %{_mandir}/man1/mysql_convert_table_format.1*
439%doc %attr(644, root, man) %{_mandir}/man1/mysql_fix_extensions.1*
440%doc %attr(644, root, man) %{_mandir}/man8/mysqld.8*
441%doc %attr(644, root, man) %{_mandir}/man1/mysqld_multi.1*
442%doc %attr(644, root, man) %{_mandir}/man1/mysqld_safe.1*
443%doc %attr(644, root, man) %{_mandir}/man1/mysqldumpslow.1*
444%doc %attr(644, root, man) %{_mandir}/man1/mysql_install_db.1*
445%doc %attr(644, root, man) %{_mandir}/man1/mysql_plugin.1*
446%doc %attr(644, root, man) %{_mandir}/man1/mysql_secure_installation.1*
447%doc %attr(644, root, man) %{_mandir}/man1/mysql_setpermission.1*
448%doc %attr(644, root, man) %{_mandir}/man1/mysql_upgrade.1*
449%doc %attr(644, root, man) %{_mandir}/man1/mysqlhotcopy.1*
450%doc %attr(644, root, man) %{_mandir}/man1/mysqlman.1*
451%doc %attr(644, root, man) %{_mandir}/man1/mysql.server.1*
452%doc %attr(644, root, man) %{_mandir}/man1/mysqltest.1*
453%doc %attr(644, root, man) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
454%doc %attr(644, root, man) %{_mandir}/man1/mysql_zap.1*
455%doc %attr(644, root, man) %{_mandir}/man1/mysqlbug.1*
456%doc %attr(644, root, man) %{_mandir}/man1/perror.1*
457%doc %attr(644, root, man) %{_mandir}/man1/replace.1*
458%doc %attr(644, root, man) %{_mandir}/man1/resolve_stack_dump.1*
459%doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
460
461%ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
462
463%attr(755, root, root) %{_bindir}/innochecksum
464%attr(755, root, root) %{_bindir}/my_print_defaults
465%attr(755, root, root) %{_bindir}/myisam_ftdump
466%attr(755, root, root) %{_bindir}/myisamchk
467%attr(755, root, root) %{_bindir}/myisamlog
468%attr(755, root, root) %{_bindir}/myisampack
469%attr(755, root, root) %{_bindir}/mysql_convert_table_format
470%attr(755, root, root) %{_bindir}/mysql_fix_extensions
471%attr(755, root, root) %{_bindir}/mysql_install_db
472%attr(755, root, root) %{_bindir}/mysql_plugin
473%attr(755, root, root) %{_bindir}/mysql_secure_installation
474%attr(755, root, root) %{_bindir}/mysql_setpermission
475%attr(755, root, root) %{_bindir}/mysql_tzinfo_to_sql
476%attr(755, root, root) %{_bindir}/mysql_upgrade
477%attr(755, root, root) %{_bindir}/mysql_zap
478%attr(755, root, root) %{_bindir}/mysqlbug
479%attr(755, root, root) %{_bindir}/mysqld_multi
480%attr(755, root, root) %{_bindir}/mysqld_safe
481%attr(755, root, root) %{_bindir}/mysqldumpslow
482%attr(755, root, root) %{_bindir}/mysqlhotcopy
483%attr(755, root, root) %{_bindir}/mysqltest
484%attr(755, root, root) %{_bindir}/perror
485%attr(755, root, root) %{_bindir}/replace
486%attr(755, root, root) %{_bindir}/resolve_stack_dump
487%attr(755, root, root) %{_bindir}/resolveip
488
489%attr(755, root, root) %{_sbindir}/mysqld
490%attr(755, root, root) %{_sbindir}/rcmysql
491%attr(755, root, root) %{_libdir}/mysql/plugin/*.so
492
493%attr(644, root, root) %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
494%attr(755, root, root) %{_sysconfdir}/init.d/mysql
495
496%attr(755, root, root) %{_datadir}/mysql/
497
498%files client
499%defattr(-, root, root, 0755)
500%attr(755, root, root) %{_bindir}/msql2mysql
501%attr(755, root, root) %{_bindir}/mysql
502%attr(755, root, root) %{_bindir}/mysql_find_rows
503%attr(755, root, root) %{_bindir}/mysql_waitpid
504%attr(755, root, root) %{_bindir}/mysqlaccess
505# XXX: This should be moved to %{_sysconfdir}
506%attr(644, root, root) %{_bindir}/mysqlaccess.conf
507%attr(755, root, root) %{_bindir}/mysqladmin
508%attr(755, root, root) %{_bindir}/mysqlbinlog
509%attr(755, root, root) %{_bindir}/mysqlcheck
510%attr(755, root, root) %{_bindir}/mysqldump
511%attr(755, root, root) %{_bindir}/mysqlimport
512%attr(755, root, root) %{_bindir}/mysqlshow
513%attr(755, root, root) %{_bindir}/mysqlslap
514
515%doc %attr(644, root, man) %{_mandir}/man1/msql2mysql.1*
516%doc %attr(644, root, man) %{_mandir}/man1/mysql.1*
517%doc %attr(644, root, man) %{_mandir}/man1/mysql_find_rows.1*
518%doc %attr(644, root, man) %{_mandir}/man1/mysql_waitpid.1*
519%doc %attr(644, root, man) %{_mandir}/man1/mysqlaccess.1*
520%doc %attr(644, root, man) %{_mandir}/man1/mysqladmin.1*
521%doc %attr(644, root, man) %{_mandir}/man1/mysqlbinlog.1*
522%doc %attr(644, root, man) %{_mandir}/man1/mysqlcheck.1*
523%doc %attr(644, root, man) %{_mandir}/man1/mysqldump.1*
524%doc %attr(644, root, man) %{_mandir}/man1/mysqlimport.1*
525%doc %attr(644, root, man) %{_mandir}/man1/mysqlshow.1*
526%doc %attr(644, root, man) %{_mandir}/man1/mysqlslap.1*
527
528%files source
529%defattr(-, root, root, 0755)
530%{_datadir}/MySQL-source
531
532%files devel -f optional-files-devel
533%defattr(-, root, root, 0755)
534%doc %attr(644, root, man) %{_mandir}/man1/comp_err.1*
535%doc %attr(644, root, man) %{_mandir}/man1/mysql_config.1*
536%attr(755, root, root) %{_bindir}/mysql_config
537%dir %attr(755, root, root) %{_includedir}/mysql
538%dir %attr(755, root, root) %{_libdir}/mysql
539%{_includedir}/mysql/*
540%{_datadir}/aclocal/mysql.m4
541%{_libdir}/*.so
542%{_sysconfdir}/rpm/*
543%exclude %{_libdir}/*.a
544
545%files -n %{libpkgname}
546%defattr(-, root, root, 0755)
547# Shared libraries (omit for architectures that don't support them)
548%{_libdir}/libmysql*.so.*
549#/etc/ld.so.conf.d/*
550
551%files test
552%defattr(-, root, root, 0755)
553%attr(-, root, root) %{_datadir}/mysql-test
554%attr(755, root, root) %{_bindir}/mysql_client_test
555%attr(755, root, root) %{_bindir}/mysql_client_test_embedded
556%attr(755, root, root) %{_bindir}/mysqltest_embedded
557%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test.1*
558%doc %attr(644, root, man) %{_mandir}/man1/mysql-stress-test.pl.1*
559%doc %attr(644, root, man) %{_mandir}/man1/mysql-test-run.pl.1*
560%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
561%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
562
563%files embedded-devel
564%defattr(-,root,root)
565#{_libdir}/libmysqld.a
566%{_bindir}/mysql_embedded
567%{_bindir}/mysql_client_test_embedded
568%{_bindir}/mysqltest_embedded
569%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
570%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
571
572%changelog
573* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
574- new upstream release.
575
576* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
577- new upstream release.
578
579* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
580- new upstream release.
581- added a sub-package 'MySQL-source".
582- added some macros for rpm.
583
584* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
585- new upstream release.
586
587* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
588- new upstream release.
589
590* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
591- new upstream release.
592- added "Vendor:" and "Distribution:" tag.
593
594* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
595- new upstream release.
596- removed NDB cluster support.
597
598* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
599- Added "BR: zlib-devel" to MySQL-devel.
600
601* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
602- Added "BR: openssl-devel" to MySQL-devel.
603
604* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
605- new upstream release.
606
607* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
608- new upstream release.
609- updated jp-patch.
610- added ssl support.
611
612* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
613- new upstream release.
614- replaced '%%__find_requires' to '%%__perl_requires'.
615- updated jp-patch.
616
617* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
618- added mysql-5.1.44-lib64.patch (on x86_64)
619- added -fPIC (on x86_64)
620
621* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
622- made embedded package again
623
624* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
625- new upstream release.
626- updated jp-patch.
627
628* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
629- VineSeed: rebuilt with new toolchain.
630
631* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
632- new upstream release.
633  - fixed CVE-2009-4484.
634
635* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
636- new upstream release.
637
638* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
639- added net-tools to 'Requires'.
640- added groff to 'BuildRequires'.
641- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
642
643* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
644- new upstream release.
645
646* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
647- new upstream release.
648
649* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
650- new upstream release.
651- dropped %%Patch100 (fixed in upstream).
652
653* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
654- new upstream release.
655- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
656
657* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
658- new upstream release.
659- rename 'MySQL-bench' to 'MySQL-test'.
660- update Patch0.
661- change default charset to 'utf8'.
662
663* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
664- new upstream release.
665- update Patch0.
666- add "--with-client-charset=ujis".
667- sync %%files to official RPM.
668- remove MySQL-Max.
669
670* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
671- for VineSeed
672
673* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
674- move shared library from /usr/lib/ to /usr/lib/mysql/
675- add /etc/ld.so.conf.d/*.conf
676- fix broken libmysqlcient*.la files (or should we remove them permanently?)
677
678* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
679- rebuild <BTS:VineLinux:534>
680
681* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
682- added -fPIC
683
684* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
685- fixed dependency. <BTS:338>
686
687* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
688- add %%Patch1. <BTS:320>
689
690* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
691- new upstream release.
692
693* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
694- new upstream release.
695
696* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
697- new upstream release.
698
699* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
700- release++.
701
702* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
703- new upstream release.
704- for VineSeed.
705
706* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
707- new upstream release.
708- replace Patch0 for MySQL-4.1.16.
709
710* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
711- new upstream release.
712- add Patch0.
713
714* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
715- new upstream version
716        -- mysql-4.0.25
717
718* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
719- new upstream version
720        -- mysql-4.0.23
721
722* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
723- new upstream version
724        -- mysql-4.0.22
725 
726* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
727- new upstream version
728        -- mysql-4.0.21
729 
730* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
731- new upstream version
732        -- mysql-4.0.20
733 
734* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
735- modify CFLAGS, CXXFLAGS and configure options for alpha
736
737* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
738- Upgraded to MySQL-4
739- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
740- merged to MySQL Official packages
741        -- renamed package "MySQL" to "MySQL-server"
742        -- when using gcc, _always_ use CXX=gcc
743        -- replaced Copyright with License field (Copyright is obsolete)
744        -- added myisam_ftdump to the Server package
745        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
746        -- fixed file permissions (BUG 1672)
747        -- removed dependency on MySQL-client from the MySQL-devel subpackage
748        -- as it is not really required. (BUG 1610)
749        -- Fixed BUG 1162 (removed macro names from the changelog)
750        -- Really fixed BUG 998 (disable the checking for installed but
751        --  unpackaged files)
752        -- Fixed BUG 959 (libmysqld not being compiled properly)
753        -- Fixed BUG 998 (RPM build errors): added missing files to the
754        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
755        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
756        -- removed the GIF Icon (file was not included in the sources anyway)
757        -- removed unused variable shared_lib_version
758        -- do not run automake before building the standard binary
759        --  (should not be necessary)
760        -- add server suffix '-standard' to standard binary (to be in line
761        -- with the binary tarball distributions)
762        -- allow overriding CC and CXX (required when building
763        -- with other compilers)
764
765* Thu Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
766- added BuildRequires:  automake16
767                                                                               
768* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
769- add '-fPIC -DPIC' to CFLAGS on alpha
770- little fix of spec file
771                                                                               
772* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
773- enable MySQL-shared subpackage for alpha
774- delete 'BuildPrereq: kernel24-headers' for alpha
775- fix shared %files (exclude sparc)
776                                                                               
777* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
778- new upstream version
779                                                                               
780* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
781- fixed devel %files (dropped *.la files)
782                                                                               
783* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
784- new upstream version
785- fixed document permission
786                                                                               
787* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
788- new upstream version
789                                                                               
790* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
791- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
792        -- don't work
793                                                                               
794* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
795- new upstream version
796- diseble-assembler in configure on sparc,sparc64,alpha
797                                                                               
798* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
799- new upstream version
800- moved some man files to main package
801- added enable-local-infile in configure
802- changed --with-extra-charsets=all in configure
803                                                                               
804* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
805- fixed changelog
806                                                                               
807* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
808- updated to mysql-3.23.51
809                                                                               
810* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
811- rebuild on zlib-1.1.4(security fix.)
812                                                                               
813* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
814- updated to mysql-2.23.49
815                                                                               
816* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
817- add 'BuildPrereq: kernel24-headers' on alpha
818- remove shared library and max on alpha
819                                                                               
820* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
821- updated to mysql-3.23.48
822                                                                               
823* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
824- updated to mysql-3.23.47
825                                                                               
826* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
827- updated to mysql-3.23.46
828                                                                               
829* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
830- updated to mysql-3.23.45
831                                                                               
832* Tue Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
833- updated to mysql-3.23.44
834                                                                               
835* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
836- updated to mysql-3.23.43
837- removed shared library and max on sparc
838                                                                               
839* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
840- updated to mysql-3.23.42
841- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
842                                                                               
843* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
844- updated to mysql-3.23.41
845                                                                               
846* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
847- updated to mysql-3.23.40
848                                                                               
849* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
850- updated to mysql-3.23.39
851
852* Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
853- added configure --with-charset=ujis
854                                                                               
855* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
856- used some rpmmacro
857                                                                               
858* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
859- updated to MySQL-3.23.38
860                                                                               
861* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
862- removed Bench pakages
863                                                                               
864* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
865- removed pt_BR locale
866- build on Vine Linux
867- partially used rpmmacros
868- added %clean tag
869                                                                               
870* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
871- Added separate libmysql_r directory; now both a threaded
872  and non-threaded library is shipped.
873                                                                               
874* Wed Sep 28 1999 David Axmark <davida@mysql.com>
875- Added the support-files/my-example.cnf to the docs directory.
876- Removed devel dependency on base since it is about client
877  development.
878                                                                               
879* Wed Sep 8 1999 David Axmark <davida@mysql.com>
880- Cleaned up some for 3.23.
881                                                                               
882* Thu Jul 1 1999 David Axmark <davida@mysql.com>
883- Added support for shared libraries in a separate sub
884  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
885- The --enable-assembler switch is now automatically disables on
886  platforms there assembler code is unavailable. This should allow
887  building this RPM on non i386 systems.
888                                                                               
889* Mon Feb 22 1999 David Axmark <david@detron.se>
890- Removed unportable cc switches from the spec file. The defaults can
891  now be overridden with environment variables. This feature is used
892  to compile the official RPM with optimal (but compiler version
893  specific) switches.
894- Removed the repetitive description parts for the sub rpms. Maybe add
895  again if RPM gets a multiline macro capability.
896- Added support for a pt_BR translation. Translation contributed by
897  Jorge Godoy <jorge@bestway.com.br>.
898                                                                               
899* Wed Nov 4 1998 David Axmark <david@detron.se>
900- A lot of changes in all the rpm and install scripts. This may even
901  be a working RPM :-)
902                                                                               
903* Sun Aug 16 1998 David Axmark <david@detron.se>
904- A developers changelog for MySQL is available in the source RPM. And
905  there is a history of major user visible changed in the Reference
906  Manual.  Only RPM specific changes will be documented here.
907
Note: See TracBrowser for help on using the repository browser.