source: projects/specs/trunk/M/MySQL/MySQL-vl.spec @ 4643

Revision 4643, 32.0 KB checked in by tomop, 13 years ago (diff)

MySQL-5.5.15-1

Line 
1%define mysqld_user             mysql
2%define mysqld_group            mysql
3%define server_suffix -community
4%define mysqldatadir /var/lib/mysql
5
6%{?_with_static:%define STATIC_BUILD 1}
7%{!?_with_static:%define STATIC_BUILD 0}
8
9# Working around perl dependency problem
10%define __perl_requires %{SOURCE998}
11
12# We don't package all files installed into the build root by intention -
13# See BUG#998 for details.
14%define _unpackaged_files_terminate_build 0
15
16%define see_base For a description of MySQL see the base MySQL RPM or http://www.mysql.com
17
18%define mysql_version           5.5.15
19%define client_version          18
20
21%if %{?_dist_release}!="vl5"
22%define libpkgname libmysqlclient%{client_version}
23%else
24%define libpkgname MySQL-shared
25%endif
26
27Packager:       tomop
28Name: MySQL
29Summary:        MySQL: a very fast and reliable SQL database server
30Version:        %{mysql_version}
31Release:        1%{_dist_release}
32
33Group:          Applications/Databases
34# exceptions allow client libraries to be linked with most open source SW,
35# not only GPL code.
36License:        GPLv2 with exceptions
37URL:            http://www.mysql.com/
38
39Source:         mysql-%{version}.tar.gz
40# Don't depend on lib::mtr*
41Source998:      perl-requires-%{name}.sh
42Patch0:         mysql-5.5.15-jp-all.patch
43
44# lib64 patch for vine
45Patch200:       pysql-5.1.44-lib64.patch
46
47BuildRoot:      %{_tmppath}/%{name}-%{version}-root
48BuildRequires:  perl, readline-devel, libaio-devel
49BuildRequires:  gcc-c++, ncurses-devel, zlib-devel, openssl-devel
50BuildRequires:  groff, cmake, bison
51Requires:       fileutils sh-utils
52Provides:       msqlormysql MySQL-server mysql
53Obsoletes:      mysql MySQL5
54
55# From the manual
56%description
57The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
58and robust SQL (Structured Query Language) database server. MySQL Server
59is intended for mission-critical, heavy-load production systems as well
60as for embedding into mass-deployed software. MySQL is a trademark of
61Sun Microsystems, Inc.
62
63Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
64Use is subject to license terms.
65
66This software comes with ABSOLUTELY NO WARRANTY. This is free software,
67and you are welcome to modify and redistribute it under the GPL license.
68
69The MySQL web site (http://www.mysql.com/) provides the latest
70news and information about the MySQL software. Also please see the
71documentation and the manual for more information.
72
73%package server
74Release: %{release}
75Summary:        MySQL: a very fast and reliable SQL database server
76Group:          Applications/Databases
77Requires:       fileutils sh-utils net-tools
78Provides:       msqlormysql mysql-server mysql MySQL MySQL5-server
79Obsoletes:      MySQL mysql mysql-server MySQL5-server MySQL-Max
80
81%description server
82The MySQL(TM) software delivers a very fast, multi-threaded, multi-user,
83and robust SQL (Structured Query Language) database server. MySQL Server
84is intended for mission-critical, heavy-load production systems as well
85as for embedding into mass-deployed software. MySQL is a trademark of
86Sun Microsystems, Inc.
87
88Copyright 2000-2008 MySQL AB, 2009 Sun Microsystems, Inc.  All rights reserved.
89Use is subject to license terms.
90
91This software comes with ABSOLUTELY NO WARRANTY. This is free software,
92and you are welcome to modify and redistribute it under the GPL license.
93
94The MySQL web site (http://www.mysql.com/) provides the latest
95news and information about the MySQL software. Also please see the
96documentation and the manual for more information.
97
98This package includes the MySQL server binary (incl. InnoDB) as well
99as related utilities to run and administrate a MySQL server.
100
101If you want to access and work with the database, you have to install
102package "MySQL-client" as well!
103
104%package client
105Summary: MySQL - Client
106Group: Applications/Databases
107Obsoletes: mysql-client MySQL5-client
108Provides: mysql-client MySQL5-client
109
110%description client
111This package contains the standard MySQL clients and administration tools.
112
113%{see_base}
114
115%package test
116Requires: %{name}-client = %{version}-%{release} perl-DBI perl
117Summary: MySQL - Test suite
118Group: Applications/Databases
119Obsoletes: mysql-bench MySQL5-bench MySQL-bench
120
121%description test
122This package contains the MySQL regression test suite.
123
124%{see_base}
125
126
127%package devel
128Summary: MySQL - Development header files and libraries
129Group: Development/Libraries
130Requires: %{libpkgname} = %{version}-%{release}
131Requires: openssl-devel, zlib-devel
132Provides: mysql-devel MySQL5-devel
133Obsoletes: mysql-devel MySQL5-devel
134
135%description devel
136This package contains the development header files and libraries
137necessary to develop MySQL client applications.
138
139%{see_base}
140
141%package -n %{libpkgname}
142Summary: The shared libraries required for MySQL clients
143Group: System Environment/Libraries
144%if %{?_dist_release}!="vl5"
145Obsoletes: MySQL-shared < %{version}
146%endif
147
148%description -n %{libpkgname}
149This package contains the shared libraries (*.so*) which certain
150languages and applications need to dynamically load and use MySQL.
151
152
153#%package embedded
154#Summary: MySQL as an embeddable library
155#Group: System Environment/Libraries
156#Obsoletes: mysql-embedded MySQL5-embedded
157#Provides: mysql-embedded MySQL5-embedded
158
159#%description embedded
160#MySQL is a multi-user, multi-threaded SQL database server. This
161#package contains a version of the MySQL server that can be embedded
162#into a client application instead of running as a separate process.
163
164#%{see_base}
165
166%package embedded-devel
167Summary: Development files for MySQL as an embeddable library
168Group: Development/Libraries
169Requires: %{name}-devel = %{version}-%{release}
170
171%description embedded-devel
172MySQL is a multi-user, multi-threaded SQL database server. This
173package contains files needed for developing and testing with
174the embedded version of the MySQL server.
175
176%{see_base}
177
178%prep
179%setup -q -n mysql-%{version}
180
181%patch0 -p1 -b .jp
182#%if %{_lib} == lib64
183#%patch200 -p0 -b .lib64
184#%endif
185#aclocal
186#autoheader
187#libtoolize --automake --force
188#automake --add-missing --copy
189#autoconf
190#perl -pi -e 's/-Werror"/"/' configure
191
192
193%build
194
195# Be strict about variables, bail at earliest opportunity, etc.
196set -eu
197
198# Optional package files
199touch optional-files-devel
200
201export PATH=${MYSQL_BUILD_PATH:-$PATH}
202export CC=${MYSQL_BUILD_CC:-${CC:-gcc}}
203export CXX=${MYSQL_BUILD_CXX:-${CXX:-gcc}}
204export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
205export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
206export LDFLAGS=${MYSQL_BUILD_LDFLAGS:-${LDFLAGS:-}}
207export CMAKE=${MYSQL_BUILD_CMAKE:-${CMAKE:-cmake}}
208export MAKE_JFLAG=${MYSQL_BUILD_MAKE_JFLAG:-}
209
210# Build full release
211mkdir release
212(
213  cd release
214  # XXX: MYSQL_UNIX_ADDR should be in cmake/* but mysql_version is included before
215  # XXX: install_layout so we can't just set it based on INSTALL_LAYOUT=RPM
216  ${CMAKE} ../ -DBUILD_CONFIG=mysql_release -DINSTALL_LAYOUT=RPM \
217           -DCMAKE_BUILD_TYPE=RelWithDebInfo \
218           -DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
219           -DFEATURE_SET="community" \
220           -DCOMPILATION_COMMENT="VineLinux MySQL RPM" \
221           -DMYSQL_SERVER_SUFFIX="%{server_suffix}" \
222           -DWITH_PIC="ON" \
223           -DWITH_ZLIB="system" \
224           -DWITH_EMBEDDED_SERVER="ON" \
225           -DWITH_SSL="yes"
226  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
227  make %{?_smp_mflags} VERBOSE=1
228)
229
230# Use the build root for temporary storage of the shared libraries.
231RBR=$RPM_BUILD_ROOT
232
233# Clean up the BuildRoot first
234[ "$RBR" != "/" ] && [ -d "$RBR" ] && rm -rf "$RBR";
235
236# For gcc builds, include libgcc.a in the devel subpackage (BUG 4921).  This
237# needs to be during build phase as $CC is not set during install.
238if "$CC" -v 2>&1 | grep '^gcc.version' >/dev/null 2>&1
239then
240  libgcc=`$CC $CFLAGS --print-libgcc-file`
241  if [ -f $libgcc ]
242  then
243    mkdir -p $RBR%{_libdir}/mysql
244#    install -m 644 $libgcc $RBR%{_libdir}/mysql/libmygcc.a
245#    echo "%{_libdir}/mysql/libmygcc.a" >>optional-files-devel
246  fi
247fi
248
249##############################################################################
250%install
251RBR=$RPM_BUILD_ROOT
252MBD=$RPM_BUILD_DIR/mysql-%{mysql_version}
253
254rm -rf $RBR
255
256# Ensure that needed directories exists
257install -d $RBR%{_sysconfdir}/{logrotate.d,init.d}
258install -d $RBR%{mysqldatadir}/mysql
259install -d $RBR%{_datadir}/mysql-test
260install -d $RBR%{_includedir}
261install -d $RBR%{_libdir}
262install -d $RBR%{_mandir}
263install -d $RBR%{_sbindir}
264
265# Install all binaries
266# Install all binaries
267(
268  cd $MBD/release
269  make DESTDIR=$RBR install
270)
271
272# Install logrotate and autostart
273install -m 644 $MBD/release/support-files/mysql-log-rotate $RBR%{_sysconfdir}/logrotate.d/mysql
274install -m 755 $MBD/release/support-files/mysql.server $RBR%{_sysconfdir}/init.d/mysql
275
276# Create a symlink "rcmysql", pointing to the init.script. SuSE users
277# will appreciate that, as all services usually offer this.
278ln -s %{_sysconfdir}/init.d/mysql $RBR%{_sbindir}/rcmysql
279
280# Touch the place where the my.cnf config file might be located
281# Just to make sure it's in the file list and marked as a config file
282touch $RBR%{_sysconfdir}/my.cnf
283
284# Remove man pages we explicitly do not want to package, avoids 'unpackaged
285# files' warning.
286rm -f $RBR%{_mandir}/man1/make_win_bin_dist.1*
287
288##############################################################################
289
290
291%pre server
292# Shut down a previously installed server first
293if test -x %{_sysconfdir}/init.d/mysql
294then
295  %{_sysconfdir}/init.d/mysql stop > /dev/null 2>&1
296  echo "Giving mysqld a couple of seconds to exit nicely"
297  sleep 5
298elif test -x %{_sysconfdir}/rc.d/init.d/mysql
299then
300  %{_sysconfdir}/rc.d/init.d/mysql stop > /dev/null 2>&1
301  echo "Giving mysqld a couple of seconds to exit nicely"
302  sleep 5
303fi
304
305%post server
306mysql_datadir=%{mysqldatadir}
307
308# Create data directory if needed
309if test ! -d $mysql_datadir; then mkdir -m 755 $mysql_datadir; fi
310if test ! -d $mysql_datadir/mysql; then mkdir $mysql_datadir/mysql; fi
311if test ! -d $mysql_datadir/test; then mkdir $mysql_datadir/test; fi
312
313# Make MySQL start/shutdown automatically when the machine does it.
314# use insserv for older SuSE Linux versions
315if test -x /sbin/insserv
316then
317        /sbin/insserv %{_sysconfdir}/init.d/mysql
318# use chkconfig on Red Hat and newer SuSE releases
319elif test -x /sbin/chkconfig
320then
321        /sbin/chkconfig --add mysql
322fi
323
324# Create a MySQL user and group. Do not report any problems if it already
325# exists.
326groupadd -r %{mysqld_group} 2> /dev/null || true
327useradd -M -r -d $mysql_datadir -s /bin/bash -c "MySQL server" -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
328# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
329usermod -g %{mysqld_group} %{mysqld_user} 2> /dev/null || true
330
331# Change permissions so that the user that will run the MySQL daemon
332# owns all database files.
333chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
334
335# Initiate databases if needed
336%{_bindir}/mysql_install_db --rpm --user=%{mysqld_user}
337
338# Upgrade databases if needed would go here - but it cannot be automated yet
339
340# Change permissions again to fix any new files.
341chown -R %{mysqld_user}:%{mysqld_group} $mysql_datadir
342
343# Fix permissions for the permission database so that only the user
344# can read them.
345chmod -R og-rw $mysql_datadir/mysql
346
347# Restart in the same way that mysqld will be started normally.
348%{_sysconfdir}/init.d/mysql start
349
350# Allow mysqld_safe to start mysqld and print a message before we exit
351sleep 2
352
353#echo "Thank you for installing the MySQL Community Server! For Production
354#systems, we recommend MySQL Enterprise, which contains enterprise-ready
355#software, intelligent advisory services, and full production support with
356#scheduled service packs and more.  Visit www.mysql.com/enterprise for more
357#information."
358
359%preun server
360if test $1 = 0
361then
362  # Stop MySQL before uninstalling it
363  if test -x %{_sysconfdir}/init.d/mysql
364  then
365    %{_sysconfdir}/init.d/mysql stop > /dev/null
366
367    # Remove autostart of mysql
368    # for older SuSE Linux versions
369    if test -x /sbin/insserv
370    then
371      /sbin/insserv -r %{_sysconfdir}/init.d/mysql
372    # use chkconfig on Red Hat and newer SuSE releases
373    elif test -x /sbin/chkconfig
374    then
375      /sbin/chkconfig --del mysql
376    fi
377  fi
378fi
379
380# We do not remove the mysql user since it may still own a lot of
381# database files.
382
383%post -n %{libpkgname}
384/sbin/ldconfig
385
386%postun -n %{libpkgname}
387/sbin/ldconfig
388
389# Clean up the BuildRoot
390%clean
391[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
392
393%files server
394%defattr(-,root,root,0755)
395
396%doc COPYING README
397%doc Docs/ChangeLog
398%doc Docs/INFO_SRC*
399%doc release/Docs/INFO_BIN*
400%doc release/support-files/my-*.cnf
401
402%doc %attr(644, root, root) %{_infodir}/mysql.info*
403
404%doc %attr(644, root, man) %{_mandir}/man1/innochecksum.1*
405%doc %attr(644, root, man) %{_mandir}/man1/my_print_defaults.1*
406%doc %attr(644, root, man) %{_mandir}/man1/myisam_ftdump.1*
407%doc %attr(644, root, man) %{_mandir}/man1/myisamchk.1*
408%doc %attr(644, root, man) %{_mandir}/man1/myisamlog.1*
409%doc %attr(644, root, man) %{_mandir}/man1/myisampack.1*
410%doc %attr(644, root, man) %{_mandir}/man1/mysql_convert_table_format.1*
411%doc %attr(644, root, man) %{_mandir}/man1/mysql_fix_extensions.1*
412%doc %attr(644, root, man) %{_mandir}/man8/mysqld.8*
413%doc %attr(644, root, man) %{_mandir}/man1/mysqld_multi.1*
414%doc %attr(644, root, man) %{_mandir}/man1/mysqld_safe.1*
415%doc %attr(644, root, man) %{_mandir}/man1/mysqldumpslow.1*
416%doc %attr(644, root, man) %{_mandir}/man1/mysql_install_db.1*
417%doc %attr(644, root, man) %{_mandir}/man1/mysql_secure_installation.1*
418%doc %attr(644, root, man) %{_mandir}/man1/mysql_setpermission.1*
419%doc %attr(644, root, man) %{_mandir}/man1/mysql_upgrade.1*
420%doc %attr(644, root, man) %{_mandir}/man1/mysqlhotcopy.1*
421%doc %attr(644, root, man) %{_mandir}/man1/mysqlman.1*
422%doc %attr(644, root, man) %{_mandir}/man1/mysql.server.1*
423%doc %attr(644, root, man) %{_mandir}/man1/mysqltest.1*
424%doc %attr(644, root, man) %{_mandir}/man1/mysql_tzinfo_to_sql.1*
425%doc %attr(644, root, man) %{_mandir}/man1/mysql_zap.1*
426%doc %attr(644, root, man) %{_mandir}/man1/mysqlbug.1*
427%doc %attr(644, root, man) %{_mandir}/man1/perror.1*
428%doc %attr(644, root, man) %{_mandir}/man1/replace.1*
429%doc %attr(644, root, man) %{_mandir}/man1/resolve_stack_dump.1*
430%doc %attr(644, root, man) %{_mandir}/man1/resolveip.1*
431
432%ghost %config(noreplace,missingok) %{_sysconfdir}/my.cnf
433
434%attr(755, root, root) %{_bindir}/innochecksum
435%attr(755, root, root) %{_bindir}/my_print_defaults
436%attr(755, root, root) %{_bindir}/myisam_ftdump
437%attr(755, root, root) %{_bindir}/myisamchk
438%attr(755, root, root) %{_bindir}/myisamlog
439%attr(755, root, root) %{_bindir}/myisampack
440%attr(755, root, root) %{_bindir}/mysql_convert_table_format
441%attr(755, root, root) %{_bindir}/mysql_fix_extensions
442%attr(755, root, root) %{_bindir}/mysql_install_db
443%attr(755, root, root) %{_bindir}/mysql_secure_installation
444%attr(755, root, root) %{_bindir}/mysql_setpermission
445%attr(755, root, root) %{_bindir}/mysql_tzinfo_to_sql
446%attr(755, root, root) %{_bindir}/mysql_upgrade
447%attr(755, root, root) %{_bindir}/mysql_zap
448%attr(755, root, root) %{_bindir}/mysqlbug
449%attr(755, root, root) %{_bindir}/mysqld_multi
450%attr(755, root, root) %{_bindir}/mysqld_safe
451%attr(755, root, root) %{_bindir}/mysqldumpslow
452%attr(755, root, root) %{_bindir}/mysqlhotcopy
453%attr(755, root, root) %{_bindir}/mysqltest
454%attr(755, root, root) %{_bindir}/perror
455%attr(755, root, root) %{_bindir}/replace
456%attr(755, root, root) %{_bindir}/resolve_stack_dump
457%attr(755, root, root) %{_bindir}/resolveip
458
459%attr(755, root, root) %{_sbindir}/mysqld
460%attr(755, root, root) %{_sbindir}/rcmysql
461%attr(755, root, root) %{_libdir}/mysql/plugin/*.so
462
463%attr(644, root, root) %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
464%attr(755, root, root) %{_sysconfdir}/init.d/mysql
465
466%attr(755, root, root) %{_datadir}/mysql/
467
468%files client
469%defattr(-, root, root, 0755)
470%attr(755, root, root) %{_bindir}/msql2mysql
471%attr(755, root, root) %{_bindir}/mysql
472%attr(755, root, root) %{_bindir}/mysql_find_rows
473%attr(755, root, root) %{_bindir}/mysql_waitpid
474%attr(755, root, root) %{_bindir}/mysqlaccess
475# XXX: This should be moved to %{_sysconfdir}
476%attr(644, root, root) %{_bindir}/mysqlaccess.conf
477%attr(755, root, root) %{_bindir}/mysqladmin
478%attr(755, root, root) %{_bindir}/mysqlbinlog
479%attr(755, root, root) %{_bindir}/mysqlcheck
480%attr(755, root, root) %{_bindir}/mysqldump
481%attr(755, root, root) %{_bindir}/mysqlimport
482%attr(755, root, root) %{_bindir}/mysqlshow
483%attr(755, root, root) %{_bindir}/mysqlslap
484
485%doc %attr(644, root, man) %{_mandir}/man1/msql2mysql.1*
486%doc %attr(644, root, man) %{_mandir}/man1/mysql.1*
487%doc %attr(644, root, man) %{_mandir}/man1/mysql_find_rows.1*
488%doc %attr(644, root, man) %{_mandir}/man1/mysql_waitpid.1*
489%doc %attr(644, root, man) %{_mandir}/man1/mysqlaccess.1*
490%doc %attr(644, root, man) %{_mandir}/man1/mysqladmin.1*
491%doc %attr(644, root, man) %{_mandir}/man1/mysqlbinlog.1*
492%doc %attr(644, root, man) %{_mandir}/man1/mysqlcheck.1*
493%doc %attr(644, root, man) %{_mandir}/man1/mysqldump.1*
494%doc %attr(644, root, man) %{_mandir}/man1/mysqlimport.1*
495%doc %attr(644, root, man) %{_mandir}/man1/mysqlshow.1*
496%doc %attr(644, root, man) %{_mandir}/man1/mysqlslap.1*
497
498%files devel -f optional-files-devel
499%defattr(-, root, root, 0755)
500%doc %attr(644, root, man) %{_mandir}/man1/comp_err.1*
501%doc %attr(644, root, man) %{_mandir}/man1/mysql_config.1*
502%attr(755, root, root) %{_bindir}/mysql_config
503%dir %attr(755, root, root) %{_includedir}/mysql
504%dir %attr(755, root, root) %{_libdir}/mysql
505%{_includedir}/mysql/*
506%{_datadir}/aclocal/mysql.m4
507%{_libdir}/*.so
508%exclude %{_libdir}/*.a
509
510%files -n %{libpkgname}
511%defattr(-, root, root, 0755)
512# Shared libraries (omit for architectures that don't support them)
513%{_libdir}/libmysql*.so.*
514#/etc/ld.so.conf.d/*
515
516%files test
517%defattr(-, root, root, 0755)
518%attr(-, root, root) %{_datadir}/mysql-test
519%attr(755, root, root) %{_bindir}/mysql_client_test
520%attr(755, root, root) %{_bindir}/mysql_client_test_embedded
521%attr(755, root, root) %{_bindir}/mysqltest_embedded
522%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test.1*
523%doc %attr(644, root, man) %{_mandir}/man1/mysql-stress-test.pl.1*
524%doc %attr(644, root, man) %{_mandir}/man1/mysql-test-run.pl.1*
525%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
526%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
527
528%files embedded-devel
529%defattr(-,root,root)
530#{_libdir}/libmysqld.a
531%{_bindir}/mysql_client_test_embedded
532%{_bindir}/mysqltest_embedded
533%doc %attr(644, root, man) %{_mandir}/man1/mysql_client_test_embedded.1*
534%doc %attr(644, root, man) %{_mandir}/man1/mysqltest_embedded.1*
535
536%changelog
537* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
538- new upstream release.
539- removed NDB cluster support.
540
541* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
542- Added "BR: zlib-devel" to MySQL-devel.
543
544* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
545- Added "BR: openssl-devel" to MySQL-devel.
546
547* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
548- new upstream release.
549
550* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
551- new upstream release.
552- updated jp-patch.
553- added ssl support.
554
555* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
556- new upstream release.
557- replaced '%%__find_requires' to '%%__perl_requires'.
558- updated jp-patch.
559
560* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
561- added mysql-5.1.44-lib64.patch (on x86_64)
562- added -fPIC (on x86_64)
563
564* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
565- made embedded package again
566
567* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
568- new upstream release.
569- updated jp-patch.
570
571* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
572- VineSeed: rebuilt with new toolchain.
573
574* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
575- new upstream release.
576  - fixed CVE-2009-4484.
577
578* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
579- new upstream release.
580
581* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
582- added net-tools to 'Requires'.
583- added groff to 'BuildRequires'.
584- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
585
586* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
587- new upstream release.
588
589* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
590- new upstream release.
591
592* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
593- new upstream release.
594- dropped %%Patch100 (fixed in upstream).
595
596* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
597- new upstream release.
598- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
599
600* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
601- new upstream release.
602- rename 'MySQL-bench' to 'MySQL-test'.
603- update Patch0.
604- change default charset to 'utf8'.
605
606* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
607- new upstream release.
608- update Patch0.
609- add "--with-client-charset=ujis".
610- sync %%files to official RPM.
611- remove MySQL-Max.
612
613* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
614- for VineSeed
615
616* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
617- move shared library from /usr/lib/ to /usr/lib/mysql/
618- add /etc/ld.so.conf.d/*.conf
619- fix broken libmysqlcient*.la files (or should we remove them permanently?)
620
621* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
622- rebuild <BTS:VineLinux:534>
623
624* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
625- added -fPIC
626
627* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
628- fixed dependency. <BTS:338>
629
630* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
631- add %%Patch1. <BTS:320>
632
633* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
634- new upstream release.
635
636* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
637- new upstream release.
638
639* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
640- new upstream release.
641
642* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
643- release++.
644
645* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
646- new upstream release.
647- for VineSeed.
648
649* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
650- new upstream release.
651- replace Patch0 for MySQL-4.1.16.
652
653* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
654- new upstream release.
655- add Patch0.
656
657* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
658- new upstream version
659        -- mysql-4.0.25
660
661* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
662- new upstream version
663        -- mysql-4.0.23
664
665* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
666- new upstream version
667        -- mysql-4.0.22
668 
669* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
670- new upstream version
671        -- mysql-4.0.21
672 
673* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
674- new upstream version
675        -- mysql-4.0.20
676 
677* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
678- modify CFLAGS, CXXFLAGS and configure options for alpha
679
680* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
681- Upgraded to MySQL-4
682- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
683- merged to MySQL Official packages
684        -- renamed package "MySQL" to "MySQL-server"
685        -- when using gcc, _always_ use CXX=gcc
686        -- replaced Copyright with License field (Copyright is obsolete)
687        -- added myisam_ftdump to the Server package
688        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
689        -- fixed file permissions (BUG 1672)
690        -- removed dependency on MySQL-client from the MySQL-devel subpackage
691        -- as it is not really required. (BUG 1610)
692        -- Fixed BUG 1162 (removed macro names from the changelog)
693        -- Really fixed BUG 998 (disable the checking for installed but
694        --  unpackaged files)
695        -- Fixed BUG 959 (libmysqld not being compiled properly)
696        -- Fixed BUG 998 (RPM build errors): added missing files to the
697        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
698        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
699        -- removed the GIF Icon (file was not included in the sources anyway)
700        -- removed unused variable shared_lib_version
701        -- do not run automake before building the standard binary
702        --  (should not be necessary)
703        -- add server suffix '-standard' to standard binary (to be in line
704        -- with the binary tarball distributions)
705        -- allow overriding CC and CXX (required when building
706        -- with other compilers)
707
708* Thu Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
709- added BuildRequires:  automake16
710                                                                               
711* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
712- add '-fPIC -DPIC' to CFLAGS on alpha
713- little fix of spec file
714                                                                               
715* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
716- enable MySQL-shared subpackage for alpha
717- delete 'BuildPrereq: kernel24-headers' for alpha
718- fix shared %files (exclude sparc)
719                                                                               
720* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
721- new upstream version
722                                                                               
723* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
724- fixed devel %files (dropped *.la files)
725                                                                               
726* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
727- new upstream version
728- fixed document permission
729                                                                               
730* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
731- new upstream version
732                                                                               
733* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
734- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
735        -- don't work
736                                                                               
737* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
738- new upstream version
739- diseble-assembler in configure on sparc,sparc64,alpha
740                                                                               
741* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
742- new upstream version
743- moved some man files to main package
744- added enable-local-infile in configure
745- changed --with-extra-charsets=all in configure
746                                                                               
747* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
748- fixed changelog
749                                                                               
750* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
751- updated to mysql-3.23.51
752                                                                               
753* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
754- rebuild on zlib-1.1.4(security fix.)
755                                                                               
756* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
757- updated to mysql-2.23.49
758                                                                               
759* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
760- add 'BuildPrereq: kernel24-headers' on alpha
761- remove shared library and max on alpha
762                                                                               
763* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
764- updated to mysql-3.23.48
765                                                                               
766* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
767- updated to mysql-3.23.47
768                                                                               
769* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
770- updated to mysql-3.23.46
771                                                                               
772* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
773- updated to mysql-3.23.45
774                                                                               
775* Tue Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
776- updated to mysql-3.23.44
777                                                                               
778* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
779- updated to mysql-3.23.43
780- removed shared library and max on sparc
781                                                                               
782* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
783- updated to mysql-3.23.42
784- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
785                                                                               
786* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
787- updated to mysql-3.23.41
788                                                                               
789* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
790- updated to mysql-3.23.40
791                                                                               
792* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
793- updated to mysql-3.23.39
794
795* Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
796- added configure --with-charset=ujis
797                                                                               
798* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
799- used some rpmmacro
800                                                                               
801* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
802- updated to MySQL-3.23.38
803                                                                               
804* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
805- removed Bench pakages
806                                                                               
807* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
808- removed pt_BR locale
809- build on Vine Linux
810- partially used rpmmacros
811- added %clean tag
812                                                                               
813* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
814- Added separate libmysql_r directory; now both a threaded
815  and non-threaded library is shipped.
816                                                                               
817* Wed Sep 28 1999 David Axmark <davida@mysql.com>
818- Added the support-files/my-example.cnf to the docs directory.
819- Removed devel dependency on base since it is about client
820  development.
821                                                                               
822* Wed Sep 8 1999 David Axmark <davida@mysql.com>
823- Cleaned up some for 3.23.
824                                                                               
825* Thu Jul 1 1999 David Axmark <davida@mysql.com>
826- Added support for shared libraries in a separate sub
827  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
828- The --enable-assembler switch is now automatically disables on
829  platforms there assembler code is unavailable. This should allow
830  building this RPM on non i386 systems.
831                                                                               
832* Mon Feb 22 1999 David Axmark <david@detron.se>
833- Removed unportable cc switches from the spec file. The defaults can
834  now be overridden with environment variables. This feature is used
835  to compile the official RPM with optimal (but compiler version
836  specific) switches.
837- Removed the repetitive description parts for the sub rpms. Maybe add
838  again if RPM gets a multiline macro capability.
839- Added support for a pt_BR translation. Translation contributed by
840  Jorge Godoy <jorge@bestway.com.br>.
841                                                                               
842* Wed Nov 4 1998 David Axmark <david@detron.se>
843- A lot of changes in all the rpm and install scripts. This may even
844  be a working RPM :-)
845                                                                               
846* Sun Aug 16 1998 David Axmark <david@detron.se>
847- A developers changelog for MySQL is available in the source RPM. And
848  there is a history of major user visible changed in the Reference
849  Manual.  Only RPM specific changes will be documented here.
850
Note: See TracBrowser for help on using the repository browser.