source: projects/specs/trunk/M/MySQL-ruby/MySQL-ruby-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define oname   mysql-ruby
2
3%define rbindir  %(ruby -r rbconfig -e 'print Config::CONFIG["bindir"]')
4%define rlibdir  %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
5%define rarchdir %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')
6%define rdatadir %(ruby -r rbconfig -e 'print Config::CONFIG["datadir"]')
7%define libdir   %(ruby -r rbconfig -e 'print Config::CONFIG["libdir"]')
8%define incdir   %(ruby -r rbconfig -e 'print Config::CONFIG["includedir"]')
9%define mandir   %(ruby -r rbconfig -e 'print Config::CONFIG["mandir"]')
10
11Summary: mysql module for Ruby
12Name: MySQL-ruby
13Version: 2.7.6
14Release: 2%{?_dist_release}
15License: distributable
16Group: Development/Libraries
17Source: http://www.tmtm.org/mysql/ruby/%{oname}-%{version}.tar.gz
18URL: http://www.tmtm.org/mysql/ruby/
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: ruby
21BuildRequires: ruby-devel >= 1.8.1
22BuildRequires: MySQL-devel
23Requires:      libruby >= 1.8.1
24Summary(ja): Ruby 用の MySQL 拡張モジュール
25
26%description
27This is MySQL Ruby API. This have same function as C API.
28
29%description -l ja
30これは MySQL の Ruby API です。MySQL の C API とほぼ同等の機能があります。
31
32%prep
33%setup -q -n %{oname}-%{version}
34
35%build
36ruby extconf.rb --with-mysql-config
37#  --with-mysql-include-dir=%{_includedir}/mysql \
38#  --with-mysql-lib-dir=%{_libdir}/mysql
39make
40
41%install
42rm -rf ${RPM_BUILD_ROOT}
43mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
44
45# installing binaries ...
46make install prefix=${RPM_BUILD_ROOT}%{prefix} \
47             sitedir=${RPM_BUILD_ROOT}%{_libdir}/ruby
48
49(find \
50  $RPM_BUILD_ROOT%{_libdir} \
51      -type f -o -type l) |
52 sort | sed -e "s,^$RPM_BUILD_ROOT,," > MySQL-ruby.files
53
54%clean
55rm -rf ${RPM_BUILD_ROOT}
56
57%pre
58
59%post
60
61%files -f MySQL-ruby.files
62%defattr(-, root, root)
63%doc README.html README_ja.html test.rb
64
65%changelog
66* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.6-2
67- rebuilt with MySQL-5.1.34.
68
69* Thu Sep 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7.6-1vl5
70- new upstream release
71- applied new versioning policy
72- spec in UTF-8
73- built with MySQL-5.0.51a and ruby-1.8.7
74- used --with-mysql-config at configure
75- removed BuildRequires: MySQL-shared
76
77* Wed Nov 22 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5-0vl3
78- rebuilt with MySQL 5.0.27
79
80* Tue Oct 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5-0vl2
81- rebuilt for Vine Linux 4.0
82
83* Wed Sep 1 2004 Takeyuki FUJIOKA <fuj@rabbix.jp> 2.5-0vl1
84- update mysql-ruby-2.5
85
86* Tue Aug 24 2004 Satoshi MACHINO <machino@vinelinux.org> 2.4.5-0vl1
87- new upstream version (mysql-ruby-2.4.5)
88- adde some defines for ruby in spec file
89- changed to use %%setup -q -n %{oname}-%{over}
90- added MySQL-shared in BuildRequires
91- build with ruby-1.8.1
92
93* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 2.4.2a-0vl2
94- added README.ja
95
96* Thu Apr 04 2002 Satoshi MACHINO <machino@vinelinux.org> 2.4.2a-0vl1
97- update mysql-ruby-2.4.2a
98- changed License tag from Copylight
99
100* Wed Jan 09 2002 Satoshi MACHINO <machino@vinelinux.org> 2.4.2-0vl1
101- update mysql-ruby-2.4.2
102- update BuildPreReq's ruby version to 1.6.6-0vl3
103
104* Mon Oct 15 2001 akira yamada <akira@redhat.com> 2.4-0vl1
105- new upstream version.
106- mysql-ruby-2.3.1-extconf.rb.patch is no longer needed.
107
108* Thu Jul 26 2001 akira yamada <akira@redhat.com>
109- rebuild with ruby-devel-1.6.4-0vl3.
110
111* Mon Apr 23 2001 akira yamada <akira@redhat.com>
112- new upsteram version 2.3.2a.
113
114* Mon Apr 23 2001 akira yamada <akira@redhat.com>
115- Initial packaging.
Note: See TracBrowser for help on using the repository browser.