source: projects/specs/trunk/M/MySQL-python/MySQL-python-vl.spec @ 9328

Revision 9328, 9.8 KB checked in by inagaki, 9 years ago (diff)

2015-02-04 Ryoichi INAGAKI <ryo1@…>

  • MySQL-python, kio-upnp-ms, kio_mtp, python-oauth python-urlgrabber: new package
  • amarok: updated


Line 
1%bcond_with debug
2
3Summary: An interface to MySQL
4Summary(ja): MySQL に対する python インターフェース
5Name: MySQL-python
6Version: 1.2.5
7Release: 2%{?_dist_release}
8License: GPLv2+
9Group: Development/Libraries
10URL: https://github.com/farcepest/MySQLdb1
11
12Source0: http://pypi.python.org/packages/source/M/%{name}/%{name}-%{version}.zip
13
14BuildRequires: python-devel python-setuptools
15BuildRequires: libmysqlclient-devel zlib-devel
16%if %{with debug}
17BuildRequires: python-debug
18%endif
19
20%description
21Python interface to MySQL
22
23MySQLdb is an interface to the popular MySQL database server for Python.
24The design goals are:
25
26-     Compliance with Python database API version 2.0
27-     Thread-safety
28-     Thread-friendliness (threads will not block each other)
29-     Compatibility with MySQL 3.23 and up
30
31This module should be mostly compatible with an older interface
32written by Joe Skinner and others. However, the older version is
33a) not thread-friendly, b) written for MySQL 3.21, c) apparently
34not actively maintained. No code from that version is used in MySQLdb.
35
36%if %{with debug}
37%package debug
38Summary:  An interface to MySQL, built for the CPython debug runtime
39Group:    Applications/System
40# Require the base package for the .py/.pyc files:
41Requires: MySQL-python%{_isa} = %{version}-%{release}
42
43%description debug
44Python interface to MySQL, built for the CPython debug runtime
45%endif # with debug
46
47%prep
48%setup -q -n %{name}-%{version}
49
50%build
51rm -f doc/*~
52export libdirname=%{_lib}
53CFLAGS="$RPM_OPT_FLAGS" python setup.py build
54%if %{with debug}
55CFLAGS="$RPM_OPT_FLAGS" python-debug setup.py build
56%endif
57
58%install
59rm -rf $RPM_BUILD_ROOT
60export libdirname=%{_lib}
61python setup.py install --root=$RPM_BUILD_ROOT
62#python setup.py install --root=$RPM_BUILD_ROOT ---record=INSTALLED_FILES
63%if %{with debug}
64python-debug setup.py install --root=$RPM_BUILD_ROOT
65%endif
66
67%check
68# You need MySQL (or MariaDB) running
69# and ~/.my.conf configured to have access rights
70#
71# cd tests/
72# python -m unittest test_MySQLdb_capabilities
73# python -m unittest test_MySQLdb_dbapi20
74# python -m unittest test_MySQLdb_nonstandard
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%doc README.md doc/*
81%dir %{python_sitearch}/MySQLdb
82%dir %{python_sitearch}/MySQLdb/constants
83%dir %{python_sitearch}/MySQL_python-%{version}-py2.7.egg-info
84%{python_sitearch}/MySQLdb/*.py*
85%{python_sitearch}/MySQLdb/constants/*.py*
86%{python_sitearch}/MySQL_python-%{version}-py2.7.egg-info/*
87%{python_sitearch}/*.py*
88%{python_sitearch}/*.so
89
90%if %{with debug}
91%files debug
92%{python_sitearch}/_mysql_d.so
93%endif
94
95%changelog
96* Tue Feb  3 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.2.5-2
97- Inital build for Vine Linux
98
99* Wed Jan 21 2015 Roman Rakus <roman@romanrakus.cz> - 1.2.5-1
100- Update to 1.2.5
101
102* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-13
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
104
105* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-12
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
107
108* Fri Mar  7 2014 Jakub Dorňák <jdornak@redhat.com> - 1.2.3-11
109- explain how to run the tests
110Resolves: #1073847
111
112* Mon Nov 11 2013 Jakub Dorňák <jdornak@redhat.com> - 1.2.3-10
113- added --without-debug option
114Related: #669835
115
116* Mon Nov 11 2013 Jakub Dorňák <jdornak@redhat.com> - 1.2.3-9
117- added debug subpackage
118Related: #669835
119
120* Mon Jul 29 2013 Honza Horak <hhorak@redhat.com> - 1.2.3-8
121- Spec file clean-up, use proper python paths
122
123* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-7
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
125
126* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-6
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
128
129* Sat Jul 14 2012 Tom Lane <tgl@redhat.com> 1.2.3-5
130- Fix failure to enable SSL support with mysql 5.5, per Matthias Runge
131
132* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-4
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
134
135* Tue Mar 22 2011 Tom Lane <tgl@redhat.com> 1.2.3-3
136- Rebuild for libmysqlclient 5.5.10 soname version bump
137
138* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-2
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
140
141* Fri Dec 24 2010 Tom Lane <tgl@redhat.com> 1.2.3-1
142- Update to final release of 1.2.3
143Resolves: #660484
144- Rebuild was needed anyway for mysql ABI break (no more libmysqlclient_r)
145
146* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.2.3-0.5.c1
147- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
148
149* Mon Nov 23 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.4.c1
150- Fix format mismatch in _mysql_ConnectionObject_kill
151Resolves: #538234
152
153* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.3-0.3.c1
154- rebuilt with new openssl
155
156* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-0.2.c1
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
158
159* Sun Jun 28 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.1.c1
160- Update to release candidate 1.2.3c1 for better mysql 5.1 and python 2.6
161  compatibility
162Resolves: #505611
163- Use python-setuptools instead of distutils, stop using old setup.py
164Resolves: #467510
165- Remove unnecessary manual Requires: specifications
166Resolves: #507750
167
168* Wed Apr 15 2009 Karsten Hopp <karsten@redhat.com> 1.2.2-11
169- bump release and rebuild for s390x
170
171* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-10
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
173
174* Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 1.2.2-9
175- Rebuild for mysql 5.1
176
177* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.2-8
178- Rebuild for Python 2.6
179
180* Thu Jun 19 2008 Tom Lane <tgl@redhat.com> 1.2.2-7
181- Fix broken escape() method
182Resolves: #331021
183
184* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-6
185- Autorebuild for GCC 4.3
186
187* Wed Dec  5 2007 Tom Lane <tgl@redhat.com> 1.2.2-5
188- Rebuild for new openssl
189
190* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 1.2.2-4
191- Update License tag to match code.
192
193* Tue Jul  3 2007 Tom Lane <tgl@redhat.com> 1.2.2-3
194- Ooops, previous fix for quoting bug was wrong, because it converted the
195  version_info tuple to a string in Python's eyes
196Resolves: #246366
197
198* Tue Jun 12 2007 Tom Lane <tgl@redhat.com> 1.2.2-2
199- Fix quoting bug in use of older setup.py: need to quote version_info now
200Resolves: #243877
201
202* Fri Apr 20 2007 Tom Lane <tgl@redhat.com> 1.2.2-1
203- Update to 1.2.2, but not 1.2.2 setup.py (since we don't ship setuptools yet)
204
205* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.1_p2-2
206- rebuild for python 2.5
207
208* Wed Dec  6 2006 Tom Lane <tgl@redhat.com> 1.2.1_p2-1
209- Update to 1.2.1_p2
210
211* Fri Jul 21 2006 Tom Lane <tgl@redhat.com> 1.2.1-1
212- Update to 1.2.1
213- Remove hardwired python version number in favor of asking Python
214
215* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2.1
216- rebuild
217
218* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2
219- rebump for build order issues during double-long bump
220
221* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.1
222- bump again for double-long bug on ppc(64)
223
224* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2
225- rebuilt for new gcc4.1 snapshot and glibc changes
226
227* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
228- rebuilt
229
230* Wed Nov  9 2005 Tom Lane <tgl@redhat.com> 1.2.0-3
231- Rebuild due to mysql 5.0 update and openssl library update.
232
233* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 1.2.0-2
234- package all python files. INSTALLED_FILES doesn't contain files created
235  by the brp-python-bytecompile script
236
237* Thu Apr 21 2005 Tom Lane <tgl@redhat.com> 1.2.0-1
238- Update to 1.2.0, per bug #155341
239- Link against mysql 4.x not 3.x, per bug #150828
240
241* Sun Mar  6 2005 Tom Lane <tgl@redhat.com> 1.0.0-3
242- Rebuild with gcc4.
243
244* Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-2
245- bring us to python 2.4
246
247* Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-1
248- update to 1.0.0; rebuild against mysqlclient10
249
250* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
251- rebuilt
252
253* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
254- rebuilt
255
256* Fri Feb 20 2004 Tom Lane <tgl@redhat.com>
257- reinstate (and update) patch for /usr/lib64 compatibility
258- rebuilt
259
260* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
261- rebuilt
262
263* Tue Nov 25 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.2-1
264- update to 0.9.2
265- remove patches (no longer applicable)
266
267* Sat Nov 15 2003 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-10
268- bring us to python 2.3
269
270* Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-9
271- rebuilt
272
273* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 0.9.1-8
274- rebuilt
275
276* Tue Mar 04 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-7
277- explicitly define the constants directory in case a more
278  restrictive umask is encountered (#74019)
279
280* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
281- rebuilt
282
283* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 0.9.1-5
284- lib64'ize
285
286* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
287- automated rebuild
288
289* Thu May 23 2002 Tim Powers <timp@redhat.com>
290- automated rebuild
291
292* Mon May 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-2
293- Build for newer python
294
295* Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-1
296- 0.9.1
297
298* Tue Feb 26 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-6
299- Rebuild
300
301* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 0.9.0-5
302- Change python conflicts to requires
303- Use pybasever/pynextver macros.
304
305* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
306- automated rebuild
307
308* Fri Sep 14 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-3
309- Build for Python 2.2
310
311* Mon Jul 23 2001 Trond Eivind Glomsrd <teg@redhat.com>
312- Add zlib-devel to buildrequires (#49788)
313
314* Tue Jun 19 2001 Trond Eivind Glomsrd <teg@redhat.com>
315- Initial build
Note: See TracBrowser for help on using the repository browser.