source: projects/specs/trunk/M/MySQL-mroonga/MySQL-mroonga-vl.spec @ 7160

Revision 7160, 6.2 KB checked in by tomop, 11 years ago (diff)

MySQL-mroonga-2.08-1

Line 
1%{!?use_system_mysql:%define use_system_mysql 0}
2
3%define mysql_base_version %{__mysql_base_version}
4%define mysql_version %{__mysql_version}
5%define mysql_release %{__mysql_release}
6
7%define groonga_required_version 2.0.8
8
9Name:           MySQL-mroonga
10Version:        2.08
11Release:        1%{?_dist_release}
12Summary:        A fast fulltext searchable storage engine for MySQL.
13
14Group:          Applications/Databases
15License:        LGPLv2.1
16URL:            http://mroonga.github.com/
17Source0:        http://github.com/downloads/mroonga/mroonga/mroonga-%{version}.tar.gz
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
20BuildRequires:  groonga-devel >= %{groonga_required_version}
21BuildRequires:  MySQL-source
22%if "%{?mysql_version}" != ""
23Requires:       mysqlserver-%{mysql_base_version}
24Requires:       mysqlclient-%{mysql_base_version}
25%endif
26Requires:       groonga-libs >= %{groonga_required_version}
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: tomop
31
32%description
33Mroonga is a fast fulltext searchable storage plugin for MySQL.
34It is based on groonga that is a fast fulltext search engine and
35column store. Groonga is good at real-time update.
36
37%package doc
38Summary:        Documentation for mroonga
39Group:          Documentation
40License:        LGPLv2.1
41
42%description doc
43Documentation for mroonga
44
45
46%prep
47%setup -q -n mroonga-%{version}
48
49%build
50mysql_source=%{_datadir}/MySQL-source/mysql-%{mysql_version}
51%configure --disable-static --with-mysql-source=${mysql_source} \
52    %{?mroonga_configure_options}
53make %{?_smp_mflags}
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install DESTDIR=$RPM_BUILD_ROOT
59rm $RPM_BUILD_ROOT%{_libdir}/mysql/plugin/*.la
60rm $RPM_BUILD_ROOT%{_libdir}/mysql/plugin/*groonga*
61mv $RPM_BUILD_ROOT%{_datadir}/doc/mroonga/ mysql-mroonga-doc/
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post
67if [ "$1" = 2 ] ; then
68    sql="
69    DROP FUNCTION last_insert_grn_id;
70    UNINSTALL PLUGIN mroonga;
71    FLUSH TABLES;
72    "
73    command="/usr/bin/mysql -u root -e \"$sql\""
74    echo $command
75    eval $command || \
76          (echo "run the following command to unregister mroonga:"; \
77           echo "  $command")
78fi
79sql="
80DELETE IGNORE FROM mysql.plugin WHERE name = 'mroonga';
81INSTALL PLUGIN mroonga SONAME 'ha_mroonga.so';
82CREATE FUNCTION last_insert_grn_id RETURNS INTEGER soname 'ha_mroonga.so';
83"
84command="/usr/bin/mysql -u root -e \"$sql\""
85echo $command
86eval $command || \
87        (echo "run the following command to register mroonga:"; \
88         echo "  $command")
89
90%preun
91if [ "$1" = 0 ]; then
92    sql="
93    DROP FUNCTION last_insert_grn_id;
94    UNINSTALL PLUGIN mroonga;
95    FLUSH TABLES;
96    "
97    command="/usr/bin/mysql -u root -e \"$sql\""
98    echo $command
99    eval $command || \
100          (echo "run the following command to unregister mroonga:"; \
101           echo "  $command")
102fi
103
104%files
105%defattr(-,root,root,-)
106%{_libdir}/mysql/plugin/
107%{_datadir}/man/man1/*
108%{_datadir}/man/*/man1/*
109
110%files doc
111%defattr(-,root,root,-)
112%doc README COPYING
113%doc mysql-mroonga-doc/*
114
115%changelog
116* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.08-1
117- new upstream release.
118
119* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.06-1
120- initial build for Vine Linux.
121
122* Wed Aug 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.06-0
123- new upstream release.
124- make MySQL spec file name customizable.
125- make mroonga configure options customizable.
126- add missing mysql-devel BuildRequires. Reported by wing. Thanks!!!
127- use MySQL 5.5.27.
128
129* Sun Jul 29 2012 HAYASHI Kentaro <hayashi@clear-code.com> - 2.05-0
130- new upstream release.
131- use MySQL 5.5.25a.
132
133* Fri Jun 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.04-0
134- new upstream release.
135- ensure deleting mroonga plugin before install.
136  Suggested by Kazuhiro Isobe. Thanks!!!
137- use MySQL 5.5.25.
138
139* Tue May 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.03-0
140- new upstream release.
141- use MySQL 5.5.24.
142- make mysql_* variables customizable
143- require groonga 2.0.3 or later.
144
145* Sun Apr 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.02-0
146- new upstream release.
147- use MySQL 5.5.23.
148- require groonga 2.0.2 or later.
149
150* Thu Mar 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.01-0
151- new upstream release.
152- ensure plugin is uninstalled by closing all tables use mroonga.
153
154* Wed Feb 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.00-0
155- new upstream release.
156- always install/uninstall plugin.
157- use MySQL 5.1.61 and 5.5.21.
158- require groonga 2.0.0 or later.
159
160* Sun Jan 29 2012 Kouhei Sutou <kou@clear-code.com> - 1.20-0
161- new upstream release.
162- require groonga 1.3.0.
163- groonga -> mroonga.
164- use MySQL 5.5.20.
165
166* Thu Dec 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.11-0
167- new upstream release.
168
169* Sat Oct 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.10-0
170- new upstream release.
171- groonga storage engine -> mroonga.
172
173* Thu Sep 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.0.0-0
174- new upstream release.
175
176* Mon Aug 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.9-0
177- new upstream release.
178
179* Fri Jul 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.8-0
180- new upstream release.
181
182* Wed Jun 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.7-0
183- new upstream release.
184
185* Sun May 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.6-0
186- new upstream release.
187
188* Thu May 17 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-2
189- use MySQL 5.5.12.
190
191* Thu Mar 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-1
192- new upstream release.
193
194* Sat Jan 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-4
195- do not remove plugin on upgrade.
196
197* Wed Jan 12 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-3
198- rebuild without debug symbol.
199
200* Thu Dec 30 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-2
201- use MySQL 5.5.8-1.
202- fix SQL literal notation.
203
204* Mon Nov 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-1
205- use the latest MySQL.
206- new upstream release.
207
208* Sun Nov 21 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-2
209- install user define function.
210
211* Fri Oct 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-1
212- new upstream release.
213
214* Fri Oct 08 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-2
215- specify target MySQL version.
216- use %{version}.
217
218* Wed Sep 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-1
219- new upstream release.
220
221* Wed Sep 12 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-3
222- require MySQL-client-community.
223
224* Fri Sep 10 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-2
225- use MySQL-devel-community.
226
227* Fri Sep 03 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-1
228- initial packaging for CentOS.
Note: See TracBrowser for help on using the repository browser.