source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 12145

Revision 12145, 13.9 KB checked in by tomop, 5 years ago (diff)

ModemManager?-1.10.4-1

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): モバイルブロードバンドモデム運用サービス
9Version: 1.10.4
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14Vendor:                 Project Vine
15Distribution:   Vine Linux
16#
17# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
18# tarball built with:
19#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
20#    make distcheck
21#
22#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
23
24Source: https://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
25
26Patch0: buildsys-hates-openpty.patch
27Patch1: ModemManager-1.8.2-elogind-1.patch
28
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: glib2-devel >= %{glib2_version}
32BuildRequires: libgudev-devel
33BuildRequires: elogind-devel
34BuildRequires: automake autoconf intltool libtool
35BuildRequires: gobject-introspection-devel
36BuildRequires: polkit-devel
37BuildRequires: gtk-doc
38# for xsltproc
39BuildRequires: libxslt
40Requires: dbus-glib
41
42%description
43The ModemManager service manages WWAN modems and provides a consistent API for
44interacting with these devices to client applications.
45
46
47%package        devel
48Summary:        Development tools for %{name}
49Summary(ja):    %{name} の開発環境
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52Requires:       pkgconfig
53
54%description    devel
55Header files and libraries for building a extension library for the %{name}.
56
57
58%package        glib
59Summary:        Libraries for adding ModemManager support to applications that use glib.
60Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
61Group:          System Environment/Libraries
62Requires:       glib2 >= %{glib2_version}
63
64%description    glib
65This package contains the libraries that make it easier to use some ModemManager
66functionality from applications that use glib.
67
68
69%package        glib-devel
70Summary:        Development tools for %{name}-glib
71Summary(ja):    %{name}-glib の開発環境
72Group:          Development/Libraries
73Requires:       %{name}-glib = %{version}-%{release}
74Requires:       %{name}-devel = %{version}-%{release}
75Requires:       glib2-devel
76Requires:       pkgconfig
77
78%description    glib-devel
79Header files and libraries for building a extension library for the %{name}-glib.
80
81%prep
82%setup -q
83%patch0 -p1 -b .pty
84%patch1 -p1 -b .elogind
85
86%build
87autoreconf -vif
88#pppddir=`ls -1d %{_libdir}/pppd/2*`
89%configure \
90        --disable-static \
91        --enable-gtk-doc=yes \
92        --enable-vala=no \
93        --enable-more-warnings=yes \
94        --with-udev-base-dir=/lib/udev \
95        --without-mbim \
96        --without-qmi \
97        --with-dist-version=%{version}-%{release} \
98        --with-elogind-suspend-resume=yes
99
100
101make %{?_smp_mflags}
102
103%check
104make check
105
106%install
107make install DESTDIR=$RPM_BUILD_ROOT
108
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
110#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
111
112%find_lang %{name}
113
114%post
115/sbin/ldconfig
116touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
117
118%postun
119/sbin/ldconfig
120if [ $1 -eq 0 ]; then
121  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
122  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
123fi
124
125%posttrans
126gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
127
128%post   glib -p /sbin/ldconfig
129%postun glib -p /sbin/ldconfig
130
131%files -f %{name}.lang
132%defattr(-,root, root,-)
133%doc COPYING README
134%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
135%{_libdir}/girepository-1.0/ModemManager-1.0.typelib
136%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
137%attr(0755,root,root) %{_sbindir}/ModemManager
138%attr(0755,root,root) %{_bindir}/mmcli
139%dir %{_libdir}/%{name}
140%attr(0755,root,root) %{_libdir}/%{name}/*.so*
141%dir %{_datadir}/%{name}
142%{_datadir}/%{name}/*
143/lib/udev/rules.d/*
144%{_datadir}/dbus-1/interfaces/*.xml
145%{_datadir}/icons/hicolor/22x22/apps/*.png
146%{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
147%{_mandir}/man1/*
148%{_mandir}/man8/*
149%dir %{_datadir}/bash-completion
150%dir %{_datadir}/bash-completion/completions
151%{_datadir}/bash-completion/completions/*
152
153%files devel
154%defattr(-,root,root,-)
155%{_includedir}/ModemManager/*.h
156%dir %{_datadir}/gtk-doc/html/%{name}
157%{_datadir}/gir-1.0/ModemManager-1.0.gir
158%{_datadir}/gtk-doc/html/%{name}/*
159%{_libdir}/pkgconfig/%{name}.pc
160
161%files glib
162%defattr(-,root,root,-)
163%{_libdir}/libmm-glib.so.*
164
165%files glib-devel
166%defattr(-,root,root,-)
167%{_libdir}/libmm-glib.so
168%dir %{_includedir}/libmm-glib
169%{_includedir}/libmm-glib/*.h
170%{_libdir}/pkgconfig/mm-glib.pc
171%dir %{_datadir}/gtk-doc/html/libmm-glib
172%{_datadir}/gtk-doc/html/libmm-glib/*
173
174
175%changelog
176* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
177- new upstream release.
178
179* Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
180- new upstream release.
181- added elogind support.
182
183* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
184- new upstream release.
185
186* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
187- new upstream release
188- change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
189
190* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
191- fix spec file
192
193* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
194- fix spec file
195
196* Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
197- new upstream release
198- add BuildRequires: gobject-introspection-devel, polkit-devel
199
200* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
201- new upstream release
202
203* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
204- new upstream release
205
206* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
207- new upstream release
208
209* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
210- new upstream release
211
212* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
213- new upstream release
214
215* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
216- moved ModemManager-glib to System Environment/Libraries Group
217- removed BR: ppp, ppp-devel and dbus-glib-devel
218
219* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
220- new upstream release
221- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
222
223* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
224- add Patch1 (ModemManager-1.0.0-git20130911.patch)
225
226* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
227- new upstream release
228- update Patch0
229
230* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
231- update to 0.7.991 snapshot
232- fix spec file based on FC package
233  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
234  - Update to 0.7.991 snapshot
235  - Fix SMS validity parsing
236  - Allow registration changes to 'searching' without disconnecting
237  - Fix reading SMS messages from some QMI-based devices
238  - Increase connection timeout for Novatel E362
239  - Fix PIN retries checking when unlocking Ericsson devices
240  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
241- add configure option (--enable-gtk-doc=yes, --without-qmi)
242
243* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
244- new upstream release
245
246* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
247- new upstream release
248
249* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
250- delete Patch20
251
252* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
253- update Patch20 (ModemManager-0.4-git20110428.patch)
254- delete Patch21,22
255
256* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
257- update to 0.4
258- add Patch20 (ModemManager-0.4-git20100720.patch)
259- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
260- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
261
262* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
263- initial build for Vine Linux
264
265* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
266- core: ignore some failures on disconnect (rh #578280)
267- core: add support for platform serial devices
268- gsm: better Blackberry DUN support
269- gsm: periodically poll access technology
270- cdma: prevent crash on modem removal (rh #571921)
271- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
272- novatel: better signal strength reporting on CDMA cards
273- novatel: add access technology and mode preference support on GSM cards
274- zte: fix mode preference retrieval
275- longcheer: add support for Zoom modems (4595, 4596, etc)
276- longcheer: add access technology and mode preference support
277
278* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
279- Silence %%post
280- Update scripts
281
282* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
283- gsm: fix parsing Blackberry supported character sets response
284
285* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
286- mbm: fix retrieval of current allowed mode
287- gsm: fix initialization issues with some devices (like Blackberries)
288
289* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
290- core: fix detection of some generic devices (rh #579247)
291- core: fix detection regression of some Huawei devices in 0.3-5
292- cdma: periodically poll registration state and signal quality
293- cdma: really fix registration detection on various devices (rh #569067)
294
295* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
296- core: fix PPC/SPARC/etc builds
297
298* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
299- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
300- cdma: handle signal quality requests while connected for more devices
301- cdma: handle serving system requests while connected for more devices
302- gsm: determine current access technology earlier
303- huawei: work around automatic registration issues on some devices
304
305* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
306- core: ensure enabled modems are disabled when MM stops
307- core: better capability detection for Blackberry devices (rh #573510)
308- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
309- gsm: don't block modem when it requires PIN2
310- option: fix access technology updates
311
312* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
313- mbm: add device IDs for C3607w
314- mbm: fail earlier during connection failures
315- mbm: fix username/password authentication when checked by the network
316- hso: implement asynchronous signal quality updates
317- option: implement asynchronous signal quality updates
318- novatel: correctly handle CDMA signal quality
319- core: basic PolicyKit support
320- core: fix direct GSM registration information requests
321- core: general GSM PIN/PUK unlock fixes
322- core: poll GSM registration state internally for quicker status updates
323- core: implement GSM 2G/3G preference
324- core: implement GSM roaming allowed/disallowed preference
325- core: emit signals on access technology changes
326- core: better handling of disconnections
327- core: fix simple CDMA status requests
328
329* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
330- core: startup speed improvements
331- core: GSM PIN checking improvements
332- huawei: fix EVDO-only connections on various devices (rh #553199)
333- longcheer: add support for more devices
334
335* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
336- anydata: new plugin for AnyData CDMA modems (rh #547294)
337- core: fix crashes when devices are unplugged during operation (rh #553953)
338- cdma: prefer primary port for status/registration queries
339- core: fix probing/detection of some PIN-locked devices (rh #551376)
340- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
341- gsm: fix Nokia N80 network scan parsing
342
343* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
344- core: fix apparent hangs by limiting retried serial writes
345- gsm: ensure modem state is reset when disabled
346
347* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
348- sierra: fix CDMA registration detection in some cases (rh #547513)
349
350* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
351- sierra: ensure CDMA device is powered up when trying to use it
352- cdma: better signal quality parsing (fixes ex Huawei EC168C)
353- zte: handle unsolicited messages better during probing
354
355* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
356- cdma: fix signal strength reporting on some devices
357- cdma: better registration state detection when dialing (ex Sierra 5275)
358- option: always use the correct tty for dialing commands
359
360* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
361- core: fix reconnect after manual disconnect (rh #541314)
362- core: fix various segfaults during registration
363- core: fix probing of various modems on big-endian architectures (ie PPC)
364- core: implement modem states to avoid duplicate operations
365- hso: fix authentication for Icera-based devices like iCON 505
366- zte: use correct port for new devices
367- nozomi: fix detection
368
369* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
370- Update to latest git
371- core: fix pppd 2.4.5 errors about 'baudrate 0'
372- cdma: wait for network registration before trying to connect
373- gsm: add cell access technology reporting
374- gsm: allow longer-running network scans
375- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
376- nokia: don't power down phones on disconnect
377- hso: fix disconnection/disable
378
379* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
380- Fixes for Motorola and Ericsson devices
381- Fixes for CDMA "serving-system" command parsing
382
383* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
384- Fix a typo in one of the udev rules files
385
386* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
387- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
388
389* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
390- Fix source repo location
391- Fix directory ownership
392
393* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
394- Initial version
395
Note: See TracBrowser for help on using the repository browser.