source: projects/specs/trunk/M/MAKEDEV/MAKEDEV-vl.spec @ 8191

Revision 8191, 7.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

RevLine 
[521]1Summary: A script for creating the device files in /dev.
2Summary(ja): /dev 以下のデバイスファイルを作成するスクリプト
3Name: MAKEDEV
4Version: 3.24
[8191]5Release: 4%{?_dist_release}
[521]6License: GPLv2
7Group: System Environment/Base
8URL: http://www.lanana.org/docs/device-list/
9
10Source: MAKEDEV-%{version}-1.tar.gz
11Source10: fedora-changelog
12Patch10: MAKEDEV-3.24-vine.patch
13
14BuildRoot: %{_tmppath}/%{name}-root
15Requires(pre): shadow-utils
16Requires(pre): sed, coreutils, mktemp
17
[3527]18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: daisuke
21
[521]22%description
23This package contains the MAKEDEV program, which makes it easier to create
24and maintain the files in the /dev directory.  /dev directory files
25correspond to a particular device supported by Linux (serial or printer
26ports, scanners, sound cards, tape drives, CD-ROM drives, hard drives,
27etc.) and interface with the drivers in the kernel.
28
29You should install the MAKEDEV package because the MAKEDEV utility makes
30it easy to manage the /dev directory device files.
31
32%description -l ja
33このパッケージには MAKEDEV スクリプトが含まれています。これは /dev ディレ
34クトリ以下のファイルを簡単に作成するものです。/dev ディレクトリのファイル
35は、それぞれ Linux がサポートしているデバイス (シリアル/プリンタポート、
36スキャナ、サウンドカード、テープデバイス、CD-ROM ドライブ、ハードディスク
37等) に対応しており、カーネルのドライバがこれらのファイルを介してデバイス
38にアクセスします。
39
40MAKEDEV ユーティリティは /dev ディレクトリ以下のデバイスファイルを簡単に
41作成すことができますので MAKEDEV パッケージをインストールしてください。
42
43%prep
44%setup -q
45%patch10 -p1 -b .vine
46cp %{SOURCE10} .
47
48%build
49%__make OPTFLAGS="$RPM_OPT_FLAGS"
50
51%install
52%__make install DESTDIR=$RPM_BUILD_ROOT devdir=/dev makedevdir=/sbin
53rm -f $RPM_BUILD_ROOT/dev/MAKEDEV
54
55%clean
56rm -fr $RPM_BUILD_ROOT
57
58%pre
59# Add the floppy group and the vcsa user.
60getent group floppy >/dev/null || groupadd -g 19 -r floppy
61getent passwd vcsa >/dev/null || \
62useradd -r -d /dev -s /sbin/nologin -u 69 \
63    -c "virtual console memory owner" vcsa
64exit 0
65
66%triggerpostun -- dev < 3.22
67if [ -x /sbin/MAKEDEV ]; then
68    /sbin/MAKEDEV null
69    /sbin/MAKEDEV console
70else
71    /bin/mknod /dev/null c 1 3
72    /bin/mknod /dev/console c 5 1
73fi
74if [ "$(/sbin/kernelversion)" == "2.4" ] ||
75   ( [ "$(/sbin/kernelversion)" == "2.6" ] &&
76     [ $(($(uname -r |cut -f1 -d-|cut -f3 -d.))) -lt 16 ] )
77then
78    mount --bind /.dev.static /dev ||:
79    if [ -x /sbin/pam_console_apply ] ; then
80        /sbin/pam_console_apply
81    fi
82fi
83
84%files
85%defattr(-,root,root)
86%doc COPYING devices-2.6+.txt fedora-changelog
87/sbin/MAKEDEV
88%{_mandir}/man8/*
89%{_sbindir}/mksock
90%config(noreplace) %{_sysconfdir}/makedev.d
91
92%changelog
[8191]93* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.24-4
94- rebuild with VineSeed environment
95
[3527]96* Sun Apr 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-3
97- rebuild for Vine 6
98
[521]99* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.24-2
100- rebuilt with new toolchain
101
102* Mon Mar 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-1
103- new upstream release
104- remove dev package.
105
106* Thu Oct 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.22-1vl5
107- applied new versioning policy, spec in utf-8
108
109* Thu Apr 05 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.22-0vl5
110- explicitly PreReq: coreutils instead of textutils and fileutils
111
112* Sun Aug 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl4
113- make vcsa/floppy device on MAKEDEV's %%pre script.
114
115* Wed Jul 19 2006 Shu KONNO <owa@bg.wakwak.com> 3.22-0vl3
116- rebuild for x86_64
117
118* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl2
119- make null/console device in triggerpostun scripts
120
121* Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl1
122- add dev subpackage for static device files.
123  - initscripts will mount /.dev.static to /dev
124    if kernel is not support udev.
125- import changes from FC
126
127* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.21-1vl1
128- update to 3.21-3 from FC
129
130* Sat May 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.3.13-1vl3
131- include /dev/mouse (a symlink to /dev/input/mice) in the dev package
132  please note this change (or revert) only applies to ppc archtecture
133
134* Wed May 12 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl2
135- do not make mount a symlink to input/mice on non-ppc architecture.
136- add "console" and "ptmx" to "generic" device
137- add dv1394 device
138- change linux1394 device owner from '$ROOT' to '$CONSOLE'.
139
140* Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl1
141- merged with fedora package
142  see %{_docdir}/%{name}-%{version}/fedora-changelog for detail.
143
144* Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
145- 2.5.2-1vl4
146- fix change log
147
148* Sun Nov 11 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
149- 2.5.2-1vl3
150- support /dev/hdi - hdt
151
152* Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
153- 2.5.2-1vl2
154- rebuild with new %%{_mandir} definition
155- added Japanese summary and description
156
157* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.5.2-1vl1
158- build with gcc-2.95.3
159- partially used rpmmacros
160
161* Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
162- add audioctl
163
164* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
165- make vbi a symlink to vbi0
166- make vtx a symlink to vtx0, use vtx from video4linux
167
168* Sat Apr 17 1999 Michael K. Johnson <johnsonm@redhat.com>
169- create version 2.5 with a great many devices added from the 2.2 kernel
170  devices.txt
171
172* Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
173- close bug #2157
174
175* Thu Mar 25 1999 Michael Johnson <johnsonm@redhat.com>
176- sg unification
177- nb devices
178
179* Thu Mar 25 1999 Jakub Jelinek <jj@ultra.linux.cz>
180- create correct /dev/console (c 5 1), support for SCSI
181  disk devices sdi - sddx
182
183* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
184- auto rebuild in the new build environment (release 9)
185
186* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
187- glibc 2.1
188
189* Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
190- build root
191
192* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
193- translations modified for de
194
195* Thu Apr 23 1998 Prospector System <bugs@redhat.com>
196- translations modified for fr, tr
197
198* Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
199- fixed group add script (had -r instead of -o)
200
201* Fri Apr 17 1998 Erik Troan <ewt@redhat.com>
202- put -o option on groupadd after -g -- I hope Christian can tell me why
203
204* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
205- redirect groupadd call so that we're more quiet
206
207* Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
208- 2.3.1: use /usr/sbin/groupadd from new shadow utils
209
210* Mon Sep 29 1997 Michael K. Johnson <johnsonm@redhat.com>
211- Updated to 2.3, as Nick agreed to me making an interim release while
212  he figures out whether he wants to be the maintainer.
213
214* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
215- made a noarch package
216
217* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
218- added dependencies
Note: See TracBrowser for help on using the repository browser.