source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 12286

Revision 12286, 30.2 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

Field3D-1.7.2-2

ImageMagick?-6.9.10.69-1

OpenColorIO-1.1.1-1

OpenEXR-2.4.0-1

OpenImageIO-2.0.11-1

babl-0.1.72-1

e2fsprogs-1.45.4-1

elfutils-0.177-1

gegl04-0.4.16-1

python3-3.5.7-5

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.10
5%define Patchlevel 69
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: inagaki, iwamoto
21
22License: freeware
23Group: Applications/Graphics
24URL: https://legacy.imagemagick.org/
25
26%if "%{Patchlevel}" != ""
27Source: https://imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
28%else
29Source: https://imagemagick.org/download/ImageMagick-%{version}.tar.xz
30%endif
31#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
32
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34BuildRequires: bzip2-devel
35BuildRequires: cairo-devel
36BuildRequires: pango-devel
37BuildRequires: freetype2-devel >= 2.1.7
38BuildRequires: fontconfig-devel
39BuildRequires: giflib-devel
40BuildRequires: graphviz-devel
41BuildRequires: lcms2-devel
42BuildRequires: libjpeg-turbo-devel
43BuildRequires: libpng-devel >= 1.2.5
44BuildRequires: librsvg2-devel
45BuildRequires: libtiff-devel
46BuildRequires: libxml2-devel
47BuildRequires: libSM-devel
48BuildRequires: libX11-devel
49BuildRequires: libXext-devel
50BuildRequires: OpenEXR-devel
51BuildRequires: perl
52BuildRequires: xorg-x11-server-utils
53BuildRequires: zlib-devel
54BuildRequires: libXt-devel
55BuildRequires: xz-devel
56BuildRequires: xz-lzma-compat
57BuildRequires: libtool-ltdl-devel
58
59Requires: bzip2
60Requires: freetype2
61Requires: giflib
62Requires: graphviz
63Requires: lcms2
64Requires: libjpeg-turbo
65Requires: libpng
66Requires: libtiff
67Requires: libxml2
68Requires: OpenEXR-libs
69Requires: xorg-x11-server-utils
70Requires: zlib
71
72
73%description
74ImageMagick(TM) is an image display and manipulation tool for the X
75Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
76and Photo CD image formats. It can resize, rotate, sharpen, color
77reduce, or add special effects to an image, and when finished you can
78either save the completed work in the original format or a different
79one. ImageMagick also includes command line programs for creating
80animated or transparent .gifs, creating composite images, creating
81thumbnail images, and more.
82
83ImageMagick is one of your choices if you need a program to manipulate
84and dis play images. If you want to develop your own applications
85which use ImageMagick code or APIs, you need to install
86ImageMagick-devel as well.
87
88
89%description -l ja
90ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
91ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
92イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
93出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
94オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
95また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
96サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
97
98画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
99も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
100アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
101インストールして下さい.
102
103%package devel
104Summary: Static libraries and header files for ImageMagick app development.
105Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
106Group: Development/Libraries
107Requires: ImageMagick = %{version}-%{release}
108
109%description devel
110Image-Magick-devel contains the static libraries and header files you'll
111need to develop ImageMagick applications. ImageMagick is an image
112manipulation program.
113
114If you want to create applications that will use ImageMagick code or
115APIs, you need to install ImageMagick-devel as well as ImageMagick.
116You do noy need to install it if you just want to use ImageMagick,
117however.
118
119%description devel -l ja
120ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
121これらは ImageMagick アプリケーションの開発の際に必要となります.
122ImageMagick は画像処理プログラムです.
123
124ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
125この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
126する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
127インストールする必要はありません.
128
129%package c++
130Summary: ImageMagick Magick++ library (C++ bindings)
131Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
132Group: System Environment/Libraries
133Requires: ImageMagick = %{version}-%{release}
134
135%description c++
136This package contains the Magick++ library, a C++ binding to the ImageMagick
137graphics manipulation library.
138
139Install ImageMagick-c++ if you want to use any applications that use Magick++.
140
141%description c++ -l ja
142このパッケージには Magick++ ライブラリが収められています.
143Magick++ とは ImageMagick ライブラリの C++ バインディングです.
144
145Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
146パッケージをインストールして下さい.
147
148%package c++-devel
149Summary: C++ bindings for the ImageMagick library
150Summary(ja): ImageMagick ライブラリの C++ バインディング
151Group: Development/Libraries
152Requires: ImageMagick = %{version}-%{release}
153Requires: ImageMagick-c++ = %{version}-%{release}
154Requires: ImageMagick-devel = %{version}-%{release}
155
156%description c++-devel
157ImageMagick-devel contains the static libraries and header files you'll
158need to develop ImageMagick applications using the Magick++ C++ bindings.
159ImageMagick is an image manipulation program.
160
161If you want to create applications that will use Magick++ code
162or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
163ImageMagick.
164You don't need to install it if you just want to use ImageMagick, or if you
165want to develop/compile applications using the ImageMagick C interface,
166however.
167
168%description c++-devel -l ja
169ImageMagick-c++-devel には Magick++ C++ バインディングを使った
170ImageMagick アプリケーション開発に必要なスタティックライブラリと
171ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
172
173Magick++ コードや API を使ったアプリケーションを開発する場合は,
174ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
175インストールする必要があります.
176ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
177を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
178インストールする必要はありません.
179
180%package -n perl-Image-Magick
181Summary: ImageMagick perl bindings
182Summary(ja): ImageMagick の Perl バインディング
183Group: Development/Libraries
184Requires: ImageMagick = %{version}-%{release}
185Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
186Obsoletes: ImageMagick-perl < %{version}-%{release}
187Provides: ImageMagick-perl = %{version}-%{release}
188
189%description -n perl-Image-Magick
190Perl bindings to ImageMagick.
191
192Install ImageMagick-perl if you want to use any perl scripts that use
193ImageMagick.
194
195%description -n perl-Image-Magick -l ja
196このパッケージは ImageMagick の Perl バインディングです.
197
198ImageMagick を利用する perl スクリプトを使いたい場合は
199ImageMagick-perl パッケージをインストールして下さい.
200
201
202%prep
203%setup -q -n %{name}-%{VER}-%{Patchlevel}
204
205#patch1 -p1 -b .CVE-2006-5456
206
207%build
208%configure \
209    --enable-silent-rules \
210    --enable-shared \
211    --disable-static \
212    --with-modules \
213    --with-quantum-depth=16 \
214    --without-frozenpaths \
215    --with-x \
216    --without-dps \
217    --without-djvu \
218    --without-fftw \
219    --without-jbig \
220    --without-jp2 \
221    --with-lcms2 \
222    --without-wmf \
223    --with-perl \
224    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
225
226# Disable rpath
227sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
228sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
229
230make %{?_smp_mflags}
231
232%install
233rm -rf $RPM_BUILD_ROOT
234
235make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
236
237# perlmagick: fix perl path of demo files
238%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
239
240find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
241find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
242find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
243
244echo "%defattr(-,root,root)" > perl-pkg-files
245find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
246sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
247
248# remove duplicated doc files
249rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
250rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
251
252# remove files conflict with libtools
253rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
254rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
255
256# remove *.la files
257# remove only %{_libdir}/*.la
258# If you have removed module-*/*/*.la, it will fail to execute the command.
259find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
260
261rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
262
263%clean
264rm -rf $RPM_BUILD_ROOT
265
266%post -p /sbin/ldconfig
267
268%post c++ -p /sbin/ldconfig
269
270%postun -p /sbin/ldconfig
271
272%postun c++ -p /sbin/ldconfig
273
274
275%files
276%defattr(-,root,root)
277%license LICENSE
278%doc www images
279%doc ChangeLog NOTICE QuickStart.txt README* NEWS.txt index.html
280%dir %{_libdir}/%{name}-%{VER}
281%dir %{_libdir}/%{name}-%{VER}/config-Q16
282%dir %{_libdir}/%{name}-%{VER}/modules-Q16
283%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
284%{_sysconfdir}/%{name}-6/*.xml
285%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
286%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
287%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
288%{_libdir}/libMagickCore-6.Q16.so.*
289%{_libdir}/libMagickWand-6.Q16.so.*
290%{_bindir}/[a-z]*
291%{_datadir}/%{name}-6/*.xml
292%{_mandir}/man1/ImageMagick.*
293%{_mandir}/man1/[a-z]*
294
295%files devel
296%defattr(-,root,root)
297%{_bindir}/Magick-config
298%{_bindir}/Wand-config
299%{_bindir}/MagickCore-config
300%{_bindir}/MagickWand-config
301%{_libdir}/libMagickCore-6.Q16.so
302%{_libdir}/libMagickWand-6.Q16.so
303%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
304%{_libdir}/pkgconfig/ImageMagick.pc
305%{_libdir}/pkgconfig/Wand-6.Q16.pc
306%{_libdir}/pkgconfig/Wand.pc
307%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
308%{_libdir}/pkgconfig/MagickCore.pc
309%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
310%{_libdir}/pkgconfig/MagickWand.pc
311%{_includedir}/ImageMagick-6/magick
312%{_includedir}/ImageMagick-6/wand
313%{_mandir}/man1/Magick-config*
314%{_mandir}/man1/Wand-config*
315%{_mandir}/man1/MagickCore-config*
316%{_mandir}/man1/MagickWand-config*
317
318%files c++
319%defattr(-,root,root)
320%{_libdir}/libMagick++-6.Q16.so.*
321
322%files c++-devel
323%defattr(-,root,root)
324%{_bindir}/Magick++-config
325%{_includedir}/ImageMagick-6/Magick++
326%{_includedir}/ImageMagick-6/Magick++.h
327%{_libdir}/libMagick++-6.Q16.so
328%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
329%{_libdir}/pkgconfig/ImageMagick++.pc
330%{_libdir}/pkgconfig/Magick++-6.Q16.pc
331%{_libdir}/pkgconfig/Magick++.pc
332%{_mandir}/man1/Magick++-config*
333
334%files -n perl-Image-Magick -f perl-pkg-files
335%defattr(-,root,root)
336%{_mandir}/man3/*
337
338%changelog
339* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.10.69-1
340- new upstream release.
341
342* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.8-2
343- rebuild with gcc-5.4.0
344
345* Thu Jun  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.4.8-1
346- new upstream release.
347
348* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.0-1
349- new upstream release
350  (including security fix for CVE-2016-3714,3715,3716,3717,3718,4562,4563,4564)
351
352* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.4-1
353- new upstream release
354
355* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.2-1
356- new upstream release
357
358* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.1-1
359- new upstream release
360
361* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
362- new upstream release
363- built with OpenEXR 2.2.0
364
365* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
366- new upstream release
367
368* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
369- new upstream release
370
371* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
372- new upstream release
373
374* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
375- new upstream release
376
377* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
378- new upstream release
379
380* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
381- new upstream release
382
383* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
384- new upstream release
385
386* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
387- new upstream release
388
389* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
390- new upstream release
391
392* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
393- new upstream release
394
395* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
396- new upstream release
397- add BuildRequires: pango-devel
398- change BuildRequires: lcms2-devel instead of lcms-devel
399
400* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
401- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
402
403* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
404- built with perl-5.12.3
405- changed perl subpackage name
406
407* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
408- new upstream release
409
410* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
411- rebuilt with graphviz-2.26.3 again
412
413* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
414- new upstream release
415- rebuilt with graphviz-2.26.3
416
417* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
418- new upstream release
419
420* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
421- rebuild with rpm-4.8.1 for pkg-config file
422- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
423- change Requires: libjpeg-turbo instead of libjpeg
424
425* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
426- new upstream release
427- built with new toolchain
428- added --disable-static to %%configure, removed static libraries
429
430* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
431- added --without-djvu --without-fftw
432
433* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
434- new upstream release
435
436* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
437- new upstream release
438
439* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
440- new upstream release
441- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
442- add R: graphviz, OpenEXR-libs, ilmbase
443
444* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
445- new upstream release
446- added Packager tag
447
448* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
449- new upstream release
450
451* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
452- new upstream release
453- updated BuildRequires
454
455* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
456- enabled lcms as default.
457
458* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
459- new upstream release
460
461* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
462- new upstream release
463
464* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
465- new upstream release
466
467* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
468- new upstream release
469
470* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
471- new upstream release
472- spec in UTF-8
473
474* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
475- enabled to build with lcms (use '--with lcms' to enable).
476
477* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
478- new upstream release
479- rebuilt with perl-5.10.0
480
481* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
482- new upstream release
483- removed *.la files from devel packages
484
485* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
486- new upstream release
487- change files section to fit new release
488- build under new versioning policy
489
490* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
491- new upstream release
492
493* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
494- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
495- add BuildPrereq: librsvg2-devel
496- add %{?_smp_mflags} to make command arg
497
498* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
499- new upstream release
500- changed Group to Applications/Graphics
501
502* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
503- rebuilt for VineSeed
504
505* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
506- update patch1 for fix CVE-2007-0770
507
508* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
509- upstream release
510- add patch1 for fix CVE-2006-5456
511
512* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
513- rebuilt (for ppc) to resolve reference to invalid *la files
514
515* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
516- new upstream release
517
518* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
519- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
520
521* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
522- new upstream release
523- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
524- add --with-perl-options to configure option
525
526* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
527- new upstream release
528- build with XOrg-6.9.0
529
530* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
531- new upstream release
532- add %%{_mandir}/man1/ImageMagick.* to main package
533
534* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
535- source upgrade
536- remove patch1
537- update %%files
538
539* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
540- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
541  (CAN-2004-0981)
542
543* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
544- move $(pkglibdir)/modules-Q16/*/*.la to main package.
545
546* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
547- source upgrade
548- Patch: change default menu font so display can work without XOrg-75dpi-fonts
549- add missing docs
550- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
551- *.pc should be in -devel package
552- add missing pkg{lib,data}dirs to %%files
553
554* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
555- source upgrade
556- add --without-dot to %%configure option
557- update %%files section
558
559* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
560- source upgrade
561
562* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
563- source upgrade
564
565* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
566- add --without-jbig to %%configure option
567
568* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
569- add --without-lcms to %%configure option
570
571* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
572- source upgrade
573- remove commented lines
574
575* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
576- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
577
578* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
579- source upgrade
580- remove patch for freetype2, no need
581- remove commented lines
582- add --with-quantum-depth=16 --with-modules --enable-lzw
583  --without-frozenpaths to %%configure option
584- remove --with-threads --without-xml from %%configure option
585- update %%files
586
587* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
588- patch update
589- add --without-jp2 to configure option
590- change PerlMagick build method
591
592* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
593- rebuild without jasper-devel
594
595* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
596- source upgrade to 5.5.7-15
597
598* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
599- source upgrade to 5.5.7-13
600- add patch0 to build against freetype2-2.1.7
601
602* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
603- source upgrade to 5.5.7-11
604- clean up spec
605- build without previous package (do not require libMagick.so.0)
606
607* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
608- source upgrade to 5.5.7-9
609- revised name of pkgconfig files
610- remove BuildPrereq: freetype-devel
611
612* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
613- source upgrade to 5.5.7-6
614- disable all patches
615- revised %%files section
616- disable libtoolize and autotools
617- change PerlMagick build method
618- build without previous package (do not require libMagick.so.5)
619
620* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
621- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
622  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
623
624* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
625- rebuild
626
627* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
628- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
629- FIXME: rpm's macro problem?
630
631- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
632  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
633
634  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
635  - remove unnecessary duplicated %%doc files
636  - --without-xml instead of --without-ttf
637  - eliminate libungif(-devel) from BuildReq/Requires
638  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
639
640  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
641  - add delegetes.mgk (and %%{_libdir}/%%{name})
642
643  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
644  - 5.2.9-0vl4
645  - Sorry, the spec was in Shift_JIS. Fixed.
646
647  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
648  - 5.2.9-0vl3
649  - rebuilt with perl-5.6.1
650  - added Japanese summary and description :-P
651  - added --without-ttf in order to disable freetype2 (SeedPlus) support
652  - added --without-wmf in order to disable libwmf (SeedPlus) support
653
654  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
655  - 5.2.9-0vl2
656  - rebuild on Perl-5.6
657  - use %%{perl_sitearch}
658  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
659
660  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
661  - 5.2.9-0vl1
662  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
663
664* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
665- fix perl paths in file list
666
667* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
668- lib64'ize
669- don't throw stuff in /usr/X11R6, that's for X only
670- remove files we aren't shipping
671
672* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
673- rebuilt with gcc-3.2 (we hope)
674
675* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
676- build using gcc-3.2-0.1
677
678* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
679- fix non-cpp headers in -devel package
680- fix #62157 (wrong path for include files in ImageMagick-devel)
681- fix #63897 (use _target instead of _arch) in libtool workaround
682- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
683
684* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
685- update
686- fix localdoc patch
687- fix %%files section
688- disable nonroot patch
689- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
690- fix libtool workaround
691- moved Magick*-config into -devel package (#64249)
692
693* Sun May 26 2002 Tim Powers <timp@redhat.com>
694- automated rebuild
695
696* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
697- 5.4.6
698
699* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
700- Update to pl 11
701
702* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
703- Update to 5.4.3 pl5; this fixes #58080
704
705* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
706- Patchlevel 3
707
708* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
709- automated rebuild
710
711* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
712- Update to 5.4.2-2
713- Fix #57923, also don't hardcode netscape as html viewer
714
715* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
716- 5.4.1
717- Link against new libstdc++
718
719* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
720- 5.4.0.5
721- Make the error message when trying to display an hpgl file more
722  explicit (#55875)
723
724* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
725- 5.4.0.3
726- Fix names of man pages
727
728* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
729- 5.4.0
730- work around build system breakage causing applications to be named
731  %{_arch}-redhat-linux-foo rather than foo
732
733* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
734- 5.3.9
735
736* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
737- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
738  (#52611)
739
740* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
741- Remove Magick++ includes from -devel, they're already in -c++-devel
742  (#51590)
743
744* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
745- 5.3.8 (bugfix release)
746
747* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
748- fix to build Perlmagic on s390 s390x
749
750* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
751- Add delegates.mgk to the package (#50725)
752
753* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
754- 5.3.7
755- Fix build without previously installed ImageMagick-devel (#49816)
756- Move perl bindings to a separate package.
757
758* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
759- Fix build as non-root again
760- Shut up rpmlint
761
762* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
763- 5.3.6
764- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
765
766* Sat Jun 16 2001 Than Ngo <than@redhat.com>
767- update to 5.3.5
768- cleanup specfile
769
770* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
771- 5.3.3-respin, fixes #41196
772
773* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
774- 5.3.3
775- Add a desktop file for "display" (RFE#17417)
776
777* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
778- 5.3.2
779- work around bugs in ia64 glibc headers
780
781* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
782- remove patch for s390, it is not necessary
783
784* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
785- 5.2.7
786
787* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
788- 5.2.6
789
790* Mon Dec 18 2000 Than Ngo <than@redhat.com>
791- ported to s390
792
793* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
794- 5.2.4
795- Fix up and package the C++ bindings in the new c++/c++-devel packages.
796
797* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
798- rebuild against new libpng
799
800* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
801- include images with docs (#10312)
802
803* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
804- don't build with -ggdb, use -g instead.
805
806* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
807- automatic rebuild
808
809* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
810- update to 5.2.2 beta
811
812* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
813- update to 5.2.1, redone patches as they failed
814
815* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
816- remove hacks to move perl man pages
817- don't include the perl*/man stuff, these files go in /usr/share/man now.
818
819* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
820- disable optimization on Alpha and Sparc
821
822* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
823- update to 5.2.0
824- update URL
825- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
826
827* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
828- bootstrap rebuilt to nuke broken libbz2 deps
829- add Prefix: tag such that the FHS macros work properly
830
831* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
832- now compiles with bzip2 1.0
833- changed buildroot to include version
834
835* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
836- fix compilation with new perl
837
838* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
839- 5.1.1
840
841* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
842- Rebuild to get compressed man pages
843
844* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
845- ugly hack to print with lpr instead of lp
846
847* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
848- update to 4.2.9
849
850* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
851- update to 4.2.8
852
853* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
854- include the perl man pages as well
855
856* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
857- remove --enable-16bit because it damages interoperability
858
859* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
860- update to 4.2.2
861- change ChangeLog to refer to actual dates.
862- strip binaries
863
864* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
865- add more files. Oops.
866
867* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
868- auto rebuild in the new build environment (release 2)
869
870* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
871- version 4.2.1
872
873* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
874- changed group
875
876* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
877- hacks to make it work with the new perl
878- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
879- make sure the libraries have the x bit on
880
881* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
882- translations modified for de, fr
883
884* Thu May 07 1998 Prospector System <bugs@redhat.com>
885- translations modified for de, fr, tr
886
887* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
888- updated to 4.0.5
889
890* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
891- updated to 4.0.4
892- added BuildRoot
893
894* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
895- updated from 3.8.3 to 3.9.1
896- removed PNG patch (appears to be fixed)
897
898* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
899- build against new libpng
900
901* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
902- built against glibc
903
904* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
905- updated to version 3.8.3.
906- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.