source: projects/specs/trunk/I/IIIMECF/IIIMECF-vl.spec @ 2750

Revision 2750, 4.6 KB checked in by munepi, 13 years ago (diff)

updated emacs, emacs24, wl, yatex, auctex, IIIMECF; added wl-beta; supported new vine-default

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define         origver         0.75
5%define         release         6%{?_dist_release}
6%define         emacs           emacs
7%define         origname        IIIMECF
8
9Summary:        Internet/Intranet Input Method Emacs Client Framework
10Summary(ja):    Emacs クライアント用 Internet/Intranet Input Method フレームワーク
11Name:           %{origname}
12Version:        %{origver}
13Release:        %{release}
14License:        GPL
15Group:          Applications/Editors/Emacs
16URL:            http://www.meadowy.org/~kawabata/iiimecf/
17#Source:                ftp://ftp.m17n.org/pub/mule/IIIM/%{origname}-%{version}.tar.gz
18Source:         http://www.meadowy.org/~kawabata/iiimecf/%{origname}-%{version}.tar.gz
19Source1:        %{origname}-install.sh
20Source2:        %{origname}-remove.sh
21Source3:        %{origname}-init.el
22Source4:        vine-default-%{origname}.el
23BuildArch:      noarch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26PreReq:        emacsen, gzip
27%prereq_ge     emacsen-common
28BuildRequires: emacsen-common
29## 0.7.5: Emacs 21 のみ Mule-UCS が必要です
30# PreReq:        Mule-UCS
31# Requires:      Mule-UCS
32
33#Packager:      Shoji Matsumoto <shom@vinelinux.org>
34Distribution:  Vine Linux
35Vendor:        Project Vine
36
37
38%description
39  IIIMECF conforms IIIM Protocol Specification defined by Sun Microsystems,
40and consists of a library to create IIIM awared applications and a simple
41input method library controlled by IIIM server(s).
42
43If you use IIIMECF on Emacs 21, Mule-UCS is required.
44
45%description -l ja
46  IIIMECFは、Sun Microsystems社の定めるIIIM Protocolに基づき、Emacs上で
47IIIM対応のapplicationを構築するためのlibraryと、それを用いた、Server sideで
48制御されるシンプルなInput Method libraryによって構成されています。
49
50Emacs 21 では Mule-UCS が必要です。
51
52%prep
53#% setup -n %{origname}-%{version}
54%setup -n iiimecf
55
56%__cp -a %{SOURCE3} %{SOURCE4} .
57
58%install
59[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
60[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
61
62%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{origname}
63%__mkdir_p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
64%__mkdir_p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
65
66cp -r *.el lisp ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
67
68#
69# install  script( bytecompile el and install elc , remove )   
70#
71
72%_installemacsenscript %{origname} %{SOURCE1}
73
74%_removeemacsenscript  %{origname} %{SOURCE2}
75
76%post
77#
78# bytecompile and install
79#
80
81if [ "$1" = 2 ]; then
82
83%_emacsenPackageRemove %{origname}
84
85fi
86
87%_addemacsenlist %{origname}
88
89%_emacsenPackageInstall %{origname}
90
91%preun
92
93if [ "$1" = 0 ]; then
94
95%_emacsenPackageRemove %{origname}
96
97%_removeemacsenlist %{origname}
98
99fi
100
101
102%clean
103[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
104
105
106%files
107%defattr(-,root,root)
108%doc COPYING*  ChangeLog* README* lisp
109
110%{_datadir}/emacs/site-lisp/%{origname}
111%{emacsen_pkgdir}/install/%{origname}
112%{emacsen_pkgdir}/remove/%{origname}
113
114
115%changelog
116* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.75-6
117- updated IIIMECF-init.el
118  - output "Loading vine-default-IIIMECF ..." to the buffer *Messages*
119- fixed some comments of vine-default-IIIMECF.el
120
121* Sat Jul 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-5
122- updated yatex-install.sh
123  - *-init.el: changed from hard copy to symbolic link
124    on /etc/emacs-XX.YY/site-start.d
125
126* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-4
127- fixed some STDOUT messages in IIIMECF-install.sh
128
129* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-3
130- updated vine-default-IIIMECF.el
131
132* Thu Apr 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-2
133- added vine-default-IIIMECF.el, IIIMECF-init.el
134- updated wl-install.sh for vine-default-wl.el
135
136* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-1
137- new upstream relase
138- spec in utf8
139- applied new versioning policy
140- added URL:
141- added some comments about Mule-UCS in %%description
142- dropped Requires: Mule-UCS and BuildRequires: Mule-UCS
143  - ONLY Emacs 21 needs Mule-UCS
144
145* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6-0vl5
146- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
147
148* Sat Jul 22 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6-0vl4
149- correct Summary <BTS:VineLinux:65>
150- add Summary(ja)
151- use License tag instead of CopyLight tag
152- change License from distibutable to GPL
153- rebuild for VineSeed (4.0)
154
155* Thu Nov 14 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.6-0vl2
156- add Prereq: gzip
157- Not Support xemacs-21.1.* in IIIMECF-install.sh
158
159* Fri Oct 04 2002 Tomoya TAKA <taka@vinelinux.org> 0.6-0vl1
160- add Prereq: Mule-UCS
161
162* Tue Aug 13 2002 Shoji Matsumoto <shom@vinelinux.org> 0.6-0vl0
163- created
Note: See TracBrowser for help on using the repository browser.