source: projects/specs/trunk/H/HelixPlayer/HelixPlayer-vl.spec @ 521

Revision 521, 11.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Open source media player based on the Helix framework
2Summary(ja): Helix ¥Õ¥ì¡¼¥à¥ï¡¼¥¯¤Ë´ð¤Å¤¯¥á¥Ç¥£¥¢¥×¥ì¥¤¥ä¡¼
3Name: HelixPlayer
4Version: 1.0.7
5Release: 6vl1
6Group: Applications/Multimedia
7License: RPSL, GPL
8URL: https://player.helixcommunity.org/
9Source0: https://helixcommunity.org/download.php/1950/hxplay-1.0.7-source.tar.bz2
10Source1: HelixPlayer-buildrc
11
12Obsoletes: G2player, RealOne
13Provides:  G2player, RealOne
14
15Patch0:         %{name}-1.0.beta20040615-cvs-no-update.patch
16Patch1:         %{name}-1.0.3-disable-asm.patch
17Patch2:         hxplay-1.0.4-nptl.patch
18Patch3:         %{name}-1.0.5-missing-header.patch
19Patch4:     HelixPlayer-1.0.7-ogg.patch
20Patch5:     HelixPlayer-1.0.7-CVE-2007-3410.patch
21
22BuildRequires: libtheora-devel >= 1.0-0.alpha3
23BuildRequires: libvorbis-devel
24BuildRequires: gtk2-devel python prelink
25BuildRequires: libogg-devel XOrg-devel
26BuildRequires: desktop-file-utils >= 0.9
27
28ExcludeArch: ppc64 x86_64 s390 s390x ia64
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31%description
32The Helix Player is an open-source media player built in the Helix
33Community for consumers. Built using GTK, it plays open source formats,
34like Ogg Vorbis and Theora using the powerful Helix DNA Client Media
35Engine.
36
37%description -l ja
38Helix Player ¤Ï Helix Community ¤ÇºîÀ®¤µ¤ì¤¿¥³¥ó¥·¥å¡¼¥Þ¸þ¤±¤Î
39¥ª¡¼¥×¥ó¥½¡¼¥¹¤Ê¥á¥Ç¥£¥¢¥×¥ì¥¤¥ä¡¼¤Ç¤¹¡¥GTK¤òÍøÍѤ·¤ÆºîÀ®¤µ¤ì¤Æ¤ª¤ê¡¤¶¯ÎϤÊ
40Helix DNA Client Media Engine ¤òÍøÍѤ·¤Æ Ogg Vorbis ¤ä Theora ¤Ê¤É¤Î
41¥ª¡¼¥×¥ó¥½¡¼¥¹¥Õ¥©¡¼¥Þ¥Ã¥È¤Î¥Õ¥¡¥¤¥ë¤ò±éÁÕ/±ÜÍ÷¤¹¤ë¤³¤È¤¬²Äǽ¤Ç¤¹¡¥
42
43%package plugin
44Summary:    HelixPlayer's webbrowser plugin
45Group:      Applications/Multimedia
46Requires:   %{name} = %{version}-%{release}
47Requires:   %{_libdir}/mozilla/plugins
48
49%description plugin
50This plugin lets your webbrowser play multimedia content through
51HelixPlayer
52
53
54%prep
55%setup -q -n hxplay-%{version}
56%patch0 -p1 -b cvs-no-update
57%patch1 -p1 -b .disable-asm
58%patch2 -p1 -b .nptl
59%patch3 -p1 -b .missing-header
60%patch4 -p0 -b .ogg
61%patch5 -p1 -b .CVE-2007-3410
62
63%build
64# Change hxplay_gtk_release to whatever string is in the Makefile
65BUILDRC=%{SOURCE1} BUILD_ROOT="`pwd`/build" \
66        PATH="$PATH:$$BUILD_ROOT/bin" \
67        python build/bin/build -v -t release -k -y \
68        %{?_smp_mflags} -m hxplay_gtk_release \
69        -p green -P helix-client-all-defines-free \
70        player_all
71
72chmod -x build/*.txt
73
74%install
75rm -rf %{buildroot}
76mkdir -p $RPM_BUILD_ROOT%{_bindir}
77
78cat > $RPM_BUILD_ROOT%{_bindir}/hxplay <<EOF
79#!/bin/sh
80HELIX_LIBS=%{_libdir}/helix
81export HELIX_LIBS
82exec %{_bindir}/hxplay.bin "\$@"
83EOF
84
85install -p -m 755 release/hxplay.bin %{buildroot}/%{_bindir}/
86chmod a+x %{buildroot}/%{_bindir}/*
87
88mkdir -p %{buildroot}/%{_libdir}/helix/common
89install -p -m 755 player/installer/archive/temp/common/*.so %{buildroot}/%{_libdir}/helix/common/
90mkdir -p %{buildroot}/%{_libdir}/helix/plugins
91install -p -m 755 player/installer/archive/temp/plugins/*.so %{buildroot}/%{_libdir}/helix/plugins/
92
93mkdir -p %{buildroot}/%{_libdir}/helix
94install -p -m 644 player/installer/archive/temp/LICENSE %{buildroot}/%{_libdir}/helix/
95install -p -m 644 player/installer/archive/temp/README %{buildroot}/%{_libdir}/helix/
96(cd %{buildroot}/%{_docdir}/%{name}-%{version} && ln -s %{_libdir/helix} .)
97
98mkdir -p %{buildroot}/%{_libdir}/helix/codecs
99install -p -m 755 player/installer/archive/temp/codecs/*.so %{buildroot}/%{_libdir}/helix/codecs/
100mkdir -p %{buildroot}/%{_libdir}/mozilla/plugins
101install -p -m 755 player/installer/archive/temp/mozilla/nphelix.so %{buildroot}/%{_libdir}/mozilla/plugins/
102install -p -m 644 player/installer/archive/temp/mozilla/nphelix.xpt %{buildroot}/%{_libdir}/mozilla/plugins
103mkdir -p %{buildroot}/%{_datadir}/application-registry/
104install -p -m 644 player/installer/common/hxplay.applications %{buildroot}/%{_datadir}/application-registry/
105# Desktop file
106mkdir -p %{buildroot}/%{_datadir}/applications/
107cp -p player/installer/common/hxplay.desktop player/installer/common/realplay.desktop
108desktop-file-install  --vendor vine \
109        --dir %{buildroot}%{_datadir}/applications \
110        --add-category X-Fedora \
111        player/installer/common/realplay.desktop
112
113mkdir -p %{buildroot}/%{_datadir}/mime-info/
114install -p -m 644 player/installer/common/hxplay.keys %{buildroot}/%{_datadir}/mime-info/
115install -p -m 644 player/installer/common/hxplay.mime %{buildroot}/%{_datadir}/mime-info/
116
117mkdir -p %{buildroot}/%{_libdir}/helix/share/hxplay
118(cd %{buildroot}/%{_libdir}/helix/share/ && ln -s %{_datadir}/icons/hicolor/48x48/apps/hxplay.png .)
119install -p -m 644 player/app/gtk/res/default/*.png %{buildroot}/%{_libdir}/helix/share/hxplay/
120install -p -m 644 player/app/gtk/res/hxplay/*.png %{buildroot}/%{_libdir}/helix/share/hxplay/
121
122for LANGUAGE in "de" "es" "fr" "it" "ja" "ko" "pt_BR" "zh_CN" "zh_TW"; do
123        dir=%{buildroot}/%{_datadir}/locale/$LANGUAGE/LC_MESSAGES/
124        mkdir -p $dir
125        install -p -m 644 "player/installer/archive/temp/share/locale/$LANGUAGE/player.mo" "$dir/hxplay.mo"
126        install -p -m 644 "player/installer/archive/temp/share/locale/$LANGUAGE/widget.mo" "$dir/libgtkhx.mo"
127done
128
129for SIZE in "16x16" "32x32" "48x48" "128x128" "192x192" ; do
130        mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$SIZE
131        mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$SIZE/apps
132        mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$SIZE/mimetypes
133
134        ICON=player/app/gtk/res/icons/hxplay/hxplay_${SIZE}.png
135        if [ -f "$ICON" ] ; then
136                mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/apps
137                install -p -m 644 "$ICON" %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/apps/hxplay.png
138        fi
139
140        for MIME in \
141                "application-ram"     \
142                "application-rpm"     \
143                "application-rm"      \
144                "audio-ra"            \
145                "video-rv" ; do
146
147                ICON=player/app/gtk/res/icons/hxplay/mime-${MIME}_${SIZE}.png
148                if [ -f "$ICON" ] ; then
149                        mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/mimetypes
150                        install -p -m 644 "$ICON" %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/mimetypes/hxplay-${MIME}.png
151                fi
152        done
153done
154
155# Hack to get rid of executable stack on shared object files
156execstack -c %{buildroot}/%{_libdir}/helix/codecs/colorcvt.so
157execstack -c %{buildroot}/%{_libdir}/helix/codecs/cvt1.so
158execstack -c %{buildroot}/%{_libdir}/helix/plugins/vidsite.so
159
160
161chmod -x %{buildroot}/%{_datadir}/application-registry/hxplay.applications
162chmod -x %{buildroot}/%{_datadir}/mime-info/hxplay.mime
163chmod -x %{buildroot}/%{_libdir}/helix/LICENSE
164chmod -x %{buildroot}/%{_datadir}/mime-info/hxplay.keys
165
166%{find_lang} hxplay
167%{find_lang} libgtkhx
168cat hxplay.lang > %{name}.lang
169cat libgtkhx.lang >> %{name}.lang
170
171%clean
172rm -rf $RPM_BUILD_ROOT
173
174%post
175update-desktop-database %{_datadir}/applications
176touch --no-create %{_datadir}/icons/hicolor || :
177%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
178
179%postun
180update-desktop-database %{_datadir}/applications
181touch --no-create %{_datadir}/icons/hicolor || :
182%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
183
184%files -f %{name}.lang
185%defattr(-,root,root)
186%doc build/*.txt
187%{_bindir}/hxplay*
188%{_libdir}/helix
189#{_libdir}/mozilla/plugins/*
190%{_datadir}/icons/hicolor/*
191%{_datadir}/mime-info/*
192%{_datadir}/applications/*.desktop
193%{_datadir}/application-registry/hxplay.applications
194#{_datadir}/locale/*/*
195
196%files plugin
197%defattr(-,root,root)
198%{_libdir}/mozilla/plugins/*
199
200
201%changelog
202* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-6vl1
203- new upstream release
204  * Thu Jun 28 2007 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-6
205  - fix bug 245838 (CVE-2007-3410)
206  * Fri Dec 08 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-5
207  - add patch to make ogg/vorbis work (bug 218896)
208  * Thu Sep 28 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-4
209  - fixes from bug 201006 comment 20
210  * Thu Sep 28 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-3
211  - split the webbrowser plugin
212  * Tue Sep 19 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-2
213  - added fixes from bug 201006 comment 2
214
215* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1vl1
216- new upstream release
217  * Tue Sep 27 2005 John (J5) Palmieri <johnp@redhat.com> - 1:1.0.6-1
218  - Fix for CAN-2005-2710
219  * Fri Jun 24 2005 Colin Walters <walters@redhat.com> 1:1.0.5-1
220  - New patch HelixPlayer-1.0.5-missing-header.patch
221
222* Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-4vl1
223- new upstream release
224  * Thu Mar 3 2005 Ray Strode <rstrode@redhat.com> 1:1.0.3-4
225  - Update to 1.0.3 to fix 150098 and 150103.
226  - Add some execshield foo to stop some execstack regressions
227  - Add libogg-devel build req to tame compiler
228  * Wed Jan 24 2005 Colin Walters <walters@redhat.com> 1:1.0.2-3
229  - Remove EULA from License field (there is no EULA AFAICS), and
230    add GPL
231  * Wed Jan 05 2005 Colin Walters <walters@redhat.com> 1:1.0.2-2
232  - Apply patch from ville.skytta@iki.fi to avoid
233    owning /usr/lib/mozilla (144237)
234  * Mon Jan 03 2005 Colin Walters <walters@redhat.com> 1:1.0.2-1
235  - New upstream version 1.0.2
236  - Switch to hxplay_gtk_stable branch
237
238* Sat Oct 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-1vl1
239- new upstream release
240- Drop upstreamed HelixPlayer-1.0.beta20040615-mmx-clobber.patch
241- Drop HelixPlayer-1.0.beta20040615-desktop.patch per request
242- Switch to bingo-gold target
243- added Japanese summary and description
244
245* Thu Sep  9 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0.298-3vl2
246- fixed %files section (Thanks to IWAI Masaharu)
247- added GPL and RPSL files into %doc
248
249* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0.298-3vl1
250- Build for Vine
251- changed version numberring
252
253* Mon Aug 23 2004 Colin Walters <walters@redhat.com> 1.0.gold-3
254- Install README and LICENSE
255
256* Fri Aug 06 2004 Colin Walters <walters@redhat.com> 1.0.gold-2
257- Put mozilla plugins in correct directory (#129305)
258
259* Mon Aug 02 2004 Colin Walters <walters@redhat.com> 1.0.gold-1
260- Update to gold
261- Use setup -n to set directory instead of repacking tarball
262- Switch bif target to bingo-gold-free
263
264* Thu Jul 29 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-6
265- Rework Summary a bit
266- Minor spec cleanups
267
268* Mon Jul 26 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-5
269- Add patch to port to GtkFileChooser
270- ExcludeArch ppc
271
272* Fri Jul 16 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-4
273- Restore MIME icon installation into hicolor directory
274
275* Fri Jul 16 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-3
276- Add patch to fix desktop file name
277- Set build failure color to "green" to exit on any error
278- Add smp_mflags variable for parallel building
279
280* Thu Jul 15 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-2
281- BR latest theora
282- More spec file bits
283- Install logo for real
284
285* Mon Jul 12 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-1
286- Some spec file cleanups
287
288* Mon Jun 8 2004 Ryan Gammon <rgammon@real.com>
289- Adding /usr/share/pixmap, document icons
290
291* Mon Jun 7 2004 Nicholas Hart <nhart@real.com>
292- added .mime/.keys/.applications files
293
294* Wed May 5 2004 Ryan Gammon <rggammon@helixcommunity.org>
295- Updating icons
296
297* Thu Jan 13 2004  Nicholas Hart <nhart@helixcommunity.org>
298- tweaked some paths to deal with tarball generated by player/installer/app
299- changed, reformatted some of the package info
300
301* Sat Dec 27 2003 Thomas Chung <tchung@linuxinstall.org> 0.2.0.0-20031224
302- First RPM build for Fedora Core 1
Note: See TracBrowser for help on using the repository browser.