source: projects/specs/trunk/G/GraphicsMagick/GraphicsMagick-vl.spec @ 11702

Revision 11702, 12.6 KB checked in by ara_t, 6 years ago (diff)

GraphicsMagick?: update to 1.3.29

Line 
1%define pkg_name    GraphicsMagick
2%define pkg_version 1.3.29
3%define pkg_release 1%{?_dist_release}
4
5%define quant 16
6%define perlm 1
7
8
9Name:        %{pkg_name}
10Summary:     An X application for displaying and manipulating images
11Summary(ja): 画像ファイルの表示/処理を行うXのアプリケーション
12Version:     %{pkg_version}
13Release:     %{pkg_release}
14
15License: MIT License
16Group:   Applications/Graphics
17URL:     http://www.graphicsmagick.org/
18# Source:  ftp://ftp.GraphicsMagick.org/pub/%{name}/%{name}-%{version}.tar.gz
19Source:  %{name}-%{version}.tar.xz
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: bzip2-devel
23BuildRequires: freetype2-devel >= 2.0.1
24BuildRequires: libjpeg-turbo-devel
25BuildRequires: libpng-devel >= 1.2.5
26BuildRequires: libtiff-devel
27BuildRequires: lcms-devel
28BuildRequires: xz-devel
29BuildRequires: libX11-devel
30BuildRequires: libxml2-devel
31BuildRequires: zlib-devel
32BuildRequires: libtool-ltdl-devel
33
34Requires: bzip2
35Requires: freetype2 >= 2.0.1
36Requires: libjpeg-turbo
37Requires: libpng
38Requires: libtiff
39Requires: lcms
40Requires: libxml2
41Requires: xz
42Requires: zlib
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: ara_t
47
48
49%description
50GraphicsMagick(TM) provides a powerful image manipulation and
51translation utility. It is capable of displaying still images and
52animations using the X Window system, provides a simple interface for
53interactively editing images, and is capable of importing selected
54windows or the entire desktop. GraphicsMagick can read and write over
5588 image formats, including JPEG, TIFF, WMF, SVG, PNG, PNM, GIF, and
56Photo CD. It can resize, rotate, sharpen, color reduce, or add special
57effects to the image and save the result to any supported format.
58GraphicsMagick may be used to create animated or transparent .gifs,
59create composite images, create thumbnail images, and much, much,
60more.
61
62GraphicsMagick is one of your choices if you need a program to manipulate
63and display images. If you want to develop your own applications
64which use GraphicsMagick code or APIs, you need to install
65GraphicsMagick-devel as well.
66
67%description -l ja
68GraphicsMagick(TM)はXウィンドウシステム用の画像表示/処理ツールです。
69GraphicsMagickが読み書き出来る画像形式にはJPEG, TIFF, PNM, GIF, Photo CD
70イメージ型式等があります。また画像のリサイズ、回転、シャープ化、減色が
71出来ますし、画像に対してイフェクトをかけることも出来ます、変更した画像は
72オリジナルと同じ画像形式ででも、異なる画像形式にでも保存することが出来ます。
73またGraphicsMagickにはアニメーションGIFや透過GIFの作成、画像の合成、
74サムネール画像の作成等々を行うコマンドラインプログラムも含まれています。
75
76画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば、
77GraphicsMagickも選択肢の一つとなるでしょう。
78また、GraphicsMagickのコードやAPIを使ったアプリケーションを開発したい場合は、
79GraphicsMagick-develパッケージも同時にインストールして下さい。
80
81%package  devel
82Summary:     Static libraries and header files for GraphicsMagick app development.
83Summary(ja): GraphicsMagickアプリケーション開発用ライブラリ/ヘッダファイル
84Group:    Development/Libraries
85Requires: %{name} = %{version}-%{release}
86
87%description devel
88GraphicsMagick-devel contains the static libraries and header files you'll
89need to develop GraphicsMagick applications. GraphicsMagick is an image
90manipulation program.
91
92If you want to create applications that will use GraphicsMagick code or
93APIs, you need to install GraphicsMagick-devel as well as GraphicsMagick.
94You do not need to install it if you just want to use GraphicsMagick,
95however.
96#'
97
98%description devel -l ja
99GraphicsMagick-develにはスタティックライブラリとヘッダファイルが収められており、
100これらはGraphicsMagickアプリケーションの開発の際に必要となります。
101GraphicsMagickは画像処理プログラムです。
102
103GraphicsMagickのコードやAPIを使ったアプリケーションを作りたい場合には、
104このGraphicsMagick-develパッケージをGraphicsMagickパッケージと共にインストール
105する必要があります。単にGraphicsMagickを使いたいだけならば、
106develパッケージはインストールする必要はありません。
107
108
109%package c++
110Summary:     GraphicsMagick Magick++ library (C++ bindings)
111Summary(ja): GraphicsMagick Magick++ライブラリ (C++バインディング)
112Group: System Environment/Libraries
113Requires: %{name} = %{version}-%{release}
114
115%description c++
116This package contains the Magick++ library, a C++ binding to the GraphicsMagick
117graphics manipulation library.
118
119Install GraphicsMagick-c++ if you want to use any applications that use
120Magick++.
121
122%description c++
123このパッケージにはMagick++ライブラリが収められています。
124Magick++とはImageMagickライブラリのC++バインディングです。
125
126Magick++を使ったアプリケーションを利用する際にはImageMagick-c++
127パッケージをインストールして下さい。
128
129
130%package c++-devel
131Summary:     C++ bindings for the GraphicsMagick library
132Summary(ja): GraphicsMagickライブラリのC++バインディング
133Group: Development/Libraries
134Requires: %{name} = %{version}
135Requires: %{name}-c++ = %{version}
136Requires: %{name}-devel = %{version}
137Requires: bzip2-devel, freetype-devel
138Requires: libjpeg-turbo-devel libpng-devel libtiff-devel
139Requires: zlib-devel libxml2-devel
140
141%description c++-devel
142GraphicsMagick-c++-devel contains the static libraries and header files you'll
143need to develop GraphicsMagick applications using the Magick++ C++ bindings.
144GraphicsMagick is an image manipulation program.
145
146If you want to create applications that will use Magick++ code or APIs,
147you'll need to install GraphicsMagick-c++-devel, GraphicsMagick-devel and
148GraphicsMagick.  You don't need to install it if you just want to use
149GraphicsMagick, or if you want to develop/compile applications using the
150GraphicsMagick C interface, however.
151#'
152
153%description c++-devel -l ja
154GraphicsMagick-c++-devel にはMagick++ C++バインディングを使った
155GraphicsMagickアプリケーション開発に必要なスタティックライブラリと
156ヘッダファイルが収められています。
157GraphicsMagickとは画像処理プログラムです。
158
159Magick++コードやAPIを使ったアプリケーションを開発する場合は、
160GraphicsMagick-c++-devel、GraphicsMagick-devel、GraphicsMagickパッケージを
161インストールする必要があります。
162GraphicsMagickプログラムを使うだけの場合、あるいはGraphicsMagick Cインタフェース
163を使ってアプリケーション開発を行う場合は,GraphicsMagick-c++-devel パッケージは
164インストールする必要はありません。
165
166
167%if %{perlm}
168%package -n perl-GraphicsMagick
169Summary:     GraphicsMagick perl bindings
170Summary(ja): GraphicsMagickのPerlバインディング
171Group: System Environment/Libraries
172BuildRequires: perl >= 5.6.0
173Requires: %{name} = %{version}-%{release}
174Requires: perl >= 5.6.0
175
176%description -n perl-GraphicsMagick
177Perl bindings to GraphicsMagick.
178
179Install GraphicsMagick-perl if you want to use any perl scripts that use
180GraphicsMagick.
181
182%description -n perl-GraphicsMagick -l ja
183このパッケージはGraphicsMagickのPerlバインディングです。
184
185GraphicsMagickを利用するperlスクリプトを使いたい場合は
186perl-GraphicsMagickパッケージをインストールして下さい。
187%endif
188
189
190%prep
191%{__rm} -rf ${RPM_BUILD_ROOT}
192%setup -q
193
194%build
195%{configure} \
196    --enable-silent-rules \
197    --enable-shared \
198    --disable-static \
199    --with-modules \
200    --with-quantum-depth=%{quant} \
201    --without-frozenpaths \
202    --with-x \
203    --with-magick-plus-plus \
204    --without-dps \
205    --without-fpx \
206    --without-gslib \
207    --without-jbig \
208    --without-jp2 \
209    --without-trio \
210    --without-webp \
211    --without-wmf \
212    --docdir=%{_datadir}/doc/%{name}-%{version} \
213%if %{perlm}
214    --with-perl \
215    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
216%else
217    --without-perl \
218%endif
219
220%{__make} %{?_smp_mflags}
221%if %{perlm}
222%{__make} all-perl
223%endif
224
225%install
226%{make_install}
227
228%if %{perlm}
229%{__make} install-exec-perl DESTDIR=${RPM_BUILD_ROOT}
230# Remove unpackaged files.
231%{__rm} -f `find ${RPM_BUILD_ROOT}%{_libdir}/perl*/ -name perllocal.pod -type f`
232%{__rm} -f `find ${RPM_BUILD_ROOT}%{_libdir}/perl*/ -name .packlist -type f`
233%endif
234
235%clean
236%{__rm} -rf ${RPM_BUILD_ROOT}
237
238%post -p %{_syssbindir}/ldconfig
239%postun -p %{_syssbindir}/ldconfig
240
241%post c++ -p %{_syssbindir}/ldconfig
242%postun c++ -p %{_syssbindir}/ldconfig
243
244
245%files
246%defattr(-,root,root)
247%{_bindir}/gm
248%{_libdir}/lib%{name}.so.*
249%{_libdir}/lib%{name}Wand.so.*
250%{_libdir}/%{name}-%{version}/
251%{_datadir}/%{name}-%{version}/config/*.mgk
252%{_docdir}/%{name}-%{version}/
253%{_mandir}/man1/gm.1.gz
254%{_mandir}/man4/*gz
255%{_mandir}/man5/*gz
256
257%files devel
258%defattr(-,root,root)
259%{_bindir}/%{name}-config
260%{_bindir}/%{name}Wand-config
261%{_includedir}/%{name}/wand/
262%{_includedir}/%{name}/magick/
263%{_libdir}/lib%{name}.*a
264%{_libdir}/lib%{name}.so
265%{_libdir}/lib%{name}Wand.*a
266%{_libdir}/lib%{name}Wand.so
267%{_libdir}/pkgconfig/%{name}.pc
268%{_libdir}/pkgconfig/%{name}Wand.pc
269%{_mandir}/man1/%{name}-config.1.gz
270%{_mandir}/man1/%{name}Wand-config.1.gz
271
272%files c++
273%defattr(-,root,root)
274%{_libdir}/lib%{name}++.so.*
275
276%files c++-devel
277%defattr(-,root,root)
278%{_bindir}/%{name}++-config
279%{_includedir}/%{name}/Magick++.h
280%{_includedir}/%{name}/Magick++/
281%{_libdir}/lib%{name}++.*a
282%{_libdir}/lib%{name}++.so
283%{_libdir}/pkgconfig/%{name}++.pc
284%{_mandir}/man1/%{name}++-config.1.gz
285
286%if %{perlm}
287%files -n perl-GraphicsMagick
288%defattr(-,root,root)
289%{_libdir}/perl*/vendor_perl/
290%{_mandir}/man3/*gz
291%endif
292
293
294%changelog
295* Mon Jun 04 2018 Toshiaki Ara <ara_t@384.jp> 1.3.29-1
296- update to 1.3.29
297
298* Tue Jun 28 2016 Toshiaki Ara <ara_t@384.jp> 1.3.24-2
299- rebuild with gcc-5.4.0
300
301* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.24-1
302- update to 1.3.24
303
304* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.23-2
305- correct SPEC file
306
307* Wed Mar 16 2016 Toshiaki Ara <ara_t@384.jp> 1.3.23-1
308- new package for Vine Linux
309
310* Fri Apr 16 2010 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3.13
311- Avoided duplicate copies of documentation files.  Put documentation
312  into a versioned directory as used by Red Hat and CentOS.  Include
313  archive libraries in developer package.
314
315* Tue Apr 13 2010 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3.13
316- Fixed PerlMagick build and install which was broken by Makefile
317  changes.
318
319* Wed Jan 23 2009 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3
320- The module .la files need to be installed as part of the base
321  install or else the modules will fail to load.
322
323* Wed Jan 21 2009 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3
324-  --enable-lzw option is not longer needed
325
326* Tue Nov 11 2008 Giacomo Tenaglia 1.3 <gtenagli at sf . net>.
327- The *-config scripts were listed twice.
328- Add definition for %{_datadir}/doc directory
329
330* Wed Jun 02 2004 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.2
331- Install *-config scripts with mode 755 rather than default 644.
332
333* Sat Feb 21 2004 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.1-1
334- Added some comments.
335- Eliminated DATE variable.
336- Support creating RPMs of snapshots packages.
337- Don't remove /usr/include/magick or %{_datadir}/%{name} since they
338  are not created anymore.
339- Fixed location of .mgk files.
340
341* Mon Jul 28 2003 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.1-1
342- Changed default quantum depth to 8 bits.
343
344* Mon Jun 28 2003 Troy Edwards <vallimar@sexorcisto.net> 1.1-20030628
345- Updated to CVS build, added the GraphicsMagickWand files to the spec.
346- Only try to remove the unneeded perl package files if we are using
347  PerlMagick.
348
349* Mon Jun 09 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-3
350- removed libungif as a dependancy
351- changed with/without-magick_plus_plus -> with/without-magick-plus-plus
352- Use --with-perl-options instead of patching Makefile.in
353- Only set a perl prefix if we aren't using perl >= 5.8.0
354
355* Sat Jun 07 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-2
356- patch to pass DESTDIR to install-exec-perl since some users
357  reported problems
358
359* Sat Jun 07 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-1
360- updated to 1.0.2
361
362* Tue May 05 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0-1
363- updated to 1.0 Final
364
365* Fri Apr 25 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0-Beta1-1
366- updated to 1.0-Beta1
367
368* Mon Oct 22 2002 Troy Edwards <vallimar@sexorcisto.net>
369- updated to 1.0.0pre
370
Note: See TracBrowser for help on using the repository browser.