source: projects/specs/trunk/G/GraphicsMagick/GraphicsMagick-vl.spec @ 10150

Revision 10150, 12.5 KB checked in by ara_t, 8 years ago (diff)

An X application for displaying and manipulating images

Line 
1%define pkg_name    GraphicsMagick
2%define pkg_version 1.3.23
3%define pkg_release 2%{?_dist_release}
4
5%define quant 16
6%define perlm 1
7
8
9Name:        %{pkg_name}
10Summary:     An X application for displaying and manipulating images
11Summary(ja): 画像ファイルの表示/処理を行うXのアプリケーション
12Version:     %{pkg_version}
13Release:     %{pkg_release}
14
15License: MIT License
16Group:   Applications/Graphics
17URL:     http://www.graphicsmagick.org/
18Source:  ftp://ftp.GraphicsMagick.org/pub/%{name}/%{name}-%{version}.tar.gz
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: bzip2-devel
22BuildRequires: freetype2-devel >= 2.0.1
23BuildRequires: libjpeg-turbo-devel
24BuildRequires: libpng-devel >= 1.2.5
25BuildRequires: libtiff-devel
26BuildRequires: lcms-devel
27BuildRequires: xz-devel
28BuildRequires: libX11-devel
29BuildRequires: libxml2-devel
30BuildRequires: zlib-devel
31BuildRequires: libtool-ltdl-devel
32
33Requires: bzip2
34Requires: freetype2 >= 2.0.1
35Requires: libjpeg-turbo
36Requires: libpng
37Requires: libtiff
38Requires: lcms
39Requires: libxml2
40Requires: xz
41Requires: zlib
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: ara_t
46
47
48%description
49GraphicsMagick(TM) provides a powerful image manipulation and
50translation utility. It is capable of displaying still images and
51animations using the X Window system, provides a simple interface for
52interactively editing images, and is capable of importing selected
53windows or the entire desktop. GraphicsMagick can read and write over
5488 image formats, including JPEG, TIFF, WMF, SVG, PNG, PNM, GIF, and
55Photo CD. It can resize, rotate, sharpen, color reduce, or add special
56effects to the image and save the result to any supported format.
57GraphicsMagick may be used to create animated or transparent .gifs,
58create composite images, create thumbnail images, and much, much,
59more.
60
61GraphicsMagick is one of your choices if you need a program to manipulate
62and display images. If you want to develop your own applications
63which use GraphicsMagick code or APIs, you need to install
64GraphicsMagick-devel as well.
65
66%description -l ja
67GraphicsMagick(TM)はXウィンドウシステム用の画像表示/処理ツールです。
68GraphicsMagickが読み書き出来る画像形式にはJPEG, TIFF, PNM, GIF, Photo CD
69イメージ型式等があります。また画像のリサイズ、回転、シャープ化、減色が
70出来ますし、画像に対してイフェクトをかけることも出来ます、変更した画像は
71オリジナルと同じ画像形式ででも、異なる画像形式にでも保存することが出来ます。
72またGraphicsMagickにはアニメーションGIFや透過GIFの作成、画像の合成、
73サムネール画像の作成等々を行うコマンドラインプログラムも含まれています。
74
75画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば、
76GraphicsMagickも選択肢の一つとなるでしょう。
77また、GraphicsMagickのコードやAPIを使ったアプリケーションを開発したい場合は、
78GraphicsMagick-develパッケージも同時にインストールして下さい。
79
80%package  devel
81Summary:     Static libraries and header files for GraphicsMagick app development.
82Summary(ja): GraphicsMagickアプリケーション開発用ライブラリ/ヘッダファイル
83Group:    Development/Libraries
84Requires: %{name} = %{version}-%{release}
85
86%description devel
87GraphicsMagick-devel contains the static libraries and header files you'll
88need to develop GraphicsMagick applications. GraphicsMagick is an image
89manipulation program.
90
91If you want to create applications that will use GraphicsMagick code or
92APIs, you need to install GraphicsMagick-devel as well as GraphicsMagick.
93You do not need to install it if you just want to use GraphicsMagick,
94however.
95#'
96
97%description devel -l ja
98GraphicsMagick-develにはスタティックライブラリとヘッダファイルが収められており、
99これらはGraphicsMagickアプリケーションの開発の際に必要となります。
100GraphicsMagickは画像処理プログラムです。
101
102GraphicsMagickのコードやAPIを使ったアプリケーションを作りたい場合には、
103このGraphicsMagick-develパッケージをGraphicsMagickパッケージと共にインストール
104する必要があります。単にGraphicsMagickを使いたいだけならば、
105develパッケージはインストールする必要はありません。
106
107
108%package c++
109Summary:     GraphicsMagick Magick++ library (C++ bindings)
110Summary(ja): GraphicsMagick Magick++ライブラリ (C++バインディング)
111Group: System Environment/Libraries
112Requires: %{name} = %{version}-%{release}
113
114%description c++
115This package contains the Magick++ library, a C++ binding to the GraphicsMagick
116graphics manipulation library.
117
118Install GraphicsMagick-c++ if you want to use any applications that use
119Magick++.
120
121%description c++
122このパッケージにはMagick++ライブラリが収められています。
123Magick++とはImageMagickライブラリのC++バインディングです。
124
125Magick++を使ったアプリケーションを利用する際にはImageMagick-c++
126パッケージをインストールして下さい。
127
128
129%package c++-devel
130Summary:     C++ bindings for the GraphicsMagick library
131Summary(ja): GraphicsMagickライブラリのC++バインディング
132Group: Development/Libraries
133Requires: %{name} = %{version}
134Requires: %{name}-c++ = %{version}
135Requires: %{name}-devel = %{version}
136Requires: bzip2-devel, freetype-devel
137Requires: libjpeg-turbo-devel libpng-devel libtiff-devel
138Requires: zlib-devel libxml2-devel
139
140%description c++-devel
141GraphicsMagick-c++-devel contains the static libraries and header files you'll
142need to develop GraphicsMagick applications using the Magick++ C++ bindings.
143GraphicsMagick is an image manipulation program.
144
145If you want to create applications that will use Magick++ code or APIs,
146you'll need to install GraphicsMagick-c++-devel, GraphicsMagick-devel and
147GraphicsMagick.  You don't need to install it if you just want to use
148GraphicsMagick, or if you want to develop/compile applications using the
149GraphicsMagick C interface, however.
150#'
151
152%description c++-devel -l ja
153GraphicsMagick-c++-devel にはMagick++ C++バインディングを使った
154GraphicsMagickアプリケーション開発に必要なスタティックライブラリと
155ヘッダファイルが収められています。
156GraphicsMagickとは画像処理プログラムです。
157
158Magick++コードやAPIを使ったアプリケーションを開発する場合は、
159GraphicsMagick-c++-devel、GraphicsMagick-devel、GraphicsMagickパッケージを
160インストールする必要があります。
161GraphicsMagickプログラムを使うだけの場合、あるいはGraphicsMagick Cインタフェース
162を使ってアプリケーション開発を行う場合は,GraphicsMagick-c++-devel パッケージは
163インストールする必要はありません。
164
165
166%if %{perlm}
167%package -n perl-GraphicsMagick
168Summary:     GraphicsMagick perl bindings
169Summary(ja): GraphicsMagickのPerlバインディング
170Group: System Environment/Libraries
171BuildRequires: perl >= 5.6.0
172Requires: %{name} = %{version}-%{release}
173Requires: perl >= 5.6.0
174
175%description -n perl-GraphicsMagick
176Perl bindings to GraphicsMagick.
177
178Install GraphicsMagick-perl if you want to use any perl scripts that use
179GraphicsMagick.
180
181%description -n perl-GraphicsMagick -l ja
182このパッケージはGraphicsMagickのPerlバインディングです。
183
184GraphicsMagickを利用するperlスクリプトを使いたい場合は
185perl-GraphicsMagickパッケージをインストールして下さい。
186%endif
187
188
189%prep
190%{__rm} -rf ${RPM_BUILD_ROOT}
191%setup -q
192
193%build
194%{configure} \
195    --enable-silent-rules \
196    --enable-shared \
197    --disable-static \
198    --with-modules \
199    --with-quantum-depth=%{quant} \
200    --without-frozenpaths \
201    --with-x \
202    --with-magick-plus-plus \
203    --without-dps \
204    --without-fpx \
205    --without-gslib \
206    --without-jbig \
207    --without-jp2 \
208    --without-trio \
209    --without-webp \
210    --without-wmf \
211    --docdir=%{_datadir}/doc/%{name}-%{version} \
212%if %{perlm}
213    --with-perl \
214    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
215%else
216    --without-perl \
217%endif
218
219%{__make} %{?_smp_mflags}
220%if %{perlm}
221%{__make} all-perl
222%endif
223
224%install
225%{make_install}
226
227%if %{perlm}
228%{__make} install-exec-perl DESTDIR=${RPM_BUILD_ROOT}
229# Remove unpackaged files.
230%{__rm} -f `find ${RPM_BUILD_ROOT}%{_libdir}/perl*/ -name perllocal.pod -type f`
231%{__rm} -f `find ${RPM_BUILD_ROOT}%{_libdir}/perl*/ -name .packlist -type f`
232%endif
233
234%clean
235%{__rm} -rf ${RPM_BUILD_ROOT}
236
237%post -p %{_syssbindir}/ldconfig
238%postun -p %{_syssbindir}/ldconfig
239
240%post c++ -p %{_syssbindir}/ldconfig
241%postun c++ -p %{_syssbindir}/ldconfig
242
243
244%files
245%defattr(-,root,root)
246%{_bindir}/gm
247%{_libdir}/lib%{name}.so.*
248%{_libdir}/lib%{name}Wand.so.*
249%{_libdir}/%{name}-%{version}/config/*.mgk
250%{_libdir}/%{name}-%{version}/modules-Q%{quant}/*/*.so
251%{_libdir}/%{name}-%{version}/modules-Q%{quant}/*/*.la
252%{_datadir}/%{name}-%{version}/config/*.mgk
253%{_docdir}/%{name}-%{version}/
254%{_mandir}/man1/gm.1.gz
255%{_mandir}/man4/*gz
256%{_mandir}/man5/*gz
257
258%files devel
259%defattr(-,root,root)
260%{_bindir}/%{name}-config
261%{_bindir}/%{name}Wand-config
262%{_includedir}/%{name}/wand/
263%{_includedir}/%{name}/magick/
264%{_libdir}/lib%{name}.*a
265%{_libdir}/lib%{name}.so
266%{_libdir}/lib%{name}Wand.*a
267%{_libdir}/lib%{name}Wand.so
268%{_libdir}/pkgconfig/%{name}.pc
269%{_libdir}/pkgconfig/%{name}Wand.pc
270%{_mandir}/man1/%{name}-config.1.gz
271%{_mandir}/man1/%{name}Wand-config.1.gz
272
273%files c++
274%defattr(-,root,root)
275%{_libdir}/lib%{name}++.so.*
276
277%files c++-devel
278%defattr(-,root,root)
279%{_bindir}/%{name}++-config
280%{_includedir}/%{name}/Magick++.h
281%{_includedir}/%{name}/Magick++/
282%{_libdir}/lib%{name}++.*a
283%{_libdir}/lib%{name}++.so
284%{_libdir}/pkgconfig/%{name}++.pc
285%{_mandir}/man1/%{name}++-config.1.gz
286
287%if %{perlm}
288%files -n perl-GraphicsMagick
289%defattr(-,root,root)
290%{_libdir}/perl*/vendor_perl/
291%{_mandir}/man3/*gz
292%endif
293
294
295%changelog
296* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.23-2
297- correct SPEC file
298
299* Wed Mar 16 2016 Toshiaki Ara <ara_t@384.jp> 1.3.23-1
300- new package for Vine Linux
301
302* Fri Apr 16 2010 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3.13
303- Avoided duplicate copies of documentation files.  Put documentation
304  into a versioned directory as used by Red Hat and CentOS.  Include
305  archive libraries in developer package.
306
307* Tue Apr 13 2010 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3.13
308- Fixed PerlMagick build and install which was broken by Makefile
309  changes.
310
311* Wed Jan 23 2009 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3
312- The module .la files need to be installed as part of the base
313  install or else the modules will fail to load.
314
315* Wed Jan 21 2009 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3
316-  --enable-lzw option is not longer needed
317
318* Tue Nov 11 2008 Giacomo Tenaglia 1.3 <gtenagli at sf . net>.
319- The *-config scripts were listed twice.
320- Add definition for %{_datadir}/doc directory
321
322* Wed Jun 02 2004 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.2
323- Install *-config scripts with mode 755 rather than default 644.
324
325* Sat Feb 21 2004 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.1-1
326- Added some comments.
327- Eliminated DATE variable.
328- Support creating RPMs of snapshots packages.
329- Don't remove /usr/include/magick or %{_datadir}/%{name} since they
330  are not created anymore.
331- Fixed location of .mgk files.
332
333* Mon Jul 28 2003 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.1-1
334- Changed default quantum depth to 8 bits.
335
336* Mon Jun 28 2003 Troy Edwards <vallimar@sexorcisto.net> 1.1-20030628
337- Updated to CVS build, added the GraphicsMagickWand files to the spec.
338- Only try to remove the unneeded perl package files if we are using
339  PerlMagick.
340
341* Mon Jun 09 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-3
342- removed libungif as a dependancy
343- changed with/without-magick_plus_plus -> with/without-magick-plus-plus
344- Use --with-perl-options instead of patching Makefile.in
345- Only set a perl prefix if we aren't using perl >= 5.8.0
346
347* Sat Jun 07 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-2
348- patch to pass DESTDIR to install-exec-perl since some users
349  reported problems
350
351* Sat Jun 07 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-1
352- updated to 1.0.2
353
354* Tue May 05 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0-1
355- updated to 1.0 Final
356
357* Fri Apr 25 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0-Beta1-1
358- updated to 1.0-Beta1
359
360* Mon Oct 22 2002 Troy Edwards <vallimar@sexorcisto.net>
361- updated to 1.0.0pre
362
Note: See TracBrowser for help on using the repository browser.