source: projects/specs/trunk/G/GeoIP/GeoIP-vl.spec @ 9005

Revision 9005, 6.4 KB checked in by inagaki, 10 years ago (diff)

2014-10-12 Ryoichi INAGAKI <ryo1@…>

  • GeoIP: rebuild
  • OpenIPMI, nasm, yasm: update


Line 
1%define geoipupadte_ver 2.0.0
2
3Name: GeoIP
4Summary: C library for country/city/organization to IP address or hostname mapping
5Summary(ja): 国/都市/組織と IP アドレス/ホスト名とのマッピングを取るための C ライブラリ
6Version: 1.6.0
7Release: 2%{?_dist_release}
8
9Group: System Environment/Libraries
10License: GPLv2+ and LGPLv2+
11URL: http://www.maxmind.com/app/c
12
13Source0: https://github.com/maxmind/geoip-api-c/releases/download/v%{version}/GeoIP-%{version}.tar.gz
14Source1: https://github.com/maxmind/geoipupdate/releases/download/v%{geoipupadte_ver}/geoipupdate-%{geoipupadte_ver}.tar.gz
15Source2: LICENSE.txt
16Source3: fetch-geoipdata-city.pl
17Source4: fetch-geoipdata.pl
18Source5: README.Fedora
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildRequires: curl-devel
22BuildRequires: zlib-devel
23Obsoletes: geoip < %{version}-%{release}
24Provides: geoip = %{version}-%{release}
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: tomop
29
30%description
31GeoIP is a C library that enables the user to find the country that any IP
32address or hostname originates from. It uses a file based database that is
33accurate as of March 2003. This database simply contains IP blocks as keys, and
34countries as values. This database should be more complete and accurate than
35using reverse DNS lookups.
36
37%package devel
38Summary: Development headers and libraries for GeoIP
39Summary(ja): GeoIP の開発用ヘッダファイル及びライブラリ
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Provides: geoip-devel = %{version}-%{release}
43Obsoletes: geoip-devel < %{version}-%{release}
44
45%description devel
46Development headers and libraries for building GeoIP-based applications
47
48%prep
49%setup -q -a 1
50install -D -m644 %{SOURCE2} LICENSE.txt
51install -D -m644 %{SOURCE3} fetch-geoipdata-city.pl
52install -D -m644 %{SOURCE4} fetch-geoipdata.pl
53install -D -m644 %{SOURCE5} README.fedora
54
55%build
56autoreconf -ivf
57%configure --disable-static --disable-dependency-tracking
58make %{?_smp_mflags}
59
60pushd geoipupdate-%{geoipupadte_ver}
61./bootstrap
62%configure
63make %{?_smp_mflags}
64popd
65
66%install
67rm -rf %{buildroot}
68make DESTDIR=%{buildroot} install
69
70# nix the stuff we don't need like .la files.
71rm -f %{buildroot}%{_libdir}/*.la
72
73mkdir -p %{buildroot}%{_datadir}/GeoIP
74
75
76pushd geoipupdate-%{geoipupadte_ver}
77make DESTDIR=%{buildroot} install
78popd
79
80mkdir -p geoipupdate
81cp -f geoipupdate-%{geoipupadte_ver}/{ChangeLog.md,LICENSE,README.md} ./geoipupdate/
82
83%clean
84rm -rf %{buildroot}
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root,-)
92%doc AUTHORS COPYING ChangeLog README.* TODO INSTALL LICENSE* fetch-* geoipupdate
93%{_libdir}/libGeoIP.so.*
94%{_bindir}/geoiplookup6
95%{_bindir}/geoiplookup
96%{_bindir}/geoipupdate
97%config(noreplace) %{_sysconfdir}/GeoIP.conf.default
98%config(noreplace) %{_sysconfdir}/GeoIP.conf
99%{_datadir}/GeoIP
100%{_mandir}/man1/geoiplookup.1*
101%{_mandir}/man1/geoiplookup6.1*
102%{_mandir}/man1/geoipupdate.1*
103%{_mandir}/man5/GeoIP.conf.5.*
104
105%files devel
106%defattr(-,root,root,-)
107%{_libdir}/pkgconfig/geoip.pc
108%{_includedir}/GeoIP.h
109%{_includedir}/GeoIPCity.h
110%{_libdir}/libGeoIP.so
111
112%changelog
113* Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.6.0-2
114- added Japanese summary
115- moved main package to System Environment/Libraries
116
117* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.0-1
118- new upstream release.
119
120* Mon Oct 08 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-3
121- initial build for Vine Linux.
122
123* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2.1
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
125
126* Tue Sep 6 2011 Michael Fleming <mfleming+rpm@thatfleminggent.com> - 1.4.8-1.1
127- Remove -ipv6 path
128- Bump to 1.4.8 release
129
130* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-0.2.20090931cvs
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
132
133* Mon Aug 31 2009 Matt Domsch <mdomsch@fedoraproject.org> - 1.4.7.0.1.20090931
134- apply CVS HEAD 20090931 which includes IPv6 functions
135
136* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-2
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Sun Mar 08 2009 Michael Fleming <mfleming+rpm@enlartenment.com> - 1.4.6-1
140- Add geoiplookup6 man page
141- Update to 1.4.6
142
143* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-3
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
145
146* Sat Nov 29 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.5-2
147- Update to 1.4.5
148- Fix database URL locations in Perl helper scripts
149
150* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-2
151- Autorebuild for GCC 4.3
152
153* Mon Jan 28 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.4-1
154- New upstream release.
155
156* Wed Sep 5 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.3-1
157- New upstream release.
158- Fix GeoIPCity fetcher script
159- Update License tag
160
161* Mon Feb 12 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.2-1
162- New upstream release.
163
164* Mon Jan 8 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-2
165- License is actually LGPL now.
166
167* Sun Jan 7 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-1
168- New upstream release
169- Add fetch-geoipdata* scripts to pull free databases automatically if
170  desired (bz #198137)
171- README.fedora added to briefly explain above.
172
173* Mon Nov 27 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-4
174- Fix %%install scripts to satisfy newer mock builds
175
176* Sun Sep 3 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-3
177- Upstream upgrade
178- Added LICENSE.txt file to %%doc, covering GeoIP country/city data license
179  (bz #198137)
180
181* Mon May 15 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.17-1
182- New upstream release (minor fixes)
183
184* Mon May 1 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.16-1
185- New upstream release
186- Add INSTALL document to package.
187
188* Sat Feb 18 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-3
189- Fix Obsoletes/Provides for old "geoip"-convention packages
190- Move .so symlinks to -devel where they should be
191
192* Fri Feb 10 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-2
193- Remamed to match upstream tarball name
194- Removed static libraries
195- Added symlinks to packages
196- Mark config file noreplace
197
198* Sun Feb 5 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-1
199- Initial review package for Extras
Note: See TracBrowser for help on using the repository browser.