source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 6011

Revision 6011, 15.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.8
4%define orbit2_version 2.14.19
5%define glib2_version 2.32.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 3.2.5
13Release: 1%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/3.2/GConf-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk3-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Patch0: GConf-2.18.0.1-reload.patch
32# http://bugzilla.gnome.org/show_bug.cgi?id=568845
33Patch1: GConf-gettext.patch
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: Takemikaduchi
38
39
40%description
41GConf is a process-transparent configuration database API used to
42store user preferences. It has pluggable backends and features to
43support workgroup administration.
44
45%description -l ja
46GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
47ベースの API です。バックエンドに接続しワークグループ管理をサポー
48トする機能を持っています。
49
50%package devel
51Summary: Headers and libraries for GConf development
52Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
53Group: Development/Libraries
54Requires: %{name} = %{version}
55Requires: ORBit2-devel >= %{orbit2_version}
56Requires: glib2-devel >= %{glib2_version}
57
58%description devel
59GConf development package. Contains files needed for doing
60development using GConf.
61
62%description -l ja devel
63GConf 開発パッケージです。GConf を使って開発するために必要なファ
64イルが含まれています。
65
66%package gtk
67Summary: Graphical GConf utilities
68Summary(ja): GConf グラフィカルユーティリティ
69Group: System Environment/Base
70Requires: %{name} = %{version}-%{release}
71
72%description gtk
73The GConf2-gtk package contains graphical GConf utilities
74which require GTK+.
75
76%description -l ja gtk
77GConf2-gtk パッケージには gtk3 を利用したグラフィカルな GConf
78ユーティリティが含まれています。
79
80
81
82%if %{build_compat32}
83#######################################################################
84# compat32
85%package -n compat32-%{name}
86Summary: A process-transparent configuration system
87Summary(ja): プロセス透過型設定システム
88Group: System Environment/Base
89Requires: compat32-glib2 >= %{glib2_version}
90
91%description -n compat32-%{name}
92GConf is a process-transparent configuration database API used to
93store user preferences. It has pluggable backends and features to
94support workgroup administration.
95
96%description -l ja -n compat32-%{name}
97GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
98ベースの API です。バックエンドに接続しワークグループ管理をサポー
99トする機能を持っています。
100
101%package -n compat32-%{name}-devel
102Summary: Headers and libraries for GConf development
103Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
104Group: Development/Libraries
105Requires: compat32-%{name} = %{version}
106Requires: %{name} = %{version}
107Requires: compat32-glib2 >= %{glib2_version}
108
109%description -n compat32-%{name}-devel
110GConf development package. Contains files needed for doing
111development using GConf.
112
113%description -l ja -n compat32-%{name}-devel
114GConf 開発パッケージです。GConf を使って開発するために必要なファ
115イルが含まれています。
116
117%endif
118
119%prep
120%setup -q -n GConf-%{version}
121
122%patch0 -p1 -b .reload
123%patch1 -p1 -b .gettext
124
125%build
126%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=3.0
127%__make %{?_smp_mflags}
128
129%install
130rm -fr $RPM_BUILD_ROOT
131%__make install DESTDIR=$RPM_BUILD_ROOT
132
133mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
135
136rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
137rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
138rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
139
140%find_lang %name
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post
146/sbin/ldconfig
147if [ $1 -gt 1 ]; then
148    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
149        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
150    fi
151fi
152   
153%postun -p /sbin/ldconfig
154
155%files -f %{name}.lang
156%defattr(-, root, root)
157%doc COPYING ChangeLog NEWS README backends/README.evoldap
158%config %{_sysconfdir}/gconf/2/path
159%config %{_sysconfdir}/gconf/2/evoldap.conf
160%dir %{_sysconfdir}/gconf
161%dir %{_sysconfdir}/gconf/2
162%dir %{_sysconfdir}/gconf/gconf.xml.defaults
163%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
164%dir %{_sysconfdir}/gconf/gconf.xml.system
165%dir %{_sysconfdir}/gconf/schemas
166%{_bindir}/*
167%{_libexecdir}/*
168%{_libdir}/*.so.*
169%dir %{_libdir}/GConf
170%dir %{_libdir}/GConf/2
171%{_libdir}/GConf/2/*.so
172%{_libdir}/girepository-1.0
173%{_mandir}/man1/*
174%{_datadir}/sgml/gconf/gconf-1.0.dtd
175%{_datadir}/GConf
176%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
177%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
178%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
179%{_datadir}/dbus-1/services/org.gnome.GConf.service
180%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
181%{_libdir}/gio/modules/libgsettingsgconfbackend.so
182
183%files devel
184%defattr(-, root, root)
185%{_libdir}/*.so
186%{_includedir}/gconf
187%{_datadir}/aclocal/*.m4
188%{_datadir}/gtk-doc
189%{_datadir}/gir-1.0
190%{_libdir}/pkgconfig/*
191
192%files gtk
193%defattr(-, root, root)
194%{_libexecdir}/gconf-sanity-check-2
195
196%if %{build_compat32}
197%files -n compat32-%{name}
198%defattr(-,root,root,-)
199%{_libdir}/*.so.*
200%dir %{_libdir}/GConf
201%dir %{_libdir}/GConf/2
202%{_libdir}/GConf/2/*.so
203%{_libdir}/girepository-1.0
204%{_libdir}/gio/modules/libgsettingsgconfbackend.so
205
206%files -n compat32-%{name}-devel
207%defattr(-, root, root)
208%{_libdir}/*.so
209%{_libdir}/pkgconfig/*
210
211%endif
212
213%changelog
214* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
215- new upstream release
216
217* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
218- new upstream release
219
220* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
221- new upstream release
222
223* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
224- new upstream release
225
226* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
227- new upstream release
228
229* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
230- new upstream release
231
232* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-1
233- new upstream release
234- remove Patch2
235
236* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
237- new upstream release
238- change configure option (from --with-gtk=2.0 to --with-gtk=3.0)
239- replace Patch2 (GConf2-3.1.4-gsettings-data-convert.patch)
240- delete Patch3,4
241
242* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
243- add gtk subpackage to include gconf-sanity-check-2
244- add --with-gtk=2.0
245
246* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
247- new upstream release
248
249* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
250- new upstream release
251- add BuildRequires: gobject-introspection-devel
252- create compat32-%{name} package
253
254* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
255- build with rpm-4.8.1-1 for pkg-config file
256
257* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
258- new upstream release
259- drop Patch2, Patch3, Patch4
260
261* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
262- import upstream patches from fedora
263  - Patch1: gettext fix
264  - Patch2: avoid crash wen gconftool-2 cant read the db
265  - Patch3: make the defaults mechanism use the right polkit actions
266  - Patch4: donot catch segv etc. let abrt catch them
267- build with polkit, add BR: polkit-devel
268
269* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
270- new upstream release
271
272* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
273- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
274
275* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
276- new upstream release
277
278* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
279- drop obsolete patch1
280
281* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
282- rebuilt with openldap-2.4.11
283
284* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
285- new upstream release
286
287* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
288- new upstream release
289
290* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
291- new upstream release
292
293* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
294- spec in UTF-8
295
296* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
297- new upstream release
298
299* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
300- new upstream release
301- removed Prereq: install-info
302
303* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
304- rebuild with new environment
305
306* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
307- new upstream release
308
309* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
310- add BuildRequires: gtk2-devel
311
312* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
313- rebuilt with openldap-2.3.27-0vl1
314
315* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
316- rebuilt with openldap-2.3.24-0vl1
317
318* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
319- add BuildRequires: openldap-devel
320
321* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
322- new upstream release
323
324* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
325- reload gconf2 when schema is added/removed (patch0 from mdk)
326- only sync db once when installing multiple schemas. (patch1 from fc)
327
328* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
329- new upstream release
330
331* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
332- new upstream release
333
334* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
335- new upstream release
336
337* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
338- new upstream release
339
340* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
341- new upstream release
342
343* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
344- new upstream version
345
346* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
347- add Japanese summaries and descriptions.
348  thanks to spec file translation project.
349
350* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
351- new upstream release
352
353* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
354- new upstream release
355
356* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
357- new upstream release
358
359* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
360- new upstream release
361
362* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
363- new upstream release
364- fix specfile kanjicode
365
366* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
367- new upstream release
368
369* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
370- new upstream release
371
372* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
373- build for Vine Linux
374
375* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
376- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
377
378* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
379- add dialog to offer to delete gconf locks
380
381* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
382- 1.2.1
383- include libexecdir stuff
384
385* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
386- move .pc fle to -devel package
387
388* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
389- automated rebuild
390
391* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
392- automated rebuild
393
394* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
395- fix warning on gnome-panel install
396
397* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
398- 1.2.0
399- own libdir/GConf/2 directory
400- include gtk-doc docs
401- don't include static lib for backend modules
402
403* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
404- rebuild in different environment
405
406* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
407- 1.1.11
408- remove AUTHORS for rpmlint
409
410* Sun May 26 2002 Tim Powers <timp@redhat.com>
411- automated rebuild
412
413* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
414- rebuild in different environment
415
416* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
417- rebuild in different environment
418
419* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
420- 1.1.10
421
422* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
423- 1.1.9
424
425* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
426- 1.1.8
427- remove .la files
428
429* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
430- Version 1.1.6
431- Rebuild for dependencies
432
433* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
434- automated rebuild
435
436* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
437- 1.1.5.93 snap with important bugfix so gconf actually works
438
439* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
440- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
441
442* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
443- 1.1.5.91 snap with gconf.m4 fix for libgnome
444
445* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
446- since every other build seems to avoid libglib-1.3.so.11,
447  rebuild and hope
448
449* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
450- cvs snap 1.1.5.90
451
452* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
453- GConf 1.1.5, glib 1.3.11
454
455* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
456- rebuild for glib 1.3.10
457
458* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
459- 1.1.3
460
461* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
462- cvs snap, remove bonobo-activation deps
463
464* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
465- update to new CVS snap, rebuild
466
467* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
468- create gconf2 rpm based on gconf1, comment out pofiles
469- include .pc files
470
471* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
472- fix description/summary
473
474* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
475- Add po files from sources.redhat.com
476
477* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
478- Add po files from sources.redhat.com
479
480* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
481- upgrade to 1.0.4 release I just made
482- fixes #51223, syslog spew
483
484* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
485- move gconf-config to devel RPM
486
487* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
488- how many releases of GConf can I make before it works?
489
490* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
491- Upgrade to 1.0.2 (which contains only bugfixes that
492  I reviewed and/or wrote myself)
493
494* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
495- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
496
497* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
498- Install the .la files in the devel package.
499
500* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
501- Use %%{_tmppath}
502- Move the .so files to the devel subpackage
503- langify
504- Move changelog to the end, where it should be :)
505- Don't specify (a bad) doc directory
506- Don't define name, version and release and use it in the rpm headers later
507- Remove "Packager:"
508- s/Copyright/License/
509
510* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
511- add --direct option to gconftool to avoid spawning oafd,
512  then commented out gconftool entirely since it checks
513  whether gconfd is running and that spawns oafd anyhow.
514  oafd simply needs to exit when unused.
515
516* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
517- Fix post, pointed out by Bill
518
519* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
520- Upgrade to 1.0.1
521
522* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
523- Import to Red Hat build system.
524
525* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
526
527- Created the .spec file
Note: See TracBrowser for help on using the repository browser.