source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 4704

Revision 4704, 15.5 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2 beta 1 (3.1.90)

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.8
4%define orbit2_version 2.14.19
5%define glib2_version 2.26.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 3.1.90
13Release: 1%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/3.1/GConf-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk3-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Patch0: GConf-2.18.0.1-reload.patch
32# http://bugzilla.gnome.org/show_bug.cgi?id=568845
33Patch1: GConf-gettext.patch
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: Takemikaduchi
38
39
40%description
41GConf is a process-transparent configuration database API used to
42store user preferences. It has pluggable backends and features to
43support workgroup administration.
44
45%description -l ja
46GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
47ベースの API です。バックエンドに接続しワークグループ管理をサポー
48トする機能を持っています。
49
50%package devel
51Summary: Headers and libraries for GConf development
52Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
53Group: Development/Libraries
54Requires: %{name} = %{version}
55Requires: libxml2-devel >= %{libxml2_version}
56Requires: ORBit2-devel >= %{orbit2_version}
57Requires: glib2-devel >= %{glib2_version}
58Requires: dbus-devel >= %{dbus_version}
59Requires: dbus-glib-devel >= %{dbus_glib_version}
60
61%description devel
62GConf development package. Contains files needed for doing
63development using GConf.
64
65%description -l ja devel
66GConf 開発パッケージです。GConf を使って開発するために必要なファ
67イルが含まれています。
68
69%package gtk
70Summary: Graphical GConf utilities
71Summary(ja): GConf グラフィカルユーティリティ
72Group: System Environment/Base
73Requires: %{name} = %{version}-%{release}
74
75%description gtk
76The GConf2-gtk package contains graphical GConf utilities
77which require GTK+.
78
79%description -l ja gtk
80GConf2-gtk パッケージには gtk3 を利用したグラフィカルな GConf
81ユーティリティが含まれています。
82
83
84
85%if %{build_compat32}
86#######################################################################
87# compat32
88%package -n compat32-%{name}
89Summary: A process-transparent configuration system
90Summary(ja): プロセス透過型設定システム
91Group: System Environment/Base
92Requires: compat32-glib2 >= %{glib2_version}
93
94%description -n compat32-%{name}
95GConf is a process-transparent configuration database API used to
96store user preferences. It has pluggable backends and features to
97support workgroup administration.
98
99%description -l ja -n compat32-%{name}
100GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
101ベースの API です。バックエンドに接続しワークグループ管理をサポー
102トする機能を持っています。
103
104%package -n compat32-%{name}-devel
105Summary: Headers and libraries for GConf development
106Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
107Group: Development/Libraries
108Requires: compat32-%{name} = %{version}
109Requires: %{name} = %{version}
110Requires: compat32-glib2 >= %{glib2_version}
111
112%description -n compat32-%{name}-devel
113GConf development package. Contains files needed for doing
114development using GConf.
115
116%description -l ja -n compat32-%{name}-devel
117GConf 開発パッケージです。GConf を使って開発するために必要なファ
118イルが含まれています。
119
120%endif
121
122%prep
123%setup -q -n GConf-%{version}
124
125%patch0 -p1 -b .reload
126%patch1 -p1 -b .gettext
127
128%build
129%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=3.0
130%__make %{?_smp_mflags}
131
132%install
133rm -fr $RPM_BUILD_ROOT
134%__make install DESTDIR=$RPM_BUILD_ROOT
135
136mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
137mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
138
139rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
140rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
141rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
142
143%find_lang %name
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149/sbin/ldconfig
150if [ $1 -gt 1 ]; then
151    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
152        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
153    fi
154fi
155   
156%postun -p /sbin/ldconfig
157
158%files -f %{name}.lang
159%defattr(-, root, root)
160%doc COPYING ChangeLog NEWS README backends/README.evoldap
161%config %{_sysconfdir}/gconf/2/path
162%config %{_sysconfdir}/gconf/2/evoldap.conf
163%dir %{_sysconfdir}/gconf
164%dir %{_sysconfdir}/gconf/2
165%dir %{_sysconfdir}/gconf/gconf.xml.defaults
166%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
167%dir %{_sysconfdir}/gconf/gconf.xml.system
168%dir %{_sysconfdir}/gconf/schemas
169%{_bindir}/*
170%{_libexecdir}/*
171%{_libdir}/*.so.*
172%dir %{_libdir}/GConf
173%dir %{_libdir}/GConf/2
174%{_libdir}/GConf/2/*.so
175%{_libdir}/girepository-1.0
176%{_mandir}/man1/*
177%{_datadir}/sgml/gconf/gconf-1.0.dtd
178%{_datadir}/GConf
179%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
180%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
181%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
182%{_datadir}/dbus-1/services/org.gnome.GConf.service
183%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
184%{_libdir}/gio/modules/libgsettingsgconfbackend.so
185
186%files devel
187%defattr(-, root, root)
188%{_libdir}/*.so
189%{_includedir}/gconf
190%{_datadir}/aclocal/*.m4
191%{_datadir}/gtk-doc
192%{_datadir}/gir-1.0
193%{_libdir}/pkgconfig/*
194
195%files gtk
196%defattr(-, root, root)
197%{_libexecdir}/gconf-sanity-check-2
198
199%if %{build_compat32}
200%files -n compat32-%{name}
201%defattr(-,root,root,-)
202%{_libdir}/*.so.*
203%dir %{_libdir}/GConf
204%dir %{_libdir}/GConf/2
205%{_libdir}/GConf/2/*.so
206%{_libdir}/girepository-1.0
207%{_libdir}/gio/modules/libgsettingsgconfbackend.so
208
209%files -n compat32-%{name}-devel
210%defattr(-, root, root)
211%{_libdir}/*.so
212%{_libdir}/pkgconfig/*
213
214%endif
215
216%changelog
217* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
218- new upstream release
219
220* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-1
221- new upstream release
222- remove Patch2
223
224* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
225- new upstream release
226- change configure option (from --with-gtk=2.0 to --with-gtk=3.0)
227- replace Patch2 (GConf2-3.1.4-gsettings-data-convert.patch)
228- delete Patch3,4
229
230* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
231- add gtk subpackage to include gconf-sanity-check-2
232- add --with-gtk=2.0
233
234* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
235- new upstream release
236
237* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
238- new upstream release
239- add BuildRequires: gobject-introspection-devel
240- create compat32-%{name} package
241
242* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
243- build with rpm-4.8.1-1 for pkg-config file
244
245* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
246- new upstream release
247- drop Patch2, Patch3, Patch4
248
249* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
250- import upstream patches from fedora
251  - Patch1: gettext fix
252  - Patch2: avoid crash wen gconftool-2 cant read the db
253  - Patch3: make the defaults mechanism use the right polkit actions
254  - Patch4: donot catch segv etc. let abrt catch them
255- build with polkit, add BR: polkit-devel
256
257* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
258- new upstream release
259
260* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
261- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
262
263* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
264- new upstream release
265
266* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
267- drop obsolete patch1
268
269* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
270- rebuilt with openldap-2.4.11
271
272* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
273- new upstream release
274
275* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
276- new upstream release
277
278* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
279- new upstream release
280
281* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
282- spec in UTF-8
283
284* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
285- new upstream release
286
287* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
288- new upstream release
289- removed Prereq: install-info
290
291* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
292- rebuild with new environment
293
294* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
295- new upstream release
296
297* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
298- add BuildRequires: gtk2-devel
299
300* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
301- rebuilt with openldap-2.3.27-0vl1
302
303* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
304- rebuilt with openldap-2.3.24-0vl1
305
306* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
307- add BuildRequires: openldap-devel
308
309* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
310- new upstream release
311
312* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
313- reload gconf2 when schema is added/removed (patch0 from mdk)
314- only sync db once when installing multiple schemas. (patch1 from fc)
315
316* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
317- new upstream release
318
319* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
320- new upstream release
321
322* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
323- new upstream release
324
325* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
326- new upstream release
327
328* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
329- new upstream release
330
331* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
332- new upstream version
333
334* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
335- add Japanese summaries and descriptions.
336  thanks to spec file translation project.
337
338* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
339- new upstream release
340
341* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
342- new upstream release
343
344* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
345- new upstream release
346
347* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
348- new upstream release
349
350* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
351- new upstream release
352- fix specfile kanjicode
353
354* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
355- new upstream release
356
357* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
358- new upstream release
359
360* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
361- build for Vine Linux
362
363* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
364- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
365
366* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
367- add dialog to offer to delete gconf locks
368
369* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
370- 1.2.1
371- include libexecdir stuff
372
373* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
374- move .pc fle to -devel package
375
376* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
377- automated rebuild
378
379* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
380- automated rebuild
381
382* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
383- fix warning on gnome-panel install
384
385* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
386- 1.2.0
387- own libdir/GConf/2 directory
388- include gtk-doc docs
389- don't include static lib for backend modules
390
391* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
392- rebuild in different environment
393
394* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
395- 1.1.11
396- remove AUTHORS for rpmlint
397
398* Sun May 26 2002 Tim Powers <timp@redhat.com>
399- automated rebuild
400
401* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
402- rebuild in different environment
403
404* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
405- rebuild in different environment
406
407* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
408- 1.1.10
409
410* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
411- 1.1.9
412
413* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
414- 1.1.8
415- remove .la files
416
417* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
418- Version 1.1.6
419- Rebuild for dependencies
420
421* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
422- automated rebuild
423
424* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
425- 1.1.5.93 snap with important bugfix so gconf actually works
426
427* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
428- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
429
430* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
431- 1.1.5.91 snap with gconf.m4 fix for libgnome
432
433* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
434- since every other build seems to avoid libglib-1.3.so.11,
435  rebuild and hope
436
437* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
438- cvs snap 1.1.5.90
439
440* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
441- GConf 1.1.5, glib 1.3.11
442
443* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
444- rebuild for glib 1.3.10
445
446* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
447- 1.1.3
448
449* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
450- cvs snap, remove bonobo-activation deps
451
452* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
453- update to new CVS snap, rebuild
454
455* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
456- create gconf2 rpm based on gconf1, comment out pofiles
457- include .pc files
458
459* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
460- fix description/summary
461
462* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
463- Add po files from sources.redhat.com
464
465* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
466- Add po files from sources.redhat.com
467
468* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
469- upgrade to 1.0.4 release I just made
470- fixes #51223, syslog spew
471
472* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
473- move gconf-config to devel RPM
474
475* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
476- how many releases of GConf can I make before it works?
477
478* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
479- Upgrade to 1.0.2 (which contains only bugfixes that
480  I reviewed and/or wrote myself)
481
482* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
483- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
484
485* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
486- Install the .la files in the devel package.
487
488* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
489- Use %%{_tmppath}
490- Move the .so files to the devel subpackage
491- langify
492- Move changelog to the end, where it should be :)
493- Don't specify (a bad) doc directory
494- Don't define name, version and release and use it in the rpm headers later
495- Remove "Packager:"
496- s/Copyright/License/
497
498* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
499- add --direct option to gconftool to avoid spawning oafd,
500  then commented out gconftool entirely since it checks
501  whether gconfd is running and that spawns oafd anyhow.
502  oafd simply needs to exit when unused.
503
504* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
505- Fix post, pointed out by Bill
506
507* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
508- Upgrade to 1.0.1
509
510* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
511- Import to Red Hat build system.
512
513* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
514
515- Created the .spec file
Note: See TracBrowser for help on using the repository browser.