source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 4616

Revision 4616, 15.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.7
4%define orbit2_version 2.14.19
5%define glib2_version 2.26.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 3.1.4
13Release: 1%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/3.1/GConf-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk3-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Patch0: GConf-2.18.0.1-reload.patch
32# http://bugzilla.gnome.org/show_bug.cgi?id=568845
33Patch1: GConf-gettext.patch
34
35Patch2: GConf2-3.1.4-gsettings-data-convert.patch
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: Takemikaduchi
40
41
42%description
43GConf is a process-transparent configuration database API used to
44store user preferences. It has pluggable backends and features to
45support workgroup administration.
46
47%description -l ja
48GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
49ベースの API です。バックエンドに接続しワークグループ管理をサポー
50トする機能を持っています。
51
52%package devel
53Summary: Headers and libraries for GConf development
54Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
55Group: Development/Libraries
56Requires: %{name} = %{version}
57Requires: libxml2-devel >= %{libxml2_version}
58Requires: ORBit2-devel >= %{orbit2_version}
59Requires: glib2-devel >= %{glib2_version}
60Requires: dbus-devel >= %{dbus_version}
61Requires: dbus-glib-devel >= %{dbus_glib_version}
62
63%description devel
64GConf development package. Contains files needed for doing
65development using GConf.
66
67%description -l ja devel
68GConf 開発パッケージです。GConf を使って開発するために必要なファ
69イルが含まれています。
70
71%package gtk
72Summary: Graphical GConf utilities
73Summary(ja): GConf グラフィカルユーティリティ
74Group: System Environment/Base
75Requires: %{name} = %{version}-%{release}
76
77%description gtk
78The GConf2-gtk package contains graphical GConf utilities
79which require GTK+.
80
81%description -l ja gtk
82GConf2-gtk パッケージには gtk3 を利用したグラフィカルな GConf
83ユーティリティが含まれています。
84
85
86
87%if %{build_compat32}
88#######################################################################
89# compat32
90%package -n compat32-%{name}
91Summary: A process-transparent configuration system
92Summary(ja): プロセス透過型設定システム
93Group: System Environment/Base
94Requires: compat32-glib2 >= %{glib2_version}
95
96%description -n compat32-%{name}
97GConf is a process-transparent configuration database API used to
98store user preferences. It has pluggable backends and features to
99support workgroup administration.
100
101%description -l ja -n compat32-%{name}
102GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
103ベースの API です。バックエンドに接続しワークグループ管理をサポー
104トする機能を持っています。
105
106%package -n compat32-%{name}-devel
107Summary: Headers and libraries for GConf development
108Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
109Group: Development/Libraries
110Requires: compat32-%{name} = %{version}
111Requires: %{name} = %{version}
112Requires: compat32-glib2 >= %{glib2_version}
113
114%description -n compat32-%{name}-devel
115GConf development package. Contains files needed for doing
116development using GConf.
117
118%description -l ja -n compat32-%{name}-devel
119GConf 開発パッケージです。GConf を使って開発するために必要なファ
120イルが含まれています。
121
122%endif
123
124%prep
125%setup -q -n GConf-%{version}
126
127%patch0 -p1 -b .reload
128%patch1 -p1 -b .gettext
129%patch2 -p1 -b .gdc
130
131%build
132%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=3.0
133%__make %{?_smp_mflags}
134
135%install
136rm -fr $RPM_BUILD_ROOT
137%__make install DESTDIR=$RPM_BUILD_ROOT
138
139mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
140mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
141
142rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
143rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
144rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
145
146%find_lang %name
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%post
152/sbin/ldconfig
153if [ $1 -gt 1 ]; then
154    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
155        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
156    fi
157fi
158   
159%postun -p /sbin/ldconfig
160
161%files -f %{name}.lang
162%defattr(-, root, root)
163%doc COPYING ChangeLog NEWS README backends/README.evoldap
164%config %{_sysconfdir}/gconf/2/path
165%config %{_sysconfdir}/gconf/2/evoldap.conf
166%dir %{_sysconfdir}/gconf
167%dir %{_sysconfdir}/gconf/2
168%dir %{_sysconfdir}/gconf/gconf.xml.defaults
169%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
170%dir %{_sysconfdir}/gconf/gconf.xml.system
171%dir %{_sysconfdir}/gconf/schemas
172%{_bindir}/*
173%{_libexecdir}/*
174%{_libdir}/*.so.*
175%dir %{_libdir}/GConf
176%dir %{_libdir}/GConf/2
177%{_libdir}/GConf/2/*.so
178%{_libdir}/girepository-1.0
179%{_mandir}/man1/*
180%{_datadir}/sgml/gconf/gconf-1.0.dtd
181%{_datadir}/GConf
182%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
183%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
184%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
185%{_datadir}/dbus-1/services/org.gnome.GConf.service
186%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
187%{_libdir}/gio/modules/libgsettingsgconfbackend.so
188
189%files devel
190%defattr(-, root, root)
191%{_libdir}/*.so
192%{_includedir}/gconf
193%{_datadir}/aclocal/*.m4
194%{_datadir}/gtk-doc
195%{_datadir}/gir-1.0
196%{_libdir}/pkgconfig/*
197
198%files gtk
199%defattr(-, root, root)
200%{_libexecdir}/gconf-sanity-check-2
201
202%if %{build_compat32}
203%files -n compat32-%{name}
204%defattr(-,root,root,-)
205%{_libdir}/*.so.*
206%dir %{_libdir}/GConf
207%dir %{_libdir}/GConf/2
208%{_libdir}/GConf/2/*.so
209%{_libdir}/girepository-1.0
210%{_libdir}/gio/modules/libgsettingsgconfbackend.so
211
212%files -n compat32-%{name}-devel
213%defattr(-, root, root)
214%{_libdir}/*.so
215%{_libdir}/pkgconfig/*
216
217%endif
218
219%changelog
220* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
221- new upstream release
222- change configure option (from --with-gtk=2.0 to --with-gtk=3.0)
223- replace Patch2 (GConf2-3.1.4-gsettings-data-convert.patch)
224- delete Patch3,4
225
226* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
227- add gtk subpackage to include gconf-sanity-check-2
228- add --with-gtk=2.0
229
230* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
231- new upstream release
232
233* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
234- new upstream release
235- add BuildRequires: gobject-introspection-devel
236- create compat32-%{name} package
237
238* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
239- build with rpm-4.8.1-1 for pkg-config file
240
241* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
242- new upstream release
243- drop Patch2, Patch3, Patch4
244
245* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
246- import upstream patches from fedora
247  - Patch1: gettext fix
248  - Patch2: avoid crash wen gconftool-2 cant read the db
249  - Patch3: make the defaults mechanism use the right polkit actions
250  - Patch4: donot catch segv etc. let abrt catch them
251- build with polkit, add BR: polkit-devel
252
253* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
254- new upstream release
255
256* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
257- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
258
259* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
260- new upstream release
261
262* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
263- drop obsolete patch1
264
265* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
266- rebuilt with openldap-2.4.11
267
268* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
269- new upstream release
270
271* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
272- new upstream release
273
274* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
275- new upstream release
276
277* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
278- spec in UTF-8
279
280* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
281- new upstream release
282
283* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
284- new upstream release
285- removed Prereq: install-info
286
287* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
288- rebuild with new environment
289
290* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
291- new upstream release
292
293* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
294- add BuildRequires: gtk2-devel
295
296* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
297- rebuilt with openldap-2.3.27-0vl1
298
299* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
300- rebuilt with openldap-2.3.24-0vl1
301
302* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
303- add BuildRequires: openldap-devel
304
305* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
306- new upstream release
307
308* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
309- reload gconf2 when schema is added/removed (patch0 from mdk)
310- only sync db once when installing multiple schemas. (patch1 from fc)
311
312* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
313- new upstream release
314
315* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
316- new upstream release
317
318* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
319- new upstream release
320
321* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
322- new upstream release
323
324* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
325- new upstream release
326
327* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
328- new upstream version
329
330* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
331- add Japanese summaries and descriptions.
332  thanks to spec file translation project.
333
334* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
335- new upstream release
336
337* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
338- new upstream release
339
340* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
341- new upstream release
342
343* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
344- new upstream release
345
346* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
347- new upstream release
348- fix specfile kanjicode
349
350* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
351- new upstream release
352
353* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
354- new upstream release
355
356* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
357- build for Vine Linux
358
359* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
360- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
361
362* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
363- add dialog to offer to delete gconf locks
364
365* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
366- 1.2.1
367- include libexecdir stuff
368
369* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
370- move .pc fle to -devel package
371
372* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
373- automated rebuild
374
375* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
376- automated rebuild
377
378* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
379- fix warning on gnome-panel install
380
381* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
382- 1.2.0
383- own libdir/GConf/2 directory
384- include gtk-doc docs
385- don't include static lib for backend modules
386
387* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
388- rebuild in different environment
389
390* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
391- 1.1.11
392- remove AUTHORS for rpmlint
393
394* Sun May 26 2002 Tim Powers <timp@redhat.com>
395- automated rebuild
396
397* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
398- rebuild in different environment
399
400* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
401- rebuild in different environment
402
403* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
404- 1.1.10
405
406* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
407- 1.1.9
408
409* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
410- 1.1.8
411- remove .la files
412
413* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
414- Version 1.1.6
415- Rebuild for dependencies
416
417* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
418- automated rebuild
419
420* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
421- 1.1.5.93 snap with important bugfix so gconf actually works
422
423* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
424- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
425
426* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
427- 1.1.5.91 snap with gconf.m4 fix for libgnome
428
429* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
430- since every other build seems to avoid libglib-1.3.so.11,
431  rebuild and hope
432
433* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
434- cvs snap 1.1.5.90
435
436* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
437- GConf 1.1.5, glib 1.3.11
438
439* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
440- rebuild for glib 1.3.10
441
442* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
443- 1.1.3
444
445* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
446- cvs snap, remove bonobo-activation deps
447
448* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
449- update to new CVS snap, rebuild
450
451* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
452- create gconf2 rpm based on gconf1, comment out pofiles
453- include .pc files
454
455* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
456- fix description/summary
457
458* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
459- Add po files from sources.redhat.com
460
461* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
462- Add po files from sources.redhat.com
463
464* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
465- upgrade to 1.0.4 release I just made
466- fixes #51223, syslog spew
467
468* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
469- move gconf-config to devel RPM
470
471* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
472- how many releases of GConf can I make before it works?
473
474* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
475- Upgrade to 1.0.2 (which contains only bugfixes that
476  I reviewed and/or wrote myself)
477
478* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
479- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
480
481* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
482- Install the .la files in the devel package.
483
484* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
485- Use %%{_tmppath}
486- Move the .so files to the devel subpackage
487- langify
488- Move changelog to the end, where it should be :)
489- Don't specify (a bad) doc directory
490- Don't define name, version and release and use it in the rpm headers later
491- Remove "Packager:"
492- s/Copyright/License/
493
494* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
495- add --direct option to gconftool to avoid spawning oafd,
496  then commented out gconftool entirely since it checks
497  whether gconfd is running and that spawns oafd anyhow.
498  oafd simply needs to exit when unused.
499
500* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
501- Fix post, pointed out by Bill
502
503* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
504- Upgrade to 1.0.1
505
506* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
507- Import to Red Hat build system.
508
509* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
510
511- Created the .spec file
Note: See TracBrowser for help on using the repository browser.