source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 2767

Revision 2767, 14.7 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.7
4%define orbit2_version 2.14.19
5%define glib2_version 2.26.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 2.32.1
13Release: 1%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/2.32/GConf-%{version}.tar.bz2
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk2-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Patch0: GConf-2.18.0.1-reload.patch
32# http://bugzilla.gnome.org/show_bug.cgi?id=568845
33Patch1: GConf-gettext.patch
34#
35Patch2: GConf-2.28.0-no-access-crash.patch
36# upstream fix
37Patch3: 0001-Make-the-defaults-mechanism-find-the-right-polkit-ac.patch
38# https://bugzilla.gnome.org/show_bug.cgi?id=608705
39Patch4: 0001-gconfd-Remove-worse-than-useless-signal-handlers-for.patch
40
41
42
43%description
44GConf is a process-transparent configuration database API used to
45store user preferences. It has pluggable backends and features to
46support workgroup administration.
47
48%description -l ja
49GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
50ベースの API です。バックエンドに接続しワークグループ管理をサポー
51トする機能を持っています。
52
53%package devel
54Summary: Headers and libraries for GConf development
55Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
56Group: Development/Libraries
57Requires: %{name} = %{version}
58Requires: libxml2-devel >= %{libxml2_version}
59Requires: ORBit2-devel >= %{orbit2_version}
60Requires: glib2-devel >= %{glib2_version}
61Requires: dbus-devel >= %{dbus_version}
62Requires: dbus-glib-devel >= %{dbus_glib_version}
63
64%description devel
65GConf development package. Contains files needed for doing
66development using GConf.
67
68%description -l ja devel
69GConf 開発パッケージです。GConf を使って開発するために必要なファ
70イルが含まれています。
71
72%if %{build_compat32}
73#######################################################################
74# compat32
75%package -n compat32-%{name}
76Summary: A process-transparent configuration system
77Summary(ja): プロセス透過型設定システム
78Group: System Environment/Base
79Requires: compat32-glib2 >= %{glib2_version}
80
81%description -n compat32-%{name}
82GConf is a process-transparent configuration database API used to
83store user preferences. It has pluggable backends and features to
84support workgroup administration.
85
86%description -l ja -n compat32-%{name}
87GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
88ベースの API です。バックエンドに接続しワークグループ管理をサポー
89トする機能を持っています。
90
91%package -n compat32-%{name}-devel
92Summary: Headers and libraries for GConf development
93Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
94Group: Development/Libraries
95Requires: compat32-%{name} = %{version}
96Requires: %{name} = %{version}
97Requires: compat32-glib2 >= %{glib2_version}
98
99%description -n compat32-%{name}-devel
100GConf development package. Contains files needed for doing
101development using GConf.
102
103%description -l ja -n compat32-%{name}-devel
104GConf 開発パッケージです。GConf を使って開発するために必要なファ
105イルが含まれています。
106
107%endif
108
109%prep
110%setup -q -n GConf-%{version}
111
112%patch0 -p1 -b .reload
113%patch1 -p1 -b .gettext
114## %patch2 -p1 -b .no-access
115## %patch3 -p1 -b .defaults-actions
116## %patch4 -p1 -b .segv
117
118%build
119%configure --disable-gtk-doc --disable-static --enable-defaults-service
120%__make %{?_smp_mflags}
121
122%install
123rm -fr $RPM_BUILD_ROOT
124%__make install DESTDIR=$RPM_BUILD_ROOT
125
126mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
127mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
128
129rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
130rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
131rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
132
133%find_lang %name
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post
139/sbin/ldconfig
140if [ $1 -gt 1 ]; then
141    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
142        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
143    fi
144fi
145   
146%postun -p /sbin/ldconfig
147
148%files -f %{name}.lang
149%defattr(-, root, root)
150%doc COPYING ChangeLog NEWS README backends/README.evoldap
151%config %{_sysconfdir}/gconf/2/path
152%config %{_sysconfdir}/gconf/2/evoldap.conf
153%dir %{_sysconfdir}/gconf
154%dir %{_sysconfdir}/gconf/2
155%dir %{_sysconfdir}/gconf/gconf.xml.defaults
156%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
157%dir %{_sysconfdir}/gconf/gconf.xml.system
158%dir %{_sysconfdir}/gconf/schemas
159%{_bindir}/*
160%{_libexecdir}/*
161%{_libdir}/*.so.*
162%dir %{_libdir}/GConf
163%dir %{_libdir}/GConf/2
164%{_libdir}/GConf/2/*.so
165%{_libdir}/girepository-1.0
166%{_mandir}/man1/*
167%{_datadir}/sgml/gconf/gconf-1.0.dtd
168%{_datadir}/GConf
169%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
170%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
171%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
172%{_datadir}/dbus-1/services/org.gnome.GConf.service
173%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
174%{_libdir}/gio/modules/libgsettingsgconfbackend.so
175
176%files devel
177%defattr(-, root, root)
178%{_libdir}/*.so
179%{_includedir}/gconf
180%{_datadir}/aclocal/*.m4
181%{_datadir}/gtk-doc
182%{_datadir}/gir-1.0
183%{_libdir}/pkgconfig/*
184
185%if %{build_compat32}
186%files -n compat32-%{name}
187%defattr(-,root,root,-)
188%{_libdir}/*.so.*
189%dir %{_libdir}/GConf
190%dir %{_libdir}/GConf/2
191%{_libdir}/GConf/2/*.so
192%{_libdir}/girepository-1.0
193%{_libdir}/gio/modules/libgsettingsgconfbackend.so
194
195%files -n compat32-%{name}-devel
196%defattr(-, root, root)
197%{_libdir}/*.so
198%{_libdir}/pkgconfig/*
199
200%endif
201
202%changelog
203* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
204- new upstream release
205
206* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
207- new upstream release
208- add BuildRequires: gobject-introspection-devel
209- create compat32-%{name} package
210
211* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
212- build with rpm-4.8.1-1 for pkg-config file
213
214* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
215- new upstream release
216- drop Patch2, Patch3, Patch4
217
218* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
219- import upstream patches from fedora
220  - Patch1: gettext fix
221  - Patch2: avoid crash wen gconftool-2 cant read the db
222  - Patch3: make the defaults mechanism use the right polkit actions
223  - Patch4: donot catch segv etc. let abrt catch them
224- build with polkit, add BR: polkit-devel
225
226* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
227- new upstream release
228
229* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
230- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
231
232* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
233- new upstream release
234
235* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
236- drop obsolete patch1
237
238* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
239- rebuilt with openldap-2.4.11
240
241* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
242- new upstream release
243
244* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
245- new upstream release
246
247* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
248- new upstream release
249
250* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
251- spec in UTF-8
252
253* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
254- new upstream release
255
256* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
257- new upstream release
258- removed Prereq: install-info
259
260* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
261- rebuild with new environment
262
263* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
264- new upstream release
265
266* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
267- add BuildRequires: gtk2-devel
268
269* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
270- rebuilt with openldap-2.3.27-0vl1
271
272* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
273- rebuilt with openldap-2.3.24-0vl1
274
275* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
276- add BuildRequires: openldap-devel
277
278* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
279- new upstream release
280
281* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
282- reload gconf2 when schema is added/removed (patch0 from mdk)
283- only sync db once when installing multiple schemas. (patch1 from fc)
284
285* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
286- new upstream release
287
288* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
289- new upstream release
290
291* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
292- new upstream release
293
294* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
295- new upstream release
296
297* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
298- new upstream release
299
300* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
301- new upstream version
302
303* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
304- add Japanese summaries and descriptions.
305  thanks to spec file translation project.
306
307* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
308- new upstream release
309
310* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
311- new upstream release
312
313* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
314- new upstream release
315
316* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
317- new upstream release
318
319* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
320- new upstream release
321- fix specfile kanjicode
322
323* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
324- new upstream release
325
326* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
327- new upstream release
328
329* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
330- build for Vine Linux
331
332* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
333- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
334
335* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
336- add dialog to offer to delete gconf locks
337
338* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
339- 1.2.1
340- include libexecdir stuff
341
342* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
343- move .pc fle to -devel package
344
345* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
346- automated rebuild
347
348* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
349- automated rebuild
350
351* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
352- fix warning on gnome-panel install
353
354* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
355- 1.2.0
356- own libdir/GConf/2 directory
357- include gtk-doc docs
358- don't include static lib for backend modules
359
360* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
361- rebuild in different environment
362
363* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
364- 1.1.11
365- remove AUTHORS for rpmlint
366
367* Sun May 26 2002 Tim Powers <timp@redhat.com>
368- automated rebuild
369
370* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
371- rebuild in different environment
372
373* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
374- rebuild in different environment
375
376* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
377- 1.1.10
378
379* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
380- 1.1.9
381
382* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
383- 1.1.8
384- remove .la files
385
386* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
387- Version 1.1.6
388- Rebuild for dependencies
389
390* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
391- automated rebuild
392
393* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
394- 1.1.5.93 snap with important bugfix so gconf actually works
395
396* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
397- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
398
399* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
400- 1.1.5.91 snap with gconf.m4 fix for libgnome
401
402* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
403- since every other build seems to avoid libglib-1.3.so.11,
404  rebuild and hope
405
406* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
407- cvs snap 1.1.5.90
408
409* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
410- GConf 1.1.5, glib 1.3.11
411
412* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
413- rebuild for glib 1.3.10
414
415* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
416- 1.1.3
417
418* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
419- cvs snap, remove bonobo-activation deps
420
421* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
422- update to new CVS snap, rebuild
423
424* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
425- create gconf2 rpm based on gconf1, comment out pofiles
426- include .pc files
427
428* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
429- fix description/summary
430
431* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
432- Add po files from sources.redhat.com
433
434* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
435- Add po files from sources.redhat.com
436
437* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
438- upgrade to 1.0.4 release I just made
439- fixes #51223, syslog spew
440
441* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
442- move gconf-config to devel RPM
443
444* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
445- how many releases of GConf can I make before it works?
446
447* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
448- Upgrade to 1.0.2 (which contains only bugfixes that
449  I reviewed and/or wrote myself)
450
451* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
452- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
453
454* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
455- Install the .la files in the devel package.
456
457* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
458- Use %%{_tmppath}
459- Move the .so files to the devel subpackage
460- langify
461- Move changelog to the end, where it should be :)
462- Don't specify (a bad) doc directory
463- Don't define name, version and release and use it in the rpm headers later
464- Remove "Packager:"
465- s/Copyright/License/
466
467* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
468- add --direct option to gconftool to avoid spawning oafd,
469  then commented out gconftool entirely since it checks
470  whether gconfd is running and that spawns oafd anyhow.
471  oafd simply needs to exit when unused.
472
473* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
474- Fix post, pointed out by Bill
475
476* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
477- Upgrade to 1.0.1
478
479* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
480- Import to Red Hat build system.
481
482* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
483
484- Created the .spec file
Note: See TracBrowser for help on using the repository browser.