source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 1856

Revision 1856, 12.5 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21791]

Line 
1%define libxml2_version 2.6.23
2%define orbit2_version 2.14.17
3%define glib2_version 2.20.0
4%define dbus_version 1.2.16
5%define dbus_glib_version 0.82
6
7Summary: A process-transparent configuration system
8Summary(ja): プロセス透過型設定システム
9Name: GConf2
10Version: 2.28.1
11Release: 2%{?_dist_release}
12License: LGPL
13Group: System Environment/Base
14Source: GConf-%{version}.tar.bz2
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16URL: http://www.gnome.org
17BuildRequires: libxml2-devel >= %{libxml2_version}
18BuildRequires: ORBit2-devel >= %{orbit2_version}
19BuildRequires: glib2-devel >= %{glib2_version}
20BuildRequires: dbus-devel >= %{dbus_version}
21BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
22BuildRequires: gtk2-devel
23BuildRequires: openldap-devel
24BuildRequires: gtk-doc >= 0.9
25BuildRequires: polkit-devel >= 0.92
26Requires: dbus
27
28Patch0: GConf-2.18.0.1-reload.patch
29# http://bugzilla.gnome.org/show_bug.cgi?id=568845
30Patch1: GConf-gettext.patch
31#
32Patch2: GConf-2.28.0-no-access-crash.patch
33# upstream fix
34Patch3: 0001-Make-the-defaults-mechanism-find-the-right-polkit-ac.patch
35# https://bugzilla.gnome.org/show_bug.cgi?id=608705
36Patch4: 0001-gconfd-Remove-worse-than-useless-signal-handlers-for.patch
37
38
39
40%description
41GConf is a process-transparent configuration database API used to
42store user preferences. It has pluggable backends and features to
43support workgroup administration.
44
45%description -l ja
46GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
47ベースの API です。バックエンドに接続しワークグループ管理をサポー
48トする機能を持っています。
49
50%package devel
51Summary: Headers and libraries for GConf development
52Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
53Group: Development/Libraries
54Requires: %{name} = %{version}
55Requires: libxml2-devel >= %{libxml2_version}
56Requires: ORBit2-devel >= %{orbit2_version}
57Requires: glib2-devel >= %{glib2_version}
58Requires: dbus-devel >= %{dbus_version}
59Requires: dbus-glib-devel >= %{dbus_glib_version}
60
61%description devel
62GConf development package. Contains files needed for doing
63development using GConf.
64
65%description -l ja devel
66GConf 開発パッケージです。GConf を使って開発するために必要なファ
67イルが含まれています。
68
69%prep
70%setup -q -n GConf-%{version}
71
72%patch0 -p1 -b .reload
73%patch1 -p1 -b .gettext
74## %patch2 -p1 -b .no-access
75## %patch3 -p1 -b .defaults-actions
76## %patch4 -p1 -b .segv
77
78%build
79%configure --disable-gtk-doc --disable-static --enable-defaults-service
80%__make %{?_smp_mflags}
81
82%install
83rm -fr $RPM_BUILD_ROOT
84%__make install DESTDIR=$RPM_BUILD_ROOT
85
86mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
87mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
88
89rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
90rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
91
92%find_lang %name
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post
98/sbin/ldconfig
99if [ $1 -gt 1 ]; then
100    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
101        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
102    fi
103fi
104   
105%postun -p /sbin/ldconfig
106
107%files -f %{name}.lang
108%defattr(-, root, root)
109%doc COPYING ChangeLog NEWS README backends/README.evoldap
110%config %{_sysconfdir}/gconf/2/path
111%config %{_sysconfdir}/gconf/2/evoldap.conf
112%dir %{_sysconfdir}/gconf
113%dir %{_sysconfdir}/gconf/2
114%dir %{_sysconfdir}/gconf/gconf.xml.defaults
115%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
116%dir %{_sysconfdir}/gconf/gconf.xml.system
117%dir %{_sysconfdir}/gconf/schemas
118%{_bindir}/*
119%{_libexecdir}/*
120%{_libdir}/*.so.*
121%{_libdir}/GConf/2/*.so
122%dir %{_libdir}/GConf
123%dir %{_libdir}/GConf/2
124%{_mandir}/man1/*
125%{_datadir}/sgml/gconf/gconf-1.0.dtd
126%{_datadir}/GConf
127%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
128%{_libexecdir}/gconf-defaults-mechanism
129%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
130%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
131%{_datadir}/dbus-1/services/org.gnome.GConf.service
132
133%files devel
134%defattr(-, root, root)
135%{_libdir}/*.so
136%{_includedir}/gconf
137%{_datadir}/aclocal/*.m4
138%{_datadir}/gtk-doc
139%{_libdir}/pkgconfig/*
140
141%changelog
142* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
143- build with rpm-4.8.1-1 for pkg-config file
144
145* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
146- new upstream release
147- drop Patch2, Patch3, Patch4
148
149* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
150- import upstream patches from fedora
151  - Patch1: gettext fix
152  - Patch2: avoid crash wen gconftool-2 cant read the db
153  - Patch3: make the defaults mechanism use the right polkit actions
154  - Patch4: donot catch segv etc. let abrt catch them
155- build with polkit, add BR: polkit-devel
156
157* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
158- new upstream release
159
160* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
161- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
162
163* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
164- new upstream release
165
166* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
167- drop obsolete patch1
168
169* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
170- rebuilt with openldap-2.4.11
171
172* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
173- new upstream release
174
175* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
176- new upstream release
177
178* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
179- new upstream release
180
181* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
182- spec in UTF-8
183
184* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
185- new upstream release
186
187* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
188- new upstream release
189- removed Prereq: install-info
190
191* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
192- rebuild with new environment
193
194* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
195- new upstream release
196
197* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
198- add BuildRequires: gtk2-devel
199
200* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
201- rebuilt with openldap-2.3.27-0vl1
202
203* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
204- rebuilt with openldap-2.3.24-0vl1
205
206* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
207- add BuildRequires: openldap-devel
208
209* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
210- new upstream release
211
212* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
213- reload gconf2 when schema is added/removed (patch0 from mdk)
214- only sync db once when installing multiple schemas. (patch1 from fc)
215
216* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
217- new upstream release
218
219* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
220- new upstream release
221
222* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
223- new upstream release
224
225* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
226- new upstream release
227
228* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
229- new upstream release
230
231* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
232- new upstream version
233
234* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
235- add Japanese summaries and descriptions.
236  thanks to spec file translation project.
237
238* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
239- new upstream release
240
241* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
242- new upstream release
243
244* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
245- new upstream release
246
247* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
248- new upstream release
249
250* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
251- new upstream release
252- fix specfile kanjicode
253
254* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
255- new upstream release
256
257* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
258- new upstream release
259
260* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
261- build for Vine Linux
262
263* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
264- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
265
266* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
267- add dialog to offer to delete gconf locks
268
269* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
270- 1.2.1
271- include libexecdir stuff
272
273* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
274- move .pc fle to -devel package
275
276* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
277- automated rebuild
278
279* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
280- automated rebuild
281
282* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
283- fix warning on gnome-panel install
284
285* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
286- 1.2.0
287- own libdir/GConf/2 directory
288- include gtk-doc docs
289- don't include static lib for backend modules
290
291* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
292- rebuild in different environment
293
294* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
295- 1.1.11
296- remove AUTHORS for rpmlint
297
298* Sun May 26 2002 Tim Powers <timp@redhat.com>
299- automated rebuild
300
301* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
302- rebuild in different environment
303
304* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
305- rebuild in different environment
306
307* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
308- 1.1.10
309
310* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
311- 1.1.9
312
313* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
314- 1.1.8
315- remove .la files
316
317* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
318- Version 1.1.6
319- Rebuild for dependencies
320
321* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
322- automated rebuild
323
324* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
325- 1.1.5.93 snap with important bugfix so gconf actually works
326
327* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
328- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
329
330* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
331- 1.1.5.91 snap with gconf.m4 fix for libgnome
332
333* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
334- since every other build seems to avoid libglib-1.3.so.11,
335  rebuild and hope
336
337* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
338- cvs snap 1.1.5.90
339
340* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
341- GConf 1.1.5, glib 1.3.11
342
343* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
344- rebuild for glib 1.3.10
345
346* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
347- 1.1.3
348
349* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
350- cvs snap, remove bonobo-activation deps
351
352* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
353- update to new CVS snap, rebuild
354
355* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
356- create gconf2 rpm based on gconf1, comment out pofiles
357- include .pc files
358
359* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
360- fix description/summary
361
362* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
363- Add po files from sources.redhat.com
364
365* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
366- Add po files from sources.redhat.com
367
368* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
369- upgrade to 1.0.4 release I just made
370- fixes #51223, syslog spew
371
372* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
373- move gconf-config to devel RPM
374
375* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
376- how many releases of GConf can I make before it works?
377
378* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
379- Upgrade to 1.0.2 (which contains only bugfixes that
380  I reviewed and/or wrote myself)
381
382* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
383- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
384
385* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
386- Install the .la files in the devel package.
387
388* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
389- Use %%{_tmppath}
390- Move the .so files to the devel subpackage
391- langify
392- Move changelog to the end, where it should be :)
393- Don't specify (a bad) doc directory
394- Don't define name, version and release and use it in the rpm headers later
395- Remove "Packager:"
396- s/Copyright/License/
397
398* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
399- add --direct option to gconftool to avoid spawning oafd,
400  then commented out gconftool entirely since it checks
401  whether gconfd is running and that spawns oafd anyhow.
402  oafd simply needs to exit when unused.
403
404* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
405- Fix post, pointed out by Bill
406
407* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
408- Upgrade to 1.0.1
409
410* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
411- Import to Red Hat build system.
412
413* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
414
415- Created the .spec file
Note: See TracBrowser for help on using the repository browser.