source: projects/specs/trunk/F/FreeWnn/FreeWnn-vl.spec @ 521

Revision 521, 20.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define version 1.1.1
2%define release 2%{?_dist_release}
3%define alpha         018
4%define localstatedir /var
5
6Summary: FreeWnn Japanese Input System
7Name: FreeWnn
8Version: %{version}
9Release: %{release}
10Group: Applications/System
11License: GPL
12URL: http://www.freewnn.org/
13%define tarball       %{name}-%{version}-a%{alpha}
14Source0: ftp://ftp.freewnn.org/pub/FreeWnn/alpha/%{tarball}.tar.bz2
15Source1: FreeWnn.init
16Source2: cWnn.init
17Source3: tWnn.init
18Source4: kWnn.init
19Patch0: FreeWnn-fsstnd.patch
20Patch1: FreeWnn-ja-a017.patch
21Patch2: FreeWnn-noroot.patch
22Patch3: FreeWnn-noroot2.patch
23Patch4: jserverrc-g-jinmei.patch
24Patch5: FreeWnn-1.1.1-a018-cpp.patch
25Patch6: FreeWnn-1.1.1-config.sub.patch
26Patch7: FreeWnn-1.1.1-js.patch
27
28Prereq: grep, textutils, shadow-utils
29Requires: FreeWnn-common, chkconfig
30Conflicts: wnn6
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Summary(ja): FreeWnn 日本語入力システム
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37This distribution contains FreeWnn Japanese Input System.
38FreeWnn is a network-extensible Kana-to-Kanji conversion system
39and was jointly developed and released by the Software Research Group
40of KyotoUniversity Research Institute for Mathematical Science, OMRON
41Corporation and Astec, Inc.
42
43%description -l ja
44FreeWnn 仮名漢字変換システムは、京都大学数理解析研究所、オムロン株式会社、
45株式会社アステックの3者によって開発されたネットワーク仮名漢字変換シス
46テムです。
47
48このパッケージには日本語入力サーバのみ含まれます。
49
50%package devel
51Summary: development library and header file for FreeWnn
52Group: Development/Libraries
53Summary(ja): FreeWnn(jserver) 用開発ライブラリとヘッダファイル
54
55%description devel
56This package contains the header file and library for building programs
57with use FreeWnn.
58
59%description devel -l ja
60このパッケージには FreeWnn を利用した日本語入力 client を
61コンパイルするために必要なヘッダファイルとライブラリが
62含まれています。
63
64############################################################
65# FreeWnn-common
66############################################################
67%package common
68Summary: common File for Wnn
69Group: Applications/System
70Prereq: ldconfig
71
72%description common
73FreeWnn-common includes the files you need to run FreeWnn, cWnn or kWnn.
74Install FreeWnn-common if you will be using Wnn System.
75
76#############################################################
77#  cWnn
78#############################################################
79%package -n cWnn
80Summary: cWnn Chinese Input System
81Group: Applications/System
82Requires: FreeWnn-common, cWnn-common
83Prereq: shadow-utils, cWnn-common
84
85%description -n cWnn
86This package include FreeWnn Chinese Input System.
87
88%package -n cWnn-common
89Summary: cWnn/tWnn Chinese Input System common file
90Group: Applications/System
91Requires: FreeWnn-common
92Prereq: shadow-utils, ldconfig
93
94%description -n cWnn-common
95This package include cWnn/tWnn Chinese Input System common file.
96
97%package -n cWnn-devel
98Summary: development library and header file for cWnn,tWnn.
99Group: Development/Libraries
100
101%description -n cWnn-devel
102This package contains the header file and library for building programs
103with use cWnn,tWnn.
104
105#############################################################
106#  tWnn
107#############################################################
108%package -n tWnn
109Summary: tWnn Chinese Input System
110Group: Applications/System
111Requires: FreeWnn-common, cWnn-common
112Prereq: shadow-utils, cWnn-common
113
114%description -n tWnn
115tWnn Chinese Input System
116
117#############################################################
118#  kWnn
119#############################################################
120%package -n kWnn
121Summary: kWnn Korean Input System
122Group: Applications/System
123Requires: FreeWnn-common
124Prereq: shadow-utils, ldconfig
125
126%description -n kWnn
127kWnn Korean Input System
128
129%package -n kWnn-devel
130Summary: development library and header file for kWnn
131Group: Development/Libraries
132
133%description -n kWnn-devel
134This package contains the header file and library for building programs
135with use kWnn.
136
137%prep
138%setup -q -n FreeWnn-1.1.1-a017-pl4/Xsi
139%patch0 -p2
140%patch1 -p2
141%patch2 -p2
142%patch3 -p2
143%patch4 -p2
144%patch5 -p2
145%patch6 -p2 -b .config.sub
146%patch7 -p2 -b .js
147
148cp -p %{SOURCE2} .
149
150%build
151autoconf
152%configure --target=%{_arch}-pc-linux-gnu
153
154## for smp system.
155if [ "$SMP" != "" ]; then
156  make -j$SMP "MAKE=make -j$SMP"
157  make
158else
159  make
160fi
161
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166make DESTDIR=$RPM_BUILD_ROOT install
167make DESTDIR=$RPM_BUILD_ROOT install.man
168#make DESTDIR=$RPM_BUILD_ROOT \
169#    MANDIR=%{_prefix}/X11R6/man/ja_JP.ujis/man1 \
170#    LIBMANDIR=%{_prefix}/X11R6/man/ja_JP.ujis/man3 \
171#    install.man
172
173mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man1
174mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man3
175mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man4
176mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man5
177cd $RPM_BUILD_ROOT%{_mandir}/man1
178for i in atod.1 atof.1 dtoa.1 jserver.1 oldatonewa.1 uum.1 wddel.1 wdreg.1 \
179        wnnkill.1 wnnstat.1 wnntouch.1
180do
181        mv $i $RPM_BUILD_ROOT%{_mandir}/ja/man1/
182done
183cd $RPM_BUILD_ROOT%{_mandir}/man3
184for i in *.3
185do
186        mv $i $RPM_BUILD_ROOT%{_mandir}/ja/man3/
187done
188
189cd $RPM_BUILD_ROOT%{_mandir}/man4
190for i in 2a_ctrl.4 2b_romkana.4 cvt_key_tbl.4 fzk.data.4 fzk.u.4 \
191        hinsi_data.4 jserverrc.4 mode.4 serverdefs.4 ujis_dic.4 \
192        uumkey.4 uumrc.4 wnnenvrc.4
193do
194        mv $i $RPM_BUILD_ROOT%{_mandir}/ja/man4/
195done
196
197cd $RPM_BUILD_ROOT%{_mandir}/man5
198for i in pubdic.5 usr_dic.5
199do
200        mv $i $RPM_BUILD_ROOT%{_mandir}/ja/man5/
201done
202
203mkdir -p ${RPM_BUILD_ROOT}/etc/rc.d/init.d
204install -m755 %{SOURCE1} \
205        $RPM_BUILD_ROOT/etc/rc.d/init.d/FreeWnn
206install -m755 %{SOURCE2} \
207        $RPM_BUILD_ROOT/etc/rc.d/init.d/cWnn
208install -m755 %{SOURCE3} \
209        $RPM_BUILD_ROOT/etc/rc.d/init.d/tWnn
210install -m755 %{SOURCE4} \
211        $RPM_BUILD_ROOT/etc/rc.d/init.d/kWnn
212
213ln -sf /var/lib/wnn/ja/dic ${RPM_BUILD_ROOT}/etc/FreeWnn/ja/dic
214ln -sf /var/lib/wnn/zh_CN/dic ${RPM_BUILD_ROOT}/etc/FreeWnn/zh_CN/dic
215ln -sf /var/lib/wnn/zh_TW/dic ${RPM_BUILD_ROOT}/etc/FreeWnn/zh_TW/dic
216ln -sf /var/lib/wnn/ko_KR/dic ${RPM_BUILD_ROOT}/etc/FreeWnn/ko_KR/dic
217
218%clean
219rm -rf $RPM_BUILD_ROOT
220
221%pre
222# Do only for the first install
223if [ "$1" = 1 ] ; then
224  # Add the wnn4 lines to /etc/services
225  if (grep '22273/tcp' /etc/services >/dev/null); then
226    cat <<'_EOD1_' >&2
227warning: The wnn4 services appear to be present in /etc/services.
228_EOD1_
229    true
230  else
231    cat <<'_EOD2_' >>/etc/services
232# start of wnn4 services
233wnn4              22273/tcp
234# end of wnn4 services
235_EOD2_
236  fi
237fi
238
239# add user 'wnn'
240if  ! grep -q '^wnn:' /etc/passwd
241then
242    /usr/sbin/useradd -M -u 127 wnn -c "Wnn System Account"
243fi
244
245%post
246/sbin/chkconfig --level 2345 FreeWnn on
247%{_bindir}/wnntouch  /var/lib/wnn/ja/dic/gerodic/g-jinmei.dic
248cd /var/lib/wnn/ja/dic/pubdic
249%{_bindir}/wnntouch *.*
250
251%preun
252# Do only for the last un-install
253if [ "$1" = 0 ] ; then
254  # remove the wnn4 lines from /etc/services
255  if (grep '^# start of wnn4 services$' /etc/services >/dev/null && \
256      grep '^# end of wnn4 services$' /etc/services >/dev/null ); then
257    sed -e '/^# start of wnn4 services$/,/^# end of wnn4 services$/d' \
258        </etc/services >/tmp/services.tmp$$
259    cat /tmp/services.tmp$$ >/etc/services
260    rm /tmp/services.tmp$$
261  else
262    cat <<'_EOD3_' >&2
263warning: Unable to find the lines `# start of wnn4 services' and
264warning: `# end of wnn4 services' in the file /etc/services.
265warning: You should remove the wnn4 services from /etc/service manually.
266_EOD3_
267  fi
268fi
269/sbin/chkconfig --del FreeWnn
270
271
272%pre common
273# add user 'wnn'
274if  ! grep -q '^wnn:' /etc/passwd
275then
276    %{_sbindir}/useradd -M -u 127 wnn -c "Wnn System Account"
277fi
278
279%post common
280/sbin/ldconfig
281
282%postun common
283/sbin/ldconfig
284
285%pre -n cWnn
286# Do only for the first install
287if [ "$1" = 1 ] ; then
288  # Add the wnn4_Cn lines to /etc/services
289  if (grep '22289/tcp' /etc/services >/dev/null); then
290    cat <<'_EOD1_' >&2
291warning: The cserver services appear to be present in /etc/services.
292_EOD1_
293    true
294  else
295    cat <<'_EOD2_' >>/etc/services
296# start of wnn4_Cn services
297wnn4_Cn              22289/tcp
298# end of wnn4_Cn services
299_EOD2_
300  fi
301fi
302
303# add user 'wnn'
304if  ! grep -q '^wnn:' /etc/passwd
305then
306    %{_sbindir}/useradd -M -u 127 wnn -c "Wnn System Account"
307fi
308
309%post -n cWnn
310/sbin/chkconfig --add cWnn
311cd /var/lib/wnn/zh_CN/dic/sys
312%{_bindir}/cwnntouch *.*
313
314%preun -n cWnn
315# Do only for the last un-install
316if [ "$1" = 0 ] ; then
317  # remove the wnn4_Cn lines from /etc/services
318  if (grep '^# start of wnn4_Cn services$' /etc/services >/dev/null && \
319      grep '^# end of wnn4_Cn services$' /etc/services >/dev/null ); then
320    sed -e '/^# start of wnn4_Cn services$/,/^# end of wnn4_Cn services$/d' \
321        </etc/services >/tmp/services.tmp$$
322    cat /tmp/services.tmp$$ >/etc/services
323    rm /tmp/services.tmp$$
324  else
325    cat <<'_EOD3_' >&2
326warning: Unable to find the lines `# start of wnn4_Cn services' and
327warning: `# end of wnn4_Cn services' in the file /etc/services.
328warning: You should remove the wnn4_Cn services from /etc/service manually.
329_EOD3_
330  fi
331fi
332/sbin/chkconfig --del cWnn
333
334%pre -n tWnn
335# Do only for the first install
336if [ "$1" = 1 ] ; then
337  # Add the wnn4_Tw lines to /etc/services
338  if (grep '22321/tcp' /etc/services >/dev/null); then
339    cat <<'_EOD1_' >&2
340warning: The wnn4_Tw services appear to be present in /etc/services.
341_EOD1_
342    true
343  else
344    cat <<'_EOD2_' >>/etc/services
345# start of wnn4_Tw services
346wnn4_Tw              22321/tcp
347# end of wnn4_Tw services
348_EOD2_
349  fi
350fi
351
352%post -n cWnn-common
353/sbin/ldconfig
354
355%postun -n cWnn-common
356/sbin/ldconfig
357
358%post -n tWnn
359/sbin/chkconfig --add tWnn
360cd /var/lib/wnn/zh_TW/dic/sys
361%{_bindir}/cwnntouch *.*
362
363# Do only for the last un-install
364%preun -n tWnn
365if [ "$1" = 0 ] ; then
366  # remove the wnn4_Tw lines from /etc/services
367  if (grep '^# start of wnn4_Tw services$' /etc/services >/dev/null && \
368      grep '^# end of wnn4_Tw services$' /etc/services >/dev/null ); then
369    sed -e '/^# start of wnn4_Tw services$/,/^# end of wnn4_Tw services$/d' \
370        </etc/services >/tmp/services.tmp$$
371    cat /tmp/services.tmp$$ >/etc/services
372    rm /tmp/services.tmp$$
373  else
374    cat <<'_EOD3_' >&2
375warning: Unable to find the lines `# start of wnn4_Tw services' and
376warning: `# end of wnn4_Tw services' in the file /etc/services.
377warning: You should remove the wnn4_Tw services from /etc/service manually.
378_EOD3_
379  fi
380fi
381/sbin/chkconfig --del tWnn
382
383%pre -n kWnn
384# Do only for the first install
385if [ "$1" = 1 ] ; then
386  # Add the wnn4_Kr lines to /etc/services
387  if (grep '22305/tcp' /etc/services >/dev/null); then
388    cat <<'_EOD1_' >&2
389warning: The kserver services appear to be present in /etc/services.
390_EOD1_
391    true
392  else
393    cat <<'_EOD2_' >>/etc/services
394# start of wnn4_Kr services
395wnn4_Kr              22305/tcp
396# end of wnn4_Kr services
397_EOD2_
398  fi
399fi
400
401%post -n kWnn
402/sbin/chkconfig --add kWnn
403cd /var/lib/wnn/ko_KR/dic/sys
404%{_bindir}/kwnntouch *.*
405/sbin/ldconfig
406
407%preun -n kWnn
408# Do only for the last un-install
409if [ "$1" = 0 ] ; then
410  # remove the wnn4_Kr lines from /etc/services
411  if (grep '^# start of wnn4_Kr services$' /etc/services >/dev/null && \
412      grep '^# end of wnn4_Kr services$' /etc/services >/dev/null ); then
413    sed -e '/^# start of wnn4_Kr services$/,/^# end of wnn4_Kr services$/d' \
414        </etc/services >/tmp/services.tmp$$
415    cat /tmp/services.tmp$$ >/etc/services
416    rm /tmp/services.tmp$$
417  else
418    cat <<'_EOD3_' >&2
419warning: Unable to find the lines `# start of wnn4_Kr services' and
420warning: `# end of wnn4_Kr services' in the file /etc/services.
421warning: You should remove the wnn4_Kr services from /etc/service manually.
422_EOD3_
423  fi
424fi
425/sbin/chkconfig --del kWnn
426
427%postun -n kWnn
428/sbin/ldconfig
429
430%files
431%defattr(-,root,root)
432%doc Wnn/manual Wnn/manual.en
433%config /etc/rc.d/init.d/FreeWnn
434%attr(-,wnn,root) %{_bindir}/atod
435%attr(-,wnn,root) %{_bindir}/dtoa
436%attr(-,wnn,root) %{_bindir}/oldatonewa
437%attr(-,wnn,root) %{_bindir}/wdreg
438%attr(-,wnn,root) %{_bindir}/wnnstat
439%attr(-,wnn,root) %{_bindir}/atof
440%attr(4711,wnn,root) %{_bindir}/jserver
441%attr(-,wnn,root) %{_bindir}/wddel
442%attr(-,wnn,root) %{_bindir}/wnnkill
443%attr(-,wnn,root) %{_bindir}/wnntouch
444%{_mandir}/ja/man1/*
445%{_mandir}/ja/man4/*
446%{_mandir}/ja/man5/*
447%attr(-,wnn,root)/var/lib/wnn/ja/dic
448%dir /etc/FreeWnn/ja
449/etc/FreeWnn/ja/dic
450%config /etc/FreeWnn/ja/hinsi.data
451%config /etc/FreeWnn/ja/jserverrc
452%config /etc/FreeWnn/ja/libwnn.msg
453%config /etc/FreeWnn/ja/rk
454%config /etc/FreeWnn/ja/rk.vi
455%config /etc/FreeWnn/ja/uum.msg
456%config /etc/FreeWnn/ja/uumkey
457%config /etc/FreeWnn/ja/uumkey.omr
458%config /etc/FreeWnn/ja/uumkey_e
459%config /etc/FreeWnn/ja/uumrc
460%config /etc/FreeWnn/ja/uumrc.omr
461%config /etc/FreeWnn/ja/uumrc.rev
462%config /etc/FreeWnn/ja/uumrc_e
463%config /etc/FreeWnn/ja/uumrc_vi
464%config /etc/FreeWnn/ja/wnnenvrc
465%config /etc/FreeWnn/ja/wnnenvrc.omr
466%config /etc/FreeWnn/ja/wnnenvrc.rem
467%config /etc/FreeWnn/ja/wnnenvrc.rev
468%config /etc/FreeWnn/ja/wnnenvrc_R
469%config /etc/FreeWnn/ja/wnnenvrc_R.omr
470%config /etc/FreeWnn/ja/wnnenvrc_R.rem
471%config /etc/FreeWnn/ja/wnnstat.msg
472%dir /etc/FreeWnn/lt_LN
473/etc/FreeWnn/lt_LN/rk
474%config /etc/FreeWnn/lt_LN/uum.msg
475%config /etc/FreeWnn/lt_LN/uumkey
476%config /etc/FreeWnn/lt_LN/uumkey_e
477%config /etc/FreeWnn/lt_LN/uumrc
478
479%files devel
480%defattr(-,root,root)
481%{_includedir}/wnn/*
482%{_libdir}/libjd.a
483%{_libdir}/libjd.so
484%{_libdir}/libwnn.a
485%{_libdir}/libwnn.so
486%{_mandir}/ja/man3/*
487
488%files common
489%defattr(-,root,root)
490%doc CONTRIBUTORS ChangeLog
491%{_libdir}/libjd.so.*
492%{_libdir}/libwnn.so.*
493%dir /etc/FreeWnn
494%config /etc/FreeWnn/cvt_key_empty
495%config /etc/FreeWnn/cvt_key_tbl
496%config /etc/FreeWnn/cvt_key_tbl.ST
497%config /etc/FreeWnn/cvt_key_tbl.gm
498%config /etc/FreeWnn/cvt_key_tbl.kt
499%config /etc/FreeWnn/cvt_key_tbl.mv
500%config /etc/FreeWnn/cvt_key_tbl.vt
501%config /etc/FreeWnn/serverdefs
502
503%files -n cWnn
504%defattr(-,root,root)
505%config /etc/rc.d/init.d/cWnn
506%attr(4711,wnn,root) %{_bindir}/cserver
507%dir /etc/FreeWnn/zh_CN
508%config /etc/FreeWnn/zh_CN/cixing.data
509%config /etc/FreeWnn/zh_CN/cserverrc
510/etc/FreeWnn/zh_CN/dic
511%attr(-,wnn,root)/var/lib/wnn/zh_CN/dic
512%config /etc/FreeWnn/zh_CN/libwnn.msg
513/etc/FreeWnn/zh_CN/rk
514/etc/FreeWnn/zh_CN/rk_p
515/etc/FreeWnn/zh_CN/rk_z
516/etc/FreeWnn/zh_CN/uum.msg
517/etc/FreeWnn/zh_CN/uumkey
518/etc/FreeWnn/zh_CN/uumkey_e
519/etc/FreeWnn/zh_CN/uumkey_p
520%config /etc/FreeWnn/zh_CN/uumrc
521%config /etc/FreeWnn/zh_CN/uumrc_p
522%config /etc/FreeWnn/zh_CN/uumrc_z
523%config /etc/FreeWnn/zh_CN/wnnenvrc
524%config /etc/FreeWnn/zh_CN/wnnenvrc_Qi
525%config /etc/FreeWnn/zh_CN/wnnenvrc_QiR
526%config /etc/FreeWnn/zh_CN/wnnenvrc_R
527%config /etc/FreeWnn/zh_CN/wnnenvrc_Wu
528%config /etc/FreeWnn/zh_CN/wnnenvrc_WuR
529%config /etc/FreeWnn/zh_CN/wnnstat.msg
530%{_mandir}/man1/cserver.1*
531
532%files -n cWnn-common
533%defattr(-,root,root)
534%doc cWnn/manual cWnn/manual.en
535%{_libdir}/libcwnn.so.*
536%{_bindir}/catod
537%{_bindir}/catof                 
538%{_bindir}/cdtoa
539%{_bindir}/cwddel
540%{_bindir}/cwdreg
541%{_bindir}/cwnnkill
542%{_bindir}/cwnnstat
543%{_bindir}/cwnntouch
544%{_mandir}/man1/catod.1*
545%{_mandir}/man1/catof.1*
546%{_mandir}/man1/cdicsort.1*
547%{_mandir}/man1/cdtoa.1*
548%{_mandir}/man1/cuum.1*
549%{_mandir}/man1/cwddel.1*
550%{_mandir}/man1/cwdreg.1*
551%{_mandir}/man1/cwnnkill.1*
552%{_mandir}/man1/cwnnstat.1*
553%{_mandir}/man4/cenv.4*
554%{_mandir}/man4/ckey.4*
555%{_mandir}/man4/cwnn.4*
556%{_mandir}/man4/cst_end.4*
557
558%files -n cWnn-devel
559%defattr(-,root,root)
560%{_includedir}/cwnn/*
561%{_libdir}/libcwnn.a
562%{_libdir}/libcwnn.so
563
564%files -n tWnn
565%defattr(-,root,root)
566%config /etc/rc.d/init.d/tWnn
567%attr(4711,wnn,root) %{_bindir}/tserver
568%dir /etc/FreeWnn/zh_TW
569%config /etc/FreeWnn/zh_TW/cixing.data
570/etc/FreeWnn/zh_TW/dic
571%attr(-,wnn,root) /var/lib/wnn/zh_TW/dic
572%config /etc/FreeWnn/zh_TW/libwnn.msg
573/etc/FreeWnn/zh_TW/rk
574/etc/FreeWnn/zh_TW/rk_p
575/etc/FreeWnn/zh_TW/rk_z
576%config /etc/FreeWnn/zh_TW/tserverrc
577%config /etc/FreeWnn/zh_TW/uum.msg
578%config /etc/FreeWnn/zh_TW/uumkey
579%config /etc/FreeWnn/zh_TW/uumkey_e
580%config /etc/FreeWnn/zh_TW/uumkey_p
581%config /etc/FreeWnn/zh_TW/uumrc
582%config /etc/FreeWnn/zh_TW/uumrc_p
583%config /etc/FreeWnn/zh_TW/uumrc_z
584%config /etc/FreeWnn/zh_TW/wnnenvrc
585%config /etc/FreeWnn/zh_TW/wnnenvrc_R
586%config /etc/FreeWnn/zh_TW/wnnstat.msg
587
588%files -n kWnn
589%defattr(-,root,root)
590%config /etc/rc.d/init.d/kWnn
591%{_libdir}/libkwnn.so.*
592%{_bindir}/katod
593%{_bindir}/katof
594%{_bindir}/kdtoa
595%attr(4711,wnn,root) %{_bindir}/kserver
596%{_bindir}/kwddel
597%{_bindir}/kwdreg
598%{_bindir}/kwnnkill
599%{_bindir}/kwnnstat
600%{_bindir}/kwnntouch
601%dir /etc/FreeWnn/ko_KR
602/etc/FreeWnn/ko_KR/dic
603%attr(-,wnn,root) /var/lib/wnn/ko_KR/dic
604%config /etc/FreeWnn/ko_KR/hinsi.data
605%config /etc/FreeWnn/ko_KR/kserverrc
606%config /etc/FreeWnn/ko_KR/libwnn.msg
607/etc/FreeWnn/ko_KR/rk
608%config /etc/FreeWnn/ko_KR/uum.msg
609%config /etc/FreeWnn/ko_KR/uumkey
610%config /etc/FreeWnn/ko_KR/uumrc
611%config /etc/FreeWnn/ko_KR/wnnenvrc
612%config /etc/FreeWnn/ko_KR/wnnenvrc_R
613%config /etc/FreeWnn/ko_KR/wnnstat.msg
614
615%files -n kWnn-devel
616%defattr(-,root,root)
617%{_includedir}/kwnn/*
618%{_libdir}/libkwnn.a
619%{_libdir}/libkwnn.so
620
621%changelog
622* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2vl5
623- applied new versioning policy, spec in utf-8
624
625* Sat Sep 01 2007 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl11
626- s/Copyright/License/
627- added Patch6: FreeWnn-1.1.1-config.sub.patch
628- added Patch7: FreeWnn-1.1.1-js.patch
629- added option '--target=%%{_arch}-pc-linux-gnu' to %%configure
630
631* Wed Aug 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
632- 1.1.1-1vl10
633- added Patch5 along with adding "autoconf" in %%build section
634  (cpp is /lib/cpp, not `gcc -print-prog-name=cpp`, ad-hoc though...)
635
636* Wed Jul 18 2001 Yasuhide OOMORI <dasen@icntv.ne.jp>
637- 1.1.1-1vl9
638- rebuilt on egcs-1.1.2-24vl19
639- update to FreeWnn-1.1.1-a018
640- renewed FreeWnn-noroot.patch
641
642* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
643- 1.1.1-1vl8
644- rebuilt for VineSeed (with new %%{_mandir} definition)
645
646* Thu Jan 11 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 1.1.1-1vl7
647- removed options of %%configure
648
649* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.1.1-1vl6
650- build with gcc-2.95.3
651- partially used rpmmacros
652
653* Tue Jul 25 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
654- changed: each package (except devel) owns /etc/FreeWnn/* by adding %dir
655- modified again *.init to do with socket left in /tmp
656
657* Fri Jul 14 2000 Lisa Sagami <czs14350@nifty.ne.jp>
658- add %pre to addusr 127/wnn to avoid non-root build failure
659- modified *.init to do with socket left in /tmp
660- correct %doc
661
662* Tue Jul 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
663- 1.1.1-1vl3
664- modified %patch0 -p3 -> %patch0 -p2
665- modified BuildRoot:
666
667* Thu Jul  6 2000 Jun Nishii <jun@vinelinux.org>
668- 1.1.1-1vl2
669- fix bug in FreeWnn-ja-a017.patch
670
671* Wed Jul  5 2000 Jun Nishii <jun@vinelinux.org>
672- 1.1.1-1vl1
673- handle man page compress
674- update to FreeWnn-1.1.1-a017
675
676* Mon Jan 31 2000 Norihito Ohmori <nono@kondara.org>
677- ja_JP -> ja
678- configuration file move to /etc
679- change group.
680- add cWnn and kWnn.
681- add FreeWnn-common Package.
682- remove sample.eggrc
683
684* Tue Jan 25 2000 Norihito Ohmori <nono@vinelinux.org>
685- add defattr and attr for %files section
686
687* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
688- add Requires: chkconfig
689- Conflicts change from Wnn6 to wnn6
690
691* Fri Nov 12 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
692- FreeWnn-1.1.1-0.a013.4
693- added Prereq: grep,textutils
694
695* Wed Nov 10 1999 Jun Nishii <jun@flatout.org>
696- remove cWnn and kWnn
697
698* Sun Nov  7 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
699- [FreeWnn-1.1.1-0.a013.2]
700- Added a sample file of .eggrc to utilize gerodic.
701- Now do not ldconfig after installation of FreeWnn-devel.
702- Enabled you to compile with multi processors.
703- Added 'Prereq: shadow-utils' for installation.
704- Modified FreeWnn-jserver.script against error at boot time.
705
706* Wed Oct 20 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
707- [FreeWnn-1.1.1-0.a013.1]
708- Updated to FreeWnn-1.1.1-a013.
709- Separated cWnn,kWnn packages again.
710- Make this package relocatable.
711- Keep jserverrc and wnnenvrc when upgrading.
712
713* Fri Sep 24 1999 Masaru Yokoi <yokoi @yk.fks.ryukoku.ac.jp>
714- [FreeWnn-1.10-3]
715- Added /var/lib/wnn/*/dic/usr .
716- Moved libwnn.a from FreeWnn package to FreeWnn-devel package.
717- Moved Japanese manuals from /usr/X11R6/man/man*
718- to /usr/X11R6/man/ja_JP.ujis/man* .
719
720* Wed Aug 11 1999 Masaru Yokoi <yokoi@yk.fks.ryukoku.ac.jp>
721- First release.  Original idea is Sat Jul 12 1999 Norihito Ohmori
722- <ohmori@flatout.org>
Note: See TracBrowser for help on using the repository browser.