source: projects/specs/trunk/F/Field3D/Field3D-vl.spec @ 12510

Revision 12510, 6.2 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

Field3D-1.7.3-2

ImageMagick?-6.9.11.48-1

OpenEXR-2.5.3-1

OpenImageIO-2.2.9.0-1

babl-0.1.82-1

fmt-7.1.3-2

gegl04-0.4.26-2

gimp-2.10.22-1

hdf5-1.12.0-1

opencv-4.5.0-1

robin-map-0.6.3-4

Line 
1Name:           Field3D
2Version:        1.7.3
3Release:        2%{?_dist_release}
4Summary:        Library for storing voxel data
5Summary(ja):    ボクセルデータを蓄積するためのライブラリ
6Group:          system
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        BSD
11URL:            https://sites.google.com/site/field3d/
12# https://github.com/imageworks/Field3D/archive/v1.6.2.tar.gz
13Source0:        https://github.com/imageworks/Field3D/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  cmake doxygen
17BuildRequires:  hdf5-devel
18BuildRequires:  ilmbase-devel
19BuildRequires:  libboost-devel
20BuildRequires:  libboost-atomic
21BuildRequires:  libboost-chrono
22BuildRequires:  libboost-date-time
23BuildRequires:  libboost-program-options
24BuildRequires:  libboost-regex
25BuildRequires:  libboost-system
26BuildRequires:  libboost-thread
27BuildRequires:  zlib-devel
28
29Requires:       hdf5
30
31
32%description
33Field3D is an open source library for storing voxel data. It provides C++
34classes that handle in-memory storage and a file format based on HDF5 that
35allows the C++ objects to be written to and read from disk.
36
37
38%package devel
39Summary:        Development files for %{name}
40Summary(ja):    %{name} の開発用ファイル
41Group:          programming
42Requires:       %{name} = %{version}-%{release}
43
44%description devel
45Development headers and documentation for %{name}.
46
47# Need devel-docs subpackage.
48
49
50%debug_package
51
52
53%prep
54%setup -q
55
56# for OpenEXR (IlmBase) >= 2.4.0
57SFX=`pkg-config --variable=libsuffix IlmBase`
58
59sed -i \
60        -e "s/ Iex / Iex$SFX /" \
61        -e "s/ Half / Half$SFX /" \
62        -e "s/ IlmThread / IlmThread$SFX /" \
63        -e "s/ Imath/ Imath$SFX/" \
64        CMakeLists.txt
65
66%build
67export CFLAGS="%{?optflags} -DH5_USE_110_API=1"
68export CXXFLAGS="%{?optflags} -DH5_USE_110_API=1"
69
70rm -rf build && mkdir build && pushd build
71%cmake -DINSTALL_DOCS=OFF \
72       ../
73
74make %{?_smp_mflags}
75popd
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80pushd build
81make install DESTDIR=$RPM_BUILD_ROOT
82popd
83
84install -D -m 0644 man/f3dinfo.1 $RPM_BUILD_ROOT%{_mandir}/man1/f3dinfo.1
85
86
87%check
88pushd build
89LD_LIBRARY_PATH=`pwd` ./unitTest
90popd
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99
100%files
101%license COPYING
102%doc CHANGES README
103%{_bindir}/f3dinfo
104%{_libdir}/libField3D.so.*
105%{_mandir}/man1/f3dinfo.1.gz
106
107%files devel
108%doc docs/html/
109%{_includedir}/Field3D/
110%{_libdir}/libField3D.so
111
112
113%changelog
114* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-2
115- rebuilt with OpenEXR-2.5.3 and hdf5-1.12.0.
116
117* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-1
118- new upstream release.
119- built with boost-1.72.0.
120
121* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.2-2
122- rebuilt with ilmbase-2.4.0.
123
124* Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> - 1.7.2-1
125- update to 1.7.2
126
127* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-4
128- rebuild with hdf5-1.8.20
129
130* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-3
131- rebuild with libboost-1.66.0
132
133* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-2
134- rebuild with gcc-5.4.0
135
136* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-1
137- new upstream release
138- add BuildRequires: libboost-{atomic,chrono,date-time}
139
140* Fri Jan 30 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.3-2
141- added Group tag
142- added %%clean section
143
144* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.3-1
145- initial build for Vine Linux
146
147* Wed Jan 07 2015 Orion Poplawski <orion@cora.nwra.com> - 1.4.3-3
148- Rebuild for hdf5 1.8.4
149
150* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.3-2
151- rebuild (ilmbase), add matching/missing popd's
152
153* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.3-1
154- Update to latest upstream release.
155
156* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-19
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
158
159* Tue Jun 10 2014 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-18
160- Rebuild for hdf 1.8.13
161
162* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-17
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
164
165* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 1.3.2-16
166- Rebuild for boost 1.55.0
167
168* Fri Dec 27 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-15
169- Rebuild for hdf5 1.8.12
170
171* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-14
172- rebuild (ilmbase)
173
174* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-13
175- rebuild (ilmbase)
176
177* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-12
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
179
180* Sat Jul 27 2013 pmachata@redhat.com - 1.3.2-11
181- Rebuild for boost 1.54.0
182
183* Thu May 16 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-10
184- Rebuild for hdf5 1.8.11
185
186* Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-9
187- Rebuild for Boost-1.53.0
188
189* Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-8
190- Rebuild for Boost-1.53.0
191
192* Mon Dec  3 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-7
193- Rebuild for hdf5 1.8.10
194
195* Wed Aug  8 2012 David Malcolm <dmalcolm@redhat.com> - 1.3.2-6
196- rebuild against boost-1.50
197
198* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-4
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
200
201* Tue May 15 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-3
202- Rebuild for hdf5 1.8.9
203- Explicitly require the version of hdf5 built with
204
205* Fri Mar 23 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-2
206- Bump EVR for oops with F17 package to make sure rawhide package is newer.
207
208* Tue Feb 28 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-1
209- Update to latest release.
210
211* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
212- Rebuilt for c++ ABI breakage
213
214* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-3
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
216
217* Mon Jan 09 2012 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-2
218- Fixed building under GCC 4.7.0.
219
220* Sat Nov 12 2011 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
221- Initial release.
Note: See TracBrowser for help on using the repository browser.