source: projects/specs/trunk/F/Field3D/Field3D-vl.spec @ 12537

Revision 12537, 6.3 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

Field3D-1.7.3-3

OpenImageIO-2.2.11.1-1

c-ares-1.17.1-1

curl-7.75.0-1

galera-26.4.6-1

libboost-1.75.0-1

nghttp2-1.43.0-1

source-highlight-3.1.8-3

Line 
1Name:           Field3D
2Version:        1.7.3
3Release:        3%{?_dist_release}
4Summary:        Library for storing voxel data
5Summary(ja):    ボクセルデータを蓄積するためのライブラリ
6Group:          system
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        BSD
11URL:            https://sites.google.com/site/field3d/
12# https://github.com/imageworks/Field3D/archive/v1.6.2.tar.gz
13Source0:        https://github.com/imageworks/Field3D/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  cmake doxygen
17BuildRequires:  hdf5-devel
18BuildRequires:  ilmbase-devel
19BuildRequires:  libboost-devel
20BuildRequires:  libboost-atomic
21BuildRequires:  libboost-chrono
22BuildRequires:  libboost-date-time
23BuildRequires:  libboost-program-options
24BuildRequires:  libboost-regex
25BuildRequires:  libboost-system
26BuildRequires:  libboost-thread
27BuildRequires:  zlib-devel
28
29Requires:       hdf5
30
31%description
32Field3D is an open source library for storing voxel data. It provides C++
33classes that handle in-memory storage and a file format based on HDF5 that
34allows the C++ objects to be written to and read from disk.
35
36
37%package devel
38Summary:        Development files for %{name}
39Summary(ja):    %{name} の開発用ファイル
40Group:          programming
41Requires:       %{name} = %{version}-%{release}
42
43%description devel
44Development headers and documentation for %{name}.
45
46# Need devel-docs subpackage.
47
48
49%debug_package
50
51
52%prep
53%setup -q
54
55# for OpenEXR (IlmBase) >= 2.4.0
56SFX=`pkg-config --variable=libsuffix IlmBase`
57
58sed -i \
59        -e "s/ Iex / Iex$SFX /" \
60        -e "s/ Half / Half$SFX /" \
61        -e "s/ IlmThread / IlmThread$SFX /" \
62        -e "s/ Imath/ Imath$SFX/" \
63        CMakeLists.txt
64
65%build
66export CFLAGS="%{?optflags} -DH5_USE_110_API=1"
67export CXXFLAGS="%{?optflags} -DH5_USE_110_API=1"
68
69rm -rf build && mkdir build && pushd build
70%cmake -DINSTALL_DOCS=OFF \
71       ../
72
73make %{?_smp_mflags}
74popd
75
76
77%install
78rm -rf $RPM_BUILD_ROOT
79pushd build
80make install DESTDIR=$RPM_BUILD_ROOT
81popd
82
83install -D -m 0644 man/f3dinfo.1 $RPM_BUILD_ROOT%{_mandir}/man1/f3dinfo.1
84
85
86%check
87pushd build
88LD_LIBRARY_PATH=`pwd` ./unitTest
89popd
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98
99%files
100%license COPYING
101%doc CHANGES README
102%{_bindir}/f3dinfo
103%{_libdir}/libField3D.so.*
104%{_mandir}/man1/f3dinfo.1.gz
105
106%files devel
107%doc docs/html/
108%{_includedir}/Field3D/
109%{_libdir}/libField3D.so
110
111
112%changelog
113* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-3
114- rebuilt with libboost-1.75.0.
115
116* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-2
117- rebuilt with OpenEXR-2.5.3 and hdf5-1.12.0.
118
119* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-1
120- new upstream release.
121- built with boost-1.72.0.
122
123* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.2-2
124- rebuilt with ilmbase-2.4.0.
125
126* Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> - 1.7.2-1
127- update to 1.7.2
128
129* Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-4
130- rebuild with hdf5-1.8.20
131
132* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-3
133- rebuild with libboost-1.66.0
134
135* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-2
136- rebuild with gcc-5.4.0
137
138* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-1
139- new upstream release
140- add BuildRequires: libboost-{atomic,chrono,date-time}
141
142* Fri Jan 30 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.3-2
143- added Group tag
144- added %%clean section
145
146* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.3-1
147- initial build for Vine Linux
148
149* Wed Jan 07 2015 Orion Poplawski <orion@cora.nwra.com> - 1.4.3-3
150- Rebuild for hdf5 1.8.4
151
152* Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.3-2
153- rebuild (ilmbase), add matching/missing popd's
154
155* Fri Sep  5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.3-1
156- Update to latest upstream release.
157
158* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-19
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
160
161* Tue Jun 10 2014 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-18
162- Rebuild for hdf 1.8.13
163
164* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-17
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
166
167* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 1.3.2-16
168- Rebuild for boost 1.55.0
169
170* Fri Dec 27 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-15
171- Rebuild for hdf5 1.8.12
172
173* Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-14
174- rebuild (ilmbase)
175
176* Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-13
177- rebuild (ilmbase)
178
179* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-12
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
181
182* Sat Jul 27 2013 pmachata@redhat.com - 1.3.2-11
183- Rebuild for boost 1.54.0
184
185* Thu May 16 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-10
186- Rebuild for hdf5 1.8.11
187
188* Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-9
189- Rebuild for Boost-1.53.0
190
191* Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-8
192- Rebuild for Boost-1.53.0
193
194* Mon Dec  3 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-7
195- Rebuild for hdf5 1.8.10
196
197* Wed Aug  8 2012 David Malcolm <dmalcolm@redhat.com> - 1.3.2-6
198- rebuild against boost-1.50
199
200* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-4
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
202
203* Tue May 15 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-3
204- Rebuild for hdf5 1.8.9
205- Explicitly require the version of hdf5 built with
206
207* Fri Mar 23 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-2
208- Bump EVR for oops with F17 package to make sure rawhide package is newer.
209
210* Tue Feb 28 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-1
211- Update to latest release.
212
213* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
214- Rebuilt for c++ ABI breakage
215
216* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-3
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
218
219* Mon Jan 09 2012 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-2
220- Fixed building under GCC 4.7.0.
221
222* Sat Nov 12 2011 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
223- Initial release.
Note: See TracBrowser for help on using the repository browser.