source: projects/specs/trunk/D/DeviceKit-power/DeviceKit-power-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define glib2_version           2.22.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.82
4%define polkit_version          0.92
5%define parted_version          1.8.8
6
7Summary: Power Management Service
8Summary(ja): 電源管理サービス
9Name: DeviceKit-power
10Version: 013
11Release: 1%{?_dist_release}
12License: GPLv2+
13Group: System Environment/Libraries
14URL: http://cgit.freedesktop.org/DeviceKit/DeviceKit-power/
15Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
16Patch10: DeviceKit-power-011-gcc41.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Requires(post): /sbin/ldconfig
21Requires(postun): /sbin/ldconfig
22BuildRequires: glib2-devel >= %{glib2_version}
23BuildRequires: dbus-devel  >= %{dbus_version}
24BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
25BuildRequires: polkit-devel >= %{polkit_version}
26BuildRequires: sqlite3-devel
27BuildRequires: libtool
28BuildRequires: intltool
29BuildRequires: gettext
30BuildRequires: libgudev1-devel
31BuildRequires: libusb-devel
32
33Requires: dbus
34Requires: dbus-glib
35Requires: glib2
36Requires: polkit
37Requires: udev
38Requires: pm-utils
39
40%description
41DeviceKit-power provides a daemon, API and command line tools for
42managing power devices attached to the system.
43
44%package devel
45Summary: Headers and libraries for DeviceKit-power
46Summary(ja): %{name} の開発ファイル
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description devel
51Headers and libraries for DeviceKit-power.
52
53%prep
54%setup -q
55%patch10 -p1 -b .gcc41
56
57%build
58%configure
59make %{?_smp_mflags}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT
64
65rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
66rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
67
68mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
69cp README AUTHORS NEWS COPYING HACKING doc/TODO $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post -p /sbin/ldconfig
75
76%postun -p /sbin/ldconfig
77
78%files
79%defattr(-,root,root,-)
80
81%doc %dir %{_datadir}/doc/%{name}-%{version}
82%doc %{_datadir}/doc/%{name}-%{version}/NEWS
83%doc %{_datadir}/doc/%{name}-%{version}/COPYING
84%doc %{_datadir}/doc/%{name}-%{version}/AUTHORS
85%doc %{_datadir}/doc/%{name}-%{version}/HACKING
86%doc %{_datadir}/doc/%{name}-%{version}/README
87%doc %{_datadir}/doc/%{name}-%{version}/TODO
88%{_libdir}/libdevkit-power-gobject*.so.*
89%{_sysconfdir}/dbus-1/system.d/*.conf
90/lib/udev/rules.d/*.rules
91%dir %{_localstatedir}/lib/DeviceKit-power
92%{_bindir}/*
93%{_libexecdir}/*
94
95%{_mandir}/man1/*
96%{_mandir}/man7/*
97%{_mandir}/man8/*
98
99%{_datadir}/polkit-1/actions/*.policy
100%{_datadir}/dbus-1/system-services/*.service
101
102%files devel
103%defattr(-,root,root,-)
104%{_datadir}/dbus-1/interfaces/*.xml
105%dir %{_datadir}/gtk-doc/html/devkit-power
106%{_datadir}/gtk-doc/html/devkit-power/*
107%{_libdir}/libdevkit-power-gobject*.so
108%{_libdir}/pkgconfig/*.pc
109%dir %{_includedir}/DeviceKit-power/devkit-power-gobject
110%{_includedir}/DeviceKit-power/devkit-power-gobject/*.h
111
112%changelog
113* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 013-1
114- new upstream release
115
116* Wed Nov 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 012-1
117- new upstream release
118
119* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 011-1
120- initial build for Vine Linux
121
122* Mon Sep 14 2009 Richard Hughes  <rhughes@redhat.com> - 011-0.1.20090914git
123- Update to todays git snapshot to fix the session exploding when a USB UPS is
124  inserted then removed a few times.
125
126* Mon Aug 03 2009 Richard Hughes <richard@hughsie.com> - 010-4
127- Continue to poll when we guessed a status value, and only stop when the
128  kernel says definitively that we are fully charged.
129
130* Sun Aug 02 2009 Richard Hughes <richard@hughsie.com> - 010-3
131- Put the development include files in the devel package not the main package.
132- Fixes #515104
133
134* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 010-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
136
137* Wed Jul 22 2009 Richard Hughes <richard@hughsie.com> - 010-1
138- Update to 010
139- Fixes a few problems with multi-battery laptops
140- Port to GUdev and PolicyKit1
141
142* Mon Jul 06 2009 Richard Hughes <richard@hughsie.com> - 009-1
143- Update to 009
144- Fixes many problems with multi-battery laptops
145- Use pm-powersave like HAL used to
146- Fix detecting UPS devices
147- Add support for recalled laptop batteries
148
149* Tue Jun 16 2009 Richard Hughes  <rhughes@redhat.com> - 009-0.4.20090616git
150- Do autoreconf as well due to different values of automake on koji.
151
152* Tue Jun 16 2009 Richard Hughes  <rhughes@redhat.com> - 009-0.3.20090616git
153- Do autoconf and automake as the polkit patch is pretty invasive
154- Fix up file lists with the new polkit action paths
155
156* Tue Jun 16 2009 Richard Hughes  <rhughes@redhat.com> - 009-0.2.20090616git
157- Apply a patch to convert to the PolKit1 API.
158
159* Tue Jun 16 2009 Richard Hughes  <rhughes@redhat.com> - 009-0.1.20090616git
160- Update to todays git snapshot to fix reporting issues with empty batteries.
161
162* Mon Jun 01 2009 Richard Hughes <richard@hughsie.com> 008-1
163- Update to 008
164- Fixes #497563 and #495493
165
166* Wed May 13 2009 Richard Hughes  <rhughes@redhat.com> - 008-0.3.20090513git
167- Update to todays git snapshot which should fix some polling issues.
168- Fixes #495493
169
170* Thu May 07 2009 Richard Hughes  <rhughes@redhat.com> - 008-0.2.20090507git
171- Update to todays git snapshot which has the lid close property.
172
173* Tue Apr 01 2009 Richard Hughes  <rhughes@redhat.com> - 008-0.1.20090401git
174- Update to todays git snapshot which works with the new permissive DBus.
175
176* Mon Mar 30 2009 Richard Hughes <richard@hughsie.com> 007-2
177- Try to fix a compile error with koji and the new gcc.
178
179* Mon Mar 30 2009 Richard Hughes <richard@hughsie.com> 007-1
180- Update to 007
181
182* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 006-3
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
184
185* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 006-2
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
187
188* Mon Feb 10 2009 Richard Hughes <richard@hughsie.com> 006-1
189- Update to 006
190
191* Mon Feb 02 2009 Richard Hughes <richard@hughsie.com> 005-1
192- Update to 005
193
194* Fri Jan 23 2009 Richard Hughes <richard@hughsie.com> 004-1
195- Update to 004
196
197* Tue Dec 09 2008 Richard Hughes <richard@hughsie.com> 003-1
198- Update to 003
199
200* Thu Nov 13 2008 Matthias Clasen <mclasen@redhat.com> 002-1
201- Update to 002
202
203* Sat Sep 06 2008 Richard Hughes <richard@hughsie.com> 001-2
204- Fix the licence, and some directory ownership issues for the review request
205
206* Tue Sep 02 2008 Richard Hughes <richard@hughsie.com> 001-1
207- Initial spec file
208
Note: See TracBrowser for help on using the repository browser.