source: projects/specs/trunk/C/Cython/Cython-vl.spec @ 9646

Revision 9646, 2.2 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Summary:        A language for writing Python extension modules
2Summary(ja):    Python 拡張モジュールを簡単に作成するためのプログラミング言語
3Name:           Cython
4Version:        0.22.1
5Release:        1%{?_dist_release}
6
7Group:          Development/Languages
8License:        Apache
9URL:            http://cython.org/
10Source0:        http://cython.org/release/%{name}-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  python-devel
14
15Vendor:         Project Vine
16Distribution:   Vine Linux
17Packager:       Takemikaduchi
18
19%description
20Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
21
22The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
23This allows the compiler to generate very efficient C code from Cython code.
24The generated C code compiles with Python 2.4 and later (including Python 3).
25
26This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
27
28
29%prep
30%setup -q
31
32%build
33%{__python} setup.py build
34
35
36%install
37rm -rf $RPM_BUILD_ROOT
38%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
39
40%clean
41rm -rf $RPM_BUILD_ROOT
42
43
44%files
45%defattr(-,root,root,-)
46%doc COPYING.txt LICENSE.txt README.txt USAGE.txt
47%{_bindir}/cygdb
48%{_bindir}/cython
49%{_bindir}/cythonize
50%{python_sitearch}/Cython
51%{python_sitearch}/pyximport
52%{python_sitearch}/Cython-%{version}-py2.7.egg-info
53%{python_sitearch}/cython.*
54
55
56%changelog
57* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
58- new upstream release
59
60* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21.2-1
61- new upstream release
62- moved to Development/Languages Group
63
64* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.19.2-1
65- new upstream release
66
67* Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-1
68- new upstream release
69
70* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.1-1
71- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.