source: projects/specs/trunk/C/Cython/Cython-vl.spec @ 12469

Revision 12469, 3.7 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Summary:        A language for writing Python extension modules
2Summary(ja):    Python 拡張モジュールを簡単に作成するためのプログラミング言語
3Name:           Cython
4Version:        0.29.21
5Release:        1%{?_dist_release}
6Group:          programming
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        Apache
11URL:            https://cython.org/
12Source0:        https://github.com/cython/cython/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  python-rpm-macros
16
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19BuildRequires:  python2-rpm-macros
20
21%description
22Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
23
24The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
25This allows the compiler to generate very efficient C code from Cython code.
26The generated C code compiles with Python 2.4 and later (including Python 3).
27
28This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
29
30
31%package -n python3-Cython
32Summary:        A language for writing Python extension modules
33Summary(ja):    Python 拡張モジュールを簡単に作成するためのプログラミング言語
34Group:          programming
35BuildRequires:  python3-devel
36BuildRequires:  python3-setuptools
37BuildRequires:  python3-rpm-macros
38
39%description -n python3-Cython
40Cython is a language that makes writing C extensions for the Python language as easy as Python itself. Cython is based on the well-known Pyrex, but supports more cutting edge functionality and optimizations.
41
42The Cython language is very close to the Python language, but Cython additionally supports calling C functions and declaring C types on variables and class attributes.
43This allows the compiler to generate very efficient C code from Cython code.
44The generated C code compiles with Python 2.4 and later (including Python 3).
45
46This makes Cython the ideal language for wrapping external C libraries, and for fast C modules that speed up the execution of Python code.
47
48
49%prep
50%setup -q -n cython-%{version}
51
52%build
53%{py2_build}
54%{py3_build}
55
56
57%install
58rm -rf $RPM_BUILD_ROOT
59%{py2_install}
60%{py3_install}
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66
67%files
68%defattr(-,root,root,-)
69%license COPYING.txt LICENSE.txt
70%doc README.txt USAGE.txt
71#{_bindir}/cygdb
72#{_bindir}/cython
73#{_bindir}/cythonize
74%{python_sitearch}/Cython
75%{python_sitearch}/pyximport
76%{python_sitearch}/Cython-%{version}-*-info
77%{python_sitearch}/cython.*
78
79%files -n python3-Cython
80%license COPYING.txt LICENSE.txt
81%doc README.txt USAGE.txt
82%{_bindir}/cygdb
83%{_bindir}/cython
84%{_bindir}/cythonize
85%{python3_sitearch}/*
86
87
88%changelog
89* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.21-1
90- new upstream release.
91
92* Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.29.13-1
93- new upstream release.
94
95* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.4-1
96- new upstream release
97
98* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
99- new upstream release
100
101* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21.2-1
102- new upstream release
103- moved to Development/Languages Group
104
105* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.19.2-1
106- new upstream release
107
108* Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-1
109- new upstream release
110
111* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.1-1
112- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.