source: projects/specs/trunk/C/ConsoleKit/ConsoleKit-vl.spec @ 6890

Revision 6890, 9.8 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define glib2_version           2.26.0
2%define dbus_version            1.4.14
3%define dbus_glib_version       0.94
4%define polkit_version          0.101
5
6Summary: System daemon for tracking users, sessions and seats
7Summary(ja): ユーザ、セッションおよび座席を捕捉するシステムデーモン
8Name: ConsoleKit
9Version: 0.4.5
10Release: 2%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Daemons
13URL: http://www.freedesktop.org/wiki/Software/ConsoleKit
14
15Source0: http://people.freedesktop.org/~mccann/dist/ConsoleKit-%{version}.tar.bz2
16# Convert to new upstart syntax
17Patch0: ConsoleKit-0.4.1-upstart06.patch
18
19Patch1: ConsoleKit-0.4.5-git20120320.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: glib2-devel >= %{glib2_version}
23BuildRequires: dbus-devel  >= %{dbus_version}
24BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
25BuildRequires: polkit-devel >= %{polkit_version}
26BuildRequires: pam-devel
27BuildRequires: libX11-devel
28BuildRequires: zlib-devel
29BuildRequires: xmlto
30Requires: dbus
31Requires: dbus-glib
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37ConsoleKit is a system daemon for tracking what users are logged
38into the system and how they interact with the computer (e.g.
39which keyboard and mouse they use).
40
41It provides asynchronous notification via the system message bus.
42
43
44%package x11
45Summary: X11-requiring add-ons for ConsoleKit
46Summary(ja): X11 を必要とする ConsoleKit アドオン
47License: GPLv2+
48Group: System Environment/Daemons
49Requires: %name = %{version}-%{release}
50Requires: libX11
51
52%description x11
53ConsoleKit contains some tools that require Xlib to be installed,
54those are in this separate package so server systems need not install
55X. Applications (such as xorg-x11-xinit) and login managers (such as
56gdm) that need to register their X sessions with ConsoleKit needs to
57have a Requires: for this package.
58
59
60%package libs
61Summary: ConsoleKit libraries
62Summary(ja): ConsoleKit ライブラリ
63License: MIT
64Group: System Environment/Libraries
65Requires: pam
66Requires: dbus
67
68%description libs
69Libraries and a PAM module for interacting with ConsoleKit.
70
71
72%package devel
73Summary: Development libraries and headers for ConsoleKit
74Summary(ja): Development libraries and headers for ConsoleKit
75License: MIT
76Group: Development/Libraries
77Requires: dbus-devel
78Requires: pkgconfig
79
80%description devel
81Headers, libraries and API docs for ConsoleKit
82
83
84%package docs
85Summary: Developer documentation for ConsoleKit
86Summary(ja): ConsoleKit の開発用ドキュメント
87Group: Development/Libraries
88Requires: %name = %{version}-%{release}
89
90%description docs
91Developer documentation for ConsoleKit.
92
93
94%prep
95%setup -q
96%patch0 -p1 -b .upstart06
97%patch1 -p1
98
99%build
100%configure --with-pid-file=%{_localstatedir}/run/console-kit-daemon.pid --enable-pam-module --with-pam-module-dir=/%{_lib}/security --enable-docbook-docs --docdir=%{_datadir}/doc/%{name}-%{version}
101
102make
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107make install DESTDIR=$RPM_BUILD_ROOT
108
109rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
110rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
111rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.a
112rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
113
114# make sure we don't package a history log
115rm -f $RPM_BUILD_ROOT/%{_var}/log/ConsoleKit/history
116
117cp AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO \
118        $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
119
120#mkdir -p %{buildroot}%{_sysconfdir}/init.d
121#install -m 755 %{SOURCE10} %{buildroot}%{_sysconfdir}/init.d/ConsoleKit
122
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127
128%post
129if [ -f /var/log/ConsoleKit/history ]; then
130   chmod a+r /var/log/ConsoleKit/history
131fi
132
133%post libs -p /sbin/ldconfig
134
135%postun libs -p /sbin/ldconfig
136
137%files
138%defattr(-,root,root,-)
139%doc %dir %{_datadir}/doc/%{name}-%{version}
140%doc %{_datadir}/doc/%{name}-%{version}/[A-Z]*
141%{_sysconfdir}/dbus-1/system.d/*
142#%{_sysconfdir}/init.d/ConsoleKit
143%{_datadir}/dbus-1/system-services/*.service
144%{_datadir}/polkit-1/actions/*.policy
145%dir %{_sysconfdir}/ConsoleKit
146%dir %{_sysconfdir}/ConsoleKit/seats.d
147%dir %{_sysconfdir}/ConsoleKit/run-seat.d
148%dir %{_sysconfdir}/ConsoleKit/run-session.d
149%dir %{_prefix}/lib/ConsoleKit
150%dir %{_prefix}/lib/ConsoleKit/scripts
151%dir %{_prefix}/lib/ConsoleKit/run-seat.d
152%dir %{_prefix}/lib/ConsoleKit/run-session.d
153%dir %{_var}/run/ConsoleKit
154%attr(755,root,root) %dir %{_var}/log/ConsoleKit
155%config %{_sysconfdir}/ConsoleKit/seats.d/00-primary.seat
156%{_sbindir}/console-kit-daemon
157%{_sbindir}/ck-log-system-restart
158%{_sbindir}/ck-log-system-start
159%{_sbindir}/ck-log-system-stop
160%{_bindir}/ck-history
161%{_bindir}/ck-launch-session
162%{_bindir}/ck-list-sessions
163%{_prefix}/lib/ConsoleKit/scripts/*
164
165%files x11
166%defattr(-,root,root,-)
167%{_libexecdir}/*
168
169%files libs
170%defattr(-,root,root,-)
171%{_libdir}/lib*.so.*
172/%{_lib}/security/*.so
173%{_mandir}/man8/pam_ck_connector.8.gz
174
175%files devel
176%defattr(-,root,root,-)
177%{_libdir}/lib*.so
178%{_libdir}/pkgconfig/*
179%{_includedir}/*
180%{_datadir}/dbus-1/interfaces/org.freedesktop.ConsoleKit.*.xml
181
182%files docs
183%defattr(-,root,root,-)
184%doc %dir %{_datadir}/doc/%{name}-%{version}/spec
185%doc %{_datadir}/doc/%{name}-%{version}/spec/*
186
187
188%changelog
189* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-2
190- add Patch0 (ConsoleKit-0.4.1-upstart06.patch)
191- add Patch1 (ConsoleKit-0.4.5-git20120320.patch)
192
193* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
194- new upstream release
195
196* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
197- new upstream release
198
199* Wed Oct 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.2-1
200- new upstream release
201
202* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.1-2
203- rebuilt with rpm-4.8.1 for pkg-config
204
205* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.1-1
206- new upstream release
207
208* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-6
209- add patch11 to enable policy access to the Manager.GetSessions
210  method in the default ConsoleKit.conf
211  https://bugs.freedesktop.org/show_bug.cgi?id=20471
212  http://bugzilla.gnome.org/show_bug.cgi?id=580259
213
214* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-5
215- add patch10 to fix dbus permissions
216  https://bugs.freedesktop.org/show_bug.cgi?id=19020
217  (This patch is already committed to master)
218
219* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-4
220- changed Group to System Environment/Daemons
221- changed x11 subpackage's Group to System Environment/Daemons
222- changed libs subpackage's Group to System Environment/Libraries
223- added %%post, %%postun section fo libs subpackage
224
225* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.0-3
226- changed %%{_libdir}/ConsoleKit to %%{_prefix}/lib/ConsoleKit
227
228* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-2
229- remove init script, console-kit-daemon is now launched from dbus.
230
231* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-1
232- new upstream release
233
234* Tue Jul  1 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-3
235- fix Japanese description
236- spec in UTF-8
237- add Source10 (init.d script for console-kit-daemon);
238  add %%post/%%preun scripts, until "initng" being introduced to Vine
239
240* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-2
241- rebuilt with PolicyKit-0.8
242
243* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.10-1
244- new upstream release
245- new versioning policy
246
247* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-0vl1
248- initial build for Vine Linux
249
250* Mon Oct 22 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.3-2
251- Rebuild against new dbus-glib
252
253* Tue Sep 18 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.3-1
254- Update to 0.2.3
255
256* Mon Sep 17 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.2-1
257- Update to 0.2.2
258
259* Mon Aug  6 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.1-4
260- Update license field
261
262* Fri Jul  6 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.1-3
263- Add LSB header to init script (#246894)
264
265* Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-2
266- Set doc directory correctly
267
268* Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-1
269- Update to upstream release 0.2.1
270- Drop the patch to daemonize properly as that was merged upstream
271
272* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-0.git20070402
273- Update to git snapshot to get a lot of bug fixes
274- Use libX11 rather than gtk2 to verify X11 sessions; update BR and R
275- Split X11-using bits into a new subpackage ConsoleKit-x11 (#233982)
276- Use correct location for PAM module on 64-bit (#234545)
277- Build developer documentation and put them in ConsoleKit-docs
278
279* Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-2
280- BR gtk2-devel and make ConsoleKit Require gtk2 (could just be
281  libX11 with a simple patch)
282
283* Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-1
284- Update to upstream release 0.2.0
285- Daemonize properly (#229206)
286
287* Sat Mar  3 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301.1
288- Allow caller to pass uid=0 in libck-connector
289
290* Thu Mar  1 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301
291- Update to git snapshot
292- Drop all patches as they are committed upstream
293- New tool ck-list-sessions
294- New -libs subpackage with run-time libraries and a PAM module
295- New -devel subpackage with headers
296
297* Tue Feb  6 2007 David Zeuthen <davidz@redhat.com> - 0.1.0-5%{?dist}
298- Start ConsoleKit a bit earlier so it starts before HAL (98 -> 90)
299- Minimize stack usage so VIRT size is more reasonable (mclasen)
300- Make session inactive when switching to non-session (davidz)
301
302* Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-4
303- Don't mark initscripts %%config
304- Use proper lock and pid ile names
305
306* Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-3
307- More package review feedback
308
309* Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-2
310- Incorporate package review feedback
311
312* Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-1
313- Update to the first public release 0.1.0
314- Some spec cleanups
315
316* Mon Oct 23 2006 David Zeuthen <davidz@redhat.com> - 0.0.3-1
317- Initial build.
318
Note: See TracBrowser for help on using the repository browser.