source: projects/specs/trunk/C/ConsoleKit/ConsoleKit-vl.spec @ 1983

Revision 1983, 9.2 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define glib2_version           2.20.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.80
4%define polkit_version          0.92
5
6Summary: System daemon for tracking users, sessions and seats
7Summary(ja): ユーザ、セッションおよび座席を捕捉するシステムデーモン
8Name: ConsoleKit
9Version: 0.4.1
10Release: 2%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Daemons
13URL: http://www.freedesktop.org/wiki/Software/ConsoleKit
14
15Source0: http://people.freedesktop.org/~mccann/dist/ConsoleKit-%{version}.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: dbus-devel  >= %{dbus_version}
20BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
21BuildRequires: polkit-devel >= %{polkit_version}
22BuildRequires: pam-devel
23BuildRequires: libX11-devel
24BuildRequires: zlib-devel
25BuildRequires: xmlto
26Requires: dbus
27Requires: dbus-glib
28
29%description
30ConsoleKit is a system daemon for tracking what users are logged
31into the system and how they interact with the computer (e.g.
32which keyboard and mouse they use).
33
34It provides asynchronous notification via the system message bus.
35
36
37%package x11
38Summary: X11-requiring add-ons for ConsoleKit
39Summary(ja): X11 を必要とする ConsoleKit アドオン
40License: GPLv2+
41Group: System Environment/Daemons
42Requires: %name = %{version}-%{release}
43Requires: libX11
44
45%description x11
46ConsoleKit contains some tools that require Xlib to be installed,
47those are in this separate package so server systems need not install
48X. Applications (such as xorg-x11-xinit) and login managers (such as
49gdm) that need to register their X sessions with ConsoleKit needs to
50have a Requires: for this package.
51
52
53%package libs
54Summary: ConsoleKit libraries
55Summary(ja): ConsoleKit ライブラリ
56License: MIT
57Group: System Environment/Libraries
58Requires: pam
59Requires: dbus
60
61%description libs
62Libraries and a PAM module for interacting with ConsoleKit.
63
64
65%package devel
66Summary: Development libraries and headers for ConsoleKit
67Summary(ja): Development libraries and headers for ConsoleKit
68License: MIT
69Group: Development/Libraries
70Requires: dbus-devel
71Requires: pkgconfig
72
73%description devel
74Headers, libraries and API docs for ConsoleKit
75
76
77%package docs
78Summary: Developer documentation for ConsoleKit
79Summary(ja): ConsoleKit の開発用ドキュメント
80Group: Development/Libraries
81Requires: %name = %{version}-%{release}
82
83%description docs
84Developer documentation for ConsoleKit.
85
86
87%prep
88%setup -q
89
90%build
91%configure --with-pid-file=%{_localstatedir}/run/console-kit-daemon.pid --enable-pam-module --with-pam-module-dir=/%{_lib}/security --enable-docbook-docs --docdir=%{_datadir}/doc/%{name}-%{version}
92
93make
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99
100rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
101rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
102rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.a
103rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
104
105# make sure we don't package a history log
106rm -f $RPM_BUILD_ROOT/%{_var}/log/ConsoleKit/history
107
108cp AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO \
109        $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
110
111#mkdir -p %{buildroot}%{_sysconfdir}/init.d
112#install -m 755 %{SOURCE10} %{buildroot}%{_sysconfdir}/init.d/ConsoleKit
113
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118
119%post
120if [ -f /var/log/ConsoleKit/history ]; then
121   chmod a+r /var/log/ConsoleKit/history
122fi
123
124%post libs -p /sbin/ldconfig
125
126%postun libs -p /sbin/ldconfig
127
128%files
129%defattr(-,root,root,-)
130%doc %dir %{_datadir}/doc/%{name}-%{version}
131%doc %{_datadir}/doc/%{name}-%{version}/[A-Z]*
132%{_sysconfdir}/dbus-1/system.d/*
133#%{_sysconfdir}/init.d/ConsoleKit
134%{_datadir}/dbus-1/system-services/*.service
135%{_datadir}/polkit-1/actions/*.policy
136%dir %{_sysconfdir}/ConsoleKit
137%dir %{_sysconfdir}/ConsoleKit/seats.d
138%dir %{_sysconfdir}/ConsoleKit/run-seat.d
139%dir %{_sysconfdir}/ConsoleKit/run-session.d
140%dir %{_prefix}/lib/ConsoleKit
141%dir %{_prefix}/lib/ConsoleKit/scripts
142%dir %{_prefix}/lib/ConsoleKit/run-seat.d
143%dir %{_prefix}/lib/ConsoleKit/run-session.d
144%dir %{_var}/run/ConsoleKit
145%attr(755,root,root) %dir %{_var}/log/ConsoleKit
146%config %{_sysconfdir}/ConsoleKit/seats.d/00-primary.seat
147%{_sbindir}/console-kit-daemon
148%{_sbindir}/ck-log-system-restart
149%{_sbindir}/ck-log-system-start
150%{_sbindir}/ck-log-system-stop
151%{_bindir}/ck-history
152%{_bindir}/ck-launch-session
153%{_bindir}/ck-list-sessions
154%{_prefix}/lib/ConsoleKit/scripts/*
155
156%files x11
157%defattr(-,root,root,-)
158%{_libexecdir}/*
159
160%files libs
161%defattr(-,root,root,-)
162%{_libdir}/lib*.so.*
163/%{_lib}/security/*.so
164%{_mandir}/man8/pam_ck_connector.8.gz
165
166%files devel
167%defattr(-,root,root,-)
168%{_libdir}/lib*.so
169%{_libdir}/pkgconfig/*
170%{_includedir}/*
171%{_datadir}/dbus-1/interfaces/org.freedesktop.ConsoleKit.*.xml
172
173%files docs
174%defattr(-,root,root,-)
175%doc %dir %{_datadir}/doc/%{name}-%{version}/spec
176%doc %{_datadir}/doc/%{name}-%{version}/spec/*
177
178
179%changelog
180* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.1-2
181- rebuilt with rpm-4.8.1 for pkg-config
182
183* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.1-1
184- new upstream release
185
186* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-6
187- add patch11 to enable policy access to the Manager.GetSessions
188  method in the default ConsoleKit.conf
189  https://bugs.freedesktop.org/show_bug.cgi?id=20471
190  http://bugzilla.gnome.org/show_bug.cgi?id=580259
191
192* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-5
193- add patch10 to fix dbus permissions
194  https://bugs.freedesktop.org/show_bug.cgi?id=19020
195  (This patch is already committed to master)
196
197* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-4
198- changed Group to System Environment/Daemons
199- changed x11 subpackage's Group to System Environment/Daemons
200- changed libs subpackage's Group to System Environment/Libraries
201- added %%post, %%postun section fo libs subpackage
202
203* Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.0-3
204- changed %%{_libdir}/ConsoleKit to %%{_prefix}/lib/ConsoleKit
205
206* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-2
207- remove init script, console-kit-daemon is now launched from dbus.
208
209* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-1
210- new upstream release
211
212* Tue Jul  1 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-3
213- fix Japanese description
214- spec in UTF-8
215- add Source10 (init.d script for console-kit-daemon);
216  add %%post/%%preun scripts, until "initng" being introduced to Vine
217
218* Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.2.10-2
219- rebuilt with PolicyKit-0.8
220
221* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.10-1
222- new upstream release
223- new versioning policy
224
225* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-0vl1
226- initial build for Vine Linux
227
228* Mon Oct 22 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.3-2
229- Rebuild against new dbus-glib
230
231* Tue Sep 18 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.3-1
232- Update to 0.2.3
233
234* Mon Sep 17 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.2-1
235- Update to 0.2.2
236
237* Mon Aug  6 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.1-4
238- Update license field
239
240* Fri Jul  6 2007 Matthias Clasen  <mclasen@redhat.com> - 0.2.1-3
241- Add LSB header to init script (#246894)
242
243* Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-2
244- Set doc directory correctly
245
246* Mon Apr 16 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-1
247- Update to upstream release 0.2.1
248- Drop the patch to daemonize properly as that was merged upstream
249
250* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> - 0.2.1-0.git20070402
251- Update to git snapshot to get a lot of bug fixes
252- Use libX11 rather than gtk2 to verify X11 sessions; update BR and R
253- Split X11-using bits into a new subpackage ConsoleKit-x11 (#233982)
254- Use correct location for PAM module on 64-bit (#234545)
255- Build developer documentation and put them in ConsoleKit-docs
256
257* Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-2
258- BR gtk2-devel and make ConsoleKit Require gtk2 (could just be
259  libX11 with a simple patch)
260
261* Mon Mar 19 2007 David Zeuthen <davidz@redhat.com> - 0.2.0-1
262- Update to upstream release 0.2.0
263- Daemonize properly (#229206)
264
265* Sat Mar  3 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301.1
266- Allow caller to pass uid=0 in libck-connector
267
268* Thu Mar  1 2007 David Zeuthen <davidz@redhat.com> - 0.1.3-0.git20070301
269- Update to git snapshot
270- Drop all patches as they are committed upstream
271- New tool ck-list-sessions
272- New -libs subpackage with run-time libraries and a PAM module
273- New -devel subpackage with headers
274
275* Tue Feb  6 2007 David Zeuthen <davidz@redhat.com> - 0.1.0-5%{?dist}
276- Start ConsoleKit a bit earlier so it starts before HAL (98 -> 90)
277- Minimize stack usage so VIRT size is more reasonable (mclasen)
278- Make session inactive when switching to non-session (davidz)
279
280* Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-4
281- Don't mark initscripts %%config
282- Use proper lock and pid ile names
283
284* Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-3
285- More package review feedback
286
287* Fri Jan 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-2
288- Incorporate package review feedback
289
290* Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.1.0-1
291- Update to the first public release 0.1.0
292- Some spec cleanups
293
294* Mon Oct 23 2006 David Zeuthen <davidz@redhat.com> - 0.0.3-1
295- Initial build.
296
Note: See TracBrowser for help on using the repository browser.