source: projects/specs/trunk/A/AfterStep-APPS/AfterStep-APPS-vl.spec @ 521

Revision 521, 10.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Various applets for use with AfterStep and compatible window managers.
2Name: AfterStep-APPS
3Version: 20001212
4Release: 0vl3
5License: GPL
6Group: User Interface/Desktops
7Source0: http://www.tigr.net/afterstep/as-apps/download/as-apps-001212.tar
8Patch0: AfterStep-APPS-1.5beta1-glibc.patch
9Patch1: ascp-paths.patch
10Patch2: as-apps-compile.patch
11Patch4: xiterm-utmp.patch
12Patch5: AfterStep-APPS-xiterm-getopt.patch
13Patch6: AfterStep-APPS-xiterm-ccoptions.patch
14Patch7: 05-asdm-make.patch
15Patch100: asbutton-install.patch
16#Requires: /usr/sbin/utempter
17Requires: utempter
18Prereq: /sbin/ldconfig
19BuildPrereq: WindowMaker-devel
20BuildRoot: %{_tmppath}/%{name}-root
21
22%description
23The AfterStep-APPS package includes a group of applications for use
24with the AfterStep window manager. Applications in this package
25include an Advanced Power Management system monitor for laptops
26(asapm), a CPU load monitor (ascpu), a simple state machine (asexec),
27a filesystem monitor (asfsm), a CPU load monitor for use with the PROC
28filesystem (asload), a mail checker (asmail), a memory utilization
29monitor (asmem), a volume controller knob for the /dev/mixer device
30(asmix), a volume controller for various sound inputs (asmixer), a
31modem status monitor (asmodem), an analog clock (astime), a color
32VT102 emulator (aterm), an audio CD player (ascd), a clock (asclock),
33and a control panel for configuring AfterStep (ascp).
34
35Install AfterStep-APPS if you're planning to use the AfterStep window
36manager.
37
38%prep
39%setup -q -c
40rm -f *.asc
41for archive in *.tar.gz ; do
42        tar xzf $archive
43        rm -f $archive
44done
45%patch0 -p1 -b .glibc
46%patch1 -p1 -b .paths
47%patch4 -p1 -b .xiutmp
48%patch5 -p1 -b .getopt
49%patch6 -p1 -b .ccoptions
50# Someone forgot to make clean in some packages :/
51find . -name "*.o" -exec rm -f {} \;
52find . -name "*~" -exec rm -f {} \;
53perl -pi -e "s,#include <linux/ucdrom.h>,," ascdc-0.3/ascdc.c
54%patch100 -p0 -b .asbutton
55
56%build
57for package in `ls` ; do
58    cd $package
59    case $package in
60        ascd-* )
61            perl -pi -e "s,/etc/X11,/usr/X11R6/lib/X11,g"  * ascd/* libworkman/*
62            patch -p2 -b --suffix .compile < %{PATCH2}
63            CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" ./configure << EOF
64/mnt/cdrom
65%{_prefix}/X11R6/bin
66%{_prefix}/X11R6/man/man1
67%{_datadir}/afterstep/ascd
681
69EOF
70            perl -pi -e "s,/usr/local/share/AScd,/usr/share/$package,g" * misc/*
71            make MANDIR=/usr/X11R6/man/man1 \
72                BINDIR=/usr/X11R6/bin \
73                THEMESDIR=/usr/share/$package \
74                SHLIBDIR=/usr/X11R6/lib \
75                CDEBUGFLAGS="$RPM_OPT_FLAGS" \
76                CXXDEBUGFLAGS="$RPM_OPT_FLAGS"
77            ;;
78       
79        asdm* )
80            # xmkmf'ed stuff...
81            xmkmf -a
82            perl -pi -e "s,/etc/X11,/usr/X11R6/lib/X11,g"  *
83            # patch -b --suffix .compile < %{PATCH7}
84            make CDEBUGFLAGS="$RPM_OPT_FLAGS" \
85                 CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
86                 XDMDIR=/usr/share/asdm BINDIR=/usr/X11R6/bin \
87                 SHLIBDIR=/usr/lib
88            ;;
89        asampcd* | asDrinks* | asampmenu* | randbg* )
90            # These are perl scripts and don't need to be compiled...
91            ;;
92
93        asbutton* | miniCHESS* )
94            # Non-autoconf'ed C...
95            make CCFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
96            ;;
97           
98        aspbm* )
99            make CCFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
100            make -C conf CCFLAGS="$RPM_OPT_FLAGS" CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"
101            ;;
102        asmon* )
103            cd asmon
104            make
105            cd ..
106            ;;
107
108        ASFiles* | Tasks* | asfaces* | asfatm* | asppp* | astrash* |  astuner* |\
109        xfascd* | asxmcd* | asftavm* | aswmtheme* )
110            # ASFiles: needs some odd DnD library
111            # Tasks: must be compiled inside AfterStep source tree
112            # asfaces: broken beyond repair
113            # asfatm: needs temperature measurement kernel patch
114            # asppp: missing dial.xpm file
115            # astrash: needs OffiX
116            # astuner: needs linux/radio.h
117            # xfascd: needs XForms
118            # asxmcd: needs Motif
119            # asftavm: needs i2c& sensors not part of default 2.2 kernels
120            # aswmtheme: not a module per se.
121
122            ;;
123
124        xiterm*)
125            # cough cough, hack hack -- ewt
126            CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 \
127                --enable-xpm-background --enable-utmp --enable-wtmp \
128                --enable-menubar --enable-next-scroll --enable-kanji
129            xmkmf
130            make Makefiles
131            cd src
132            sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
133               Makefile > Makefile.foo
134            sed -e "s/-lsocket //" Makefile.foo > Makefile
135            make
136            ;;
137        asclock*)
138            perl -pi -e "s,/etc/X11,/usr/X11R6/lib/X11,g"  *
139            CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 << EOF
140classic
141
142EOF
143             make
144             ;;
145        *)
146            #just about every other thing supports autoconf
147            #
148            # Look ma, I'm broken!  What a shock.
149            rm -f config.cache
150            CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 --datadir=/usr/share --with-gtk-prefix=/usr
151            make
152            ;;
153    esac
154    cd ..
155done
156
157%install
158
159rm -rf $RPM_BUILD_ROOT
160mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
161mkdir -p $RPM_BUILD_ROOT/usr/X11R6/man/man1
162mkdir -p $RPM_BUILD_ROOT/usr/share/afterstep/desktop/icons/16bpp
163
164for package in `ls` ; do
165    cd $package
166    case $package in
167        ASFiles* | Tasks* | asfaces* | asfatm* | asppp* | astrash* | astuner* | \
168        xfascd* | asxmcd* | asftavm* )
169            # We ignore broken stuff and stuff that simply doesn't make
170            # much sense...
171            ;;
172
173        asDrinks* | asampmenu* | randbg* | aswmtheme* )
174            cp -a *.pl $RPM_BUILD_ROOT/usr/X11R6/bin
175            ;;
176
177        ascd-* | xiterm*)
178            if test -d ./ascd; then
179                mkdir -p $RPM_BUILD_ROOT/usr/share/$package
180                cp -a ascd/themes/* $RPM_BUILD_ROOT/usr/share/$package
181                perl -pi -e "s,/usr/local/include,$RPM_BUILD_ROOT/usr/include,g" libworkman/Makefile
182                perl -pi -e "s,/usr/local/lib,$RPM_BUILD_ROOT/usr/lib,g" libworkman/Makefile
183                fi
184
185            make install install.man \
186                AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
187                AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
188                MANDIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
189                BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
190                THEMESDIR=$RPM_BUILD_ROOT/usr/share/$package \
191                SHLIBDIR=$RPM_BUILD_ROOT/usr/X11R6/lib
192            ;;
193        ascp-* )
194            make install \
195                ASCP_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
196                ASCP_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
197                prefx=$RPM_BUILD_ROOT \
198                DESTDIR=$RPM_BUILD_ROOT
199            ;;
200        asmon-* )
201            cd asmon
202            perl -pi -e "s,/usr/local/bin,$RPM_BUILD_ROOT/usr/X11R6/bin,g" Makefile
203            make install \
204                AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
205                AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
206                BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
207                DESTDIR=$RPM_BUILD_ROOT
208            cd ..
209            ;;
210        asclock-* | asdm-* | sessreg-* | xpmroot-* )
211                make install DESTDIR=$RPM_BUILD_ROOT \
212                AFTER_BIN_DIR=/usr/X11R6/bin \
213                BINDIR=/usr/X11R6/bin \
214                AFTER_MAN_DIR=/usr/X11R6/man/man1 \
215                XDMDIR=/usr/share/asdm \
216                MANDIR=/usr/X11R6/man/man1 \
217                SHLIBDIR=/usr/lib
218                make install.man DESTDIR=$RPM_BUILD_ROOT \
219                AFTER_BIN_DIR=/usr/X11R6/bin \
220                         BINDIR=/usr/X11R6/bin \
221                         AFTER_MAN_DIR=/usr/X11R6/man/man1 \
222                         MANDIR=/usr/X11R6/man/man1 \
223            ;;
224           
225        miniCHESS-*)
226                make install DESTDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
227                AFTER_BIN_DIR=/usr/X11R6/bin \
228                         BINDIR=/usr/X11R6/bin \
229                         AFTER_MAN_DIR=/usr/X11R6/man/man1
230            ;;
231
232        *)
233                make install \
234                AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
235                AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
236                MANDIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
237                BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
238                DESTDIR=$RPM_BUILD_ROOT \
239                ICONDIR=$RPM_BUILD_ROOT/usr/share/afterstep/desktop/icons/16bpp
240                make install.man \
241                AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
242                AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
243                MANDIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
244                BINDIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
245                DESTDIR=$RPM_BUILD_ROOT || true # should work for non-install.man targets as well...
246            ;;
247    esac
248    cd ..
249done
250
251rm -f $RPM_BUILD_ROOT/usr/X11R6/{bin,man/man1}/{sessreg,xpmroot,qplot}*
252rm -f $RPM_BUILD_ROOT/usr/X11R6/lib/X11/app-defaults/Chooser
253chmod 0755 $RPM_BUILD_ROOT/usr/X11R6/bin/asbutton
254chmod 0755 $RPM_BUILD_ROOT/usr/share/afterstep/ascp/icons
255chmod 0644 $RPM_BUILD_ROOT/usr/X11R6/man/man1/*
256
257
258# creating file list
259rm -f $RPM_BUILD_DIR/master.list.%{name}
260
261#find $RPM_BUILD_ROOT  -type d | sed '1,2d;s|^\.|\%attr(-,root,root) \%dir |' \
262#       > $RPM_BUILD_DIR/master.list.%{name}
263
264find $RPM_BUILD_ROOT -type f -o -type l >> $RPM_BUILD_DIR/master.list.%{name}
265
266sed -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_DIR/master.list.%{name} \
267        | sed -e "s,/man[0-9]/.*,&\*,g" \
268        | sort > file.list.%{name}
269
270%clean
271rm -rf $RPM_BUILD_ROOT
272rm -f $RPM_BUILD_DIR/master.list.%{name}
273
274%post -p /sbin/ldconfig
275
276%postun -p /sbin/ldconfig
277
278%files -f file.list.%{name}
279%defattr(-,root,root)
280%dir /usr/share/ascd-*
281%dir /usr/share/asdm
282
283%changelog
284* Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 20001212-0vl3
285- Requires for utempter instead of file dependent /usr/sbin/utempter
286- s/Copyright/License/
287
288* Wed May 23 2001 <sagami@vinelinux.org>
289- 001212-0vl2: add BuildPreReq: WindowMaker-devel and actually use it(ascd)
290
291* Mon May 14 2001 <sagami@vinelinux.org>
292- 001212-0vl1 from connectiva 000909
293- --enable-kanji for xiterm
294
295* Mon Feb  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
296- remove /usr/X11R6/lib/X11/app-defaults/Chooser
297  it is provided by XFree86.
298
299* Sun Feb  6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
300- fix some Makefile issues:
301  asclock, asdm, sessreg and xpmroot got installed to
302  $RPM_BUILD_ROOT/$RPM_BUILD_ROOT and were therefore not included in the
303  RPM.
304  minichess was installed to $RPM_BUILD_ROOT/minichess, and therefore wasn't
305  included in the RPM.
306
307* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
308- Fix permissions on /usr/X11R6/bin/asbutton and /usr/share/afterstep/ascp/icons
309
310* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
311- add %defattr
312
313* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
314- fix description
315
316* Thu Jan 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
317- 20000124
318- BuildPrereq WindowMaker (we need WINGs.h)
319
320* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
321- fix various bugs
322- update source archive
323- compile/fix some more components
324
325* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
326- update source archive.
327
328* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
329- strip binaries
330
331* Mon Mar 29 1999 Bill Nottingham <notting@redhat.com>
332- update source archive
333- fix ascp
334
335* Wed Mar 24 1999 Erik Troan <ewt@redhat.com>
336- utempter support
337- got xiterm building again
338
339* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
340- auto rebuild in the new build environment (release 2)
341
342* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
343- build for glibc 2.1
344
345* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
346- updated source archive
347- remove  conflicting files with XFree86
348
349* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
350- split from afterstep and packaged for RH 5.2
Note: See TracBrowser for help on using the repository browser.