source: projects/specs/trunk/9/915resolution/915resolution-vl.spec @ 521

Revision 521, 4.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name 915resolution
2%define version 0.5.3
3%define release 1%{?_dist_release}
4
5Summary: A tool to force resolution of Intel 8xx,9xx video Card
6Summary(ja): Intel 8xx, 9xx ビデオカードの解像度を強制設定するツール
7Name: %{name}
8Version: %{version}
9Release: %{release}
10License: Public Domain
11Group: Applications/System
12Url: http://www.geocities.com/stomljen/
13
14Source0: http://www.geocities.com/stomljen/%{name}-%{version}.tar.gz
15Source1: 915resolution.init
16Source2: 915resolution.default-sysconfig
17Patch: 915resolution-0.5.3-automatically-choose-best-mode.patch
18Patch10: 915resolution-0.5.3-new-chipset.patch
19
20BuildRoot: %{_tmppath}/%{name}-buildroot
21Exclusivearch: %{ix86} x86_64
22Requires: sed, grep
23
24%description
25915resolution is a tool to modify the video BIOS of the 800 and 900 series
26Intel graphics chipsets. This includes the 845G, 855G, and 865G chipsets, as
27well as 915G, 915GM, and 945G chipsets. This modification is necessary to
28allow the display of certain graphics resolutions for an Xorg or XFree86
29graphics server.
30
31915resolution's modifications of the BIOS are transient. There is no risk of
32permanent modification of the BIOS. This also means that 915resolution must be
33run every time the computer boots inorder for it's changes to take effect.
34
35915resolution is derived from the tool 855resolution. However, the code differs
36substantially. 915resolution's code base is much simpler. 915resolution also
37allows the modification of bits per pixel.
38
39%prep
40%setup -q
41%patch0 -p1 -b .automarically-choose-best-mode
42%patch10 -p1 -b .new-chipset
43
44%build
45rm -f *.o
46%__make
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51install -D -m755 %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
52install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
53install -D -m0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
54
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post
60/sbin/chkconfig --add %{name}
61
62%preun
63if [ "$1" = 0 ]; then
64        /sbin/chkconfig --del %{name}
65fi
66
67
68%files
69%defattr(-,root,root)
70%doc chipset_info.txt README.txt
71%{_sbindir}/%{name}
72%{_sysconfdir}/rc.d/init.d/*
73%config(noreplace) %{_sysconfdir}/sysconfig/*
74
75
76%changelog
77* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.3-1vl5
78- applied new versioning policy, spec in utf-8
79
80* Tue Oct 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl2
81- add Patch10 to support 945GME,965GM/GME/GLE,G33,Q33,Q35
82
83* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
84- new upstream release
85
86* Tue Dec 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl4
87- fix init.d/915resolution (<BTS:416>)
88
89* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl3
90- update init.d/915resolution
91  - fix bugs (<BTS:0176>)
92
93* Sat Sep 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
94- update init.d/915resolution
95  - fix bugs
96  - automatically detect XRESO and YRESO from xorg.conf.
97    (use Monitor ModelName "LCD Panel XRESOxYRESO")
98
99* Sat Sep 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
100- initial build for Vine Linux based on MDV package.
101
102* Fri Aug 04 2006 Olivier Thauvin <nanardon@mandriva.org>
103+ 08/04/06 19:16:12 (52825)
104- rebuild
105
106* Fri Aug 04 2006 Olivier Thauvin <nanardon@mandriva.org>
107+ 08/04/06 19:14:11 (52823)
108Import 915resolution
109
110* Fri Jun 16 2006 Pixel <pixel@mandriva.com> 0.5.2-5mdv2007.0
111- fix patch automatically-choose-best-mode
112  (if no matching X resolution, it was chosing the last entry, even if unreachable)
113
114* Tue May 02 2006 Olivier Thauvin <nanardon@mandriva.org> 0.5.2-4mdk
115- Exclusivearch should be x86_64, not only amd64
116
117* Tue May 02 2006 Pixel <pixel@mandriva.com> 0.5.2-3mdk
118- Exclusivearch x86 and am64 (bugzilla #22203)
119
120* Fri Apr 28 2006 Pixel <pixel@mandriva.com> 0.5.2-2mdk
121- add patch automatically-choose-best-mode allowing "915resolution best <X> <Y>"
122  which chooses the first bios mode with xres == <X>
123  (or defaults to the last available mode)
124- add a service calling 915resolution before dm is launched
125
126* Thu Apr 27 2006 Olivier Thauvin <nanardon@mandriva.org> 0.5.2-1mdk
127- initial mandriva rpm
128
Note: See TracBrowser for help on using the repository browser.