source: projects/specs/tags/6_0_REL/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 4268

Revision 4268, 18.9 KB checked in by daisuke, 13 years ago (diff)

update xinf

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.15.0
10Release:   4%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# patches from upstream git
20# http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/
21Patch1: xf86-video-intel-2.15.0-git9d6e02.patch
22
23# Clamp VGA pixel clock to 250MHz,
24# anything higher's going to look awful anyway. (#559426)
25Patch10: intel-2.11.0-vga-clock-max.patch
26
27# import from ubuntu/debian package
28Patch101: intel-2.15.0-copy-fb.patch
29
30# vine patch
31# disable DRI on SandyBridge/IvyBridge for now.
32Patch200: intel-2.15.0-sandybridge-disable-dri.patch
33
34
35ExclusiveArch: %{ix86} x86_64 ia64
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37BuildRequires: autoconf, automake, libtool
38BuildRequires: xorg-x11-server-sdk >= 1.7.99
39BuildRequires: libXvMC-devel
40BuildRequires: libGL-devel >= 7.10
41BuildRequires: libdrm-devel >= 2.4.25
42BuildRequires: kernel-headers >= 2.6.33
43BuildRequires: libudev-devel
44BuildRequires: libxcb-devel >= 1.5
45BuildRequires: xcb-util-devel
46
47Requires:  hwdata
48Requires:  xorg-x11-server-Xorg
49Requires:  xcb-util
50
51Obsoletes: xorg-x11-drv-i810
52Provides: xorg-x11-drv-i810
53
54#Conflicts:  kudzu < 1.2.42-1
55
56%description
57X.Org X11 Intel video driver.
58
59%package devel
60Summary:   Xorg X11 Intel video driver XvMC development package
61Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
62Group:     Development/System
63Requires:  %{name} = %{epoch}:%{version}-%{release}
64Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
65
66%description devel
67X.Org X11 Intel video driver XvMC development package.
68
69%package -n intel-gpu-tools
70Summary:    Debugging tools for Intel graphics chips
71Group:      Development/Tools
72
73%description -n intel-gpu-tools
74Debugging tools for Intel graphics chips
75
76
77%prep
78%setup -q -n xf86-video-intel-%{version} -b3
79
80%patch1 -p1 -b .git9d6e02
81
82%patch10 -p1 -b .vga-clock
83
84%patch101 -p1 -b .copy-fb
85
86%patch200 -p1 -b .disable-dri
87
88%build
89autoreconf -vi
90
91%configure \
92  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
93  --enable-dri --enable-xvmc
94make
95
96pushd ../intel-gpu-tools-%{gputoolsdate}
97autoreconf -v --install
98%configure
99make
100popd
101
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106make install DESTDIR=$RPM_BUILD_ROOT
107mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
108install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
109
110pushd ../intel-gpu-tools-%{gputoolsdate}
111make install DESTDIR=$RPM_BUILD_ROOT
112popd
113
114
115find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%triggerpostun -- XOrg < 7.0
121if (grep -q i810 /etc/X11/xorg.conf)
122then
123  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
124  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
125fi ||:
126
127%files
128%defattr(-,root,root,-)
129%{driverdir}/intel_drv.so
130%{_datadir}/hwdata/videoaliases/intel.xinf
131%{_libdir}/libI810XvMC.so.*
132%{_libdir}/libIntelXvMC.so.*
133%{_mandir}/man4/i*
134
135%files devel
136%defattr(-,root,root,-)
137%{_libdir}/libI810XvMC.so
138%{_libdir}/libIntelXvMC.so
139
140%files -n intel-gpu-tools
141%defattr(-,root,root,-)
142%{_bindir}/intel_*
143%{_mandir}/man1/intel_*.1*
144
145
146%changelog
147* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
148- update intel.xinf
149- add patch10 from fedora
150  - Clamp VGA pixel clock to 250MHz,
151    anything higher's going to look awful anyway. (#559426)
152
153* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
154- drop patch1-3 and replaced with new patch1 from git master
155- add Patch200 to disable DRI on SandyBridge/IvyBridge
156- update intel-gpu-tools
157
158* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
159- add Patch1-3 from upstream
160
161* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
162- new upstream release
163- drop upstream patches: 107-115
164- temporary disabled patch101
165- BR: libdrm >= 2.4.25
166
167* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
168- add Patch101-115 from ubuntu/debian package
169  - Patch101: Plymouth integration patch
170  - Patch107: Check null return from uxa_acquire_solid()
171  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
172  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
173  - Patch110,114: Cherry picks to fix a large number of build warnings.
174  - Patch111: Fix clipped window plane offset
175  - Patch112: Fix issue where vertical green line and strange colors
176              shows up when playing gstreamer with certain videos,
177              when dragged.  (LP 460677)
178  - Patch113: Fixes GPU lockup during login with
179              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
180              error messages listed in the gpu dump text. (LP 710321)
181  - Patch115: Don't fill up Xorg.0.log with
182              "get vblank counter failed: Invalid argument" warnings.
183   
184* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
185- rebuild with xserver-1.10.0
186
187* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
188- new upstream release
189
190* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
191- new upstream release
192
193* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
194- rebuild with xserver-1.9.2
195
196* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
197- new upstream release
198- add Patch40: fix uxa planemask (backported)
199- add Patch61: add support for backlight on macbooks
200- add Patch62: disable page flipping for stability
201
202* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
203- new upstream release
204- drop patch70
205
206* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
207- rebuild again with xserver-1.8rc
208
209* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
210- add intel-gpu-tools as sub-package
211- rebuild with libdrm-2.4.18
212
213* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
214- new upstream release
215- import Patch1,2,60,70 from fedora
216- add BR: kernel-headers >= 2.6.33 (new drm header required)
217- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
218- add BR; libudev-devel and autoreconf for Patch60
219
220* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
221- rebuild with libdrm-2.4.17
222
223* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
224- new upstream release
225
226* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
227- new upstream release (hopefully fixes severe issues w/ efifb)
228- drop all patches already upstreamed; import Patch20/21 from Fedora
229
230* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
231- import Patch121,122 from ubuntu
232- build with libdrm-2.4.12 which fixes vt switch crash
233
234* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
235- apply patch114 to fix Xv with non-GEM kernel
236
237* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
238- update to 2.6.3
239- add patch106,107,115,118,119,120 from ubuntu
240  - add Patch106: remove triple buffering
241  - add Patch107: remove page flipping
242  - add Patch115: fix crash Xv overlay
243  - add Patch118: drop legacy3d
244  - add Patch119: fix crashes in drm bo
245  - add Patch120: fix vt switch
246- add patch130-134 from upstream git
247  - add Patch130: fix another vt switch leak
248  - add Patch131: Create known output configuration at EnterVT time
249  - add Patch132: fix leak of some 965 render state on VT switch
250  - add Patch133: fix crash with fake bufmgr and UXA
251  - add Patch134: fix EnterVT/LeaveVT
252  - add Patch135: add new chip supoprt
253
254
255* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
256- revert to 2.6.1, add Epoch
257- add Patch103-121 from ubuntu
258
259* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
260- new upstream release
261
262* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
263- new upstream release
264
265* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
266- new upstream release
267
268* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
269- add Patch5 - Dont die on irq handler failure
270
271* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
272- new upstream release
273- add BR: libdrm-devel >= 2.4.0-3
274
275* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
276- import Patch10,11,12 from ubuntu
277
278* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
279- new upstream release
280- add triggerpostun script to replace i810 driver to intel driver
281
282* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
283- new upstream release
284
285* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
286- new upstream release
287- rename i810.xinf to intel.xinf
288- update intel.xinf (add Intel 4 series)
289
290* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
291- rebuild with new xserver
292
293* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
294- new upstream release
295
296* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
297- new upstream release
298
299* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
300- new upstream release
301
302* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
303- initial build for Vine Linux
304
305* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
306- Rebuild for new server ABI.
307- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
308
309* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
310- hook up ch7017 (bz#408471)
311
312* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
313- xf86-video-intel 2.2.0
314
315* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
316- xf86-video-intel 2.1.99.
317- Drop the i810 driver.  Time to move on.
318- Require xserver 1.4.99.1
319
320* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
321- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
322
323* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
324- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
325  for textured Xv to use as an offscreen pixmap so xv actually works under
326  compiz - granted it may be unusably slow but at least stuff shows up.
327
328* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
329- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
330- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
331
332* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
333- intel-2.1.1-quirk-update.patch - update quirks from master
334
335* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
336- i810.xinf: Flip everything over to -intel by default now.  Still install
337  i810 driver just in case.
338
339* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
340- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
341
342* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
343- xf86-video-intel 2.1.1.
344
345* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
346- xf86-video-intel 2.1.0.
347
348* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
349- Update Requires and BuildRequires.
350
351* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
352- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
353  965GME, G33, Q33, and Q35 chips.
354
355* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
356- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
357  DRI clients are active, for better battery life.
358
359* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
360- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
361
362* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
363- xf86-video-intel 2.0.0.  Change the version number to match, why not.
364- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
365  rename this at some point.
366
367* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
368- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
369  915GM.
370
371* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
372- i810.xinf: More intel whitelisting (#214011, #234877)
373
374* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
375- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
376- i810.xinf: Point 965GM support at the intel driver since it's not present
377  in old i810.
378
379* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
380- xf86-video-intel-1.9.93 (RC3).
381
382* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
383- fix typo with 945GM pci id from my laptop
384
385* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
386- xf86-video-intel 1.9.92 (RC2).
387
388* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
389- Updated modesetting driver to one that will actually work with a 1.3 server.
390
391* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
392- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
393- Remove ivch and ch7017 from the install since they aren't hooked up to the
394  code anywhere
395- Disown the module
396
397* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
398- update modesetting driver to git snapshot from today
399
400* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
401- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
402
403* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
404- rebuilt for unwind info generation, broken in gcc-4.1.1-21
405
406* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
407- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
408  actually require kudzu to run.
409
410* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
411- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
412
413* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
414- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
415- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
416  driver match the corresponding terrible heuristic in the server.
417
418* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
419- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
420  correctly distinguish between Mac Mini and Macbook Pro.
421
422* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
423- i810.xinf: PCI IDs for i965.
424
425* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
426- i810.xinf: Uppercase PCI IDs.
427
428* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
429- Update i810 to 1.6.5, should fix DRI.
430- Add kuzdu requires.
431- i810.xinf: Start whitelisting devices over to intel.
432
433* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
434- intel-driver-rename.patch: Fix the driver name in more places so it'll,
435  you know, load.
436
437* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
438- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
439  LFP special casing in favor of the blacklist.
440
441* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
442- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
443  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
444  and is selected with Driver "intel" in xorg.conf.  Individual devices will
445  whitelist over to "intel" until that branch gets merged into head.
446- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
447- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
448  the BIOS is known to lie.
449
450* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
451- Today's snapshot: I2C bus creation fix.
452
453* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
454- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
455  clock when computing the modes list.
456- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
457  in centimeters as the size of the display in pixels.
458
459* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
460- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
461  probing.
462
463* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
464- Update again for a mode comparison bugfix.
465
466* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
467- Update to today's git; crash fixes, better pre-915 support, slightly better
468  autoconfigurability.
469
470* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
471- rebuild
472
473* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
474- Fix Revision number to match naming policy.
475
476* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
477- Add back modesetting changes.
478
479* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
480- Roll back modesetting changes and build for fc5 aiglx repo.
481
482* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
483- Snapshot of the git modesetting branch.
484
485* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
486- Update i810.xinf to include entries for E7221 and 945GM.
487
488* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
489- Add with_dri macro to spec file, and conditionalize build time DRI support
490
491* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
492- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
493  to pick up proto-devel as well.
494
495* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
496- Rebuild for 7.1 ABI fix.
497
498* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
499- Bump for fc5-bling build.
500
501* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
502- Update to 1.6.0 from 7.1RC1.
503
504* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
505- Add patch to add missing #include's, specifically assert.h.
506
507* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
508- Update to CVS snapshot of 20060322.
509
510* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
511- rebuilt for new gcc4.1 snapshot and glibc changes
512
513* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
514- Added 8086:2772 mapping to i810.xinf for bug (#178451)
515
516* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
517- Added 8086:2592 mapping to i810.xinf for bug (#172884)
518
519* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
520- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
521
522* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
523- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
524- Removed 'x' suffix from manpage dirs to match RC4 upstream.
525
526* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
527- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
528
529* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
530- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
531- Fix *.la file removal.
532- Added 'devel' subpackage for XvMC .so
533- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
534
535* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
536- Update BuildRoot to use Fedora Packaging Guidelines.
537- Deglob file manifest.
538- Limit "ExclusiveArch" to x86, x86_64, ia64
539
540* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
541- Initial spec file for i810 video driver generated automatically
542  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.