source: projects/specs/tags/6_0_REL/t/texlive-mathabx-type1/texlive-mathabx-type1-vl.spec @ 2504

Revision 2504, 4.9 KB checked in by munepi, 13 years ago (diff)

NEW: texlive-tetex-trans, texlive-jvf, texlive-texmacro-otf, texlive-mathabx-type1: supported only Vine Linux 5

Line 
1%if %{?_dist_release} != "vl5"
2exit 1
3%endif
4
5%define pkgname         mathabx
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define mapdir          %{texmf}-dist/fonts/map/dvips/misc
21%define mathabxdate     20050518
22
23Summary: The mathabx font series: extended and extendable series of mathematical symbols for TeX
24Summary(ja): mathabx: TeX 用の新しい数式フォント
25Name: texlive-mathabx-type1
26Version: 2005
27Release: 3%{?_dist_release}
28Source0: mathabx-%{mathabxdate}.tar.bz2
29Source1: abxtype1-%{mathabxdate}.tar.bz2
30Source2: mathabx_docs-%{mathabxdate}.tar.bz2
31URL: http://auemath.aichi-edu.ac.jp/~khotta/ghost/mathabx.html
32License: GPL
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34Group: Applications/Publishing
35BuildArch: noarch
36PreReq: sed, sh-utils
37
38Requires: texlive-collection-fontsextra
39Obsoletes: mathabx <= 2005-1
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45The mathabx font series is a high quality extended and extendable series of
46mathematical symbols.
47To use this package, you describe \usepackage{mathabx} at preamble in your
48TeX document.
49
50This package provides Type1 fonts of mathabx.
51
52
53%description -l ja
54mathabx は CM + AMS の拡張であると考えられます。 全体的に色々な工夫が見られ,
55例えば、積分記号 \int が CM より垂直に見え、不等号 ≦ は AMS のものより < と
56 = がくっついているので、日本人が見慣れているものにより近いようです。
57
58TeX 文書の最初の部分へ \usepackage{mathabx} と記述すれば、普通の数式モードに
59て mathabx の利用が可能になります。
60
61このパッケージは mathabx の Type1 を提供します。
62
63
64%prep
65%__rm -rf $RPM_BUILD_ROOT
66
67%setup -q -a 1 -a 2 -n %{pkgname}
68
69%build
70
71%install
72%__rm -rf $RPM_BUILD_ROOT
73# mkdir -p            %{build_texmf}/fonts/source/public/mathabx
74# cp -p source/*      %{build_texmf}/fonts/source/public/mathabx
75# mkdir -p            %{build_texmf}/tex/latex/mathabx
76# cp -p texinputs/*   %{build_texmf}/tex/latex/mathabx
77%__mkdir_p            %{build_texmf}/fonts/type1/mathabx
78%__cp -p abxtype1/pfb/*.pfb %{build_texmf}/fonts/type1/mathabx
79%__mkdir_p          %{buildroot}%{mapdir}
80%__cp -p abxtype1/map/mathabx.map %{buildroot}%{mapdir}/mathabx.map
81
82%post
83%{exec_texhash}
84
85[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
86
87echo -n "    " && \
88    echo -n "Running updmap: enable mathabx.map ... " && \
89    %{exec_updmap} --enable Map mathabx.map >/dev/null 2>&1 && \
90    echo "done."
91
92exit 0
93
94%postun
95if [ "$1" = "0" ]; then
96    %{exec_texhash}
97
98    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
99
100    echo -n "    " && \
101        echo -n "Running updmap: disable mathabx.map ... " && \
102        %{exec_updmap} --disable mathabx.map >/dev/null 2>&1 && \
103        echo "done."
104fi
105
106exit 0
107
108
109%clean
110%__rm -rf $RPM_BUILD_ROOT
111
112%files
113%defattr(-,root,root)
114# %{texmf}/fonts/source/public/mathabx/*
115%{texmf}/fonts/type1/mathabx/*
116# %{texmf}/tex/latex/mathabx/*
117%{mapdir}/mathabx.map
118# %doc mathtest.tex mathtest.dvi mathtest.pdf
119
120
121%changelog
122* Thu Jan 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2005-3
123- initial build based on mathabx-type1-2005-2vl6
124
125* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2005-2
126- renamed to mathabx-type1
127- TeX Live 2009
128- added Requires: texlive-collection-fontsextra
129  - texlive-collection-fontsextra has mathabx package
130
131* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2005-1vl5
132- applied new versioning policy, spec in utf-8
133
134* Tue May 16 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl4
135- fix exec_updmap: added --nostop option
136
137* Fri Dec 02 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl3
138- fix install dir of mathabx.mat
139
140* Thu Nov 17 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl2
141- fix exec_updmap
142
143* Wed Nov 16 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl1
144- source update
145- modified for tetex-3.0
146
147* Tue Feb 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl3
148- fix exec_updmap
149
150* Thu Dec 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl2
151- source update
152
153* Fri Aug 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl1
154- source update
155
156* Wed Jun 12 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl2
157- update Type1 fonts
158
159* Sun Jun 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl1
160- 1st release
Note: See TracBrowser for help on using the repository browser.