source: projects/specs/tags/6_0_REL/nonfree/self-build-mjpegtools/self-build-mjpegtools-vl.spec @ 1816

Revision 1816, 5.1 KB checked in by munepi, 14 years ago (diff)

added self-build-mjpegtools

Line 
1%define pkgname mjpegtools
2%define name    self-build-%{pkgname}
3%define version 1.9.0
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/mjpeg/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13
14Source0:        %{pkgname}-vl.spec
15Source100:      mjpegtools-1.9.0rc1-anytovcd-ffmpegver.patch
16Source101:      mjpegtools-1.9.0-gcc44.patch
17Source102:      mjpegtools-1.9.0-png-memleak.patch
18
19License:        GPLv2+
20Group:          Restricted Software
21
22# Requires(posttrans) not yet implemented. So we use (post) instead.
23Requires(post): self-build-setup >= 0.9.0
24
25Requires(post):  libjpeg-devel
26Requires(post):  nasm
27Requires(post):  libdv-devel
28Requires(post):  SDL-devel >= 1.1.3
29Requires(post):  SDL_gfx-devel
30Requires(post):  self-build-libquicktime >= 0.9.8
31Requires(post):  libpng-devel
32Requires(post):  gtk2-devel >= 2.4.0
33Requires(post):  self-build-mplayer
34Requires(post):  self-build-ffmpeg
35#Requires(post):  y4mscaler
36Requires:  which
37Requires(post): /sbin/install-info
38Requires(preun): /sbin/install-info
39
40BuildArch:      noarch
41BuildRoot:      %{_tmppath}/%{name}-%{version}-root
42
43Packager:       munepi
44
45%description
46The mjpeg programs are a set of tools that can do recording of videos
47and playback, simple cut-and-paste editing and the MPEG compression of
48audio and video under Linux.
49
50
51If you install this package, it automaticaly downloads source
52code ,compile it, and create rpm packages of %{pkgname}-%{version}.
53And the created rpm packages are automatically installed
54if installation is executed by apt-get command or synaptic
55package manager.
56
57[Note]
58This package requires many other packages to compile
59targetsoftware. So it consume more disk space than usual.
60Also installation takes logner time because of compilation.
61(This will take a few minutes to quarter or half of an hour,
62depends on building environment)
63
64[About self-build package]
65For some kind of software, distributing of binary package
66may viorate the patent or law. Therefore we chose self-build
67packge, create binary package on your machine, for such kind
68of softwares instead of distributing binary package.
69
70Please obey the national law when you use the created binary
71packages. And if you want to use the softwares using patented
72thechnology, it may be required to get a permission, make an
73agreement or purchas a license. Please consider it with your
74purpose or way of use and take appropriate action.
75
76%description -l ja
77mjpegtools は、Linux 上で
78ビデオ録画や再生、
79簡単なカット&ペーストの編集、
80オーディオやビデオの MPEG 圧縮
81ができるツール集です。
82
83
84このパッケージをインストールすると、自動的にソースコードを
85ダウンロードしてコンパイルし、%{pkgname}-%{version}
86の rpm パッケージを作成します。
87また apt-get コマンドや synaptic パッケージマネージャから実行
88した場合は、作成された rpm パッケージのインストールも自動的に
89行います。
90
91[注意]
92コンパイルに必要な多くの関連パッケージを要求するので通常より
93ディスクの領域を多く消費します。
94またインストール時にコンパイルを行うため、通常より時間がかか
95る場合があります。(環境にもよりますが数分から数十分程度)
96
97[self-build パッケージについて]
98ソフトウェアによってはバイナリパッケージの配布が特許や法律に
99違反する可能性があるものがあります。その為、このような問題が
100懸念されるソフトウェアについてはバイナリパッケージを直接配布
101せずに、ユーザの環境でバイナリを作成する self-build パッケー
102ジという方法を採っています。
103
104作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
105アのライセンス、および利用する国の各種法令に従ってください。
106また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
107センスの購入などが必要となる場合がありますので、利用する目的
108や形態に応じて各自で判断し適切な対応を取ってください。
109
110
111%prep
112[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
113
114
115%install
116%{__rm} -rf ${RPM_BUILD_ROOT}
117%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119%{__install} -m 644 \
120    %{SOURCE100} %{SOURCE101} %{SOURCE102} \
121    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
122
123
124%clean
125%{__rm} -rf ${RPM_BUILD_ROOT}
126
127%posttrans
128/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 194000
129/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
130                                 %{pkgname}-devel-%{version}-%{release}
131
132%files
133%defattr(-,root,root)
134%{_datadir}/%{name}/*
135
136
137%changelog
138* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
139- initial build
140
141### end of file
Note: See TracBrowser for help on using the repository browser.