source: projects/specs/tags/6_0_REL/nonfree/self-build-mjpegtools/mjpegtools-vl.spec @ 1816

Revision 1816, 8.7 KB checked in by munepi, 14 years ago (diff)

added self-build-mjpegtools

Line 
1# -*- coding: utf-8-unix -*-
2Name:           mjpegtools
3Version:        1.9.0
4Release:        1%{?_dist_release}
5Summary:        Tools to manipulate MPEG data
6Summary(ja):    MPEG データを操作するツール集
7
8Group:          Applications/Multimedia
9License:        GPLv2
10URL:            http://mjpeg.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
12Patch0:         mjpegtools-1.9.0rc1-anytovcd-ffmpegver.patch
13Patch1:         mjpegtools-1.9.0-gcc44.patch
14Patch2:         mjpegtools-1.9.0-png-memleak.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  libjpeg-devel
18BuildRequires:  nasm
19BuildRequires:  libdv-devel
20BuildRequires:  SDL-devel >= 1.1.3
21BuildRequires:  SDL_gfx-devel
22#BuildRequires:  libquicktime-devel >= 0.9.8
23#BuildRequires:  self-build-libquicktime >= 0.9.8
24BuildRequires:  libpng-devel
25BuildRequires:  gtk2-devel >= 2.4.0
26# mencoder for lav2avi.sh
27#Requires:       mencoder
28#Requires:       self-build-mplayer
29# ffmpeg main package, y4mscaler and which for anytovcd.sh
30#Requires:       ffmpeg
31#Requires:       self-build-ffmpeg
32#Requires:       y4mscaler
33Requires:       which
34Requires(post): /sbin/install-info
35Requires(preun): /sbin/install-info
36
37%description
38The mjpeg programs are a set of tools that can do recording of videos
39and playback, simple cut-and-paste editing and the MPEG compression of
40audio and video under Linux.
41
42%description -l ja
43mjpegtools は、Linux 上で
44ビデオ録画や再生、
45簡単なカット&ペーストの編集、
46オーディオやビデオの MPEG 圧縮
47ができるツール集です。
48
49%package        devel
50Summary:        Development files for mjpegtools libraries
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       pkgconfig
54
55%description    devel
56The mjpeg programs are a set of tools that can do recording of videos
57and playback, simple cut-and-paste editing and the MPEG compression of
58audio and video under Linux.  This package contains development files
59for building applications that use mjpegtools libraries.
60
61
62%prep
63%setup -q
64%patch0 -p1
65%patch1 -p1
66%patch2 -p1
67%__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
68%__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
69for f in docs/yuvfps.1 ; do
70    iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
71done
72
73
74%build
75%configure --disable-dependency-tracking --disable-static
76%__make # %{?_smp_mflags}
77
78
79%install
80%__rm -rf $RPM_BUILD_ROOT
81%__make install DESTDIR=$RPM_BUILD_ROOT
82%__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
83# too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
84%__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
85
86
87%clean
88%__rm -rf $RPM_BUILD_ROOT
89
90
91%post
92/sbin/ldconfig
93/sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
94
95%postun
96/sbin/ldconfig
97
98%preun
99[ $1 -eq 0 ] && \
100/sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
101
102
103%files
104%defattr(-,root,root,-)
105%doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
106%{_bindir}/*
107%{_mandir}/man1/*.1*
108%{_mandir}/man5/yuv4mpeg.5*
109%{_infodir}/mjpeg-howto.info*
110## gui
111%doc README.glav
112%{_bindir}/glav
113# lavplay and yuvplay won't save -libs/console util users from X11 and SDL
114# dependencies as long as liblavplay is in -libs, but they're inherently
115# GUI tools -> include them here
116%{_bindir}/lavplay
117%{_bindir}/y4mhist
118%{_bindir}/yuvplay
119%{_mandir}/man1/lavplay.1*
120%{_mandir}/man1/yuvplay.1*
121## libs
122%{_libdir}/lib*.so.*
123
124%files devel
125%defattr(-,root,root,-)
126%{_includedir}/%{name}
127%{_libdir}/lib*.so
128%{_libdir}/pkgconfig/%{name}.pc
129
130
131%changelog
132* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
133- new upstream release
134
135* Fri Sep  3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
136- Fix a memleak which is causing issues for LiVES
137
138* Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
139- Update to upstream 1.9.0 final release
140
141* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
142- rebuild for new F11 features
143
144* Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
145- initial build
146
147* Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
148- Release bump for rpmfusion
149- Sync with freshrpms (no changes)
150
151* Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
152- Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
153
154* Tue Dec  4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
155- 1.9.0rc3.
156
157* Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
158- Requires: which
159
160* Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
161- License: GPLv2
162
163* Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
164- Rebuild.
165
166* Fri Jun  8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
167- 1.9.0rc2.
168
169* Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
170- Split GUI utilities into -gui subpackage.
171- Don't ship mpegtranscode, it's broken/outdated.
172- Require mencoder for lav2avi.sh.
173
174* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
175- rebuilt for unwind info generation, broken in gcc-4.1.1-21
176
177* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
178- Specfile cleanup.
179
180* Sun Jun  4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
181- Get rid of undefined non-weak symbols in liblav*.
182- Apply upstream fix for compiling with libquicktime 0.9.8.
183
184* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
185- switch to new release field
186
187* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
188- add dist
189
190* Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
191- Include license text in -libs, it can be installed without the main package.
192- Convert yuvfps man page to UTF-8.
193- Fix -devel Group tag.
194
195* Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
196- Added patch to compile with gcc 4.1
197- Dropped 0 Epoch
198
199* Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
200- 1.8.0.
201
202* Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
203- 1.6.3-rc3, Altivec fixes applied upstream.
204
205* Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
206- 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
207- Fix Altivec build, kudos to upstream.
208
209* Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
210- 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
211
212* Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
213- PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
214
215* Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
216- Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
217- Require pkgconfig in -devel.
218
219* Wed Feb  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
220- Add corrected -fPIC tweak from Thorsten.
221
222* Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
223- Include PNG input support.
224- Remove no-op $RPM_OPT_FLAGS setting from %%build.
225- Remove bogus optimization settings from configure script.
226
227* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
228- CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
229  option --with-pic is not enough
230
231* Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
232- Disabling static libraries building
233
234* Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
235- Include quicktime support.
236- Apply patch from ALT Linux to fix info pages, fix typo in %%post.
237- Require /sbin/install-info.
238- Add "--without static" rpmbuild option to work around an issue with FC3 strip
239- Always enable SIMD accelerations, CPU capabilities detected at runtime.
240- Always disable use of cmov.
241
242* Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
243- Added patch to fix gcc3.4 build
244- Detected race condition in Makefiles (disabling _smp_mflags use)
245- Added info files & scriptlets
246- Dropped patch0 and patch1
247
248* Tue Jun  8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
249- Updated to 1.6.2
250
251* Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
252- Removed comment after scriptlets
253
254* Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
255- buildroot -> RPM_BUILD_ROOT
256
257* Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
258- Applied upstream patches to fix build on gcc3.3 systems
259
260* Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
261- Now test arch for configure options (from Ville)
262- Removed ImageMagick-devel BuildRequires
263
264* Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
265- Added missing BuildRequires
266- Added post/postun scriplets for libs package
267
268* Wed Apr 23 2003 Dams <anvil[AT]livna.org>
269- Initial build.
Note: See TracBrowser for help on using the repository browser.