source: projects/specs/tags/6_0_REL/nonfree/self-build-gstreamer-plugins-bad/gstreamer-plugins-bad-vl.spec @ 3143

Revision 3143, 17.3 KB checked in by munepi, 13 years ago (diff)

updated self-build-gstreamer-plugins-ffmpeg self-build-kino self-build-gstreamer-plugins-bad self-build-gstreamer-plugins-ugly self-build-ffmpeg2theora

Line 
1%define majorminor   0.10
2%define gstreamer    gstreamer
3
4%define gst_minver   0.10.22.1
5%define gstpb_minver 0.10.22.1
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer-plugins-bad
9Version: 0.10.21
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.bz2
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20
21BuildRequires: check
22BuildRequires: gettext
23BuildRequires: PyXML
24BuildRequires: libXt-devel
25
26BuildRequires: liboil-devel
27BuildRequires: libdirectfb-devel
28# BuildRequires: self-build-libdca-devel
29# BuildRequires: self-build-faac-devel
30# BuildRequires: self-build-faad2
31BuildRequires: gsm-devel
32BuildRequires: libmpcdec-devel
33BuildRequires: SDL-devel
34#BuildRequires: soundtouch-devel
35#BuildRequires: swfdec-devel
36#Buildrequires: wavpack-devel
37# BuildRequires: self-build-xvidcore-devel
38BuildRequires: bzip2-devel
39BuildRequires: mesa-libGLU-devel
40BuildRequires: neon-devel
41BuildRequires: libmms-devel
42BuildRequires: libmusicbrainz-devel
43#BuildRequires: libcdaudio-devel
44BuildRequires: jack-audio-connection-kit-devel
45#BuildRequires: mjpegtools-devel
46#BuildRequires: nas-devel
47# BuildRequires: self-build-x264-devel
48#BuildRequires: wildmidi-devel
49BuildRequires: libsndfile-devel
50#BuildRequires: libmodplug-devel
51#BuildRequires: libtimidity-devel
52#BuildRequires: gmyth-devel >= 0.4
53BuildRequires: libdc1394-devel
54BuildRequires: libexif-devel
55#BuildRequires: libiptcdata-devel
56#BuildRequires: exempi-devel
57#BuildRequires: dirac-devel
58#BuildRequires: libofa-devel
59# BuildRequires: self-build-libdvdnav-devel
60BuildRequires: jasper-devel
61BuildRequires: openssl-devel
62BuildRequires: twolame-devel
63BuildRequires: libvdpau-devel
64BuildRequires: librtmp-devel
65
66%description
67GStreamer is a streaming media framework, based on graphs of elements which
68operate on media data.
69
70This package contains plug-ins that have licensing issues, aren't tested
71well enough, or the code is not of good enough quality.
72
73
74# %package extras
75# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
76# Group: Applications/Multimedia
77# Requires: %{name} = %{version}-%{release}
78
79# %description extras
80# GStreamer is a streaming media framework, based on graphs of elements which
81# operate on media data.
82
83# gstreamer-plugins-bad contains plug-ins that have licensing issues, aren't
84# tested well enough, or the code is not of good enough quality.
85
86# This package (gstreamer-plugins-bad-extras) contains extra "bad" plugins for
87# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
88# very much and require additional libraries to be installed.
89
90
91%package devel
92Summary: Development files for the GStreamer media framework "bad" plug-ins
93Group: Development/Libraries
94Requires: %{name} = %{version}-%{release}
95Requires: gstreamer-plugins-base-devel
96
97%description devel
98GStreamer is a streaming media framework, based on graphs of elements which
99operate on media data.
100
101This package contains the development files for the plug-ins that have
102licensing issues, aren't tested well enough, or the code is not of good
103enough quality.
104
105# '
106
107%prep
108%setup -q -n gst-plugins-bad-%{version}
109
110
111%build
112%configure \
113    --enable-debug --disable-static --disable-gtk-doc \
114    --disable-ladspa --enable-experimental \
115    --disable-siren --disable-valve --disable-dtmf --disable-autoconvert \
116    --disable-liveadder \
117    ;
118
119# Don't use rpath!
120%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
121%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
122%{__make} %{?_smp_mflags}
123
124
125%install
126%{__rm} -rf %{buildroot}
127%{__make} install DESTDIR="%{buildroot}"
128%find_lang gst-plugins-bad-%{majorminor}
129
130# Clean out files that should not be part of the rpm.
131%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
132%{__rm} -f %{buildroot}%{_libdir}/*.la
133
134
135%clean
136%{__rm} -rf %{buildroot}
137
138
139%post -p /sbin/ldconfig
140
141%postun -p /sbin/ldconfig
142
143
144%files -f gst-plugins-bad-%{majorminor}.lang
145%defattr(-,root,root,-)
146%doc AUTHORS COPYING README REQUIREMENTS
147# %{_bindir}/gst-camera
148# %{_bindir}/gst-camera-perf
149%{_libdir}/*.so.*
150%{_libdir}/gstreamer-%{majorminor}/*.so
151#%{_datadir}/gstreamer-0.10/presets/GstX264Enc.prs
152#%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.glade
153#%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.ui
154
155# # Plugins without external dependencies
156# %{_libdir}/gstreamer-%{majorminor}/libgstaacparse.so
157# %{_libdir}/gstreamer-%{majorminor}/libgstaiffparse.so
158# %{_libdir}/gstreamer-%{majorminor}/libgstamrparse.so
159# %{_libdir}/gstreamer-%{majorminor}/libgstbayer.so
160# %{_libdir}/gstreamer-%{majorminor}/libgstcdxaparse.so
161# %{_libdir}/gstreamer-%{majorminor}/libgstdccp.so
162# %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace.so
163# %{_libdir}/gstreamer-%{majorminor}/libgstdeinterlace2.so
164# %{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
165# %{_libdir}/gstreamer-%{majorminor}/libgstfestival.so
166# %{_libdir}/gstreamer-%{majorminor}/libgstfilter.so
167# %{_libdir}/gstreamer-%{majorminor}/libgstflv.so
168# %{_libdir}/gstreamer-%{majorminor}/libgstfreeze.so
169# %{_libdir}/gstreamer-%{majorminor}/libgsth264parse.so
170# %{_libdir}/gstreamer-%{majorminor}/libgstlegacyresample.so
171# %{_libdir}/gstreamer-%{majorminor}/libgstrfbsrc.so
172# %{_libdir}/gstreamer-%{majorminor}/libgstmpeg4videoparse.so
173# %{_libdir}/gstreamer-%{majorminor}/libgstmpegdemux.so
174# %{_libdir}/gstreamer-%{majorminor}/libgstmpegtsmux.so
175# %{_libdir}/gstreamer-%{majorminor}/libgstmpegvideoparse.so
176# %{_libdir}/gstreamer-%{majorminor}/libgstmve.so
177# %{_libdir}/gstreamer-%{majorminor}/libgstmxf.so
178# %{_libdir}/gstreamer-%{majorminor}/libgstnsf.so
179# %{_libdir}/gstreamer-%{majorminor}/libgstnuvdemux.so
180# %{_libdir}/gstreamer-%{majorminor}/libgstpcapparse.so
181# %{_libdir}/gstreamer-%{majorminor}/libgstqtmux.so
182# %{_libdir}/gstreamer-%{majorminor}/libgstrawparse.so
183# %ifarch %{ix86} x86_64
184# %{_libdir}/gstreamer-%{majorminor}/libgstreal.so
185# %endif
186# %{_libdir}/gstreamer-%{majorminor}/libgstrtpmanager.so
187# %{_libdir}/gstreamer-%{majorminor}/libgstscaletempoplugin.so
188# %{_libdir}/gstreamer-%{majorminor}/libgstsdpelem.so
189# %{_libdir}/gstreamer-%{majorminor}/libgstselector.so
190# %{_libdir}/gstreamer-%{majorminor}/libgstspeed.so
191# %{_libdir}/gstreamer-%{majorminor}/libgststereo.so
192# %{_libdir}/gstreamer-%{majorminor}/libgstsubenc.so
193# %{_libdir}/gstreamer-%{majorminor}/libgsttta.so
194# %{_libdir}/gstreamer-%{majorminor}/libgstvideosignal.so
195# %{_libdir}/gstreamer-%{majorminor}/libgstvmnc.so
196# %{_libdir}/gstreamer-%{majorminor}/libgsty4menc.so
197
198# # System (Linux) specific plugins
199# %{_libdir}/gstreamer-%{majorminor}/libgstdvb.so
200# %{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
201# %{_libdir}/gstreamer-%{majorminor}/libgstoss4audio.so
202# %{_libdir}/gstreamer-%{majorminor}/libgstvcdsrc.so
203
204# # Plugins with external dependencies
205# %{_libdir}/gstreamer-%{majorminor}/libgstalsaspdif.so
206# %{_libdir}/gstreamer-%{majorminor}/libgstapexsink.so
207# %{_libdir}/gstreamer-%{majorminor}/libgstbz2.so
208# #%{_libdir}/gstreamer-%{majorminor}/libgstcdaudio.so
209# #%{_libdir}/gstreamer-%{majorminor}/libgstdc1394.so
210# %{_libdir}/gstreamer-%{majorminor}/libgstdfbvideosink.so
211# #%{_libdir}/gstreamer-%{majorminor}/libgstdirac.so
212# %{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
213# %{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
214# %{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
215# %{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
216# %{_libdir}/gstreamer-%{majorminor}/libgstjp2k.so
217# #%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
218# %{_libdir}/gstreamer-%{majorminor}/libgstmetadata.so
219# #%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
220# %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
221# %{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
222# %{_libdir}/gstreamer-%{majorminor}/libgstmusepack.so
223# %{_libdir}/gstreamer-%{majorminor}/libgsttrm.so
224# %{_libdir}/gstreamer-%{majorminor}/libgstneonhttpsrc.so
225# #%{_libdir}/gstreamer-%{majorminor}/libgstofa.so
226# %{_libdir}/gstreamer-%{majorminor}/libresindvd.so
227# %{_libdir}/gstreamer-%{majorminor}/libgstsdl.so
228# %{_libdir}/gstreamer-%{majorminor}/libgstsndfile.so
229# #%{_libdir}/gstreamer-%{majorminor}/libgstswfdec.so
230# #%{_libdir}/gstreamer-%{majorminor}/libgsttimidity.so
231# %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so
232# #%{_libdir}/gstreamer-%{majorminor}/libgstwildmidi.so
233# %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
234# %{_libdir}/gstreamer-%{majorminor}/libgstxvid.so
235
236# %files extras
237# %defattr(-,root,root,-)
238# # Plugins with external dependencies
239# %{_libdir}/gstreamer-%{majorminor}/libgstjack.so
240# #%{_libdir}/gstreamer-%{majorminor}/libgstmythtvsrc.so
241# #%{_libdir}/gstreamer-%{majorminor}/libgstnassink.so
242# #%{_libdir}/gstreamer-%{majorminor}/libgstsoundtouch.so
243
244%files devel
245%defattr(-,root,root,-)
246%{_libdir}/*.so
247%{_includedir}/gstreamer-%{majorminor}/gst/basecamerabinsrc/*.h
248%{_includedir}/gstreamer-%{majorminor}/gst/signalprocessor/gstsignalprocessor.h
249%{_includedir}/gstreamer-%{majorminor}/gst/video/*
250%{_includedir}/gstreamer-%{majorminor}/gst/interfaces/photography*
251%{_includedir}/gstreamer-%{majorminor}/gst/vdpau/*
252%{_libdir}/pkgconfig/*
253%{_datadir}/glib-2.0/schemas/org.freedesktop.gstreamer-0.10.default-elements.gschema.xml
254#%doc %{_datadir}/gtk-doc/html/gst-plugins-bad-plugins-0.10
255
256
257
258%changelog
259* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
260- new upstream release
261- added BuildRequires:
262  - libmms-devel
263  - librtmp-devel
264
265* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
266- new upstream release
267
268* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
269- new upstream release
270
271* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
272- new upstream release
273- added BuildRequires: libvdpau-devel
274
275* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
276- new upstream release
277
278* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
279- new upstream release
280- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
281  gst-plugins-bad-0.10.5-mms-seek.patch
282
283* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
284- new upstream release
285- dropped devel and devel-docs subpackages
286
287* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
288- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
289- changed to BuildRequires:  self-build-faad2 from faad2-devel
290
291* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
292- initial build based on RPM Fusion package
293
294* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
295- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
296
297* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
298- Rebuild for new x264 (using patch from Rathann)
299
300* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
301- New upstream release 0.10.9
302- Rebuild for new directfb
303
304* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
305- Rebuild for new x264 and to generate new magic gstreamer provides
306
307* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
308- Enable DVD navigation plugin
309
310* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
311- Release bump to keep rpmfusion version higher then livna
312
313* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
314- New upstream release 0.10.8
315- Merge changes from latest freshrpms package: enable ofa and dirac plugins
316
317* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
318- Rebuild for new x264
319
320* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
321- New upstream release 0.10.7
322- Drop many upstreamed patches
323
324* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
325- Rebuild for new x264
326
327* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
328- Enable dc1394 plugin
329
330* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
331- New upstream release 0.10.6-1
332- Drop many upstreamed patches
333- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
334
335* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
336- Fix compilation with gcc 4.3
337
338* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
339- Add flv demuxer from CVS (livna bug 1846)
340
341* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
342- Add patch fixing compilation with mjpegtools 1.9.0rc3
343
344* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
345- Add patch from upstream vcs which makes mms honor your connection speed
346  settings
347- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
348
349* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
350- Rebuild for new faad2
351
352* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
353- Rebuild for new libdca
354
355* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
356- Rebuild for new (old) faad2 (livna bug 1679)
357
358* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
359- Update mythtvsrc code to CVS version (livna bug 1660)
360
361* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
362- No libgstreal.so on ppc / ppc64
363
364* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
365- Fix detection of libdts with current livna libtds, this might need to be
366  changed back again for rpmfusion, depending on how libdts will look there
367
368* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
369- Add mythtvsrc plugin (livna 1646)
370- Put some less often used plugins, which bring in also usually not installed
371  deps in a -extras package
372
373* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
374- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
375- Set release to 4 to be higher as both livna and freshrpms latest release
376- Set package name and origin to rpmfusion
377- Make mpeg2enc plugin compile with current mjpegtools
378- Make the real plugins search for the RealPlayer .so files in various
379  known possible locations instead of using only one hardcoded path to them
380- Make the wildmidi plugin work with the default Fedora timidity patch set
381- Add a couple of missing modtracker mimetypes to the modplug plugin
382- Use the system version of libmodplug
383- Fix building of the neonsrc plugin with the latest (rawhide) neon
384- Disable the ladspa plugin as this has been added to Fedora's rawhide
385  gstreamer-plugins-good
386- Don't put an rpath in the .so's on x86_64
387- Re-enable gtk-doc now that we have a -devel package again
388- Enable libtimidity plugin
389- Fix detection of (and linking with) libdca for the dtsdec plugin
390
391* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
392- Update to 0.10.5.
393- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
394- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
395- Enable new nas, x264, wildmidi and libsndfile plugins.
396- Re-add devel package now that we have a main shared lib and header files.
397- Add check build requirement.
398
399* Wed Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
400- Update to 0.10.4 for F7.
401- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
402  somewhat more, maybe then it'll be worth re-enabling.
403- Re-enable wavpack, it works again now.
404- Enable libcdaudio support.
405- Enable jack support.
406- Enable ladspa support.
407- Enable mpeg2enc (mjpegtools) support.
408- Remove no longer present libgstvideo4linux2.so and add all new plugins.
409- Remove all gtk-doc references (all gone...?) and devel package too.
410
411* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
412- Update faad2 patch to also update the plugin sources, not just configure.
413
414* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
415- Try to rebuild against new wavpack 4.40 from Extras : Fails.
416- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
417- Try to include patch to update wavpack plugin source from 0.10.3.2
418  pre-release : Fails to find wavpack/md5.h.
419- Give up and disable wavpack support for now, sorry! Patches welcome.
420- Include patch to fix faad2 2.5 detection.
421- Add soundtouch support.
422
423* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
424- Update to 0.10.3.
425- Add new translations.
426- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
427- Add new libmusicbrainz support.
428
429* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
430- Add libmms support, thanks to Daniel S. Rogers.
431
432* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
433- Update to 0.10.1.
434- Add libgstcdxaparse.so and libgstfreeze.so.
435- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
436
437* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
438- Update to 0.10.0.1, add new plugins.
439- Spec file cleanup and rebuild for FC5.
440
441* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
442- 0.10.0-0.gst.1
443- new release
444
445* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
446- 0.9.7-0.gst.1
447- new release with 0.10 major/minor
448
449* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
450- new release
451- remove tta patch
452- don't check for languages, no translations yet
453- added gtk-doc
454
455* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
456- 0.9.4-0.gst.1
457- new release
458- added speed plugin
459
460* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
461- 0.9.3-0.gst.1
462- new release
463
Note: See TracBrowser for help on using the repository browser.