source: projects/specs/tags/6_0_REL/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl5.spec @ 3763

Revision 3763, 10.3 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg-vl.spec

Line 
1%define gpac_postinstall     gpac_postinstall_sh=$(mktemp) && \
2    rpm -q --scripts self-build-gpac | \
3    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
4    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
5
6%define pkgname ffmpeg
7%define name    self-build-%{pkgname}
8%define version 0.5.4
9#% define svndate       20090202
10%define release 2%{?svndate:.%svndate}%{?_dist_release}
11
12%define sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
13
14Summary:        Package to automatically build %{pkgname} rpm package
15Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
16Name:           %{name}
17Version:        %{version}
18Release:        %{release}
19Source0:        %{pkgname}-vl5.spec
20#Source1:       %{pkgname}-%{version}.tar.bz2
21#Source1:       %{pkgname}-%{version}.r%{svnrev}.tar.bz2
22#Source2:        %{pkgname}-snapshot.sh
23Source90:       ffmpeg.1.gz
24Source91:       ffplay.1.gz
25Source92:       ffserver.1.gz
26Source100:      %{pkgname}-textrel.patch
27Source110:      ffmpeg-0.5-disable-texi2html.patch
28
29# upstreamed patches:
30Source151: ffmpeg-0.5.4-fix-possibly-exploitable-crash.patch
31Source152: ffmpeg-0.5.4-fix-apparently-exploitable-race-condition.patch
32
33License:        GPLv2+
34Group:          Restricted Software
35
36Requires(post):         self-build-setup >= 0.8
37#Requires(post):                subversion
38
39# (build)requies of target package.
40Requires(post):         bzip2-devel
41Requires(post):         zlib-devel
42Requires(post):         SDL-devel
43Requires(post):         imlib2-devel
44#Requires(post):                texi2html
45Requires(post):         speex-devel
46Requires(post):         libogg-devel
47Requires(post):         libvorbis-devel
48#Requires(post):                openjpeg-devel
49Requires(post):         libtheora-devel
50Requires(post):         gsm-devel
51Requires(post):         libdc1394-devel
52Requires(post):         libraw1394-devel
53%ifarch %{ix86} x86_64
54Requires(post):         yasm
55%endif
56Requires(post):         self-build-xvidcore
57Requires(post):         self-build-faac
58Requires(post):         self-build-lame
59Requires(post):         self-build-x264
60Requires(post):         self-build-libdca
61Requires(post):         self-build-a52dec
62Requires(post):         self-build-faad2
63%{?_with_amr:Requires(post):            amrnb-devel amrwb-devel}
64
65BuildRoot:      %{_tmppath}/%{name}-%{version}-root
66
67Packager:       munepi
68
69%description
70FFMpeg is a complete and free Internet live audio and video
71broadcasting solution for Linux/Unix. It also includes a
72digital VCR. It can encode in real time in many formats
73including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
74real, mjpeg, and flash.
75
76If you install this package, it automaticaly downloads source
77code ,compile it, and create rpm packages of %{pkgname}-%{version}.
78And the created rpm packages are automatically installed
79if installation is executed by apt-get command or synaptic
80package manager.
81
82[Note]
83This package requires many other packages to compile
84target software. So it consume more disk space than usual.
85Also installation takes longer time because of compilation.
86(This will take a few minutes to quarter or half of an hour,
87depends on building environment)
88
89[About self-build package]
90For some kind of software, distributing of binary package
91may viorate the patent or law. Therefore we chose self-build
92packge, create binary package on your machine, for such kind
93of softwares instead of distributing binary package.
94
95Please obey the national law when you use the created binary
96packages. And if you want to use the softwares using patented
97thechnology, it may be required to get a permission, make an
98agreement or purchas a license. Please consider it with your
99purpose or way of use and take appropriate action.
100
101%description -l ja
102FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
103ブオーティオ・ビデオブロードキャスティングソリューションです.
104またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
105MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
106多様なフォーマットをリアルタイムにエンコードすることができます.
107
108このパッケージをインストールすると、自動的にソースコードを
109ダウンロードしてコンパイルし、%{pkgname}-%{version}
110の rpm パッケージを作成します。
111また apt-get コマンドや synaptic パッケージマネージャから実行
112した場合は、作成された rpm パッケージのインストールも自動的に
113行います。
114
115[注意]
116コンパイルに必要な多くの関連パッケージを要求するので通常より
117ディスクの領域を多く消費します。
118またインストール時にコンパイルを行うため、通常より時間がかか
119る場合があります。(環境にもよりますが数分から数十分程度)
120
121[self-build パッケージについて]
122ソフトウェアによってはバイナリパッケージの配布が特許や法律に
123違反する可能性があるものがあります。その為、このような問題が
124懸念されるソフトウェアについてはバイナリパッケージを直接配布
125せずに、ユーザの環境でバイナリを作成する self-build パッケー
126ジという方法を採っています。
127
128作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
129アのライセンス、および利用する国の各種法令に従ってください。
130また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
131センスの購入などが必要となる場合がありますので、利用する目的
132や形態に応じて各自で判断し適切な対応を取ってください。
133
134%prep
135[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
136
137%install
138%{__rm} -rf ${RPM_BUILD_ROOT}
139%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
140%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
141#%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
142#%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
143%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} \
144    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
145%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
146%{__install} -m 644 %{SOURCE110} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
147%{__install} -m 644 %{SOURCE151} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
148%{__install} -m 644 %{SOURCE152} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149
150%clean
151%{__rm} -rf ${RPM_BUILD_ROOT}
152
153%posttrans
154/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl5.spec "%{sourceurl0}" 640000
155/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
156                                 %{pkgname}-libs-%{version}-%{release} \
157                                 %{pkgname}-devel-%{version}-%{release}
158
159## Rebuild gpac with ffmpeg-devel
160# set locale
161case $LANG in
162    ja*)LOCALE=ja ;;
163    *) LOCALE=C ;;
164esac
165
166Rebuild_gpac_C(){
167    echo -n "     "
168    echo "Rebuild gpac with ffmpeg-devel"
169}
170
171Rebuild_gpac_ja(){
172    echo -n "     "
173    echo "ffmpeg-devel で gpac をリビルドします。"
174}
175
176Rebuild_gpac_$LOCALE
177%{gpac_postinstall}
178
179
180%files
181%defattr(-,root,root)
182%{_datadir}/%{name}
183
184%changelog
185* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.4-2
186- applied some upstreamed/security patches:
187  - AMV: fix possibly exploitable crash
188  - fix apparently exploitable race condition
189
190* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.4-1
191- new upstream release
192
193* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-2
194- collected Source0: tag
195
196* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-1
197- new upstream release
198
199* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
200- unpacked source archives
201
202* Thu Jun 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-1
203- new upstream release
204
205* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-1
206- new upstream release
207
208* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
209- dropped BuildArch: noarch
210- added ffmpeg.1, ffplay.1, ffserver.1
211
212* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
213- avoided to execute self-build-rpm.sh on RPM transaction
214  - moved %%post actions to %%posttrans
215
216* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
217- added BuildArch: noarch
218- added ffmpeg-0.5-disable-texi2html.patch
219  - dropped PreReq: texi2html
220
221* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
222- added %%{gpac_postinstall} in %%post
223
224* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
225- corrected release number
226
227* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
228- new upstream release
229- added PreReq:
230  - speex-devel
231  - bzip2-devel
232
233* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
234- change release to sync with ffmpeg
235
236* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
237- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
238
239* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
240- 20090202 snapshot
241
242* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
243- 20090110 snapshot
244- dropped some patches
245
246* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
247- source updated (r15488)
248- fixed License: GPLv2+
249- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
250- added BuildRequires: yasm (only %%ix86)
251- applied ffmpeg-cpu.patch (merged from RPM Fusion)
252
253* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
254- spec in utf8
255
256* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
257- run pre-allocate-rpm.sh in %%post
258- set PreReq: self-build-setup >= 0.8
259- change release number
260
261* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
262- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
263  include Source1 in the binary package.
264- drop "Source100: ffmpeg-vine.patch".
265- drop "PreReq: subversion".
266
267* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
268- build with new versioning policy
269- change to use svn export from svn checkout on post install
270- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
271
272* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
273- For all pre-required package that is provied by self-build, 
274  changed to its self-build package
275 
276* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
277- initial build for Vine Linux 4.2
278- snapshot 2008/01/28 + some Rev.11662 2008/01/29
279
280### end of file
Note: See TracBrowser for help on using the repository browser.