source: projects/specs/tags/6_0_REL/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec @ 3763

Revision 3763, 11.0 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg-vl.spec

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define pkgname ffmpeg
8%define name    self-build-%{pkgname}
9%define version 0.6.3
10#% define svndate       20110326
11%define release 1%{?svndate:.%svndate}%{?_dist_release}
12
13%define sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
14
15## available for v0.6 or lower
16%define with_libfaad 1
17
18%define with_faac 1
19
20%define with_vaapi 1
21%define with_libvpx 1
22
23Summary:        Package to automatically build %{pkgname} rpm package
24Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
25Name:           %{name}
26Version:        %{version}
27Release:        %{release}
28Source0:        %{pkgname}-vl.spec
29#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
30Source2:        %{pkgname}-snapshot.sh
31Source90:       ffmpeg.1.gz
32Source91:       ffplay.1.gz
33Source92:       ffserver.1.gz
34Source93:       ffprobe.1.gz
35
36License:        GPLv2+
37Group:          Restricted Software
38
39Requires(post):         self-build-setup >= 0.9.9
40#Requires(post):                subversion
41
42# (build)requies of target package.
43Requires(post):  bzip2-devel
44Requires(post): gsm-devel
45Requires(post): imlib2-devel
46Requires(post): libdc1394-devel
47Requires(post): libraw1394-devel
48Requires(post): librtmp-devel >= 2.3
49Requires(post): libtheora-devel
50%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
51Requires(post):  libvdpau-devel
52Requires(post): libvorbis-devel
53%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.1}
54%{?_with_opencore_amr:Requires(post):  opencore-amr-devel}
55##Requires(post):  openjpeg-devel
56##Requires(post):  schroedinger-devel
57Requires(post): SDL-devel
58Requires(post):  speex-devel
59##Requires(post):       texi2html
60Requires(post): zlib-devel
61Requires(post): libogg-devel
62%ifarch %{ix86} x86_64
63Requires(post):         yasm
64%endif
65Requires(post):         self-build-a52dec
66Requires(post):         self-build-faac
67Requires(post):         self-build-faad2
68Requires(post):         self-build-lame
69Requires(post):         self-build-libdca
70Requires(post):         self-build-x264 >= 0.0.0-15.20110322
71Requires(post):         self-build-xvidcore
72
73BuildRoot:      %{_tmppath}/%{name}-%{version}-root
74
75Packager:       munepi
76
77%description
78FFMpeg is a complete and free Internet live audio and video
79broadcasting solution for Linux/Unix. It also includes a
80digital VCR. It can encode in real time in many formats
81including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
82real, mjpeg, and flash.
83
84If you install this package, it automaticaly downloads source
85code ,compile it, and create rpm packages of %{pkgname}-%{version}.
86And the created rpm packages are automatically installed
87if installation is executed by apt-get command or synaptic
88package manager.
89
90[Note]
91This package requires many other packages to compile
92target software. So it consume more disk space than usual.
93Also installation takes longer time because of compilation.
94(This will take a few minutes to quarter or half of an hour,
95depends on building environment)
96
97[About self-build package]
98For some kind of software, distributing of binary package
99may viorate the patent or law. Therefore we chose self-build
100packge, create binary package on your machine, for such kind
101of softwares instead of distributing binary package.
102
103Please obey the national law when you use the created binary
104packages. And if you want to use the softwares using patented
105thechnology, it may be required to get a permission, make an
106agreement or purchas a license. Please consider it with your
107purpose or way of use and take appropriate action.
108
109%description -l ja
110FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
111ブオーティオ・ビデオブロードキャスティングソリューションです.
112またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
113MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
114多様なフォーマットをリアルタイムにエンコードすることができます.
115
116このパッケージをインストールすると、自動的にソースコードを
117ダウンロードしてコンパイルし、%{pkgname}-%{version}
118の rpm パッケージを作成します。
119また apt-get コマンドや synaptic パッケージマネージャから実行
120した場合は、作成された rpm パッケージのインストールも自動的に
121行います。
122
123[注意]
124コンパイルに必要な多くの関連パッケージを要求するので通常より
125ディスクの領域を多く消費します。
126またインストール時にコンパイルを行うため、通常より時間がかか
127る場合があります。(環境にもよりますが数分から数十分程度)
128
129[self-build パッケージについて]
130ソフトウェアによってはバイナリパッケージの配布が特許や法律に
131違反する可能性があるものがあります。その為、このような問題が
132懸念されるソフトウェアについてはバイナリパッケージを直接配布
133せずに、ユーザの環境でバイナリを作成する self-build パッケー
134ジという方法を採っています。
135
136作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
137アのライセンス、および利用する国の各種法令に従ってください。
138また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
139センスの購入などが必要となる場合がありますので、利用する目的
140や形態に応じて各自で判断し適切な対応を取ってください。
141
142%prep
143[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
144
145%install
146%{__rm} -rf ${RPM_BUILD_ROOT}
147%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
148%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149#%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
150#%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
151%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
152    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
153
154%clean
155%{__rm} -rf ${RPM_BUILD_ROOT}
156
157%posttrans
158#/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
159/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
160/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
161                                 %{pkgname}-libs-%{version}-%{release} \
162                                 %{pkgname}-devel-%{version}-%{release}
163
164## Rebuild gpac with ffmpeg-devel
165# set locale
166case $LANG in
167    ja*)LOCALE=ja ;;
168    *) LOCALE=C ;;
169esac
170
171Rebuild_gpac_C(){
172    echo -n "     "
173    echo "Rebuild gpac with ffmpeg-devel"
174}
175
176Rebuild_gpac_ja(){
177    echo -n "     "
178    echo "ffmpeg-devel で gpac をリビルドします。"
179}
180
181Rebuild_gpac_$LOCALE
182%{gpac_postinstall}
183
184
185%files
186%defattr(-,root,root)
187%{_datadir}/%{name}
188
189%changelog
190* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
191- new upstream release
192
193* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
194- new upstream release
195
196* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
197- required latest x264 build
198- added BuildRequires: librtmp-devel >= 2.3
199
200* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
201- new upstream release
202
203* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
204- unpacked source archives
205
206* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
207- fixed some dependencies
208  - Requires(post): libva-devel
209  - Requires(post): libvpx-devel >= 0.9.1
210
211* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
212- new upstream release
213
214* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
215- bumped version to pre-0.6
216- updated source snapshot 20100410
217
218* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
219- fixed self-build log size
220
221* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
222- added ffprobe.1.gz
223
224* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
225- updated source snapshot 20100401
226
227* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
228- renamed %%{Source0} to ffmpeg-vl.spec
229
230* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
231- updated source snapshot 20100216
232  - rebuild with recent x264-devel
233- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
234- added BuildRequires:  libvdpau-devel
235
236* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
237- dropped BuildArch: noarch
238- added ffmpeg.1, ffplay.1, ffserver.1
239
240* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
241- avoided to execute self-build-rpm.sh on RPM transaction
242  - moved %%post actions to %%posttrans
243
244* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
245- added BuildArch: noarch
246- added ffmpeg-0.5-disable-texi2html.patch
247  - dropped PreReq: texi2html
248
249* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
250- added %%{gpac_postinstall} in %%post
251
252* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
253- corrected release number
254
255* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
256- new upstream release
257- added PreReq:
258  - speex-devel
259  - bzip2-devel
260
261* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
262- change release to sync with ffmpeg
263
264* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
265- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
266
267* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
268- 20090202 snapshot
269
270* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
271- 20090110 snapshot
272- dropped some patches
273
274* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
275- source updated (r15488)
276- fixed License: GPLv2+
277- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
278- added BuildRequires: yasm (only %%ix86)
279- applied ffmpeg-cpu.patch (merged from RPM Fusion)
280
281* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
282- spec in utf8
283
284* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
285- run pre-allocate-rpm.sh in %%post
286- set PreReq: self-build-setup >= 0.8
287- change release number
288
289* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
290- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
291  include Source1 in the binary package.
292- drop "Source100: ffmpeg-vine.patch".
293- drop "PreReq: subversion".
294
295* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
296- build with new versioning policy
297- change to use svn export from svn checkout on post install
298- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
299
300* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
301- For all pre-required package that is provied by self-build, 
302  changed to its self-build package
303 
304* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
305- initial build for Vine Linux 4.2
306- snapshot 2008/01/28 + some Rev.11662 2008/01/29
307
308### end of file
Note: See TracBrowser for help on using the repository browser.