source: projects/specs/tags/6_0_REL/nonfree/self-build-ffmpeg/ffmpeg-vl5.spec @ 3763

Revision 3763, 8.6 KB checked in by munepi, 13 years ago (diff)

updated self-build-ffmpeg-vl.spec

Line 
1#TODO: Build with openjpeg
2%define name    ffmpeg
3%define version 0.5.4
4#% define svndate       20090227
5%define release 2%{?svndate:.%svndate}%{?_dist_release}
6
7Summary:        Digital VCR and streaming server
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11Source:         http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
12#Source1:        %{name}-snapshot.sh
13
14# For no texi2html
15# these man files for ffmpeg-0.5 are genereted with texi2html
16Source90:       ffmpeg.1.gz
17Source91:       ffplay.1.gz
18Source92:       ffserver.1.gz
19
20# get rid of textrels on x86_64 in yasm code (from RPM Fusion)
21Patch0:         %{name}-textrel.patch
22
23Patch10:        ffmpeg-0.5-disable-texi2html.patch
24
25# upstreamed patches:
26# AMV: Fix possibly exploitable crash.
27# http://git.videolan.org/gitweb.cgi?p=ffmpeg.git;a=commit;h=8210ee22e2f69d540f8835523dd78a205ae6c2a6
28Patch51: ffmpeg-0.5.4-fix-possibly-exploitable-crash.patch
29# Fix apparently exploitable race condition.
30# http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=24cd7c5df78c53c1d1a36b81fb130594e84b3f12
31Patch52: ffmpeg-0.5.4-fix-apparently-exploitable-race-condition.patch
32
33License:        GPLv2+
34Group:          Applications/Multimedia
35URL:            http://ffmpeg.org/
36
37BuildRequires:  bzip2-devel
38BuildRequires:  zlib-devel
39BuildRequires:  SDL-devel
40BuildRequires:  imlib2-devel
41BuildRequires:  speex-devel
42#BuildRequires: texi2html
43BuildRequires:  libogg-devel
44BuildRequires:  libvorbis-devel
45#BuildRequires:  openjpeg-devel
46BuildRequires:  libtheora-devel
47BuildRequires:  gsm-devel
48BuildRequires:  libdc1394-devel
49BuildRequires:  libraw1394-devel
50%ifarch %{ix86} x86_64
51BuildRequires:  yasm
52%endif
53# *-devel packages provided by other self-build-* should only be listed
54# in self-build-%{name}.spec as PreReq.
55#BuildRequires: xvidcore-devel, faac-devel, lame-devel
56#BuildRequires: x264-devel, libdca-devel, a52dec-devel
57#BuildRequires: faad2-devel
58%{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
59BuildRoot:      %{_tmppath}/%{name}-%{version}-root
60
61%description
62FFMpeg is a complete and free Internet live audio and video
63broadcasting solution for Linux/Unix. It also includes a digital
64VCR. It can encode in real time in many formats including MPEG1 audio
65and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
66
67%package libs
68Group: System Environment/Libraries
69Summary: Libraries for %{name}
70Group: System Environment/Libraries
71#Requires: a52dec, faad2
72
73%description libs
74FFMpeg is a complete and free Internet live audio and video
75broadcasting solution for Linux/Unix. It also includes a digital
76VCR. It can encode in real time in many formats including MPEG1 audio
77and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
78
79This package contains the libraries for %{name}.
80
81%package devel
82Summary: Development package for %{name}
83Group: Development/Libraries
84Requires: %{name}-libs = %{version}-%{release}
85Requires: pkgconfig
86
87%description devel
88FFMpeg is a complete and free Internet live audio and video
89broadcasting solution for Linux/Unix. It also includes a digital
90VCR. It can encode in real time in many formats including MPEG1 audio
91and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
92
93This package contains development files for %{name}.
94
95
96%prep
97#% setup -q -n %{name}-%{svndate}
98%setup -q
99%patch0 -p1 -b .textrel
100%patch10 -p1 -b .texi2html
101
102## upstreamed patches
103%patch51 -p1 -b .orig
104%patch52 -p1 -b .orig
105
106%build
107%ifarch ppc
108# compile with -mlongcall on ppc/ppc64 (rf804)
109export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
110%endif
111
112./configure \
113    --prefix=%{_prefix} \
114    --incdir=%{_includedir}/%{name} \
115    --shlibdir=%{_libdir} \
116    --libdir=%{_libdir} \
117    --mandir=%{_mandir} \
118    --arch=%{_target_cpu} \
119%ifarch %{ix86}
120    --cpu=%{_target_cpu} \
121%endif
122%ifarch ppc
123    --cpu=g3 \
124%endif
125    --enable-runtime-cpudetect \
126    --extra-cflags="$RPM_OPT_FLAGS" \
127    %{?_with_amr:--enable-libamr-nb --enable-libamr-wb --enable-nonfree} \
128    --enable-bzlib \
129    --enable-libdc1394 \
130    --enable-libfaac --enable-nonfree \
131    --enable-libfaad \
132    --enable-libgsm \
133    --enable-libmp3lame \
134    %{?_with_openjpeg:--enable-libopenjpeg} \
135    --enable-libtheora \
136    --enable-libvorbis \
137    --enable-libx264 \
138    --enable-libxvid \
139    --enable-x11grab \
140    --enable-avfilter \
141    --enable-avfilter-lavf \
142    --enable-postproc \
143    --enable-swscale \
144    --enable-pthreads \
145    --disable-static \
146    --enable-shared \
147    --enable-gpl \
148    --disable-debug \
149    --disable-stripping
150
151#% {__make} %{?_smp_mflags}
152%{__make}
153
154%install
155%__make install DESTDIR=$RPM_BUILD_ROOT
156
157## install man
158%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1
159%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} $RPM_BUILD_ROOT%{_mandir}/man1/
160   
161
162%clean
163%{__rm} -rf $RPM_BUILD_ROOT
164
165%post libs -p /sbin/ldconfig
166%postun libs -p /sbin/ldconfig
167
168
169%files
170%defattr(-,root,root,-)
171%doc COPYING.GPL CREDITS Changelog README RELEASE doc/*.*
172%{_prefix}/bin/ffmpeg
173%{_prefix}/bin/ffplay
174%{_prefix}/bin/ffserver
175%{_mandir}/man1/ffmpeg.1*
176%{_mandir}/man1/ffplay.1*
177%{_mandir}/man1/ffserver.1*
178%{_datadir}/ffmpeg
179%{?_with_amr:%{_datadir}/%{name}}
180
181%files libs
182%defattr(-,root,root,-)
183%{_libdir}/lib*.so.*
184%{_libdir}/vhook/
185
186%files devel
187%defattr(-,root,root,-)
188%{_includedir}/ffmpeg
189%{_libdir}/pkgconfig/lib*.pc
190%{_libdir}/lib*.so
191
192
193%changelog
194* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.4-2
195- applied some upstreamed/security patches:
196  - AMV: fix possibly exploitable crash
197  - fix apparently exploitable race condition
198
199* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.4-1
200- new upstream release
201
202* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-2
203- change release to sync with self-build-ffmpeg
204
205* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-1
206- new upstream release
207
208* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
209- change release to sync with self-build-ffmpeg
210
211* Thu Jun 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-1
212- new upstream release
213
214* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-1
215- new upstream release
216
217* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
218- applied ffmpeg-0.5-disable-texi2html.patch, return
219  (in face, no ffmpeg-0.5-disable-texi2html.patch applied for 0.5-4)
220- added ffmpeg.1, ffplay.1, ffserver.1
221
222* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
223- change release to sync with self-build-ffmpeg
224
225* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
226- applied ffmpeg-0.5-disable-texi2html.patch
227  - dropped BuildRequires: texi2html
228
229* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
230- change release to sync with self-build-ffmpeg
231
232* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
233- corrected release number
234
235* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
236- new upstream release
237- added BuildRequires:
238  - speex-devel
239  - bzip2-devel
240
241* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
242- 20090227 snapshot
243
244* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
245- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
246
247* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
248- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
249- dropped Requires: a52dec, faad2 in ffmpeg-libs
250
251* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
252- 20090202 snapshot
253
254* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
255- 20090110 snapshot
256- dropped some patches
257
258* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
259- source updated (r15488)
260- fixed License: GPLv2+
261- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
262- added BuildRequires: yasm (only %%ix86)
263- applied ffmpeg-cpu.patch (merged from RPM Fusion)
264
265* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
266- spec in utf8
267
268* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
269- change release to sync with self-build-ffmpeg
270
271* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
272- drop "Patch100: ffmpeg-vine.patch".
273
274* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
275- build with new versioning policy
276- change to use svn export from svn checkout on post install
277- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
278
279* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
280- [self-build-ffmpeg.spec]
281  For all pre-required package that is provied by self-build, 
282  changed to its self-build package
283
284* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
285- initial build for Vine Linux 4.2
286- snapshot 2008/01/28 + some Rev.11662 2008/01/29
287
288### end of file
Note: See TracBrowser for help on using the repository browser.