source: projects/specs/tags/6_0_REL/nonfree/self-build-ffmpeg-mh/ffmpeg-mh-vl.spec @ 615

Revision 615, 6.3 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define name ffmpeg-mh
2%define version 0.33
3%define svndate 051130
4%define release 12%{?_dist_release}
5
6%define ffmpeg_mh ffmpeg_%{svndate}
7
8# %define amrnbver 7.1.0.2
9# %define amrwbver 7.0.0.3
10#% define _with_amr 1
11
12%define _with_x264_mh 1
13%define x264_mh x264_051028
14
15Summary: 3GP Converter (Keitai Douga Henkan-kun) for UNIX---FFmpeg Mobile Hack version
16Summary(ja): Windows 用携帯動画変換君(3GP Converter)の UNIX 版
17Name: %{name}
18Version: %{version}
19Release: %{release}
20Source: http://www.nurs.or.jp/~calcium/3gpp/sources/ffmpeg-%{svndate}-%{version}.tar.gz
21# x264_051028.tar.gz: from http://mobilehackerz.jp/contents?plugin=attach&refer=3GPConv%2FSources&openfile=x264_051028.tar.gz
22# on http://mobilehackerz.jp/contents/3GPConv/Sources
23%if %{_with_x264_mh}
24Source1: x264_051028.tar.gz
25%endif
26# Source1: http://ftp.penguin.cz/pub/users/utx/amr/amrnb-%{amrnbver}.tar.bz2
27# Source2: http://ftp.penguin.cz/pub/users/utx/amr/amrwb-%{amrwbver}.tar.bz2
28Patch: http://can.homeunix.org/sw/psp/ffmpeg_psp/ffmpeg-mh-unix.patch
29#Patch1: ffmpeg-mh-include-amr.patch
30Patch2: ffmpeg-mh-0.33-disable-texi2html.patch
31License: GPL
32Group: Applications/Multimedia
33URL: http://www.nurs.or.jp/~calcium/3gpp/
34
35#Requires:
36BuildRequires: zlib-devel, SDL-devel, imlib2-devel
37#BuildRequires: texi2html
38BuildRequires: libogg-devel, libvorbis-devel, libtheora-devel
39# *-devel pacages provided by other self-build-* should only be listed
40# in self-build-%{name}.spec as PreReq.
41#BuildRequires: xvidcore-devel, faac-devel, lame-devel
42#BuildRequires: x264-devel, libdca-devel, a52dec-devel, faad2-devel
43BuildRoot: %{_tmppath}/%{name}-%{version}-root
44
45%description
46FFMpeg is a complete and free Internet live audio and video
47broadcasting solution for Linux/Unix. It also includes a digital
48VCR. It can encode in real time in many formats including MPEG1 audio
49and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
50
51ffmpeg-mh is a 3GP Converter for UNIX. It is a FFmpeg Mobile Hack version
52under unix, is enoughly customized for many mobiles from original sources
53of ffmpeg.
54
55%description -l ja
56FFMpeg は Linux/Unix に対する完全にフリーなインターネットライブ
57オーティオ・ビデオブロードキャスティングソリューションです.
58またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
59MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
60多様なフォーマットをリアルタイムにエンコードすることができます.
61
62ffmpeg-mh は Windows 用携帯動画変換君(3GP Converter)の UNIX 版です.
63FFmpeg のモバイル端末向けに改良されたバージョンで,オリジナルのソースから
64モバイル向けにたくさん調整されています.
65
66%prep
67%setup -q -n %{ffmpeg_mh}
68%patch -p1
69#%patch1 -p1 -b include
70
71# tar jxvf %{SOURCE1}
72# tar jxvf %{SOURCE2}
73
74## use x264 for Mobile Hack version
75%if %{_with_x264_mh}
76tar zxvf %{SOURCE1}
77%endif
78
79%build
80# ## build amr
81# cd amrnb-%{amrnbver}
82# ./configure \
83#     --prefix=${RPM_BUILD_DIR}/%{ffmpeg_mh} \
84#     --includedir=${RPM_BUILD_DIR}/%{ffmpeg_mh}/include/amr \
85#     --enable-static --disable-shared
86# %{__make} %{?_smp_mflags} OPT_CFLAGS="$RPM_OPT_FLAGS"
87# %{__make} install
88# cd ..
89# cd amrwb-%{amrwbver}
90# ./configure \
91#     --prefix=${RPM_BUILD_DIR}/%{ffmpeg_mh} \
92#     --includedir=${RPM_BUILD_DIR}/%{ffmpeg_mh}/include/amr_float \
93#     --enable-static --disable-shared
94# %{__make} %{?_smp_mflags} OPT_CFLAGS="$RPM_OPT_FLAGS"
95# %{__make} install
96# cd ..
97
98## build x264 for Mobile Hack version
99%if %{_with_x264_mh}
100cd %{x264_mh}
101./configure \
102    --prefix=${RPM_BUILD_DIR}/%{ffmpeg_mh} \
103    --enable-pthread \
104    --enable-static \
105    --disable-shared
106%__make
107%__make install
108cd ..
109%endif
110
111## configure ffmpeg-mh
112./configure \
113    --prefix=%{_prefix} \
114    --incdir=%{_includedir}/%{name} \
115    --libdir=%{_libdir} \
116    --shlibdir=%{_libdir} \
117    --mandir=%{_mandir} \
118    %{?_with_x264_mh:--extra-cflags=-I${RPM_BUILD_DIR}/%{ffmpeg_mh}/include} \
119    %{?_with_x264_mh:--extra-ldflags=-L${RPM_BUILD_DIR}/%{ffmpeg_mh}/lib} \
120    %{?_with_x264_mh:--enable-x264} \
121    --disable-debug \
122    --enable-mp3lame \
123    --enable-libogg \
124    --enable-vorbis \
125    --enable-faad \
126    --enable-faac \
127    --enable-xvid \
128    --enable-a52 \
129    %{?_with_amr:--enable-amr_nb --enable-amr_nb-fixed --enable-amr_wb} \
130    --enable-pp \
131    --enable-pthreads \
132    --enable-gpl \
133    --enable-static \
134    --disable-shared \
135    --disable-ffserver \
136    --disable-ffplay
137
138## build ffmpeg-mh
139%{__make} %{?_smp_mflags}
140
141%install
142%{__rm} -rf $RPM_BUILD_ROOT
143
144## install ffmpeg-mh
145install -d -m755 %{buildroot}/%{_bindir}
146install -m 755 ffmpeg %{buildroot}/%{_bindir}/%{name}
147
148%clean
149%{__rm} -rf $RPM_BUILD_ROOT
150
151%files
152%defattr(-,root,root,-)
153%{_bindir}/ffmpeg-mh
154
155
156%changelog
157* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.33-12
158- change release to sync with self-build-ffmpeg-mh
159
160* Thu Feb 18 2010 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-11
161- rebuild
162
163* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-10
164- change release to sync with self-build-ffmpeg-mh
165
166* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-9
167- applied ffmpeg-mh-0.33-disable-texi2html.patch
168  - dropped BuildRequires: texi2html
169
170* Sun Feb 8 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-8
171- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
172
173* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-7
174- change release to sync with self-build-ffmpeg-mh
175
176* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-6
177- added x264_051028 for Mobile Hack version
178- dropped BuildRequires: self-build-x264
179
180* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-5
181- spec in utf8
182- droppd BuildRequires: xvidcore-devel, faac-devel, lame-devel
183  BuildRequires: x264-devel, libdca-devel, a52dec-devel
184  (*-devel pacages provided by other self-build-*) in ffmpeg-mh.spec
185
186* Thu Apr 10 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-1vl4
187- build with new versioning policy
188
189* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-0vl2
190- [self-build-ffmpeg-mh.spec]
191  For all pre-required package that is provied by self-build, 
192  changed to its self-build package
193
194* Tue Mar 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-0vl1
195- initial build for Vine Linux 4.2
196  with ffmpeg-051130-0.33
197
198### end of file
Note: See TracBrowser for help on using the repository browser.