source: projects/specs/tags/6_0_REL/m/moonshiner/moonshiner-vl.spec @ 521

Revision 521, 2.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _installdir $RPM_BUILD_ROOT/usr
2
3Name:           moonshiner
4Version:        1.0
5Release:        4%{?_dist_release}
6Summary:        graphical frontend for Ghostscript's PostScript-to-PDF converter
7Summary(ja):    Ghostscript を使い Postscript から PDF へ変換するためのグラフィカルフロントエンド
8
9Group:          Applications/Publishing
10License:        GPLv3+
11URL:            http://moonshiner.sourceforge.net/
12Source0:        %{name}-%{version}.tar.gz
13Source1:        %{name}.desktop
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17Requires:       python >= 2.5
18Requires:       pygtk2 >= 2.10
19Requires:       ghostscript >= 8.60
20
21BuildRequires:  desktop-file-utils
22
23%description
24Moonshiner is a graphical frontend (GUI) for Ghostscript's
25PostScript-to-PDF converter.
26
27%description -l ja
28Moonshiner は Ghostscript を使い Postscript から PDF へ変換するための
29グラフィカルフロントエンドです。
30
31%prep
32%setup -q
33
34%build
35python setup.py build
36
37%install
38rm -rf %{buildroot}
39python setup.py install --skip-build --root %{buildroot}
40
41desktop-file-install \
42        --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE1}
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%post
48touch --no-create %{_datadir}/icons/hicolor || :
49%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
50update-desktop-database %{_datadir}/applications
51
52%postun
53touch --no-create %{_datadir}/icons/hicolor || :
54%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
55update-desktop-database %{_datadir}/applications
56
57%files
58%defattr(-,root,root,-)
59%doc LICENSE CHANGES README PKG-INFO
60%doc %{_docdir}/%{name}/*
61%{_bindir}/%{name}
62%{_libdir}/python2.*/site-packages/*
63%{_datadir}/applications/*.desktop
64
65%changelog
66* Fri Feb 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0-4
67- rebuilt with python-2.6.4
68- run gtk-update-icon-cache in %post, postun
69- fixed icon path in source1
70
71* Sat Nov 28 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0-3
72- fixed html helpfile include again
73- probed install process
74  - dropt Patch1
75
76* Sat Aug 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0-2
77- fixed html helpfile include
78- added Patch1 (don't require root for build)
79
80* Thu Jun 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0-1
81- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.