source: projects/specs/tags/6_0_REL/m/minitube/minitube-vl.spec @ 3905

Revision 3905, 3.6 KB checked in by Takemikaduchi, 13 years ago (diff)

minitube: new upstream release, gnac: New Package

Line 
1# Qt4 version auto-detection -- inagaki
2%define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.1)
3%define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
4
5# Move original binary to libexec dir and replace it by wrapper script
6%define MINITUBE_BIN %{_libexecdir}/%{name}
7
8Summary:        Native YouTube Client
9Summary(ja):    YouTube 専用クライアント
10Name:           minitube
11Version:        1.4.3
12Release:        1%{?_dist_release}
13Source0:        %{name}-%{version}.tar.gz
14Source10:       minitube.sh
15Source20:       minitube-ja.desktop
16License:        GPLv3+
17Group:          Applications/Multimedia
18URL:            http://flavio.tordini.org/minitube
19
20Requires:       phonon-backend-gstreamer
21Requires(post): desktop-file-utils
22Requires(postun):desktop-file-utils
23BuildRequires:  qt4-devel > 4.5
24BuildRequires:  qt4-designer
25BuildRequires:  phonon-devel
26BuildRequires:  python-devel
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29
30%description
31Minitube is a native YouTube client. With it you can watch
32YouTube videos in a new way: you type a keyword, Minitube
33gives you an endless video stream. Minitube does not require
34the Flash Player.
35
36Minitube is not about cloning the original YouTube web interface,
37it aims to create a new TV-like experience.
38
39You should install following packages to play videos.
40 - self-build-gstreamer-plugins-bad
41 - self-build-gstreamer-plugins-ffmpeg
42
43%description -l ja
44Minitube は YouTube の新しい視聴方法を提案する、専用のクライ
45アントソフトウェアです。キーワードを入力すると、Minitube は
46関連する動画をエンドレスで再生します。
47また Minitube を使うと Flash Player 無しでビデオが再生できます。
48
49Minitube は YouTube のウェブインターフェースのクローンでは無
50く、新たなテレビ風の視聴スタイルを目指しています。
51
52ビデオの再生には以下のパッケージが必要となります。併せてイン
53ストールしてください。
54 - self-build-gstreamer-plugins-bad
55 - self-build-gstreamer-plugins-ffmpeg
56
57
58%prep
59%setup -q -n %{name}
60
61
62%build
63%{qt4qmake} prefix=%{_prefix}
64%{__make} %{?_smp_mflags}
65
66
67%install
68%{__rm} -rf $RPM_BUILD_ROOT
69%{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
70
71## wrapper
72%{__mkdir_p} $RPM_BUILD_ROOT%{_libexecdir}
73%{__mv} $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{MINITUBE_BIN}
74%{__install} -m 755 %{SOURCE10}  $RPM_BUILD_ROOT%{_bindir}/%{name}
75
76# desktop file with japanese messages
77%{__install} -m 644 %{SOURCE20}  $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
78
79%clean
80%{__rm} -rf $RPM_BUILD_ROOT
81
82
83%post
84update-desktop-database %{_datadir}/applications>& /dev/null ||:
85touch --no-create %{_datadir}/icons/hicolor
86if [ -x /usr/bin/gtk-update-icon-cache ]; then
87  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
88fi
89
90
91%postun
92update-desktop-database %{_datadir}/applications>& /dev/null ||:
93touch --no-create %{_datadir}/icons/hicolor
94if [ -x /usr/bin/gtk-update-icon-cache ]; then
95  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
96fi
97
98
99%files
100%defattr(-,root,root)
101%doc AUTHORS COPYING CHANGES INSTALL TODO
102%{MINITUBE_BIN}
103%{_bindir}/%{name}
104%{_datadir}/applications/%{name}.desktop
105%{_datadir}/icons/hicolor
106%{_datadir}/%{name}/locale
107
108
109%changelog
110* Wed May 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
111- new upstream release
112
113* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-1
114- new upstream release
115
116* Fri Jul 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.1-1
117- new upstream release
118
119* Sat May 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.0-1
120- initial build for Vine Linux
121- add minitube.desktop with japanese translation
122- add wrapper script to check necessary packages at runtime
Note: See TracBrowser for help on using the repository browser.