source: projects/specs/tags/6_0_REL/m/mikmod/mikmod-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# libmikmod rpm specification file
2%define lversion 3.1.11
3
4Summary: A MOD music file player.
5Summary(ja): MOD ファイル再生プログラム
6Name: mikmod
7Version: 3.1.6
8Release: 34%{?_dist_release}
9License: GPL/LGPL
10Group: Applications/Multimedia
11Prereq: /sbin/ldconfig
12Prefix: /usr
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14Requires: gpm ncurses
15BuildRequires: gpm ncurses
16BuildPrereq: ncurses-devel texinfo
17URL: http://mikmod.raphnet.net/
18Source0: http://mikmod.raphnet.net/files/mikmod-%{version}.tar.gz
19Source1: http://mikmod.raphnet.net/files/libmikmod-%{lversion}.tar.gz
20Patch0:  http://mikmod.raphnet.net/files/libmikmod-3.1.11-a.diff
21Patch1:  mikmod-strip.patch
22Patch2:  libmikmod-esd.patch
23Patch3:  libmikmod-64bit.patch
24Patch4:  patch-mikmod-3.1.6-a
25Patch5:  mikmod-3.1.6-varargs.patch
26Patch6:  libmikmod-strip-lib.patch
27Provides: libmikmod = %{lversion}-%{release}
28#Obsoletes: tracker
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: OOI Keita <ooi.keita@gmail.com>
33
34%description
35MikMod is one of the best and most well known MOD music file players
36for UNIX-like systems.  This particular distribution is intended to
37compile fairly painlessly in a Linux environment. MikMod uses the OSS
38/dev/dsp driver including all recent kernels for output, and will also
39write .wav files. Supported file formats include MOD, STM, S3M, MTM,
40XM, ULT, and IT.  The player uses ncurses for console output and
41supports transparent loading from gzip/pkzip/zoo archives and the
42loading/saving of playlists.
43
44Install the mikmod package if you need a MOD music file player.
45
46%description -l ja
47mikmod はとても手軽な音楽トラック再生プログラムです。
48幅広い種類のモジュール形式に対応しており、
49その中には Impulse Tracker の圧縮サンプルも含まれます。
50その他にも、多くのアーカイブ形式にも対応しています。
51
52%package devel
53Group: Development/Libraries
54Summary: Header files and documentation for compiling mikmod applications.
55Requires: %{name} = %{version}-%{release}
56PreReq: /sbin/install-info
57Provides: libmikmod-devel = %{lversion}-%{release}
58
59%description devel
60This package includes the header files you will need to compile
61applications for mikmod.
62
63%prep
64%setup -q -a 1
65%patch0 -p0
66%patch1 -p1 -b .strip
67%patch2 -p1 -b .esd
68%patch3 -p1
69%patch4 -p1 -b .orig
70%patch5 -p1
71%patch6 -p1 -b .lib-strip
72
73%build
74rm -rf $RPM_BUILD_ROOT
75cd libmikmod-%{lversion}
76cp /usr/share/libtool/config.{sub,guess} .
77%configure
78make
79%makeinstall
80cd ..
81
82# Trick it into compiling while libmikmod is not installed...
83export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{prefix}/lib:$LD_LIBRARY_PATH
84perl -pi -e "s,-lmikmod,-I$RPM_BUILD_ROOT%{prefix}/include -L$RPM_BUILD_ROOT%{_libdir} -lmikmod,g" libmikmod-%{lversion}/libmikmod-config
85export LIBMIKMOD_CONFIG=`pwd`/libmikmod-%{lversion}/libmikmod-config
86cp /usr/share/libtool/config.{sub,guess} .
87%configure \
88        --with-libmikmod-prefix=$RPM_BUILD_ROOT%{prefix} \
89        --with-libmikmod-exec-prefix=$RPM_BUILD_ROOT%{prefix}/bin \
90        --disable-libmikmodtest
91make CFLAGS="$RPM_OPT_FLAGS `libmikmod-%{lversion}/libmikmod-config --cflags` -I."
92
93%install
94%makeinstall
95rm -f $RPM_BUILD_ROOT%{_infodir}/dir
96
97## remove unuse files
98rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
99
100%clean
101rm -fr $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104
105%post devel
106/sbin/install-info %{_infodir}/mikmod.info.gz %{_infodir}/dir
107
108%postun -p /sbin/ldconfig
109
110%postun devel
111if [ $1 = 0 ] ; then
112        /sbin/install-info  --delete %{_infodir}/mikmod.info.gz %{_infodir}/dir
113fi
114
115%files
116%defattr(-, root, root)
117%doc AUTHORS COPYING NEWS README
118%doc libmikmod-%{lversion}/TODO
119%{_bindir}/mikmod
120%{_mandir}/man1/mikmod*
121%{_libdir}/*.so*
122
123%files devel
124%defattr(-, root, root)
125%{_bindir}/*-config
126%{_libdir}/*.a
127#%{_libdir}/*.la
128%{_datadir}/aclocal/*
129%{_includedir}/*
130%{_infodir}/mikmod*
131%{_mandir}/man1/libmikmod-config*
132
133%changelog
134* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.6-34vl5
135- applied new versioning policy, spec in utf-8
136- removed *.la
137
138* Thu Mar 10 2005 OOI Keita <ooi.keita@gmail.com> 3.1.6-33vl2
139- build for vine
140- add ja summary and description from deb
141
142* Tue Dec 21 2004 Martin Stransky <stransky@redhat.com> 3.1.6-33
143- strip library (#143258)
144
145* Mon Dec 13 2004 Bill Nottingham <notting@redhat.com> 3.1.6-31
146- move mikmod binary back to main package (#142668)
147
148* Fri Oct  8 2004 Bill Nottingham <notting@redhat.com> 3.1.6-30
149- add texinfo buildreqs (#135088)
150
151* Wed Oct  6 2004 Bill Nottingham <notting@redhat.com> 3.1.6-29
152- install-info scripts go with -devel (#134882)
153
154* Wed Sep 22 2004 Than Ngo <than@redhat.com> 3.1.6-28
155- increase release number
156
157* Wed Sep 22 2004 Than Ngo <than@redhat.com> 3.1.6-27
158- new devel sub package, multiarch problem
159- add /sbin/ldconfig in Prereq
160- cleanup specfile
161
162* Wed Aug  4 2004 Miloslav Trmac <mitr@redhat.com> - 3.1.6-26
163- Update to libmikmod-3.1.11-a, fixes #116182
164
165* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
166- rebuilt
167
168* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
169- rebuilt
170
171* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
172- rebuilt
173
174* Wed Jul 23 2003 Bill Nottingham <notting@redhat.com> 3.1.6-23
175- remove URL (#77375)
176
177* Mon Jul 14 2003 Bill Nottingham <notting@redhat.com> 3.1.6-22
178- fix build with gcc-3.3 some more
179
180* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
181- rebuilt
182
183* Thu May 22 2003 Bill Nottingham <notting@redhat.com> 3.1.6-21
184- fix build with gcc-3.3
185
186* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
187- rebuilt
188
189* Tue Jan  7 2003 Jeff Johnson <jbj@redhat.com> 3.1.6-19
190- don't include -debuginfo files in package.
191
192* Sat Nov 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
193- add further lib64 support, clean up spec file
194
195* Sat Oct 12 2002 Florian La Roche <Florian.LaRoche@redhat.de>
196- add 64bit patch
197
198* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
199- don't strip binaries
200- fix buffering with esd output (#57154, <stssppnn@yahoo.com>)
201
202* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
203- automated rebuild
204
205* Thu May 23 2002 Tim Powers <timp@redhat.com>
206- automated rebuild
207
208* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
209- automated rebuild
210
211* Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
212- add buildprereq for ncurses-devel (#49524)
213
214* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
215- Bump release + rebuild.
216
217* Thu Dec  7 2000 Bill Nottingham <notting@redhat.com>
218- fix %doc generation
219
220* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
221- automatic rebuild
222
223* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
224- FHS fixes, etc.
225
226* Mon Apr  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
227- rebuild with current ncurses
228- library 3.1.9
229- fix build when libmikmod is not already installed
230
231* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
232- gzip info page (Bug #9035)
233- Update URL and Source fields to present location
234
235* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
236- fix description
237- get rid of useless defines
238
239* Tue Jan 11 2000 Bill Nottingham <notting@redhat.com>
240- update lib to 3.1.8
241
242* Mon Aug  2 1999 Bill Nottingham <notting@redhat.com>
243- add more patches
244
245* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
246- update to 3.1.6/3.1.7
247
248* Mon Mar 22 1999 Cristian Gafton <gafton@redhat.com>
249- fixed spec file description and group according to sepcspo
250
251* Mon Mar 22 1999 Michael Maher <mike@redhat.com>
252- changed spec file, updated package
253- added libmikmod to the package
254
255* Mon Feb 15 1999 Miodrag Vallat <miodrag@multimania.com>
256- Created for 3.1.5
257
258* Tue Jan 24 1999 Michael Maher <mike@redhat.com>
259- changed group
260- fixed bug #145
261
262* Fri Sep 04 1998 Michael Maher <mike@redhat.com>
263- added patch for alpha
264
265* Wed Sep 02 1998 Michael Maher <mike@redhat.com>
266- built package; obsoletes the ancient tracker program.
267
Note: See TracBrowser for help on using the repository browser.