source: projects/specs/tags/6_0_REL/m/mathabx-type1/mathabx-type1-vl.spec @ 3478

Revision 3478, 5.1 KB checked in by munepi, 13 years ago (diff)

udpated texmacro-otf-vl.spec, mathabx-type1-vl.spec

Line 
1%define pkgname         mathabx
2
3%define tex_destdir     %{_datadir}
4%define texmf           %{tex_destdir}/texmf
5%define texlive_src     %{tex_destdir}/texlive-sources
6%define build_tex_destdir       %{buildroot}%{tex_destdir}
7%define build_texmf     %{buildroot}%{texmf}
8
9%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
10%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
11%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
12%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
13%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
14%define vartexfonts %{_var}/lib/texmf
15
16%define mapdir          %{texmf}/fonts/map/dvips/mathabx
17%define mathabxdate     20050518
18
19Summary: The mathabx font series: extended and extendable series of mathematical symbols for TeX
20Summary(ja): mathabx: TeX 用の新しい数式フォント
21Name: mathabx-type1
22Version: 2005
23Release: 4%{?_dist_release}
24Source0: mathabx-%{mathabxdate}.tar.bz2
25Source1: abxtype1-%{mathabxdate}.tar.bz2
26Source2: mathabx_docs-%{mathabxdate}.tar.bz2
27URL: http://auemath.aichi-edu.ac.jp/~khotta/ghost/mathabx.html
28License: GPL
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30Group: Applications/Publishing
31BuildArch: noarch
32PreReq: sed, sh-utils
33
34Requires: texlive-collection-fontsextra
35Obsoletes: texlive-mathabx-type1 <= 2005
36Obsoletes: mathabx <= 2005-1
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42The mathabx font series is a high quality extended and extendable series of
43mathematical symbols.
44To use this package, you describe \usepackage{mathabx} at preamble in your
45TeX document.
46
47This package provides Type1 fonts of mathabx.
48
49
50%description -l ja
51mathabx は CM + AMS の拡張であると考えられます。 全体的に色々な工夫が見られ,
52例えば、積分記号 \int が CM より垂直に見え、不等号 ≦ は AMS のものより < と
53 = がくっついているので、日本人が見慣れているものにより近いようです。
54
55TeX 文書の最初の部分へ \usepackage{mathabx} と記述すれば、普通の数式モードに
56て mathabx の利用が可能になります。
57
58このパッケージは mathabx の Type1 を提供します。
59
60
61%prep
62%__rm -rf $RPM_BUILD_ROOT
63
64%setup -q -a 1 -a 2 -n %{pkgname}
65
66%build
67
68%install
69%__rm -rf $RPM_BUILD_ROOT
70# mkdir -p            %{build_texmf}/fonts/source/public/mathabx
71# cp -p source/*      %{build_texmf}/fonts/source/public/mathabx
72# mkdir -p            %{build_texmf}/tex/latex/mathabx
73# cp -p texinputs/*   %{build_texmf}/tex/latex/mathabx
74%__mkdir_p            %{build_texmf}/fonts/type1/mathabx
75%__cp -p abxtype1/pfb/*.pfb %{build_texmf}/fonts/type1/mathabx
76%__mkdir_p          %{buildroot}%{mapdir}
77%__cp -p abxtype1/map/mathabx.map %{buildroot}%{mapdir}/mathabx.map
78
79%post
80%{exec_texhash}
81
82[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
83
84echo -n "    " && \
85    echo -n "Running updmap: enable mathabx.map ... " && \
86    %{exec_updmap} --enable Map mathabx.map >/dev/null 2>&1 && \
87    echo "done."
88
89exit 0
90
91%postun
92if [ "$1" = "0" ]; then
93    %{exec_texhash}
94
95    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
96
97    echo -n "    " && \
98        echo -n "Running updmap: disable mathabx.map ... " && \
99        %{exec_updmap} --disable mathabx.map >/dev/null 2>&1 && \
100        echo "done."
101fi
102
103exit 0
104
105
106%clean
107%__rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(-,root,root)
111# %{texmf}/fonts/source/public/mathabx/*
112%{texmf}/fonts/type1/mathabx/*
113# %{texmf}/tex/latex/mathabx/*
114%{mapdir}/mathabx.map
115# %doc mathtest.tex mathtest.dvi mathtest.pdf
116
117
118%changelog
119* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2005-4
120- fixed %%mapdir
121
122* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2005-3
123- added Obsoletes: texlive-mathabx-type1 <= 2005
124  - for TeX Live 2009 of VinePlus/5, supported texlive-mathabx-type1
125
126* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2005-2
127- renamed to mathabx-type1
128- TeX Live 2009
129- added Requires: texlive-collection-fontsextra
130  - texlive-collection-fontsextra has mathabx package
131
132* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2005-1vl5
133- applied new versioning policy, spec in utf-8
134
135* Tue May 16 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl4
136- fix exec_updmap: added --nostop option
137
138* Fri Dec 02 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl3
139- fix install dir of mathabx.mat
140
141* Thu Nov 17 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl2
142- fix exec_updmap
143
144* Wed Nov 16 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl1
145- source update
146- modified for tetex-3.0
147
148* Tue Feb 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl3
149- fix exec_updmap
150
151* Thu Dec 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl2
152- source update
153
154* Fri Aug 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl1
155- source update
156
157* Wed Jun 12 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl2
158- update Type1 fonts
159
160* Sun Jun 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl1
161- 1st release
Note: See TracBrowser for help on using the repository browser.