source: projects/specs/tags/6_0_REL/lib/libp/libproxy/libproxy-vl.spec @ 2041

Revision 2041, 7.6 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4%define gecko_version 1.9.1
5
6Summary:        A library handling all the details of proxy configuration
7Name:           libproxy
8Version:        0.4.6
9Release:        1%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        LGPLv2+
13URL:            http://code.google.com/p/libproxy/
14Source0:        http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
15Patch0:         libproxy-0.2.3-dbus.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  python-devel
19#Virtual Provides - We need either mozjs or WebKit
20Requires: %{name}-pac >= %{version}
21#
22Requires: libproxy-python = %{version}-%{release}
23Requires: libproxy-bin = %{version}-%{release}
24
25BuildRequires:  cmake
26# gnome
27BuildRequires:  GConf2-devel
28# mozjs
29BuildRequires:  gecko-devel >= %{gecko_version}
30# NetworkManager
31BuildRequires:  NetworkManager-devel
32BuildRequires:  dbus-devel
33# webkit (gtk)
34BuildRequires:  WebKit-gtk-devel
35# kde
36BuildRequires:  kdelibs-devel
37BuildRequires:  libXmu-devel
38BuildRequires:  libX11-devel
39
40
41%description
42libproxy offers the following features:
43
44    * extremely small core footprint (< 35K)
45    * no external dependencies within libproxy core
46      (libproxy plugins may have dependencies)
47    * only 3 functions in the stable external API
48    * dynamic adjustment to changing network topology
49    * a standard way of dealing with proxy settings across all scenarios
50    * a sublime sense of joy and accomplishment
51
52Non-default rpmbuild options:
53--with webkit:           Enable WebKit-gtk support
54
55
56%package        bin
57Summary:        Binary to test %{name}
58Group:          Applications/System
59Requires:       %{name} = %{version}-%{release}
60
61%description    bin
62The %{name}-bin package contains the proxy binary for %{name}
63
64%package        python
65Summary:        Binding for %{name} and python
66Group:          System Environment/Libraries
67Requires:       %{name} = %{version}-%{release}
68
69%description    python
70The %{name}-python package contains the python binding for %{name}
71
72%package        gnome
73Summary:        Plugin for %{name} and gnome
74Group:          System Environment/Libraries
75Requires:       %{name} = %{version}-%{release}
76
77%description    gnome
78The %{name}-gnome package contains the %{name} plugin for gnome.
79
80%package        kde
81Summary:        Plugin for %{name} and kde
82Group:          System Environment/Libraries
83Requires:       %{name} = %{version}-%{release}
84
85%description    kde
86The %{name}-kde package contains the %{name} plugin for kde.
87
88%package        mozjs
89Summary:        Plugin for %{name} and mozjs
90Group:          System Environment/Libraries
91Requires:       %{name} = %{version}
92#Tweak this according to the current gecko-libs version
93Requires:       gecko-libs >= %{gecko_version}
94Provides:       %{name}-pac = %{version}-%{release}
95
96%description    mozjs
97The %{name}-mozjs package contains the %{name} plugin for mozjs.
98
99%package        webkit
100Summary:        Plugin for %{name} and webkit
101Group:          System Environment/Libraries
102Requires:       %{name} = %{version}
103Provides:       %{name}-pac = %{version}-%{release}
104
105%description    webkit
106The %{name}-webkit package contains the %{name} plugin for
107webkit.
108
109%package        devel
110Summary:        Development files for %{name}
111Group:          Development/Libraries
112Requires:       %{name} = %{version}-%{release}
113Requires:       pkgconfig
114
115%description    devel
116The %{name}-devel package contains libraries and header files for
117developing applications that use %{name}.
118
119
120%prep
121%setup -q
122## %patch0 -p1 -b .dbus
123## touch -r configure.dbus configure
124##touch -r configure.ac.dbus configure.ac
125
126
127%build
128%cmake \
129        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
130        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
131        -DWITH_PERL=OFF \
132   .
133make VERBOSE=1 %{?_smp_mflags}
134make %{?_smp_mflags}
135
136
137%install
138rm -rf $RPM_BUILD_ROOT
139make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
140find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
141
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146
147%post -p /sbin/ldconfig
148
149%postun -p /sbin/ldconfig
150
151
152%files
153%defattr(-,root,root,-)
154%doc AUTHORS COPYING README
155%{_libdir}/*.so.*
156%dir %{_libdir}/%{name}
157%dir %{_libdir}/%{name}/%{version}
158%dir %{_libdir}/%{name}/%{version}/modules
159%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
160
161%files bin
162%defattr(-,root,root,-)
163%{_bindir}/proxy
164
165%files python
166%defattr(-,root,root,-)
167%{python_sitearch}/libproxy.py
168
169%files gnome
170%defattr(-,root,root,-)
171%{_libdir}/%{name}/%{version}/modules/config_gnome.so
172%{_libexecdir}/pxgconf
173
174%files kde
175%defattr(-,root,root,-)
176%{_libdir}/%{name}/%{version}/modules/config_kde4.so
177
178%files mozjs
179%defattr(-,root,root,-)
180%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
181
182%files webkit
183%defattr(-,root,root,-)
184%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
185
186%files devel
187%defattr(-,root,root,-)
188%{_includedir}/proxy.h
189%{_libdir}/*.so
190%{_libdir}/pkgconfig/libproxy-1.0.pc
191%{_datadir}/cmake/Modules/Findlibproxy.cmake
192
193
194%changelog
195* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
196- new upstream release
197- drop Patch0
198- add BuildRequires: cmake, kdelibs-devel
199- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
200
201* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
202- rebuild with rpm-4.8.1 for pkg-config file
203
204* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
205- rebuild with python-2.6
206
207* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
208- rebuild with gecko-1.9.1
209
210* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
211- rebuild with WebKit-gtk-1.0.0-8.svn41944
212
213* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
214- initial build for Vine Linux
215
216* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
217- Rebuild for webkit
218- Raise requirement for xulrunner to 1.9.1
219
220* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
222
223* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
224- Merge NetworkManager module into the main libproxy package
225- Main Requires the -python and -bin subpackage
226 (splitted for multilibs compliance).
227
228* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
229- Disable Gnome/KDE default support via builtin modules.
230 (it needs to be integrated via Gconf2/neon instead).
231
232* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
233- Disable Obsoletes.
234- Requires ev instead of evr for optionnals sub-packages.
235
236* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
237- Use conditionals build.
238
239* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
240- Remove plugin- in the name of the packages
241
242* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
243- Move proxy.h to libproxy/proxy.h
244  This will prevent it to be included in the default include path
245- Split main to libs and util and use libproxy to install all
246
247* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
248- Rename binding-python to python
249- Add Requires: gecko-libs >= %%{gecko_version}
250- Fix some descriptions
251- Add plugin-webkit package
252 
253* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
254- Convert to Fedora spec
255
256* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
257- Updated to version 0.2.3
258* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
259- Extended spec file to build all available plugins
260* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
261- Initial spec file for Version 0.2.2
262
Note: See TracBrowser for help on using the repository browser.