source: projects/specs/tags/6_0_REL/lib/libp/libpng/libpng-vl.spec @ 4317

Revision 4317, 12.4 KB checked in by iwamoto, 13 years ago (diff)

libpng: new upstream release with security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.2.46
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.bz2
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildPrereq: zlib-devel
13Requires: zlib
14URL: http://www.libpng.org/pub/png/
15%define LIBVER 3.%{version}
16Epoch: 2
17Obsoletes: libpng12
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The libpng package contains a library of functions for creating and
24manipulating PNG (Portable Network Graphics) image format files.  PNG
25is a bit-mapped graphics format similar to the GIF format.  PNG was
26created to replace the GIF format, since GIF uses a patented data
27compression algorithm.
28
29Libpng should be installed if you need to manipulate PNG format image
30files.
31
32%description -l ja
33libpng パッケージには PNG (Portable Network Graphics) 形式の
34画像ファイルを作成/操作する為のライブラリが収められています.
35PNG はビットマップの画像形式で,GIF によく似ています.
36GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
37PNG は GIF の代替画像形式として生まれました.
38
39PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
40
41%package devel
42Summary: Development tools for programs to manipulate PNG image format files.
43Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
44Group: Development/Libraries
45Requires: libpng = %{epoch}:%{version}-%{release}
46Requires: zlib-devel
47Obsoletes: libpng12-devel
48
49%description devel
50The libpng-devel package contains the header files necessary for
51developing programs using the PNG (Portable Network Graphics) library.
52
53%description devel -l ja
54libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
55使ったプログラムを開発するのに必要なヘッダファイルが収められています.
56
57%package static
58Summary: Static library for %{name}
59Summary(ja): %{name} のスタティックライブラリ
60Group: Development/Libraries
61Requires: libpng-devel = %{epoch}:%{version}-%{release}
62
63%description static
64The libpng-static package contains the static library for libpng.
65
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A library of functions for manipulating PNG image format files.
70Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74The libpng package contains a library of functions for creating and
75manipulating PNG (Portable Network Graphics) image format files.  PNG
76is a bit-mapped graphics format similar to the GIF format.  PNG was
77created to replace the GIF format, since GIF uses a patented data
78compression algorithm.
79
80Libpng should be installed if you need to manipulate PNG format image
81files.
82
83%package -n compat32-%{name}-devel
84Summary: Development tools for programs to manipulate PNG image format files.
85Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
86Group: Development/Libraries
87Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
88Requires: zlib-devel
89
90%description -n compat32-%{name}-devel
91The libpng-devel package contains the header files and static
92libraries necessary for developing programs using the PNG (Portable
93Network Graphics) library.
94
95If you want to develop programs which will manipulate PNG image format
96files, you should install libpng-devel.  You'll also need to install
97the libpng package.
98
99#'
100%prep
101%setup -q
102
103%build
104#./autogen.sh
105%configure
106%__make %{?_smp_mflags}
107
108%install
109[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
110%makeinstall
111
112# remove unneeded files
113%__rm -f %{buildroot}%{_libdir}/libpng*.la
114
115%post -p /sbin/ldconfig
116
117%postun -p /sbin/ldconfig
118
119%post -n compat32-%{name} -p /sbin/ldconfig
120
121%postun -n compat32-%{name} -p /sbin/ldconfig
122
123%clean
124[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(-,root,root)
128%doc *.txt example.c README TODO CHANGES
129%{_libdir}/libpng*.so.*
130%{_mandir}/man5/*
131
132%files devel
133%defattr(-,root,root)
134%{_bindir}/libpng-config
135%{_bindir}/libpng12-config
136%{_includedir}/*
137%{_libdir}/libpng*.so
138%{_libdir}/pkgconfig/*
139%{_mandir}/man3/*
140
141%files static
142%defattr(-,root,root)
143%{_libdir}/libpng*.a
144
145## to build compat32 for x86_64 architecture support
146%if %{build_compat32}
147%files -n compat32-%{name}
148%defattr(-,root,root)
149%{_libdir}/libpng*.so.*
150
151%files -n compat32-%{name}-devel
152%defattr(-,root,root)
153%{_libdir}/libpng*.a
154%{_libdir}/libpng*.so
155%{_libdir}/pkgconfig/*
156%endif
157
158%changelog
159* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
160- new upstream release with security fix (VU#819894)
161- add Vendor/Distri tags
162
163* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
164- build with rpm-4.8.1-1 for pkg-config file
165
166* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
167- sync with Vine Linux 5 updates release
168  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
169  - new upstream release with security fix (CVE-2010-1205)
170
171* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
172- sync with Vine Linux 5 updates release
173  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
174  - new upstream release with security fix (CVE-2010-0205)
175
176* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
177- new upstream release with security fix
178
179* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
180- new upstream release with security fix
181
182* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
183- split static library to libpng-static
184  - needed by tuxonice-userui
185
186* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
187- new upstream release with security fix (CVE-2009-0040)
188
189* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
190- new upstream release
191
192* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
193- spec file in UTF-8
194
195* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
196- new upstream release with security fix (CVE-2008-3964)
197
198* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
199- new upstream release with security fix (CVE-2008-1382)
200- added running autogen.sh before configure
201- new versioning policy
202
203* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
204- new upstream release
205
206* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
207- removed %%if !%%{build_compat32} case condition
208
209* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
210- new upstream release
211
212* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
213- new upstream release
214
215* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
216- new upstream release (CVE-2007-2445)
217
218* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
219- new upstream release
220- drop obsolete patch100
221
222* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
223- add Patch100 for fix CVE-2006-5793.patch
224
225* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
226- [SECURITY] new upstream release
227  - potential buffer overrun in chunk error processing (CVE-2006-3334)
228- use %%configure, %%makeinstall
229- drop unneeded patch10
230
231* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
232- rebuilt with glibc-2.3.3-3vl14
233
234* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
235- fixed libdir path in libpng.pc
236
237* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
238- fixed %postun (missing to build as scriptlet by invalid comment)
239
240* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
241- added compat32-* packages for x86_64 architecture support
242- added CC='gcc -m32' to make when build_compat32
243- added LIBPATH=%{_libdir} to make
244
245* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
246- rebuild
247
248* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
249- rebuild for VineSeed
250
251* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
252- new upstream release (bug fix)
253
254* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
255- new upstream release
256
257* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
258- update to 1.2.6rc3
259- add Requires: zlib-devel to libpng-devel.
260
261* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
262- update to 1.2.6rc2
263
264* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
265- update to 1.2.6rc1
266- add patch10 to correct directory name in libpng.pc
267- clean spec file
268
269* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
270- added Patch4 from Redhat WS updates
271  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
272  - Reinstate and improve the transfix patch which got lost sometime ago,
273    but is still needed for CAN-2002-1363 (#125934)
274
275* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
276- rebuild with new toolchain
277- use License tag
278- change URL
279
280* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
281- added Obsoletes: libpng12-devel for libpng-devel
282
283* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
284- change package name from libpng12 to libpng
285- revised install and files section
286- remove all patches
287- define LIBVER 3.%{version}
288- add Obsoletes: libpng12
289
290* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
291- new upstream version
292- change package name to libpng12
293- conflicts libpng-devel(1.0.5) and libpng12-devel
294
295* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
296- added Patch200 for linking libz shared lib
297- include libpng*-config
298
299* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
300- added missing libraries in the file list
301
302* Thu Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
303- update to 1.0.15
304- now, security patch were merged source.
305
306* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
307- added another security patch to preserve libpng from processing too wide
308  image files (a patch itself extracted from DSA 140-2)
309
310* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
311- added a patch to fix buffer overflow (Patch100)
312
313* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
314- 1.0.12-0vl1
315- updated 1.0.12
316
317* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
318- 1.0.7-0vl3
319- use better macros
320- added Japanese summary and description
321
322* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
323- 1.0.7-0vl2
324- oops, spec was in Shift-JIS... Fixed it.
325
326* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
327- update to 1.0.7
328
329* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
330- update to 1.0.6
331
332* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
333- change serial to Epoch to get dependencies working correctly
334
335* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
336- move buildroot and add URL
337
338* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
339- strip library
340- rebuild to compress man pages
341
342* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
343- 1.0.5
344- some tweaks to spec file to make updating easier
345- handle RPM_OPT_FLAGS
346
347* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
348- changed requires in libpng-devel to include serial
349- corrected typo
350
351* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
352- auto rebuild in the new build environment (release 2)
353
354* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
355- rev to 1.0.3
356
357* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
358- build for 6.0
359
360* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
361- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
362  beta to this prior one
363- install man pages; set defattr defaults
364
365* Thu May 07 1998 Prospector System <bugs@redhat.com>
366- translations modified for de, fr, tr
367
368* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
369- devel subpackage moved to Development/Libraries
370
371* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
372- upgraded to 1.0.1
373- added buildroot
374
375* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
376- updated to new version
377- spec file cleanups
378
379* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
380- built against glibc
381
Note: See TracBrowser for help on using the repository browser.