source: projects/specs/tags/6_0_REL/lib/libk/libksba/libksba-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A library to access X.509 and CMS data structures.
2Summary(ja): X.509 ¤ª¤è¤Ó CMS ¥Ç¡¼¥¿¹½Â¤¤Ë¥¢¥¯¥»¥¹¤¹¤ë¤¿¤á¤Î¥é¥¤¥Ö¥é¥ê
3Name:    libksba
4Version: 1.0.3
5Release: 2%{?_dist_release}
6
7License: GPLv3
8Group:   System Environment/Libraries
9URL:     http://www.gnupg.org/
10Source0: ftp://ftp.gnupg.org/gcrypt/libksba/libksba-%{version}.tar.bz2
11Source1: ftp://ftp.gnupg.org/gcrypt/libksba/libksba-%{version}.tar.bz2.sig
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14# quick-n-dirty hack to ksba-config, TODO: consider using pkgconfig instead
15Patch1: libksba-1.0.3-multilib.patch
16
17BuildRequires: gawk
18BuildRequires: libgpg-error-devel >= 1.2
19BuildRequires: libgcrypt-devel >= 1.2.0
20
21%description
22KSBA is a library designed to build software based on the X.509 and
23CMS protocols.
24
25%package devel
26Summary: Development headers and libraries for %{name}
27Summary(ja): %{name} Íѳ«È¯¥Ø¥Ã¥À/¥é¥¤¥Ö¥é¥ê
28Group:   Development/Libraries
29Requires: %{name} = %{version}-%{release}
30Requires(post): /sbin/install-info
31Requires(preun): /sbin/install-info
32%description devel
33%{summary}.
34
35
36%prep
37%setup -q
38
39%patch1 -p1 -b .multilib
40
41
42%build
43%configure \
44  --disable-dependency-tracking \
45  --disable-static
46
47make %{?_smp_mflags}
48
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53make install DESTDIR=$RPM_BUILD_ROOT
54
55rm -f $RPM_BUILD_ROOT%{_infodir}/dir
56rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
57
58
59%check
60make check
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66
67%post -p /sbin/ldconfig
68
69%postun -p /sbin/ldconfig
70
71%post devel
72install-info %{_infodir}/ksba.info %{_infodir}/dir ||:
73
74%postun devel
75if [ $1 -eq 0 ]; then
76  install-info --delete %{_infodir}/ksba.info %{_infodir}/dir ||:
77fi
78
79
80%files
81%defattr(-,root,root,-)
82%doc AUTHORS ChangeLog COPYING NEWS README* THANKS TODO VERSION
83%{_libdir}/lib*.so.*
84
85%files devel
86%defattr(-,root,root,-)
87%{_bindir}/ksba-config
88%{_libdir}/lib*.so
89%{_includedir}/*
90%{_datadir}/aclocal/*
91%{_infodir}/*
92
93
94%changelog
95* Thu Sep 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.3-2
96- new upstream release, based on 1.0.3-2 from Fedora 9
97- Vine's previous changelogs as follows:
98  - Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-1vl5
99  - applied new versioning policy, spec in utf-8
100  - removed *.la
101  - Sun Mar  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-0vl1
102  - initial build
103
104
105* Thu Apr 03 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.3-2
106- multiarch conflicts (#342201)
107
108* Tue Feb 12 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.3-1
109- libksba-1.0.3
110
111* Fri Feb 08 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.2-4
112- respin (gcc43)
113
114* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.2-3
115- BR: gawk
116
117* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.2-2
118- respin (ppc32, BuildID)
119- License: GPLv3
120
121* Fri Jul 06 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.2-1
122- libksba-1.0.2
123
124* Fri Dec 01 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0.1-1
125- libksba-1.0.1
126
127* Mon Oct 02 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0.0-1.1
128- respin
129
130* Thu Aug 31 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0.0-1
131- libksba-1.0.0
132
133* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.15-3
134- fc6 respin
135
136* Thu Jun 20 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.15-2
137- 0.9.15
138
139* Wed Mar 1 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.13-2.1
140- fc5: gcc/glibc respin
141
142* Wed Nov 30 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.13-2
143- remove hacks
144- drop self Obsoletes
145
146* Wed Nov 30 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.13-1
147- 0.9.13
148
149* Fri Aug 26 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.11-3
150- botched Obsoletes good, let's try again.
151
152* Fri Aug 26 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.11-2
153- revert to 0.9.11 (0.9.12 makes gnupg2 fail on x86_64) using Obsoletes
154  to avoid Epoch or other ugly means.
155
156* Mon Aug  8 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.12-1
157- 0.9.12
158- --disable-static
159
160* Thu Apr 21 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.11-1
161- 0.9.11
162- drop upstreamed acquote patch
163
164* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.9-2
165- rebuilt
166
167* Tue Feb  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0:0.9.9-1
168- Minus BR libtool, add epoch to -devel req, fix underquoted ksba.m4.
169
170* Fri Oct 22 2004 Rex Dieter <rexdieter[AT]users.sf.net> 0:0.9.9-0.fdr.2
171- remove hard-coded .gz from %%post/%%postun
172- add %%check section
173
174* Tue Oct 19 2004 Rex Dieter <rexdieter[AT]users.sf.net> 0:0.9.9-0.fdr.1
175- 0.9.9
176
177* Thu Mar 20 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.4.7-0.fdr.1
178- Update to 0.4.7, and to current Fedora guidelines.
179- Exclude %%{_libdir}/*.la.
180
181* Tue Feb 12 2003 Warren Togami <warren@togami.com> 0.4.6-1.fedora.3
182- temporary workaround to lib/dir conflict problem
183
184* Sat Feb  8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.4.6-1.fedora.1
185- First Fedora release.
Note: See TracBrowser for help on using the repository browser.