source: projects/specs/tags/6_0_REL/lib/libg/libgnomeprint/libgnomeprint-vl.spec @ 2041

Revision 2041, 12.8 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1## this could go, it's really just so we notice if the soname changes
2%define sover 0
3
4%define gettext_package libgnomeprint-2.2
5
6%define glib2_base_version 2.26.0
7%define glib2_version %{glib2_base_version}
8%define pango_version 1.28.2
9%define libxml2_version 2.7.7
10%define libart_lgpl_version 2.3.16
11%define libbonobo_version 2.32.0
12%define freetype_version 2.3.7
13%define gtk_doc_version 1.1
14
15Summary: Printing library for GNOME.
16Summary(ja): GNOME プリントライブラリ
17Name:           libgnomeprint
18Version:        2.18.8
19Release:        1%{?_dist_release}
20License:        LGPL
21Group:          System Environment/Libraries
22Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: libxml2-devel >= %{libxml2_version}
28BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
29BuildRequires: libbonobo-devel >= %{libbonobo_version}
30BuildRequires: freetype2 >= %{freetype_version}
31BuildRequires: gtk-doc >= %{gtk_doc_version}
32BuildRequires: libgnomecups-devel >= 0.2.0
33BuildRequires: bison
34BuildRequires: flex
35
36Requires: libgnomecups >= 0.1.13-0vl2
37Requires: urw-fonts
38Requires: ghostscript
39Requires: ghostscript-fonts
40Requires: libxml
41Requires: perl
42
43
44%description
45GNOME (GNU Network Object Model Environment) is a user-friendly set of
46applications and desktop tools to be used in conjunction with a window
47manager for the X Window System. The gnome-print package contains
48libraries and fonts needed by GNOME applications for printing.
49
50You should install the gnome-print package if you intend to use any of
51the GNOME applications that can print. If you would like to develop
52GNOME applications that can print you will also need to install the
53gnome-print devel package.
54
55%package devel
56Summary: Libraries and include files for developing GNOME applications.
57Summary(ja): libgnomeprint のライブラリとヘッダファイル
58Group: Development/Libraries
59
60Requires: %{name} = %{version}-%{release}
61Requires: glib2-devel >= %{glib2_version}
62Requires: pango-devel >= %{pango_version}
63Requires: libxml2-devel >= %{libxml2_version}
64Requires: libart_lgpl-devel >= %{libart_lgpl_version}
65Requires: libbonobo-devel >= %{libbonobo_version}
66Requires: freetype2 >= %{freetype_version}
67
68%description devel
69GNOME (GNU Network Object Model Environment) is a user-friendly set of
70applications and desktop tools to be used in conjunction with a window
71manager for the X Window System. The gnome-print-devel package
72includes the libraries and include files needed for developing
73applications that use the GNOME printing capabilities.
74
75You should install the gnome-print-devel package if you would like to
76develop GNOME applications that will use the GNOME print capabilities.
77You do not need to install the gnome-print-devel package if you just
78want to use the GNOME desktop environment.
79
80%prep
81%setup -q -n %{name}-%{version}
82
83%build
84%configure --disable-font-install --disable-gtk-doc
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90# It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
91# instead of %%makeinstall with this hack.
92%makeinstall
93
94# remove unpackaged files
95rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
96rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
97rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(-, root, root)
108%doc AUTHORS COPYING ChangeLog NEWS README
109%dir %{_libdir}/libgnomeprint/%{version}
110%{_libdir}/libgnomeprint/%{version}/modules/*.so
111%{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
112%{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
113%{_libdir}/libgnomeprint*.so.*
114%{_datadir}/libgnomeprint
115%{_datadir}/locale/*/LC_MESSAGES/*.mo
116
117%files devel
118%defattr(-, root, root)
119%{_libdir}/libgnomeprint*.so
120%{_libdir}/*.a
121%{_includedir}/*
122%{_libdir}/pkgconfig/*.pc
123%{_datadir}/gtk-doc
124
125%changelog
126* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-1
127- new upstream release
128
129* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.18.7-2
130- build with rpm-4.8.1-1 for pkg-config file
131
132* Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
133- new upstream release
134- add BuildRequires: bison, flex
135
136* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
137- new upstream release
138
139* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
140- new upstream release
141- build with gtk+2.14
142
143* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
144- new upstream release
145- removed BuildRequires: automake17
146
147* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
148- new upstream release
149
150* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
151- rebuilt with new toolchain/environment
152
153* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
154- new upstream release
155
156* Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
157- changed Group to System Environment/Libraries
158
159* Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
160- add missing filter modules to %%files
161- remove unneeded static modules
162
163* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
164- new upstream release
165
166* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
167- new upstream release
168
169* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
170- new upstream release
171
172* Sun Jul  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
173- new upstream version
174- drop all patches that are now upstream.
175
176* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
177- new upstream version
178- drop all patches that are now upstream.
179
180* Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
181- new upstream release
182- updated patch7,8 from Fedora Development
183- added Japanese summary to devel package
184
185* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
186- new upstream release
187- add patch7,8 from fc
188
189* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
190- add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
191
192* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
193- new upstream release
194
195* Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
196- new upstream release
197
198* Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
199- Oops, spec was in Shift_JIS. Fixed.
200
201* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
202- new upstream release
203
204* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
205- new upstream release
206
207* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
208- new upstream release
209
210* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
211- new upstream release
212
213* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
214- new upstream release
215
216* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
217- new upstream release
218
219* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
220- new upstream release
221
222* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
223- add patch1 to recognize .ttc font as TrueType font.
224
225* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
226- add %%{_datadir}/libgnomeprint for %%files
227
228* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
229- new upstream release
230
231* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
232- build for Vine Linux
233- new upstream release from gnome-2.1.4
234
235* Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
236- libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
237
238* Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
239- libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
240  performance issue. (#66715)
241
242* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
243- includes redhat-update-gnome-font-install2 script. (#66899)
244- fix the install path for fontmap.
245- add some directory owners.
246
247* Thu Jul 11 2002 Tim Powers <timp@redhat.com>
248- rebuilt
249
250* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
251- 1.115.0
252- include gtk-doc docs
253- move pkg-config files to -devel package
254
255* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
256- rebuild in different environment
257
258* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
259- 1.114.0
260
261* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
262- rebuild in different environment
263
264* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
265- rebuild in different environment
266- add bonobo-activation requires to make build system happy
267
268* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
269- 1.113.0
270
271* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
272- rebuild for new libraries
273
274* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
275- 1.112.0
276
277* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
278- 1.111.0
279
280* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
281- Version 1.110.0
282
283* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
284- automake14
285
286* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
287- 1.109.0.90 snap
288- remove .options patch which is upstream
289- remove .nofontmaps patch, upstream uses sysconfdir sometimes now
290  and has --disable-font-install configure option
291- remove .fontmapdir, now fixed upstream
292
293* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
294- rebuild due to build system fuckup
295
296* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
297- cvs snap 1.106.0.90, glib 1.3.11
298
299* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
300- new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
301
302* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
303- remove epoch screwup
304
305* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
306- libgnomeprint package based on the gnome-print package
307
308* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
309- use 0.30 tarball
310
311* Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
312- new cvs snap, with headers moved
313
314* Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
315- Back out freetype change, for now, until we can get it in upstream.
316- Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
317  Making them %config doesn't seem compatible with locating them
318  in gnome-print/<ver>.
319
320* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
321- no replace profiles.
322
323* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
324- Move profiles directory to /etc/gnome-print/<ver>/profiles/
325
326* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
327- Add freetype support patch. (Bug#50360)
328
329* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
330- Add missing directory
331
332* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
333- Upgrade to 0.29
334- Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
335- Add BuildPrereq and make -devel package require gdk-pixbuf-devel
336- Make libgnomeprint package require gnome-print package; otherwise
337  packages requiring libgnomeprint might not get a runtime environment
338- Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
339
340* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
341- Kill output from run-gnome-font-install
342- s/Copyright/License/
343- Add post/postun scripts for the libgnomeprint subpackage
344
345* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
346- Bump release + rebuild.
347
348* Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
349- new version (0.28)
350
351* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
352- Rebuild for GTK+-1.2.9 include paths
353
354* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
355- langify
356- patch it to compile (didn't include locale.h when needed)
357- use %%{_tmppath}
358
359* Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
360- Fixed font problem for Japanese.
361- Fixed library dependency on VFlib (Bug#28331)
362
363* Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
364- Fixed bugzilla bug #27417, simple specfile %post fix.
365
366* Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
367- Fixed PostScript broken.
368- Added autoheader,automake,autoconf stuff.
369
370* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
371- add libtoolize to make porting to new archs easy
372
373* Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
374- Updated Japanese patch for Gnumeric.
375  Created dummy .afm.
376
377* Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
378- Fixed gdk_fontset_load().
379- Added Japanese patch for Gnumeric.
380
381* Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
382- Added Japanese patch.
383  Fixed Print and Preview with Japanese.
384
385* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
386- 0.25
387
388* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
389- added "|| true" to %%post so that if font-install screws up we don't get a
390  bad exit status.  gnome-font-install expects that the directory specified by
391  HOME env. var is writable, but it isn't always if you install with 'sudo'
392  or the equivalent.  bad. bad. bad.
393
394* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
395- Up Epoch and release
396
397* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
398- redirect %%post script output to /dev/null
399
400* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
401- automatic rebuild
402
403* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
404- Spec file fixes
Note: See TracBrowser for help on using the repository browser.