source: projects/specs/tags/6_0_REL/j/jd/jd-vl.spec @ 3064

Revision 3064, 8.0 KB checked in by iwamoto, 13 years ago (diff)

update: jd 2.8.1

Line 
1###  for Vine Linux 4.x / 5.x / VineSeed ###
2
3%define  pkg_version  2.8.1
4%define  strtag       110312
5%define  repoid       40140
6%define  vendor_rel   1
7
8%define  pre_release  0
9%if %{pre_release}
10%define  pkg_release  %{vendor_rel}.%{strtag}%{?_dist_release}
11%else
12%define  pkg_release  %{vendor_rel}%{?_dist_release}
13%endif
14
15## icon install dist dir
16%define  icondir  %{_datadir}/icons/hicolor
17
18## enable/disable sound (0:disable 1:enable)
19%define  sound  1
20
21Summary:      A 2ch browser
22Summary(ja):  2ちゃんねる用ブラウザ
23Name:         jd
24Version:      %{pkg_version}
25Release:      %{pkg_release}
26
27Source0:  http://prdownloads.sourceforge.jp/jd4linux/%{repoid}/%{name}-%{version}-%{strtag}.tgz
28Source1:  jd-vl.desktop
29
30# Vine Patch
31Patch1:     jd-vine_env.patch
32
33# upstream svn patches
34# Patch100: jd-2.5.0_http_201.patch
35# Patch100: jd-2.4.0_close_err_image.patch
36# Patch110: jd-2.4.0_tag_drawing_fix.patch
37# Patch100: jd-2.6.0_gtkmm28.patch
38# Patch100: jd-2.7.0_maru_p2.patch
39# Patch100: jd-2.7.5-command_line_color_config.patch
40Patch110: jd-2.6.5_vine4.patch
41
42License:  GPL
43Group:    Applications/Internet
44URL:      http://jd4linux.sourceforge.jp/
45
46Requires:  gtkmm2 >= 2.8
47Requires:  glibmm
48Requires:  zlib >= 1.2
49Requires:  pango
50Requires:  gnutls >= 1.2
51Requires(pre):  desktop-file-utils
52# Prereq:    desktop-file-utils
53
54BuildRequires:  libtool, automake, autoconf
55BuildRequires:  gtkmm2-devel >= 2.8
56BuildRequires:  glibmm-devel
57BuildRequires:  zlib-devel >= 1.2
58BuildRequires:  XOrg-devel
59BuildRequires:  pango-devel
60BuildRequires:  gnutls-devel >= 1.2
61BuildRequires:  libgpg-error-devel
62%if %{sound}
63BuildRequires:  alsa-lib-devel
64%endif
65BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root
66
67Packager: tomcat, iwamoto
68Vendor: Project Vine
69Distribution: Vine Linux
70
71%description
72JD is a 2ch browser based on gtkmm2.
73
74%description -l ja
75JD は gtkmm2 ベースの2ちゃんねる用ブラウザです。
76
77%prep
78%setup -q -n %{name}-%{version}-%{strtag}
79# find . -name .svn | sort -r | xargs %{__rm} -rf
80
81%patch1 -p1 -b .vine_env
82
83# Patch 100 - 200 are upstream patches
84# %patch100 -p2 -b .close_err_image
85# %patch100 -p2 -b .gtkmm28
86# %patch100 -p0 -b .maru_p2
87# %patch100 -p0 -b .color
88
89%if %{?_dist_release} == "vl4"
90%patch110 -p1 -b .vine4
91%endif
92
93%build
94autoreconf -i
95
96## set TZ for __TIME__
97export TZ='Asia/Tokyo'
98
99%if %{sound}
100%configure  --with-alsa
101%else
102%configure
103%endif
104
105%{__make} %{?_smp_mflags}
106
107%install
108%{__rm} -rf ${RPM_BUILD_ROOT}
109%{__make} install DESTDIR=${RPM_BUILD_ROOT}
110
111%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
112%{__install} -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/jd.desktop
113
114for i in 16 32 48 96;do \
115  %{__mkdir_p} ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps; \
116  %{__install} -p -m644 src/icons/%{name}$i.png ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps/%{name}.png; \
117done
118
119%clean
120%{__rm} -rf ${RPM_BUILD_ROOT}
121
122%post
123update-desktop-database %{_datadir}/applications
124
125%postun
126update-desktop-database %{_datadir}/applications
127
128
129%files
130%defattr(-,root,root)
131%doc COPYING ChangeLog README
132%{_bindir}/%{name}
133%{_datadir}/applications/%{name}.desktop
134%{_datadir}/pixmaps/%{name}.png
135%{icondir}/*/apps/%{name}.png
136
137%changelog
138* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.1-1
139- new upstream release
140
141* Tue Feb 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.1-0
142- new beta release
143
144* Thu Feb  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.0-1
145- new upstream release
146
147* Wed Feb  2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.0-0
148- testpackage (not for release)
149- drop patch100 (included in new release)
150
151* Tue Feb  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.5-3
152- use Requires(pre) tag instead of Prereq
153
154* Tue Jan 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.5-2
155- add patch100 to add config status line color setting
156
157* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.5-1
158- 2.7.5 release
159
160* Wed Dec 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.5-0.1
161- 2.7.5 beta (not for release)
162
163* Sat Dec 11 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.5-0
164- 2.7.5 beta (not for release)
165- drop Patch100 (is included in new release)
166
167* Fri Aug 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.0-2
168- add patch1 to show vine package into environment
169- add patch100 to fix maru & p2 issue
170
171* Tue Aug 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.7.0-1
172- new upstream release
173
174* Thu Apr 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-2
175- add patch110 to fix build error on Vine4
176- add BR: libgpg-error-devel
177
178* Wed Apr 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-1
179- new upstream release   
180- drop Patch100 (is included in new release)
181
182* Mon Mar 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-2
183- add Patch100 to build fix with <= gtkmm28 (Vine 4.x env)
184
185* Mon Feb  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-1
186- new upstream release   
187
188* Sat Feb  6 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-0.100130
189- 2.6.0 rc1 (not for release)
190
191* Tue Dec 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
192- new upstream release 
193
194* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091225
195- 2.5.5 rc1 (not for release)
196
197* Wed Dec 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091220
198- 2.5.5 beta (not for release)
199- drop patch100 (included in new release)
200
201* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.0-1
202- new upstream release
203
204* Mon Sep 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.2-1
205- new upstream release
206
207* Tue Sep 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
208- 2.4.2-rc090921-0
209- for test
210
211* Mon Jul 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.1-1
212- new upstream release
213
214* Sat Jul 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
215- 2.4.1-rc090705-1
216- new upstream rc release for testing
217- drop patch100, 110 (included in new release)
218
219* Sat May 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.0-2
220- Merge spec file for vl4 and for vl5
221- add patch100, 110 from upstream svn
222
223* Sat May 23 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.4.0-1vl4
224- new upstream release
225
226* Fri Mar 06 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.3.0-1vl4
227- new upstream release
228
229* Fri Jan 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.0-2vl4
230- fix icon file install method
231
232* Sun Dec 28 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.1.0-1vl4
233- new upstream release
234
235* Mon Nov 24 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.3-1vl4
236- new upstream release
237
238* Wed Oct 01 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1vl4
239- rebuild for official
240
241* Sun Sep 21 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1tomvl4
242- update to 2.0.2
243
244* Sun Feb 03 2008 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom3
245- build with gnutls-1.4.1(official package)
246
247* Sun Dec 30 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom2
248- build with gnutls-1.6.3(unofficial package)
249
250* Sat Dec 29 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom1
251- new upstream release
252- drop Patch0 (jd-1.9.5-desktop-vi.patch)
253- add Source1 (jd-vi.desktop)
254
255* Fri Nov 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.7-1tom1
256- new upstream release
257
258* Sat Oct 06 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.6-1tom1
259- new upstream release
260
261* Wed Jul 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1tom2
262- modified jd-vi.spec
263- add patch0
264
265* Sun Jul 01 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1
266- new upstream release
267
268* Wed May 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-2
269- fix the Help file is not installed
270
271* Wed Apr 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-1
272- new upstream release
273
274* Sat Feb 03 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.5-1
275- new upstream release
276
277* Mon Dec 18 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.1-1
278- new upstream release
279
280* Thu Nov 30 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.0-1
281- initial build for Vine Linux
282
283* Sun Mar  9 2006 Houritsuchu <houritsuchu@hotmail.com>
284- Version up.
285- add icon
286
287* Sat Feb 25 2006 Houritsuchu <houritsuchu@hotmail.com>
288- first
Note: See TracBrowser for help on using the repository browser.