source: projects/specs/tags/6_0_REL/j/jam/jam-vl.spec @ 521

Revision 521, 1.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name jam
2%define version 2.5
3%define release 1%{?_dist_release}
4
5Summary: Program construction tool, similar to make
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Source0: ftp://ftp.perforce.com/pub/jam/%{name}-%{version}.tar
10License: Distributable
11Group: Development/Tools
12URL: http://www.perforce.com/jam/jam.html
13
14#Requires: byacc
15BuildRequires: byacc
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18%description
19Jam is a program construction tool, like make.
20
21Jam recursively builds target files from source files,
22using dependency information and updating actions expressed in
23the Jambase file, which is written in jam's own interpreted
24language.  The default Jambase is compiled into jam and
25provides a boilerplate for common use, relying on a user-provide
26file "Jamfile" to enumerate actual targets and sources.
27
28The Jambase is described in the Jambase
29Reference and the document Using Jamfiles and Jambase.
30
31# '
32
33%prep
34%setup -q
35
36%build
37export CFLAGS="$RPM_OPT_FLAGS" CCFLAGS="$RPM_OPT_FLAGS"
38make %{?_smp_mflags}
39
40%install
41%{__rm} -rf ${RPM_BUILD_ROOT}
42mkdir -p ${RPM_BUILD_ROOT}/%{_bindir}
43install -m0755 bin.linux*/jam ${RPM_BUILD_ROOT}/%{_bindir}
44install -m0755 bin.linux*/mkjambase ${RPM_BUILD_ROOT}/%{_bindir}
45
46%clean
47%{__rm} -rf ${RPM_BUILD_ROOT}
48
49%files
50%defattr(-,root,root)
51%doc README RELNOTES *.html
52%{_bindir}/jam
53%{_bindir}/mkjambase
54
55%changelog
56* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 2.5-1vl5
57- applied new versioning policy
58
59* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.5-0vl2
60- rebuild for VineSeed
61
62* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.5-0vl1
63- initial build for Vine Linux 4.1
64
65* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.5-0vlmp1
66- initial build for Vine Linux 3.2
67
68# end of file
Note: See TracBrowser for help on using the repository browser.