source: projects/specs/tags/6_0_REL/i/iverilog/iverilog-vl.spec @ 1220

Revision 1220, 5.6 KB checked in by inagaki, 14 years ago (diff)

NEW: electronics-menu, gerbv, geda-gaf, gtkwave, iverilog, pcb

Line 
1# TODO for 1.0 release - redefine
2#Version:     0.9.%{snapshot}
3#Release:     6%{?dist}
4# to
5#Version:     1.0
6#Release:     1.snap%{snapshot}%{?dist}
7
8#
9# Test suite for iverilog is detailed on
10# https://fedorahosted.org/fedora-electronic-lab/wiki/Testing/iverilog
11# Please execute the testsuite as explained before pushed a new release to stable repos
12#
13
14%define      snapshot 20091230
15
16Name:        iverilog
17Version:     0.9.2
18Release:     1%{?_dist_release}
19Summary:     Icarus Verilog is a verilog compiler and simulator
20
21Group:       Applications/Engineering
22License:     GPLv2
23URL:         http://www.icarus.com/eda/verilog/index.html
24
25# Development Snapshot Download :
26# git clone git://icarus.com/~steve-icarus/verilog
27# cd verilog
28# git checkout --track -b v0_9-branch origin/v0_9-branch
29
30# This is the latest stable snapshot
31Source0:       ftp://ftp.icarus.com/pub/eda/verilog/v0.9/verilog-%{version}.tar.gz
32
33BuildRoot:   %{_tmppath}/%{name}-%{version}-root
34
35BuildRequires: zlib-devel
36BuildRequires: bzip2-devel
37BuildRequires: bison
38BuildRequires: flex
39BuildRequires: gperf
40BuildRequires: autoconf
41
42
43%description
44Icarus Verilog is a Verilog compiler that generates a variety of
45engineering formats, including simulation. It strives to be true
46to the IEEE-1364 standard.
47
48%package devel
49Summary:     Icarus Verilog devel files
50Group:       Development/Libraries
51Requires:    %{name} = %{version}-%{release}
52
53%description devel
54Icarus Verilog devel files.
55
56%prep
57%setup -q -n verilog-%{version}
58
59#sh autoconf.sh
60
61# clean junks from tarball
62find . -type f -name ".git" -exec rm '{}' \;
63rm -rf `find . -type d -name "autom4te.cache" -exec echo '{}' \;`
64
65
66%build
67
68CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" \
69%configure
70
71make %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75
76make         prefix=%{buildroot}%{_prefix} \
77             bindir=%{buildroot}%{_bindir} \
78             libdir=%{buildroot}%{_libdir} \
79             libdir64=%{buildroot}%{_libdir} \
80             includedir=%{buildroot}%{_includedir} \
81             mandir=%{buildroot}%{_mandir}  \
82             vpidir=%{buildroot}%{_libdir}/ivl/ \
83             INSTALL="install -p" \
84install
85
86
87
88%check
89make check
90
91%clean
92rm -rf %{buildroot}
93
94%files
95%defattr(-,root,root,-)
96# contents of QUICK_START.txt can be found also on README.txt, hence omitted
97%doc attributes.txt BUGS.txt COPYING extensions.txt glossary.txt ieee1364-notes.txt
98%doc README.txt swift.txt netlist.txt t-dll.txt vpi.txt tgt-fpga/fpga.txt
99%doc va_math.txt cadpli/cadpli.txt xilinx-hint.txt examples/
100%{_bindir}/*
101%{_libdir}/ivl
102%{_mandir}/man1/*
103
104%files devel
105%defattr(-,root,root,-)
106# headers for PLI: This is intended to be used by the user.
107%{_includedir}/*.h
108# RHBZ 480531
109%{_libdir}/*.a
110
111
112%changelog
113* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-1
114- Initial build for Vine Linux
115
116* Wed Dec 30 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091230-1
117- New stable snapshot - 0.9.2
118
119* Sat Dec 12 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091212-1
120- New development snapshot - 0.9.2 final prerelease snapshot
121
122* Sat Dec 05 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091205-1
123- New development snapshot - 0.9.2 prerelease snapshot
124
125* Fri Dec 04 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091204-1
126- New development snapshot - 0.9.2 prerelease snapshot
127
128* Sat Nov 28 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091130-1
129- New development snapshot
130
131* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20090423-6
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
133
134* Mon Jun 13 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20090423-5
135- Improved VPI support
136
137* Mon Mar 23 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20081118-4
138- new development release
139
140* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20081118-2
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
142
143* Sun Dec 07 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20081118-1
144- new snapshot release upstream.
145
146* Fri Sep 12 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080905-1
147- new snapshot release upstream.
148
149* Mon May 26 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080429-1
150- new snapshot release upstream.
151
152* Fri Mar 28 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080314-1
153- new snapshot release upstream.
154- add check section for some tests
155
156* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.20070608-2
157- Autorebuild for GCC 4.3
158
159* Sun Jun 10 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070608-1
160- new snapshot release upstream.
161
162* Mon Apr 23 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070421-1
163- new snapshot release upstream.
164
165* Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070227-1
166- new snapshot release.
167
168* Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070123-5
169- clean junks from tarball
170- exlude static library
171- smp build seems fine
172- use snapshot instead of cvsver macro
173- follow package n-v-r from fedora standard
174
175* Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-4
176- use cvsver macro
177- move examples in main.
178- more spec cleanup
179
180* Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-3
181- buildroot coherency in spec
182
183* Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-2
184- first build for fedora-extras
185- request gnu/stubs-32.h to force working gcc in 32 bit enviroment
186- fix PAGE_SIZE wich is missing on some arch
187- dont use libdir macro, all library always will be 32 bit
188
189* Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-1
190- initial release
Note: See TracBrowser for help on using the repository browser.