source: projects/specs/tags/6_0_REL/i/isight-firmware-tools/isight-firmware-tools-vl.spec @ 3461

Revision 3461, 4.5 KB checked in by shaolin, 13 years ago (diff)
  • isight-firmware-tools: updated to the newest beta release so far
Line 
1# use udev feature until things go right...
2%define with_hal        0
3
4Summary:        Firmware extraction tools for Apple Built-in iSight camera
5Summary(ja):    Apple 内蔵 iSight カメラ用ファームウェア抽出プログラム
6Name:           isight-firmware-tools
7Version:        1.5.93
8Release:        1%{?_dist_release}
9License:        GPLv2+
10Group:          System Environment/Base
11URL:            http://bersace03.free.fr/ift/
12Source0:        %{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}
15
16%if %{with_hal}
17Requires:       hal
18%else
19Requires:       udev
20%endif
21Requires(post): /sbin/install-info
22Requires(preun): /sbin/install-info
23
24BuildRequires:  gettext
25BuildRequires:  glib2-devel
26BuildRequires:  libgcrypt-devel
27BuildRequires:  libusb-devel
28%if %{with_hal}
29BuildRequires:  hal-devel
30%else
31BuildRequires:  udev
32%endif
33BuildRequires:  perl(XML::Parser)
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: shaolin
38
39
40%description
41iSight Firmware Tools provide tools to manipulate firmware for Built-in iSight
42cameras found on Apple machines since iMac G5 (November 2005).
43
44Before using Built-in iSight on Linux, you will need to extract the
45firmware to /lib/firmware/isight.fw as:
46
47    sudo ift-extract --apple-driver /path/to/AppleUSBVideoSupport
48
49AppleUSBVideoSupport driver file should be located in
50
51    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport
52
53on your Mac OS X root partition.
54
55
56%description -l ja
57iSight Firmware Tools を使って、2005年11月発売の iMac G5 以降の
58Apple 社製コンピュータに内蔵されている iSight カメラ用のファームウェアを
59操作することができます。
60
61Linux で内蔵 iSight を使う前に、
62
63    sudo ift-extract --apple-driver /path/to/AppleUSBVideoSupport
64
65という風に実行してファームウェアを /lib/firmware/isight.fw として
66取り出す必要があります。この AppleUSBVideoSupport ドライバファイルは
67通常 Mac OS X ルートパーティションの
68
69    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport
70
71に存在しているはずです。
72
73
74%prep
75%setup -q
76
77sed -i -e 's|@udevdir@|%{_libdir}/udev|g' src/isight.rules.in.in
78sed -i -e 's|SYSFS|ATTRS|g' src/isight.rules.in.in
79
80
81%build
82%if %{with_hal}
83%configure --enable-hal --disable-udev
84%else
85%configure --disable-hal --enable-udev
86%endif
87make %{?_smp_mflags}
88
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
94
95rm -f $RPM_BUILD_ROOT%{_infodir}/dir
96
97# Use %doc instead.
98rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
99
100%find_lang %{name}
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106
107%post
108/sbin/install-info %{_infodir}/ift-export.info %{_infodir}/dir || :
109/sbin/install-info %{_infodir}/ift-extract.info %{_infodir}/dir || :
110
111
112%preun
113if [ $1 = 0 ]; then
114  /sbin/install-info --delete %{_infodir}/ift-export.info %{_infodir}/dir || :
115  /sbin/install-info --delete %{_infodir}/ift-extract.info %{_infodir}/dir || :
116fi
117
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc AUTHORS ChangeLog COPYING HOWTO NEWS README
122%{_bindir}/ift-export
123%{_bindir}/ift-extract
124%{_infodir}/ift-export.info.gz
125%{_infodir}/ift-extract.info.gz
126%if %{with_hal}
127%{_libdir}/hal/ift-callout
128%{_datadir}/hal/fdi/preprobe/20thirdparty/50-isight-firmware.fdi
129%else
130%{_libdir}/udev/ift-load
131%{_sysconfdir}/udev/rules.d/isight.rules
132%endif
133%{_mandir}/man1/ift-export.1.gz
134%{_mandir}/man1/ift-extract.1.gz
135
136
137%changelog
138* Thu Apr 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.93-1
139- updated to the newest beta release
140
141* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-2
142- replace SYSFS{} with ATTRS{} in the udev file to avoid warning
143
144* Sat May 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-1
145- new upstream release
146
147* Thu Dec  4 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-2
148- switch back to udev support, until hal support gets stable
149
150* Thu Dec  4 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-1
151- new upstream release
152
153* Thu Sep 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-4
154- now enable hal support; disable udev support
155
156* Fri May 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-3
157- fix broken path in isight.rules
158
159* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-2
160- enable udev / disable hal (until Vine's udev gets updated enough)
161- import Patch10 (for MacBookAir) and Source10 (ja.po) from Debian package
162
163* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-1
164- initial build for Vine Linux
165- spec in UTF-8
Note: See TracBrowser for help on using the repository browser.